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Application Note 253 Getting Started in BIOPAC Basic Scripting

BIOPAC Basic Scripting is a scripting language development option for executing, authoring, and debugging BIOPAC
Basic scripts. It allows for viewing of runtime variables, creating new script files and editing existing script files, triggering
of individual script functions for testing and single step functionalities.

This application note begins to explain the tools available for writing scripts for AcqKnowledge version 4.1.

Scripting functionality is available through an optional license available with AcqKnowledge 4.1.1 or
above. The Scripting license must be authorized to access Script functionality.Scripting is available
for Windows Vista and Mac OS X 10.5 or above and also requires Qt SDK 4.5.0 or higher for rich
B dialog development

with
Licensed
features I

i  The Scripting license enables the Script menu, adds the Calculation channel Preset “Run Macro”,
S links the BIOPAC Basic Reference under Help, and adds Preferences for Scripting.

1. Launch a version of Acgknowledge 4.1.1 or above with an authorized Scripting license.

2. Information about the BIOPAC Scripting language — general information about the structure of the language as well as
specific information about statements that can be executed — is available in the “BIOPAC Basic Reference” manual.
This document is available via the “Help” menu of AcgKnowledge. Open this document to help convert actions that
would normally be manually performed within AcqKnowledge to statements that will be executed automatically when
the script is run.
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Manual Conventions

This section describes various formatting conventions used
throughout this manual.

Parameter Types

v

This document uses several constructs when describing macro
commands to represent the allowable type for certain
parameters. The following terms are used in this document to
describe types of input and their options:

v

[ Type || Description

Indicates an expression that, when evaluated, must
produce an integer. This can either be a straight
integer in the macro, e.g. "2", or an expression using
integers and macro variables, e.g. "(5y)". Note that
integer ||if an expression Is used, it should be always followed
by a comma.

Any additional restrictions on the integer input are
given in the type line, e.g. "integer > 0".

Updating search index

B8

Review the manual to get an overall sense of the language. An effective way to use the manual is to browse through
the Contents or Index tabs to find out how to generate statements to perform particular tasks.
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3. Select Script > Script Editor.
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4. Click the Script file pull-down menu and select New Script file. This will create a script file to edit; existing script files
can also be opened to edit.

5. Click the Macro pull-down menu and select New Macro. Scripts files are partitioned into Macros.

a. When prompted, enter a name and click OK. It is a good idea to give the Macro a nhame describing its
function. The Macro created in this example can be used to modify one of the methods for deriving a phasic

skin conductance level (SCL) from a tonic SCL. When prompted, provide the name “GeneratePhasicSCL" for
this example.

6. Set Script Editor Preferences to modify the appearance of the editor.

= Windows OS: Click Display > Preferences
= Mac OS: Click Acqknowledge > Preferences
Waveforms
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a. A major feature of the editor is the color coding of different types of text. By default, statements will appear
orange on a yellow background when the editor does not recognize them as valid instructions. “Script Editor”
preferences can be set to modify this behavior as well as the colors of other types of text.
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7. The example script generated below circumvents a problem with an analysis of skin conductance data. If a 0.05 Hz
high pass filter is used to generate phasic SCL from tonic SCL data, the first 30 seconds or so of the resulting phasic
SCL are unusable. The problem is that the filter has to “settle”. A simple way to overcome this problem is to offset the
tonic SCL data so that the first point is zero. To do that, find the value of the first data point and then subtract that
value from the entire wave.

The remainder of this note details steps to learn how to generate a script that will accomplish this task and then
automatically generate a phasic SCL unaffected by any filter settling.

8. The first step in this process is the determination of the value of the first data point. To perform that task manually,
either use the “Selection Palette” or select the I-beam tool and then use the mouse and/or cursor keys to move the
cursor to the first data point. Find its value by setting one of the Measurement boxes to “Value.”

9. The first step in BIOPAC Basic script requires a selected area.

a. Browse through the Contents tab of the Reference and double-click “Selecting Data in the Graph” in the left
pane to display that section of the manual in the right pane. Scroll down in the reading pane to the “Set
Hcursor” description.
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v Manual Conventions M acquired in Append mode.

Parameter Types

Syntax Descriptions
» Structure of BIOPAC Basic Set HCursor leftPos rightPos

Finding Commands for Commo... .

» User Interfaces Change the currently selected data range of the macro graph. If the graph is setto a
» Text Localization and Translati... time axis, the positions are expressed in seconds. If the graph is set to a frequency
¥ Working with Graphs and Graph. .. axis, the positions are expressed in kHz If the graph is set to arbitrary units, the

Stindird Chafrel Locatiohs positions are expressed directly in the arbitrary units.
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If the graph s set to display in XY mode, this command alters the time range of data
that Is displayed in the plot.

; % Due to channel downsampling, this selection may not lie on current samples. The )
Refreshing the Graph Window ShapCursorsToSamples macro command should be used to ensure that the new

Responding to Zoom Operat... selection starts and ends on actual hardware samples.
Responding to Scaling Oper...
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Markers

Key-Value Coding

Exporting Information to the... leftPos float |[Horizontal position of the left edge of the new selected area.
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¥ Measurements
Macro Commands
Measurement Presets
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rightPos float |[Horizontal position of the right edge of the new selected area.

v Transformations MakeSelectionVisible
Basic Waveform Editing
Changing Time Units Adjusts the horizontal display location to ensure the selection is contained within the
Data Transformations visible area. If the display area needs to be scrolled to display the selection, the

» Cycle/Peak Detector -} selection will be placed at the left edae of the displav. If the selection is wider then the v

Updating search index

N

The example script created here will assume that the user has already selected the tonic SCL data channel,
so the first task for the script is to move the cursor to the first data point. At that point, the time (the x axis
value) is zero. Set both the left and right edge of the selected area to zero.

= Astextis typed, the editor highlights orange with a yellow background (unless the Preferences were
changed).

= The editor attempts to anticipate by offering choices that will complete words that have been partially
typed. Scrolling down the list and clicking on the selection will complete the word. In this case, once “Set ”
has been entered, the editor provides choices for what can be set. Scroll down and select “HCursor”
without typing it:

= Note that “Set” is no longer in orange because although the entire statement is not executable (as
indicated by the yellow background), the word “Set” is recognized as the start of a valid statement.
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b. Asindicated in the BIOPAC Basic Reference, “Set Hcursor” takes two arguments, the left and right edges of

the area to be selected. Statements that require multiple arguments must have those arguments separated by
commas. With this information, the first line of BIOPAC Basic script can be completed.

@O 6

®06

[ Save As :H: Check Syntax )

l: Save As )k Check Syntax )

Revert

(i Delete :“i Run :)

f: Revert )L Delete _)(\ Run )

Set HCursor 0, 0

End

Set HCursor 0, 0
Edit Duplicate a

Transform Math Sub Value, Wa, Wa

10. The next step is to subtract the value at that point from the entire waveform. Write the transformed values to a
different channel to maintain the original waveform. To do this manually, choose Transform > Waveform Math and set
the Destination to New. A good way to find relevant script commands is to search the index for words in the menu
items. By selecting the Index tab and typing, in this case, “Math” in the “Look for:” box, the appropriate script

command will be displayed.
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destination. If xis an alphabetic character, it is interpreted as a macro variable [a-zA-Z] and the value of
that macro variable is used as the index of the source (or destination) channel for the waveform math
transformation. This allows for channel locations for waveform math operations to be changed at runtime.
| Note that only local or global numerical variables may be used with this W syntax.
Parameter|| Type Description
Add literal ||If present, add the amplitudes of the two sources.
|
Mul literal ||if present, multiply the amplitudes of the two sources.
Sub iteral || Present, subtract the amplitude of the first waveform parameter from the second
waveform parameter.
Div iteral || Present, divide the amplitude of the sacond waveform parameter by the first
waveform parameter.
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11. Create a destination channel. The description doesn't indicate a way to set the destination to “New”; this feature is not
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12.

13.

14.

15.

16.

available for this command. One way to do this manually would be to choose Edit > Duplicate Waveform. A search of
the Index for “Duplicate” indicates that this function is scripted as “Edit Duplicate” with an optional output argument.
The output, if requested, is the channel number of the new channel created by this command.

By assigning the channel to a variable, it can be specified as one of the sources as well as the destination when
“Transform Math” is executed. “Transform Math” takes up to four input arguments.

a. The first argument specifies the operation. To perform a subtraction, that argument should be “Sub”.

The second argument specifies what will be subtracted. “Value” is equivalent to a “Value” measurement — it is
the y-value of the selected channel at the cursor location. As noted above, this script assumes the original
tonic SCL channel is selected before the script is run. The “W” notation specifies that the next letter (or
number) is to be interpreted as a channel number. In the example code below, the duplicated channel number
was assigned to the variable “a”.

c. The next two arguments (both of which are “Wa”) thus specify that channel as the source from which Value
will be subtracted and also the channel that will hold the results of the transformation.

F = Fa ¥ o 5 1 i
[ Rala) Script Editor

[ Save As :ZI I Check Syntax ) Script file: | CustomPhasicFromTonic.t & |

|_\' Revert ) i\_' Delete I Run ) Macro: = GeneratePhasicSCL 3

Set HCursor 0, 0
Edit Duplicate a

Transform Math Sub Value, Wa, Wa

Select Wave a
Edit Selectall [N

Transform IIRFilter HighPass, 0.05, 0.707
Set Channel a, Label,
Autoscale

End

After the program executes the previous statements, the original tonic SCL channel is still selected. Select the
channel, “a”, that was just created and transformed. To make sure the next transformation is applied to the entire data
set, the selected area must also be changed. Searching the Index for “Select” produces a list that includes “Select
Wave” and “Edit SelectAll”; these are the statements that must be included to select all data in the new channel.

The phasic SCL will be created with an IIR Filter. A search for “Filter” brings up a list including “Transform IIRFilter.”
The AcgKnowledge manual specifies that the filter normally used to derive a phasic SCL signal has a cutoff frequency
of 0.05 Hz and a Q value of 0.707. With this information and the description of Transform IIRFilter in the BIOPAC
Basic reference, the next statement can be written.

Two typical cosmetic fixes, changing the label and vertical autoscaling, will make the data more readily interpretable.
The statements required to produce these fixes complete the sample script.

Select a graph window and then click the “Run” button in the Script Editor window.

= If, unlike this example, the file contains more than one channel, make sure that the channel containing tonic SCL
data is selected.
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T
result of running the script.

17. Save the script so that it can be run again on other data files.
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a. Select the Script Editor window so that file operations will be applied to the script instead of the graph.

b. To save a new script, click the “Save As” button or choose File > Save.

18. To access the script again in other AcqKknowledge sessions

a. Choose File > Open.
b. Set the file type to BIOPAC Basic Script (*.bbs).

Navigate to the file.

o

Click “Run” to execute the script on the current graph window.

o
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