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Application Note 118 EMG Frequency Signhal Analysis

This Application Note will explain how to extract several measures derived from the power spectrum of an EMG signal. It
is applicable to AcqKnowledge software 3.8.x to 5.x with MP160/150/36R hardware and BSL 3.7.x to 4.x software with
MP36/35 hardware. The measures to be extracted are:

Name Abbrev. Description Units
Median MedianF Frequency at which 50% of the total power within the epoch Hz
Frequency is reached.

Mean MeanF Frequency at which the average power within the epoch is Hz

Frequency reached.

Peak PeakF Frequency at which the maximum power occurs during the Hz

Frequency epoch.

Mean Power MeanP The average power of the power spectrum within the epoch. 7
(Units Note: V will be replaced with the voltage units in E
which the EMG was recorded)

Total Power TotalP The sum of the power at all frequencies of the power 72
spectrum within the epoch. E

(Units Note: V will be replaced with the voltage units in
which the EMG was recorded)

There are two ways to extract these measurements.

e Automated Scoring—Starting with Acqknowledge 4.0 for Windows or 3.9.2 for Mac the software can extract
the measurements in an automated fashion.

e Manual Scoring—If running older software or BSL, see the manual scoring instructions starting on page 4.
Part I. Automated Scoring (requires at least AcqKnowledge 4.0 for Windows or 3.9.2 for Mac)

AcgKnowledge includes a tool for automated EMG Frequency & Power Analysis (choose Analysis > Electromyography >
EMG Frequency and power analysis). For a detailed description of the algorithm, consult the software manual (available
from the Help menu)

The EMG Frequency and power analysis function will extract Median, Mean and Peak Frequency as well as Mean and
Total Power but it will do so for fixed epochs of user-specified duration. That works fine if each EMG activation of interest
occurs in perfectly spaced intervals (as would be the case if, for example, the participant was prompted to make a motor
response every 2 seconds). A recording where the bursts of EMG activity are perfectly evenly spread out (there are
exactly 2 sec between each EMG activation) will look like this:
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Using the EMG Frequency and power analysis function and setting the width of the epoch for 2 sec will result in
measurements being reported for each contraction.

But depending on experiment design, the EMG data might contain only a single contraction of interest or multiple
contractions that are spaced in uneven intervals (see the screenshot below). Additional steps are required in those cases.
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Case A: Extracting measurements from a single contraction

1. Highlight the muscle contraction of interest:
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2. Choose Edit > Copy.
3. Choose File > New and create a new graph window.

4. Choose Edit > Paste. The file will contain just a single EMG contraction:
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5. Choose Edit > Select All and set a measurement box to delta T. Write down the value in the box.

|| =|[5c =] EEERE =] - | 159900 sec

[ e

II’I

6. Runthe EMG Frequency and power analysis function.

a. Enter the value from the delta T box when prompted to enter the epoch width.

b. The software will then extract a single set of measurements for the contraction because the file consists

of 1 epoch that is of length identical to the duration of the file.
c. Select the output type of the analysis via Analysis > Electromyography > Preferences.

For this example, the Excel output of the analysis would look as follows:

£ 1 Microsoft Excel - TempSpreadsheet 1.xls

@J File Edit Wiew Insert Format  Tools  Data Window  Help
NEHRYISRIVE | $BR-IF/I-0-/8 % -
Al - fie EMG Frequency and Power Analysis, CH 1, EMG
A | 8 | ¢ | o | E | F | 5 |

1 |EMG Fregliency and Power Analysis, CH 1, EMG

2
| 3 |Epoch wid 1699 samples

4

5 |Epoch MedianF  MeanF  PeakF MeanP  TotalP
| B | 1) 8560311 1342412 68.09339 4.64E-07 0.000113

7

Case B: Extracting measurements from multiple contractions

This is very similar to case A (above).

1. Decide on the epoch width—the time interval within which the EMG contraction of interest will be analyzed.

e This will be the same for all EMG responses, so choose a width that will be at least as long as the

duration of the longest EMG activation. This example assumes that an epoch width of 2 sec is chosen.
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2. Highlight the first EMG contraction of interest so that the entire EMG contraction is highlighted and the delta T (the
width of the highlighted section) is exactly 2 sec.

e For efficient selection, use the Selection palette (Display > Show > Selection palette):
a.) Place the I-bar at the beginning of the EMG contraction.

b.) Change the value for Right (this is the right edge of the selection) in the Selection Palette to 2
plus its current value.

c.) Hitthe Tab key on the keyboard.

In this case, it would be changed from 0.79 to 2.79. This will result in the software highlighting exactly 2
seconds of data.

| >[5 = peaT =] - [ 0.00000 <ec [5c = [rere [=] - [or | > | = [peta T [=! =| z.00000 s=c [sc =] [nere [=]=[ort

[ A=

| oelection E
Left| 0.79 58 Right:| 0.79 sec = Left:| 0.79 sec Right:| 2.73 sec =

[o.00 2.00 [0.00 2.00

Choose Edit > Copy.
Choose File > New (New Graph option) to create a new File.

Choose Edit > Paste and the new file will contain the EMG contraction.

L

To create a file that is a concatenation of EMG contractions, each contained within a 2-sec window of data, repeat
these steps (except that you will not need to create a new file in subsequent steps) to copy and paste more EMG
contractions in the new file (see the figure below).
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7. Runthe EMG Frequency and power analysis function and set the epoch width to 2 sec.

e It will provide you with measurements for all of the contractions you have pasted into this new file. In this
example 4 contractions are pasted in and the Excel output will look like this:

Microsoft Excel - TempSpreadsheet 2.xls

@J File Edit ‘ew Insert Format Tools Data  Window  Help

NEEHRSSAIVA X B2RA-F|/9--18 = -
Al - A EMG Frequency and Power Analysis, CH 1, EMG

A | B | ¢ | o | E | F | & |

1 |EMG Freg!.lency and Power Analysis, CH 1, EMG

2

| 3 |Epoch wid, 2000 samples

4

5 |Epoch MedianF  MeanF  PeakF MeanP  TotalP

| B | 1) 93.38521 143.9669 93.38521 2.96E-07 7E1E-05

L 7| 2 89.49416 1420233 50.58366 3.59E-07 9.23E-05

| 8 | 3 89.49416 138.1323 §3.65759 3B2E07 9.31E05

| 9 | 4 91.43965 1400778 81.71206 4.36E07 0.000112

10
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Part Il. Manual Scoring (Current BSL and older versions of AcgKknowledge)

When running Biopac Student Lab or older versions of AcqKknowledge, Median,
Mean and Peak Frequency as well as Mean and Total Power for each EMG
contraction are obtained with manual steps.

www.biopac.com

Analysis - FFT N

2048 point of FFT

(% padwith zeros ¢ Pad with last point

I~ Removemean ¥ Magnitude | ¢ d8 & Linear

1. Highlight the EMG contraction.
I~ Removetrend | Phase I~ Show modified input:
2. Choose Transform > FFT and establish the following settings:
Pad with zeros, magnitude, Linear, Windows: Hamming. e O
I~ FFT of entire wave OK -Cancel
3. A new graph will be generated with Magnitude as a function of frequency. e I el
ol
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4. To obtain the graph of the squared FFT
magnitude, choose Transform > Waveform cource 1 Source 2 Destinati
Math, enter the following parameters (CH1 s ki il
', N s i - | |+ - s i | = e -
Magnitude * CH1 Magnitude => New), and [oHt, magniude =] | =] Jor, magnitude ] = TN - |
click OK. k: [0.000410
. . . |Enter the constant walue k' here and choose 'K’ from one of |
5. This should result in two channels in the
graph window. The top channel represents
the FFT magnitude and the bottom channel = ¥ Transfarm entire wave oK | Cancel
(labeled CH1*CH1) is the squared FFT
magnitude.
e Choose Display > Autoscale Waveforms to autoscale the channels if necessary.
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6. Create the integral of the squared FFT channel.

a.) Select the bottom channel and choose Edit > Duplicate waveform.

b.) Select the new channel that is generated (the graph window will have 3 channels and you need to select

the bottom channel).
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c.) Choose Transform > Integral.

d.) Choose Display > Autoscale Waveforms.
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e.) Change the channel label by double-clicking on its label (where it says CH1*CH1) and entering
“Integrated FFT squared.”

7. Normalize the Integrated FFT squared channel.
a.) Select the Integrated FFT channel.
b.) Choose Edit > Select All.

c.) Set a measurement box to Max and write down the measurement. The result should resembile this:

= | 0.02585 vlts |

8. Choose Transform > Waveform Math, enter the following parameters (CH3 / K => CH3), enter K as the value
from the Max measurement box, and click OK.

Transformation - Waveform Math

Source 1 Source 2 Destinakion
| CH3, Tntegrated FFT: > | |/ =k x| == |cH3, Integrated FFT: x|

K: |0.02585]

Iv Transform entire wawe O I Cancel |

9. Choose Display > Autoscale Waveforms and the screen should resemble this:
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10. Obtain the desired measurements.

e The following steps describe how to obtain each measurement (report measurement results in the units
indicated in parentheses).

e |IMPORTANT—If different instances of EMG activation are to be compared in terms of Mean Power and
Total Power, keep the duration of each identical or, otherwise, perform normalization.

e Write measurement results down or paste them to the Journal via Edit > Journal > Paste Measurements.
Median Frequency (Hz)
Definition: Frequency at which 50% of the total power within the epoch is reached.

Set measurement boxes to CH3 and Value and SC and Freq (frequency). Place the cursor exactly where
value is 0.5. The Freq measurement result is the Median Frequency.

HL”3 - [wale |3=| 050110 volts  [5C || [EECH - | - | 5586710 Hz
H\l\l\z\l? Integrated FFT souared
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Mean Frequency (Hz)

Definition: Frequency at which the average power within the epoch is reached.

Set measurement boxes to CH3 and Mean and SC and Frequency. Choose Edit > Select All.
Write down the Mean measurement result—in our example, the result is 0.76293 volts:

|:-= ~| O - | - | 0.75202 volts

Set another measurement box to CH3 and Value. Click with the I-bar on the Integrated FFT squared
waveform (CH3) to place the I-bar exactly at 0.76293 volts (as indicated in the Mean measurement
result). Use the keyboard arrow keys to move the I-bar left or right to place it precisely at the location

where the Mean measurement result reads 0.76293. The Frequency measurement result is the Mean
Frequency.

Peak Frequency (Hz)
Definition: Frequency at which the maximum power occurs during the epoch.

Set a measurement box to CH2 (the squared FFT channel) and Max F. Choose Edit > Select All.
The Max F measurement result is the Peak Frequency.

Mean Power (Volts?/Hz)

Definition: The average power of the power spectrum within the epoch.
Units Note: V will be replaced with the voltage units in which the EMG was recorded.

Set a measurement box to CH2 (The squared FFT channel) and Mean. Choose Edit > Select All.
The Mean measurement result is the Mean Power.

Total Power (Volts squared/Hz)

Definition: The sum of the power at all frequencies of the power spectrum within the epoch.
Units Note: V will be replaced with the voltage units in which the EMG was recorded.

Set a measurement box to CH2 (the squared FFT channel) and Integral. Choose Edit > Select All.
The Integral measurement result is the Total Power.
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Related Readings

Thongpanja, S. & Phinyomark, Angkoon & Limsakul, Chusak & Phukpattaranont, P.. (2015). Application of Mean and
Median Frequency Methods for Identification of Human Joint Angles Using EMG Signal. Lecture Notes in Electrical
Engineering. 339. 10.1007/978-3-662-46578-3_81.

Abstract: The analysis of surface electromyography (EMG) signals is generally based on three major issues, i.e.,
the detection of muscle force, muscle geometry, and muscle fatigue. Recently, there are not any techniques that
can analyse all the issues. Mean frequency (MNF) and median frequency (MDF) have been successfully applied
to be used as muscle force and fatigue indices in previous studies. However, there is the lack of consensus upon
the effect of muscle geometry on the basis of varying joint angles. In this paper, the modification of MNF and MDF

using a min-max normalization technique was proposed to provide a consistent relationship between feature
value and joint angle across subjects...

Keywords: Feature extraction, Frequency analysis, Muscle fatigue, Spectral analysis, Surface electromyography
signal

Phinyomark, Angkoon & Thongpanja, S. & Hu, Huosheng & Phukpattaranont, P. & Limsakul, Chusak. (2012). The
Usefulness of Mean and Median Frequencies in Electromyography Analysis. 10.5772/50639.

Abstract: Mean frequency (MNF) and median frequency (MDF) are two useful and popular frequency-domain
features for electromyography analysis both in clinical and engineering applications. MNF and MDF are frequently
used as the gold standard tool to detect fatigue in the target muscles using EMG signals. The effectiveness of
MNF and MDF under many experimental conditions is presented and confirmed in this chapter...

Keywords: electromyography, muscle force, muscle geometry, muscle fatigue, human-computer interaction (HCI),
ergonomics, occupational therapy, sport science
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