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Preface to Biopac Student Lab PRO Manual 
Welcome 

Welcome to the Biopac Student Lab PRO Manual. The Biopac Student Lab PRO system includes both 
hardware and software for the acquisition and analysis of life science data. 
BSL PRO software not only makes data collection easier, but also performs analyses quickly and easily 
that are impossible on a chart recorder. Easily edit data, cut and paste sections of data, perform 
mathematical and statistical transformations, and copy data to other applications for reports and 
publication. 
The MP System (MP36, MP35, MP46, or MP45 hardware) with BSL PRO is compatible with Windows 
10, 8, & 7 or Mac OS 10.10-10.15*. 
This manual covers use of BSL PRO software with an MP System and details BIOPAC equipment 
available for a variety of applications. If a desired application is not addressed, please visit the BIOPAC 
web site at www.biopac.com to download one of our many Application Notes, or call to request a hard 
copy or talk to an Applications Specialist. 

See also: 
• BIOPAC Installation Guide—packed with the software installation disc. 
• BIOPAC Hardware Guide.pdf—available under the Help menu and installed to the User Support folder. 

Provides details on MP System transducers, electrodes, etc., and setup and calibration. 
• BIOPAC Catalogs 

Supported Platforms  
BSL PRO is supported on the following:  
 
Operating Systems MP Devices 

Windows 10, 8, or 7 MP36/35/46/45 

Mac OS 10.10 – 10.15  

 
        

 

http://www.biopac.com/
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What’s new for BSL 4.1.6 PRO 
 
Bug fixes 
Support for MP46 2-channel hardware (replaces MP45) 
Linked Acquisitions officially supported with MP36 hardware 
Measurement presets available for Epoch Analysis  
3D Visualization 

Analysis > Find Cycles > output 3D Surface 
Analysis > Waterfall Plot 

The following features have been introduced since BSL 4.1.3 was released. 
Bug fixes 
Support for upcoming MP46 2-channel hardware (will replace MP45) 
MP41 single-channel hardware support for BSL Lessons 
Chinese Simplified language support for BSL Lessons 

 macOS Catalina support (10.15) 
 BSL 4.1.4 is superseded by the release of 4.1.5 
The following features have been introduced since BSL 4.1.3 was released. 

Bug fixes 
macOS Mojave support (10.14) 
Support for new Gas System 3 O2 and CO2 Gas Analysis System (GASSYS3) 
Improved 3D Surface tools for Find Cycle and Waterfall Plot 

The following features have been introduced since BSL 4.1.2 was released. 
 Bug fixes  

macOS High Sierra support (10.13) 
 Chinese Traditional language support for BSL Lessons 
 Dropbox Version 2 support 
 Analysis Shortcuts– allows easy access to specialized analysis options from within a data channel  
 Enhanced Lesson Preferences offering easy access to PRO menu functionality and other custom features 
The following features have been introduced since BSL 4.1.1 was released. 

Bug fixes 
macOS Sierra support (10.12) 
Arbitrary Wave Output Control 
Lesson videos can now be played back without Flashplayer 
Updated Lessons and PRO Lessons 

The following features have been introduced since BSL 4.1 was released. 
Bug fixes 
Windows 10 and Windows 8 support 
Japanese language support for BSL Lessons 
Collapsible channels – quickly hide and unhide single or multiple channels with one click 
Updated Lessons and PRO Lessons 

The following features have been introduced since BSL 4.0.3 was released. 
FIR Filter Calculation Channel – apply high quality FIR filters in real time 
Slew Rate Limiter – precise real-time or offline tool for denoising and removing motion artifact 
Event-based Rate Measurements – extract the mean, median and standard deviation of online and offline Rate 
outputs 
Support for four new transducers – (OUT4 Visual Stimulator Controllable LED, SS57LA for EDA, SS25LB 
Hand Dynamometer, STIMHUM Human-safe Stimulator) 

https://www.biopac.com/product/co2-and-o2-analysis/
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Elapsed timers – stopwatch, elapsed timers and alarm to time experiment protocols 
Embedded PDF Integration – embed PDFs of procedures, analysis, etc. into graph files and journals 
Dropbox Integration – copy and store data files to Dropbox account directly from BSL application 
Simplified User Interface and UI updates 
Append event boundaries now appear in graph for easier viewing 
New Analysis menu features – Locate Animal ECG Complex Boundaries, Correlation Coefficient, Ensemble 
Average, Epoch Analysis, define Focus Areas between events or appended segments, and Waterfall Plot 
Curriculum Manager – Instructors may customize analysis procedures, data reports, lesson introduction, 
recording procedure and onscreen instructions and broadcast the customized content to all student 
workstations (Licensed Functionality) 
Preset transducer detection – presets automatically check to see if correct transducer is connected 
Simplified calibration for selected presets 
New sample data files 
New Lesson 11A for measuring visual stimulus reaction time 
Updated PRO Lessons with PRO Lesson PDFs now embedded in graph template file 
Bug fixes 

The following features have been introduced since BSL 4.0 was released. 
Consolidated hardware support 
Single executable launches application for all supported hardware types 
Rate detector enhancements 
Adjustable baseline window width 
Adjustable averaging output modes 
Customizable Rate “signal type” presets 
Textual values display and toolbar 
Tabbed graph interface (shows multiple graphs in single window) 
Focus areas for indicating areas of data to be analyzed by the Cycle Detector 
Selection palette toolbar button 
Show most recent data only in XY mode 
Configurable measurement columns 
Linked media files can be imported from BSL 3.x files (Windows only) 
Screencast radio button in Startup Wizard and Help menu 
Journal hyperlinks 
Application preference to show/hide individual lessons or PRO lessons 
Horizontal split view – allows viewing of two independent horizontal axis areas in same graph 

 
BSL PRO Windows included the following new features since BSL PRO 3.7.7 was released. If upgrading from an 
older version of BSL PRO, see the "BSL 3.7.7 PRO Manual" for a more complete list of features. 

  Analysis Packages 
Histogram 
Power Spectral Density 
FFT/IFFT 
Find Cycle 
Find Rate 
Detect and Classify Heartbeats 
Locate Human ECG Complex Boundaries 
Locate Animal ECG Complex Boundaries 
Heart Rate Variability 
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Correlation Coefficient 
Digital Input to Stim Events 
Ensemble Average 
Epoch Analysis 
Focus Areas (define events) 
Waterfall Plot 

Multichannel Event Marking System 

Event marking system is now combined with Cycle/Peak Detector, allowing automated measurements around 
specific events and additional event marking based on measurements taken. For example, mark when a dose or 
task occurs and automatically measure and mark the maximum response. 

Cycle (Peak) Detector interface 
Advanced Cycle/Peak Detector combines with powerful new Event Marking System. Perform amplitude, time, or 
event-based measurements. New output options for measurements, averaging, events, and 3D surface (cycle data, 
histogram, and FFT). 

Transformations 
Most recently used files, transformation and analysis 
Delay transformation 
Cubic spline resampling options 
Spectrum analyzer/real-time FFT
Calculation Channels 
Calculation metachannels—daisy-chain calculations, such as Filter and Difference, on one channel 
Dynamic digital filter options 

Measurements 
Expression enhancements—online and post-acquisition 
Interpolated measurements 
New measurement options to optimize event marking system 

User Interface – Display and control of data 
Text annotations—add zest to publication screen shots or annotate the file beyond event notes 
Print functions—adjust data range for printing; print waveform data in black; print file to PDF 
Adaptive scaling—vertical scale updates in real time to optimize data display 
Grids—Friendly grid scaling; Flexible grid options Grid Tool 
Balloon Help 
Multiple levels of Undo 
Jump tool 
Rescale operations 
Selection palette—place cursors at specific time points 
Mouse scrollwheel support 
Keyboard Shortcuts added (accelerator keys) 
Replay data 
 
Data processing 
Large file support 
Batch acquisitions 
Multithreaded operation 
 
File Formats 
Excel Export (for reports with tabular data) 
Save Selection As moved to File menu and added = Wav, EDF, JPEG; removed = Metafile (*.WMF)  
Open Mac Biopac Student Lab 3 Graph 
BSL file import 
EDF file import and export 
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Igor Pro Experiment import/export 
WAV file format import/export 
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Using this Manual 
The BSL PRO Manual is divided into four parts: 
Part A Getting Started 
 Please review Getting Started whether new to computer-based data acquisition systems or an old hand at 

physiological monitoring. Use this section to become acquainted with how the system works and the most 
frequently used features. 

Part B Acquisition Functions 
 Explains data acquisition features and gives a detailed summary of different acquisition parameters. 

Provides an in-depth description of the commands used to determine acquisition rate, acquisition duration, 
and specialized functions such as triggering, averaging, and online calculation of different values. 

Part C Analysis Functions 
 Details information on analysis features; covers the range of post-acquisition analysis functions and 

transformations available with the MP System. Describes how to edit data, take measurements and perform 
basic file management options (save, print, etc). 

Part D Appendices 
 Answers frequently asked questions, offers hints for working with files, includes information on upgrading 

from previous versions, provides technical information about the MP System and other information about 
the BSL PRO software. 

 
See also: 

BIOPAC Installation Guide 
This guide was included with the software CD. It contains full instructions for hardware and software 
installation, and how to be up and running with the MP System in just a few minutes. 
 
BSL Hardware Guide 
BIOPAC MP Hardware Guide.pdf is available under the Help menu. It gives practical examples of how 
the MP data acquisition unit is used with different components for common types of data acquisition, and 
includes sample results and applications for widely used test procedures. This guide provides instructions 
for connecting external devices to the MP36, MP35, MP46 or MP45, electrodes, transducers etc. 
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User Support 
User Support files can be found in the following hard drive location; BIOPAC Systems, Inc/BSL PRO 4.0/User 
Support in the Program Files or Applications folder. 
 
 BSL PRO Manual.pdf is the software support document 
 
 BSL Hardware Guide.pdf is the hardware guide (with specifications) 
  
The User Support files can also be opened directly from the CD. 
 
The files are in PDF format, and can be read by Adobe Acrobat Reader. 

• Adobe Acrobat Reader can be downloaded for free at www.adobe.com under the Adobe Acrobat Reader 
site. 

The Samples folder in the BIOPAC program folder contains sample files, graph template, Lesson and PRO Lesson 
files for a variety of applications. These templates establish the channel setup and acquisition parameters required 
for a variety of applications. 

• To open sample files from the Startup Wizard, choose “Open a graph File, choose the “Sample data file” 
radio button and select the desired folder. From within the application, go to File > Open then Browse to 
the BIOPAC Samples folder. 

• To open a graph template file from the Startup Wizard, choose “Create and/or record a new experiment”, 
choose the “Sample graph template” radio button and select the desired folder. From within the 
application, choose File > Open then Browse to the BIOPAC Samples folder (be sure to select/enable the 
desired file type). 
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Where do I find help? 
The Introductory sections are intended to provide enough information to get up and running with the MP System, 
and become familiarized with some basic BSL PRO functions. There are far more features than described in the 
first few pages, so here is a guide for how to continue using this manual. 
 Help menu 

The software Help menu includes basic information about standard BSL PRO functions and links to the 
tutorial, manual and hardware guide for online searchable Help while running BSL PRO, plus links to the 
BIOPAC web site. 

 Application Notes 
The BIOPAC web site at http://www.biopac.com has more than 50 available Application Notes. 
Download the desired Application Note or call to request a hard copy. 

 Acquiring data 
For more specific information on different types of acquisitions, see Part B—Acquisition Functions. It 
covers basic acquisition parameters in detail, and describes some acquisition features (such as peak 
detection techniques and online Calculation channels) not covered in the Getting Started section. 

 Analysis 
Information about how to edit, display and transform data can be found in Part C—Analysis Functions. It 
explains how to import and export data, how to save files, and other file management commands. This 
section also explains how to use all of the post-acquisition features of the BSL PRO software. 

 Connecting input devices 
To find out how specific modules connect to the MP data acquisition unit, turn to the BIOPAC MP 
Hardware Guide PDF file. This section describes how to connect signal-conditioning modules to the MP 
data acquisition unit and how to connect electrodes and transducers to the modules. 

 Working with large files 
Many users need to perform high speed (i.e., fast sampling rates) or long duration acquisitions. These types 
of acquisitions tend to generate large (several megabytes) data files that can be difficult to load, store, and 
view. The MP System can handle such acquisitions—see the Appendices for information on how to 
optimize setup for these types of acquisitions. 

 Troubleshooting 
Includes a list of the most frequently asked questions regarding the MP System. Check this section 
(Appendix B) for commonly encountered problems and solutions. 

http://www.biopac.com/
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IMPORTANT SAFETY NOTICE 
BIOPAC Systems, Inc. instrumentation is designed for educational and research-oriented life science 
investigations. BIOPAC Systems, Inc. does not condone the use of its instruments for clinical medical 
applications. Instruments, components, and accessories provided by BIOPAC Systems, Inc. are not intended for 
the diagnosis, mitigation, treatment, cure, or prevention of disease. 
The MP data acquisition unit is an electrically isolated data acquisition system, designed for biophysical 
measurements. 
Exercise extreme caution when applying electrodes and taking bioelectric measurements while using the MP 
System (MP36, MP35, MP46, or MP45) with other external equipment that also uses electrodes or transducers 
that may make electrical contact with the Subject. Always assume that currents can flow between any electrodes 
or electrical contact points. 
Extreme caution is also required when performing general stimulation (electrical or otherwise) on a subject. 
Stimulation currents should not be allowed to pass through the heart. Keep stimulation electrodes far from the 
heart and located close together on the same side of the subject’s body. 
It is very important (in case of equipment failure) that significant currents are not allowed to pass through the 
heart. If electrocautery or defibrillation equipment is used, it is recommended that all BIOPAC Systems, Inc. 
instrumentation be disconnected from the Subject. 
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Human Anatomy & Physiology Society Position Statement on Animal Use 

 (Adopted July 28, 1995, Modified January 2001, Approved April 29, 2012) 
It is the position of the Human Anatomy and Physiology Society (HAPS) that dissection and the manipulation of 
animal tissues and organs are important elements in scientific investigation that introduce students to the 
excitement and challenge of their future careers. HAPS supports the use of biological specimens as part of a 
program of study, provided their use is in strict compliance with federal legislation and the guidelines of the 
National Institutes of Health and the United States Department of Agriculture, and that such use fulfills clearly 
defined educational objectives. 

The mission of the  Human Anatomy and Physiology Society (HAPS) is to promote excellence in the teaching of 
anatomy and physiology.  A fundamental tenet of science is the ordered process of inquiry requiring careful and 
thoughtful observation by the investigator. As subdivisions of biology, both anatomy and physiology share a long 
history of careful and detailed examination, exploration and critical inquiry into the structure and function of the 
human and animal body.  

Consistent with the origins and nature of scientific inquiry, HAPS endorses the use of animals as part of the 
laboratory experiences in both human anatomy and human physiology. 

Historically, an important tool of investigation in human and animal anatomy has been dissection. A complete 
anatomy learning experience that includes dissection goes beyond naming structures and leads the student to 
conclusions and insights about the nature and relatedness of living organisms that are not otherwise possible. To 
succeed in their future careers, students must become thoroughly familiar with anatomical structures, their design 
features and their relationships to one another. Dissection is based on observational and kinesthetic learning that 
instills a recognition and appreciation for the three-dimensional structure of the animal body, the interconnections 
between organs and organ systems, and the uniqueness of biological material. Dissection conveys the inherent 
variability of living organisms not otherwise observable in simulations and models. Physiology experiments 
involving humans and live animals provide an excellent opportunity to learn the basic elements specific to 
scientific investigation and experimentation. It is here that students pose questions, propose hypotheses, develop 
technical skills, collect data, analyze results and develop and improve critical thinking and problem solving skills 

Since effective teaching requires a diversity of strategies and approaches, HAPS endorses the use of computer 
atlases and simulations, modeling, and video programs to meet educational objectives and the needs of students. 
Science educators choosing not to use animals or biological specimens should choose alternatives that are able to 
convey equivalent anatomical and physiological intricacies to meet their educational objectives. 

Science educators have in common a respect and reverence for the natural world and therefore have a 
responsibility to share this with their students. They must communicate the importance of a serious approach to the 
study of anatomy and physiology. HAPS also encourages educators to be responsive to student concerns regarding 
use of animals and to provide students who object to animal use with alternative learning materials. 

HAPS contends that science educators should retain responsibility for making decisions regarding the educational 
uses of animals and other strategies and techniques for the betterment of their student’s  learning. Furthermore, it 
opposes any legislation or administrative policy that would erode the educator’s role in decision making or restrict 
dissection and animal experimentation in biology. 

Used with permission of:  
The Human Anatomy & Physiology Society (HAPS)  
251 S. L. White Blvd., P. O. Box 2945, LaGrange, GA 30241-2945 
800-448-HAPS (4277)    Fax: (706) 883-8215    www.hapsweb.org 

http://www.hapsweb.org/
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Part A—Getting Started 
Chapter 1  MP Systems Overview 

Part A - Getting Started covers the basics of data acquisition and analysis with an MP System (MP36, MP35, 
MP46, or MP45). All of the material in this section is covered in more detail in subsequent sections (see 
Using this Manual, page 16 ). 
 
Overview 
The MP System is a computer-based data acquisition system that performs many of the same functions as a 
chart recorder or other data viewing device, but is superior to such devices in that it transcends the physical 
limits commonly encountered (such as paper width or speed). Data collection generally involves taking 
incoming signals (usually analog) and sending them to the computer, where they are (a) displayed on the 
screen and (b) stored in the computer’s memory (or on the hard disk). These signals can then be stored for 
future examination, much as a word processor stores a document or a statistics program saves a data file. 
Graphical and numerical representations of the data can also be produced for use with other programs. 
The MP System utilizes the same hardware, excepting the computer interface. The software has the same 
“look and feel” on computers running Windows® or Mac® OS. 
The MP System consists of several major components, including hardware and software. The BSL PRO 
software included with the MP system allows full control over editing data, the way it appears on the screen, 
and performs four general functions: 

(a) Control the data acquisition process. 
(b) Perform real-time calculations (such as digital filtering and rate detection). 
(c) Perform post-acquisition transformations (such as FFT’s and math functions). 
(d) Handle file management commands (saving, printing, and the like). 

The heart of the MP System is the MP data acquisition unit, which converts incoming physiological data into 
digital signals that can be processed and displayed on a computer interface. The MP3x and MP4x systems 
connect via USB 2.0. 
A wall transformer is included with the MP System to convert AC mains power into DC power suitable for 
system operation and safety. 
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MP36/MP35 support 
The MP36/MP35 is a four-channel data acquisition unit designed to work with BSL PRO. BSL PRO support 
for the MP36/MP35 unit includes:  
 Standard data acquisition and data acquisition features (triggering, multiple channels, variable 

sampling rate, input values)  
 Output control functionality for controlling stimulators, digital channel, and channel redirection to 

output.  
 Standard analog presets for all SS series transducers 
 Electrode Check support  
 Control channel support for changing digital output lines based on calculation channel analysis  

 
MP3x Notes  The computer sleep mode should be disabled—if the computer goes to sleep while BSL PRO 

is running, communication with the MP36 may be lost and the application may freeze. To 
prevent this from occurring, modify the computer settings to prevent the computer from 
going to sleep. 
 If sleep mode is enabled and causes the application to freeze, force quit the application 

and ‘power cycle’ the MP unit to re-establish communication. 

 
 During an unresponsive period, the ‘Connect Hardware’ dialog may display odd 

characters in place of the MP serial number or the computer, upon waking up, may 
generate a“Driver irql not less or equal” error dialog. 

 Mac OS users: Connect the MP3x directly to the computer, do not connect MP36 via hub or 
keyboard. 

MP System Requirements 
Suggested minimum system requirements are detailed below. Recommendations are included to optimize 
system performance; more memory and a faster system will enhance MP System performance. If planning to 
acquire data for more than a few hours and/or are sampling at more than 1,000 samples per second, see the 
Disk Space note. 

Windows For BSL PRO 
OS Requires Windows 10/8/7 or Mac OS 10.10-10.15 

Port MP36/MP35 and MP46/45 require USB. 

Hard Disk Requires 5 GB free hard disk space for files, data, and videos 

RAM 4 GB minimum, 8 GB recommended 

Processor PC and Mac: Intel Core Duo minimum, Intel i5 dual core recommended 

 

MP46 and MP45 Support 
The MP46 and MP45 are two-channel data acquisition units designed to work with BSL PRO. Like the 
MP36/MP35, the MP46/45 connects via the USB port but uses the computer’s audio card as a signal 
processing source. The MP46/45 functionality is more limited than the MP36/MP35, as triggering, Electrode 
Checker and certain Output Controls are not supported. While digital channels are not supported throught the 
MP45, the MP46 can connect to digital devices via a BN-SMART-IOCBL TTL interface cable. 

http://www.biopac.com/calculating-file-sizes
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Sound Errors for MP45 Users  
 Audio Properties  

BIOPAC MP45 USB Data System must be selected as the default device from the Sound Playback menu 
(Control Panel > Sound) in order for sound to be heard. If the Sound/Audio Properties are not setup 
properly, no sound will be heard; no warning prompts will appear if set incorrectly. 

   
 Device Volume  

The Device volume slider must be set to “High” and “Mute” must not be enabled. 

Disk Space 
With any program, adequate disk space is necessary for storage of data files. Although BIOPAC saves 
files in a format as compact as possible, some users may generate data files of several dozens of 
megabytes. To acquire data for long periods (more than a few hours) while sampling at relatively fast 
rates (more than 1,000 samples per second), as much disk space as possible should be available. (A 
removable drive may also be used). See the Appendices for hints on working with large files. 
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MP System Features 
The MP System (MP36, MP35, MP46, or MP45) is a complete system for acquiring almost any form of 
continuous data, whether digital or analog. The MP System can perform a range of recording tasks, from 
high-speed acquisitions to long duration acquisitions. Generally speaking, for physiological applications, the 
MP System is limited only by processor speed  and available memory or disk space. Features of the MP 
System include: 

Easy to use The MP System offers the same convenient and easy-to-use features which computer 
users are accustomed to. Since the MP System software runs under these Windows and 
Mac OS environments, other applications can be running while collecting data. In terms 
of hardware setup the MP System uses simple plug-in connectors and standard interface 
cables.  

Flexible The MP System can be configured for a wide variety of applications. Control the length of 
acquisition, the rate at which data is collected, how data is stored, and more...all with a 
few mouseclicks.  

Menu flexibility Easily customize menu displays to show only necessary functions, thereby reducing the 
risk of error or confusion in the lab. It is also useful for teaching applications where 
instructors can hide unnecessary menu items. See Appendix D—Customizing Menu 
Functionality. 

Calculation Channel 
Presets 

Customize the recording for specific measurements. 

Template files BSL PRO Lesson templates are available for over 30 lessons. Just open the template file 
and start the acquisition—appropriate settings are established for the selected application. 

Online Calculation Although the MP System provides an extensive array of measurements and 
transformations to apply to collected data, sometimes it’s necessary to perform 
computations while data is being collected. The online Calculation functions supports 
calculation of new channels based on incoming signals. For example, this feature will 
extract BPM based on raw ECG data. 

Online filtering Many times, it is preferable to filter data as it is being collected, rather than having to wait 
until after the fact, so filters can be applied to incoming data and the results viewed in real 
time. 

Online measurements The MP System can instantly compute over a dozen measurements and computations for 
any given data point(s). These options are available from pull-down menus and include 
mean, peak-to-peak, value, standard deviation, frequency, and BPM. 

Measurement 
Validation 

Validate measurements with the ValidateMeasurements.acq sample file included 
with the software. The measurement definitions (page 91) include measurement 
formulas and “Sample data file” explanations. 

Previewing data Similar to chart recorders, the MP System allowsmodification of both the vertical 
and horizontal scale. Change the amplitude scale or the time scale to any custom 
value, or have BSL PRO automatically scale them. 

  

Simplified editing Delete unimportant sections of data with a keystroke, or “paste” together sections 
from different waves, or simply edit out noise spikes from individual waves. 

Append mode For some applications, data only needs to be recorded during some portions of a 
long experiment. BSL PRO has an “Append” mode that allows pausing of the 
acquisition for as long necessary, and resumes the acquisition as many times as 
needed. Appending data saves on storage space and processing time for 
transformations. 
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Digital filtering Reduce or eliminate that error by using the included digital filters and smoothing 

transformations. Smooth data across any number of samples, or filter out noise 
from virtually any frequency or bandwidth. 

Digital Output Control external devices when an input or calculation channel meets specified 
trigger conditions. Use the Control channels to output a pulse when the signal on 
an analog channel falls above or below a given threshold. 

X/Y plotting View and acquire data in the form of an X/Y plot, with one channel on the 
horizontal axis and another on the vertical axis. This allows exploration of 
relationships between different channels and opens up a whole range of 
applications, from chaos plots to respiration analysis to vectorcardiograms. 

Histogram function Easily examine the variability and the measures of central tendency of any 
waveform data with the histogram function. Set the plotting options to suit or let 
the software determine the “best fit” for graphing data. 

Math functions In many cases, simply collecting raw data is not enough. BSL PRO has an array 
of built-in mathematical functions ranging from simple absolute value to 
computation of integrals, derivatives, and operations involving multiple 
waveforms (such as subtracting one wave from another). Chain multiple functions 
together to form complex equations or expressions. 

Annotation BSL PRO has a Journal for adding comments about the data, either online or after 
the fact. This is especially useful for noting the characteristics of an acquisition 
(what was involved, what manipulations took place, and the like) for future 
reference. 
See also: Text annotation, page 58. 

Triggering To measure response times or start data collection only after a specific event has 
occurred, BSL PRO supports triggering an acquisition in a number of different 
ways. Trigger on the level of a signal, or with an external synchronizing trigger. 
(Triggering is not supported in MP46/45 hardware.) 

Event marker  Many times, especially during a long acquisition or in a laboratory setting, it is 
useful to make a note of when specific events occurred so that these events (such 
as when a manipulation occurred) can be recorded and any changes in the data 
can be noted. The event function supports the insertion of symbols in the record 
and the adding of text for each event. These can be added either while data is 
being collected or after the fact. Event functionality can be automated for 
sequential application or customized for Function keys. 
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File compatibility Data can be saved in a number of different formats. For word processor programs 

like Microsoft Word®, use Copy to Clipboard and then paste into the document. 
Use Save as Excel for Microsoft Excel®. Data can be outputted in text or 
graphical form, and BSL PRO can even read-in raw data from a text file. Open 
(import) or save as (export) MATLAB™ and Igor Pro Experiments, or raw 
(binary) data for low level exchange. 

Pattern recognition Using an advanced pattern search/recognition algorithm, the MP System can 
automatically find a specific pattern within waveforms. This is useful for finding 
abnormal waveforms (such as irregular ECG waves) within a data file. 

Cycle/Peak detection BSL PRO has a built-in algorithm to find cycle data, such as positive or negative 
peaks, from any size data file. Search for all the cycles/peaks with one command 
and automatically log statistics like time and area to the journal. 

Printing The MP System provides a range of printing options, and allows a wide range of 
formatting options. Print several graphs per page, even for one-channel 
recordings.  

Report generation BSL PRO has many features to simplify report generation. Use the Journal for 
notes and quickly copy and paste graph data or measurements to the journal or to 
another program. Cascade event markers to prevent print overlap and select the 
range of data to print and which options to display (measurements, eventss, etc.). 
Use the Playback mode to simulate acquisition for presentations. 

User Support Have a question about compatibility with existing equipment or need to develop a 
specialized measurement device? BIOPAC’s Applications Department can 
address the problem. 

 
MP System (MP36, MP35, MP46, or MP45) Application Notes 
BIOPAC has prepared a wide variety of application notes as a useful source of information concerning certain 
operations and procedures. The notes are static pages that provide detailed technical information about either 
a product or application. A partial list of Application Notes follows. View or print application notes directly 
from the Support section of the BIOPAC website www.biopac.com. 

http://www.biopac.com/
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Chapter 2  BSL PRO Overview 
Overview 

  
The full version of Biopac Student Lab 4.1 software is called BSL PRO and performs two basic functions: 
acquisition and analysis. The acquisition settings determine the basic nature of the data to be collected, such 
as the amount of time data will be collected for and at what sample rate the data will be collected. Parameters 
can be found under the MP menu. The other menu commands pertain to analysis functions such as viewing, 
editing, and transforming data. 
Note:  Some very minor differences exist between the Windows and Mac OS  screen displays and 

keystroke/mouse functionality. These differences are noted throughout this section. 
Menu Functionality See Page 

File New, Open, Open Recent, Open for Playback, Close, Save, Save As, Save Selection 
As, Save Journal Text As, Send Email as Attachment, Copy to Dropbox, Open from 
Dropbox, Logout from Dropbox, Page Setup, Print, Go to Startup Wizard, Quit 

227 

Edit Undo, Cut, Copy, Paste, Clear/Clear All, Remove Last Appended Segment, Insert 
Waveform, Duplicate Waveform, Select All, Remove Waveform, Clipboard (Copy 
Measurement, Copy Wave Data, Copy Graph, Copy Acquisition Settings, Copy Data 
Modification History for All Channels, Copy Data Modification History for Selected 
Channels, Copy Focus Area Summary, Copy Event Summary), Journal (Paste 
Measurements, Paste Wave Data, Paste Acquisition Settings, Paste Modification 
History for All Channels, Paste Modification History for Selected Channels, Paste 
Focus Area Summary, Paste Event Summary, Manage PDFs, Show Journal) 

248 

Transform operations that primarily modify the data in the graph 
Recently Used, Digital Filters, Math Functions, Template Functions, Integral, 
Derivative, Integrate, Smoothing, Difference, Resample Waveform, Resample Graph, 
Expression, Delay, Rescale, Waveform Math, Slew Rate Limiter 

257 

Analysis operations that derive data & measurements from the graph 
Recently Used, Histogram, Power Spectral Density, FFT/IFFT, Find Cycle, Find Rate, 
Detect and Classify Heartbeats, Locate Human ECG Complex Boundaries, Locate 
Animal ECG Complex Boundaries, Heart Rate Variability, Correlation Coefficient, 
Digital Input to Stim Events, Ensemble Average, Epoch Analysis,  Focus Areas (define 
events), Waterfall Plot 

283 
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Menu Functionality See Page 

Display Tile Waveforms, Autoscale Waveforms, Optimize Ranges, Overlap Waveforms, 
Compare Waveforms, Autoscale Horizontal, Show All Data, Show Default Scales, 
Zoom back/forward, Reset Chart Display, Reset Grid, Adjust Grid Spacing, Set Wave 
Positions, Set Channel Visibility, Wave Color, Horizontal Axis, Show, Customize 
Toolbars, Channel Info, Preferences, Size Window, Cursor Style, Split View, Create 
Data View, Create Focus Area, Load All Data Into Memory 

326 

MP36/35/MP45* Set Up Data Acquisition , (Channels, Length/Rate, Event Marking, Segment Labels, 
Stimulator, Trigger, Sound Feedback), Show Input Values, Output Control, Show 
Gauge, Electrode Checker, Auto Plot, Scroll, Warn on Overwrite, Organize Channel 
Presets, Exit Playback Mode, Manage Hardware Connections 

101 

Playback Replaces the MP menu when Playback mode is active (use File > Open for Playback 
and Playback > Quit playback to toggle playback and acquisition modes) 

39 

Window Controls the position of windows on the monitor 353 
Help Provides online support files (PDF format and web links). 353 
Media Capture or Playback media files(.avi, .wmv, or mpg) and synchronize with .acq data 355 

*Triggering and Electrode Checker are not supported in MP46/45 hardware. 
 
Launching the BSL PRO software 
The first step is to launch the software by double-clicking the Biopac Student Lab desktop icon. If a 
hardware prompt appears after launching BSL PRO, there are two possibilities: The cable 
connections are faulty or the MP unit has not been properly powered on. Either of these conditions 
will generate the following warnings: 

 

  

 To use BSL PRO without an MP data acquisition unit, click the “Analyze Only” button. Click “Do 
not ask me again” or set “Preferences > Hardware” to “Always work with no data acquisition 
hardware connected.” 

 
Assuming everything is properly connected and there are no conflicts, the Startup Wizard will appear. Use 
this wizard to choose whether to create a new experiment, open a saved graph for analysis or access the Help 
and support files.  
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Startup Wizard Functionality 

Record or Analyze a BIOPAC Lesson Displays the BSL Lessons and PRO Lessons menus. This is the default view 
presented when launching the Wizard. 

Create/Record a new experiment Displays options to create a BSL PRO new graph, or open an existing graph 
template or sample graph template. (*.gtl file) 

Open a graph file Displays options to launch existing data graph files by browsing, or selecting from a 
list of recently-opened graphs. Sample data files also accessible from this view. 

Customize my lab Displays options for customizing standard or PRO Lesson procedures and onscreen 
instructions with the Curriculum Manager (licensed feature). For more information 

on the Curriculum Manager, see Chapter 18. 
Help: Manuals, User Support Links Offers Help and Support options, including a link to Web Tutorial Screencasts. 

Quit/OK buttons Cancels or confirms selected operation. 
NOTE: The Startup Wizard can be disabled in the Preferences, if desired. (Display > Preferences > Other) 

 
A “window” is the term used for the screen area where data is displayed and/or manipulated. The graph 
window on the screen is designed to provide a powerful yet easy-to-use interface for working with data. 
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Launching the BSL 4.1 Application 
To launch the full BSL application (referred to in this guide as BSL PRO), choose the “Create/Record a new 
experiment” Startup Wizard option and click OK. 
By default, the Data Acquisition Settings window is presented whenever a new graph is launched. This 
window acts as a “command central” for setting up important initial parameters such as channel setup, sample 
rate, acquisition length, event marking, triggering and more.  

 
Once these settings are in place, they can be saved for future experiments by choosing the “Save as Graph 
Template” option. Since all selected settings are saved in the template, the Data Acquisition Settings window 
will not be presented when the graph template is re-opened. However, for all new graphs, this window will 
appear on top of the application for convenient access to necessary parameters. To open the application and 
set the acquisition parameters later, click “Close.” (To set up acquisition parameters from within the open 
application window select the MP menu and choose “Set Up Data Acquisition.”) 
After setting the above parameters, use the current application window, create a new window, or open an 
existing window. To create a new or additional graph window after the original launch, choose File > New > 
Graph Window. 
Basic Analog Channel Information 
The first option under Data Acquisition Settings is “Channels.” Under this setup dialog, up to four analog 
channels, 16 calculation channels, or 8 digital channels can be selected. For more information on channel 
setups, see the analog channel setup sections beginning on page 103. 

• The default setting enables the Acquire, Plot and Value options for one channel of data on Analog 
CH1. It’s normally recommended that all three of these boxes be checked for each selected channel.  

• Four analog channels are available in MP36/MP35 hardware, two analog channels in MP46/45 
hardware. 

• Digital channels are not supported in MP45 hardware. They are supported in MP46 hardware via the 
BN-SMART-IOCBL TTL interface cable. 
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Acquire Checking the Acquire box for a given channel indicates data will be collected on that channel. 
Plot Determines if data will be plotted in real-time during the acquisition. If the plot box is unchecked, 

data will still be recorded, but the associated channel will remain hidden. The channel (and data) 
can be “unhidden” by positioning the mouse pointer over the channel number box and 
Alt+clicking.  

Value Enables a separate “Show Input Values” bar graph for numerically and/or graphically displaying 
the values for each channel in real time. 

Channel Available Channel tabs are Analog, Digital, or Calculation. In the sample above, “CH1” indicates 
Analog channel one. 

 In contrast to analog data, Digital channels collect binary data that signify when a measuring 
instrument is “on” or “off.” For example, Digital channels record whether an internal switch is 
open or closed, as in reaction time studies or control applications. Digital channels are acquired, 
plotted, and display values in the same fashion as analog channels. Digital channels are not 
supported in MP46/45 hardware. 

 Calculation channels are used for online computations and transformations of other channels. 
These channels are set up similarly to analog and digital channels but include additional dialogs 
for specifying types of transformations and computations to be performed. For a detailed 
summary of Calculation channel options, see the Calculation Channel section beginning on page 
118. 

Label To the right of each channel number is an editable field for entering channel information. 
Preset Analog and Calculation channels include onboard Presets—choose a preset and the software 

automatically sets the gain, offset, etc. appropriate for the selected application. Choose from the 
list of available presets or create a custom preset; see page 105 for details. 

Channel The channel sample rate can be varied from the acquisition sample rate. Channel sample rate 
Sampling options are equal to or less than the acquisition sample rate (as established via “MP 
Rate   > Set Up Acquisition”). The options are a specific power of 2 less than the acquisition 
 sample rate. Channel sample rate info is included in the Display > Channel Info dialog. Use 
  the pull-down menu to set the channel sample rate. See page 105 for details. 
Basic Digital Channel Information 
In contrast to analog data, Digital channels collect binary data that represent when a measuring instrument is 
“on” or “off.” (For example, records whether a switch is open or closed, as in reaction time studies or control 
applications.) Digital channels are acquired, plotted, and have values listed the same fashion as analog 
channels. For more details about Digital channels, see page 118. 
Basic Calculation Channel Information 
Calculation channels are used for online computations and transformations of other channels. These channels 
are configured similarly to analog and digital channels, but also have additional dialogues to specify the types 
of transformations and computations to be performed.  
Calculation channels include Presets as a quick way to get started—choose a preset and the software 
automatically sets the gain, offset, etc. appropriate for the selected application.  
When a new Calculation channel is enabled, a simple setup dialog corresponding to the selected preset is 
presented, which helps facilitate proper setup. Choose from the list of available presets or create a custom 
preset; see page 123 for details. 
For a detailed summary of Calculation channel options, see the Calculation Channel Chapter on page 123. 
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Setting up Acquisitions 

 
Once the channel parameters have been established, the next step is to specify the acquisition settings. Choose 
Set Up Acquisition from the MP menu to generate the acquisition parameter dialog. The basic parameters 
involve specifying:  

a) How data should be collected and stored 
b) The data collection rate 
c) The acquisition duration (total length) 

Storage Record and Append to Memory is the default acquisition option. Under this option, the hardware 
automatically records data into a single continuous file, and stores the data in computer memory 
during the acquisition. 
The third popup menu at the top of the dialog (which defaults to Memory) specifies how data is stored 
during the acquisition. The available options are Memory or Disk . Computer memory is usually faster 
(but less abundant) than disk space. Data cannot be stored directly to the hardware. 

Rate Acquisition Sample Rate is analogous to “mm/sec” on a chart recorder, and refers to how many 
samples the MP System should take each second. The higher the sample rate, the higher the signal 
quality. However, as the sampling rate increases, so does the demand for system resources (memory, 
disk space, etc.). There is a “point of diminishing return” in terms of sampling rate for almost all types 
of analog signals, where sampling above a given threshold adds relatively little information. 
The MP36/MP35 sampling rate has a lower bound of 2 samples per hour, and an upper bound of 400 
kHz aggregate. The MP46/45 sampling rate has a lower bound of 2 samples per hour and an upper 
bound of 96 kHz aggregate. The MP unit must use a pre-defined rate; it does not accept custom rates. 
The default Acquisition Rate is 2000 samples per second. 
Choose the best acquisition sample rate from the pop-up list. 
Note:  Channel sample rates are variable based on the acquisition sample rate. All channel sample 

rate options are equal to or a specific power of 2 less than the acquisition sample rate. 

Duration The final acquisition parameter is Acquisition Length (Total Length), which controls how long an 
acquisition will last. This can be scaled in seconds, minutes, hours, milliseconds or number of 
samples. Set this value either by entering a number in the acquisition length  box, or by sliding the 
Acquisition Length scrollbar left or right. The default Acquisition Length is 1800 seconds (30 minutes). 

Starting an Acquisition (Recording) 
Once the acquisition parameters have been specified and the channel setup defined, the next step is to start the 
acquisition. If a file window is not already open, choose File > New > Graph window. 
Status 
To the left of the Start button, a green circular status light should appear. The status light indicates the active 
communication link between the computer and the MP data acquisition unit. 
 If the data acquisition unit is properly connected to the computer and is powered on, the circle will be 

solid and green. 
 If the data acquisition unit is not properly connected or not communicating with the computer, the circle 

will be solid gray. 
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Start 

To start an acquisition, position the cursor over the  button and click the mouse button, or select Ctrl+ 
Spacebar. If no input devices (e.g., electrodes or transducers) are connected to the hardware, it will collect a 
small value of random signal “noise” with a mean of about 0.0 Volts. 
 For information on how to connect measurement devices to the hardware, see the BSL Hardware 

Guide.pdf. 
 To start an acquisition using a variety of “triggers,” see page 213. 
 Graphs that open without a Start Button 

o Compressed Graphs 
o Igor Pro Experiment 
o PhysioNet 
o Raw Data Files 
o Text Files 

o Analysis menu operations: 
Histogram; FFT (Magnitude and 
Phase); IFFT; Rate (put result in new 
graph option) 
 

 
Once an acquisition has started, the Start button status will toggle to Stop, and two opposing arrows will 
blink, indicating that data is being collected. The green “BUSY” indicator light on the front of the MP data 
acquisition unit will illuminate. 
Stopping an Acquisition 

To stop an acquisition at any time, click the  button in the lower right corner of the screen or select 
Ctrl+ Spacebar. 
An acquisition will stop automatically when it has recorded an amount of data equal to that indicated in the 
Total Length box. To save this data file, choose File > Save. 
Display modes 
The display modes are Chart, Scope, X/Y, Stacked Plot, and Playback. The onscreen data display can be 
changed at any time, even during an acquisition. To change the display mode, click the corresponding icon in 
the toolbar. 

 Chart mode  
Chart mode is the default display mode. 
Chart mode plots data much as it might appear on a 
chart recorder, with time on the horizontal axis. 
Each channel of data is in its own “track” across the 
screen, with borders between channels. The 
waveforms will not cross boundaries into the tracks 
of adjacent channels. 
If a waveform is plotted off the scale of the channel 
track, choose autoscale waveforms and BSL PRO 
will select the “best fit” for waveforms to their tracks. 
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 Scope mode  
Scope mode plots data much as it might appear on an 
oscilloscope, with time on the horizontal axis. 
Scope mode is similar to Chart mode, except that 
there are no borders between different channels. 
 To help emphasize the selected wave in Scope 

mode, select the “Gray non-selected waves” 
Preference (via Display > Preferences). 

Waveforms can overlap. The autoscale waveforms 
command will automatically separate the waveforms 
in the graph window. 
Note: When only one waveform is present, the scope 
and chart modes are identical.  

 X/Y mode  
X/Y mode plots data from two channels against each 
other, with the values from one channel on the 
horizontal axis and the values from another channel 
on the vertical axis. Plotting a channel against itself 
displays a straight line. 
X/Y mode can be useful for chaos investigations and 
respiration studies.  
Note: When viewing data in X/Y mode as it is being 

acquired, plotting only the most recently 
acquired data point can be a useful option. To 
do this, select Display > Show > Dot Plot and 
then Display > Show > Last Dot only. 

Switching to X/Y mode during acquisition can be 
slow. For best performance, switch to X/Y mode 
either before starting the acquisition or after stopping 
the acquisition. 

 

 X/Y mode continued 
Plotted channels 

• To change the channel being plotted: Click the Channel label once and hold. 

 
X-axis, click above the waveform; Y-axis, click left of the waveform. 

• To flip the axes: Click the upper left button 

• .  
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• To change the channel label for this plot: Click the Channel label. 

 
Toolbar icons 
The center cluster of toolbar items is specific to X/Y mode. The left two buttons in this group are shortcuts 
for the Autoscale vertical and Autoscale horizontal functions. Adjacent to these buttons are two buttons that 
perform the center vertical and center horizontal functions.  
Tools 

Cursor In X/Y mode, the I-beam tool in the lower right hand corner of the graph window changes into a 
crosshair. When the crosshair is moved into the graph window, the coordinates of the crosshair are displayed 
in the upper left corner of the graph window. The X value refers to the coordinate of the crosshair in terms of 
the horizontal axis, and the Y value describes the location of the cursor in terms of the vertical scale. By 
pressing the mouse, a crosshair is drawn over the closest data point and the measurement toolbar “snaps” to 
that position to show the amplitudes of the actual pair of data samples plotted on the screen. In BSL PRO and 
higher, the Channel number and label are also displayed next to the measurement values.  

 
X/Y plot with ECG on X-axis and BPM on Y-axis 

Autoscale In X/Y mode, the Autoscale waveform function changes to read Autoscale vertical, which 
plots the vertical channel so that it takes up two-thirds of the vertical channel space. This 
function controls the “height” of the data being plotted in the graph window. 

 Similarly, the Autoscale horizontal function plots the waveform so that the waveform is 
plotted in the center two-thirds of the window. This function controls the “width” of the data 
being plotted in the graph window.  
Autoscale commands adjust the center point and the range of data displayed. To manually 
change the scale, click in either the horizontal or vertical scale area. In this case, the scale at 
the bottom edge of the graph windows (which usually reflects time) is the scale for the X 
variable, and the vertical scale controls the scale for the channel plotted on the Y-axis. 

Center In X/Y mode, since only two channels can be displayed at a time, tile waveforms and 
compare waveform are replaced with Center horizontal and Center vertical. These two Center 
commands change the midpoint of the horizontal and vertical scales (respectively) so that the 
midpoint of the scale is equal to the mean value (average) for that channel. These features are 
useful for centering the display so that it is easier to interpret. 

Ch. # Box:  In X/Y mode, the channel numbering boxes are disabled. 
Meas. Menu: In X/Y mode, the measurement popup menus are disabled. 
Plot Recent Data Only 
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Use this option in X/Y mode to plot a user-defined amount of recent data. Checking the “Plot recent data 
only” and entering a value will hide plotting for all data not included in the entered time value. 

  
 Plot recent data option not applied  Plot recent data option applied with 6 sec. value 

 Stacked Plot mode 
Stacked Plot displays multiple time ranges on top of each other and is enabled for acquisitions set to Append 
(except when in X/Y mode). In this mode, all appended segments are stacked in the display, but only one 
segment “slice”is active (“selected”). To view an individual segment, click the Chart mode icon. 
 Click the Stacked Plot mode icon to display the Stacked Plot controls beneath the toolbar: 

 

To change the active slice, click the  Jump Tool or the … icon. 

 
The selected segment is used for all enabled software functions. This means that autoscaling can easily create 
what looks like a mess if the selected segment is not appropriate for scaling the largest segment.  
In compound action potential graphs in Stacked Plot, the last segment slice will most often be the largest, so 
selecting the last segment before autoscaling will likely yield the expected result. The Transform menu is 
disabled in Stacked Plot mode. 
A commonly used data visualization technique for examining the evolution of waveform morphology is the 
2D waterfall plot or “stacked plot.” A stacked plot draws multiple traces for a single waveform on top of each 
other, or “slices.” Each individual slice is a time-shifted plot of the original waveform. The slices toward the 
bottom of the plot occur earlier in time then the slices toward the top. 
Data can be acquired in stacked plot mode, but it is processor intensive. If acquisition setup includes high 
sampling rates or control channels with low latency, acquire in chart or scope mode and switch to stacked plot 
mode after acquisition. 
The slices can be aligned at any type of events in the graph. This allows for alignment at appended segments 
but also at locations found through other means. For example, an ECG waveform can be aligned at the start of 
the T-wave to examine how the T wave evolves in time. 
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Active slice In stacked plot mode, there is a single slice that is called the “active slice.” By default 
it is drawn in black; to change the color, select Stacked Plot Options > Drawing 
Settings. The values on the axes in the graph, grid, displayed events and text 
annotations, selections, and any transformations all apply to the active slice. The 
active slice can be changed using the navigation buttons in the graph toolbar. 

Vertical Separation The vertical separation between consecutive slices is expressed as a percentage of the 
entire visible area. This percentage is kept constant through zooming and scrolling 
operations. 

Stacked Plot Options 

 
Display > Show > Stacked Plot Options 

 
Slicing Event… 

 
Drawing Settings… 

Use Stacked Plot Options to activate slices or visually distinguish the active slice from other slices being 
drawn in Stacked Plot mode. (Display > Show >Stacked Plot Options) 
Automatic baseline  Adjusts the baseline of each inactive slice to overlap the baseline of the active slice 

prior to the application of any vertical separation. This helps compensate for baseline 
drift in a signal. If it is disabled, no baseline compensation will be applied and the 
stacked plot may exhibit visual vertical segment ordering problems resulting from 
baseline drift (but in this mode can be used as a tool to examine baseline drift). 

Gray inactive slices Draws the active slice with a solid pen and draws inactive slices with a dashed gray 
pattern pen. The gray pattern alternates pixels between the chosen waveform color 
and the white background and has the effect of lightening the inactive slices, so it 
may be necessary to zoom in to see the effect. 

Bold active slice Draws the active slice with a thicker pen. In step and line plot modes, plotting 
normally occurs with a one pixel wide pen. Inactive slices will remain one pixel wide 
while the active slice will have the thicker pen as indicated in the edit field. When the 
waveform is in dot plot mode, the pixel width will be added to the waveform's default 
dot size to increase the dot size for the active slice. 

Change active slice… Draws the active slice in a different color than the chosen waveform color. When 
enabled, the same color is used for the active slice of each waveform in the graph. 
The color can be changed by clicking on the colorwell to the right of the checkbox to 
generate a standard color picker to select color. 
 

Automatically jump…  Use the Jump tool (green arrow) to change the active slice. Each time the active 
slice is changed the left edge of the plot area will be changed to match the start of the 
newly activated slice. When disabled, each time the active slice is changed the 
display will be adjusted in such a way that the time interval between slice starting 
positions and the display origin is kept constant.  

Functionality in Stacked Plot mode 
Autoscaling 

When a graph is displayed in stacked plot mode, all autoscaling and related display operations (tile, 
compare, overlap) will examine the visible data of the active slice only. It will not be possible to perform 
autoscaling operations using the data of any inactive slice. 

Autoscale Horizontal 
In stacked plot mode, autoscale horizontal will make the active slice occupy the entire visible area. The 
slicing event corresponding to the beginning of the slice will be placed at the left edge of the screen and 
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the next slicing event (or last sample point of the waveform if the active slice is the last slice) will be 
placed at the right edge of the screen. The vertical offset will remain unaffected. 
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Data Views 
Different data views may have independent Stacked Plot settings. All settings are independent including 
drawing preferences, slicing events, vertical separation, and active slice settings. Stacked plot settings are 
stored individually for each data view in the graph file and will be restored when the graph file is opened 
from disk. 
Any graph-wide operation that may affect the active slice will update all data views that are configured to 
use stacked plot mode. This includes operations that affect the data (e.g. transformations) or events (e.g. 
waveform editing). 

Graphs Containing No Slices 
It is possible that graphs may not contain any slices whatsoever if no events match the slicing event 
criteria. If a graph in Stacked Plot mode contains no active slices, it will be drawn as if the graph was in 
regular chart mode with the following differences: 
All data is drawn using any active slice settings given in the stacked plot drawing options. 
The “Active slice” index will read “N/A”. 
The previous/next/choose slice graph toolbar buttons and “Display > Show > Stacked Plot Options” menu 
items will be disabled. 
It will be possible to view all data from t = 0 to the final data sample of the graph using the horizontal 
scrollbar. 
All autoscaling operations will function as if chart mode was active. Autoscale horizontal will make all of 
the data of the selected waveform visible on screen. 
If the table of available slices was being displayed prior to the removal/editing of the last matching slicing 
event, the table will be emptied and the “OK” button dimmed. The cancel button will remain active for 
the table window to be dismissed. 
The slicing event, vertical separation, and drawing menu items and toolbar controls will remain active. 

 Playback Mode (Replay) 
Playback mode will replay a graph file stored on disk in real time to 
simulate acquisition. Analog, digital and calculation channels are 
replayed as stored in the graph file, but in BSL PRO and higher, 
calculation channels can be reconfigured to reproduce online calculation 
channels that have no offline equivalents. Calculation channels from the 
original graph can be modified, extended, or removed without affecting 
the data stored on disk in the original graph file. 

1. Select File > Open for Playback. 
2. Locate a graph file and then click Open. 
3. A new graph window will be generated. 
 The “Connected to…: hardware menu will indicate that the 

graph will be “acquiring” data from the specified file and the 
Start button will change to a “Replay.” 

4. Press Replay to begin playback. 
 Button alternates with STOP, can’t pause. 

5. Select Playback > Quit Playback Mode to return to acquisition 
status. 
 Playback mode may also be entered and exited in the MP > 

Manage Hardware Connections “Connected Hardware” 
dialog. (see below) 

 
Use Playback to experiment with 
different calculation channels 
settings on the same data or to 
recreate an experiment for 
demonstration purposes. 
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Playback mode has millisecond timing accuracy and allows for reconfiguration of most acquisition 
parameters. Exceptions include: 

 Length is limited to the amount of data in the file 
 Acquisition Sample Rate is fixed (use Channel Sample Rate to downsample) 
 Number of analog and digital channels is fixed  
 Save last and MP modes are disabled 
 “Append” will replay the same data. 
 Journals will not be displayed during Open for Playback 
 Output Control panel will not be displayed during Open for Playback 

Do not record data while playing back a data file. If one data file is open in "Playback" mode and is 
'replaying' and a second data file is open in MP mode and is acquiring data, clicking back and forth between 
graph windows causes the MP menu to flip to the Playback menu (even though 'Connected to' shows 
communication with an MP unit). 
See the BSL PRO “4Channel.acq” file in the PRO Samples folder as a sample of data playback. 
(Main drive:\Program Files\BIOPAC Systems, Inc\Biopac Student Lab 4.1\Sample Data\PRO) 
Data Views 
A “Data View” window is used to provide an alternate view of the same data. Data can be presented in two or 
more modes for comparison, such as X/Y plots and chart plots. To compare responses in real time, turn off 
Autoplot in one Data View (e.g., Dose 1) and continue Autoplotting in another (e.g., Dose 2).  
To create a new Data View for the active (selected) graph, choose 
 File > New  and select type Data View or 
 Display > Create Data View 

This will generate a new window displaying the active graph’s data, and will name the new window “Data 

View of ‘Filename’ . 
TIP Use the Jump-to tool (see page 57) to correlate data views. 

Data Views share fundamental data characteristics such as channel labels, events, and sampling rates, but can 
be customized for the following: 
 horizontal scale, precision, and offset 
 vertical scale, precision, and offset 
 measurements, including number of 

rows, precision, visibility, and use of 
interpolation 

 grid settings, including spacing, 
visibility, and locking state 

 selected area 
 autoplotting 
 hidden channels 

 autoscrolling 
 channel button display state 
 wave color 
 event display state 
 channel order 
 plot mode 
 channel drawing mode (step, line, or dot, 

including dot plot size and type) 
 hardware “connected to” display 
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The Data View window can be used like any other graph window. The menus and controls can be used to change 
how the data is presented. An acquisition can be started or stopped in any of the Data Views for a graph, and any 
transformations performed on the data in the Data View will be reflected in the graph and all of the other Data 
Views. Printing a graph from a Data View will use the display settings of that Data View for outputting the graph. 
When a file is saved to disk, the display configurations of any Data Views that are open are saved into the graph 
file. When the graph file is reopened, all of the Data Views and their display settings will be restored. 
 Data Views are saved with the data file only if they are open at the time the original graph is closed and 

saved. 
 Closing a Data View causes this view to be lost; it is not saved with original file. 
 Closing a Data View that was previously saved with a data file will not be saved if 

the data file is saved after closing the Data View. 
 Closing a Data View will not invoke a warning that the Data View will not be 

saved. 
In BSL 4.0.1 and higher, a selected area can be shared across multiple Data Views by 
clicking and holding the left mouse button over the I-beam toolbar cursor and choosing 
the “Link Selections Between Data Views” option. (See example figure right.) 

 

Analysis 
Sample files were installed with the software. Select File > Open and choose a file from the list in the dialog. 
If opening the sample data file “4Channel.acq,” the screen should resemble the following sample file display. 

 
Sample File Display 

The sample graph displays four different types of data, and there is a border between the waveforms. 
To the left of each waveform is a vertical strip containing a text string that can be used to help identify each 
waveform. 
The time scale along the bottom denotes when the data was recorded relative to the beginning of the acquisition. 
The maximum vertical scale range is from +10 to -10 Volts. 

 This reflects the maximum input voltage the MP unit can accept and encompasses a 
greater range than normally encountered. 

 The display scale can be adjusted to virtually any value range, as demonstrated in the 
graph window above. 

As indicated by the horizontal scale, only a few seconds of data are displayed on the screen. Choosing “Channel 
Info…” from the Display menu will display the total length of the record along with other information. 
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To view data that was collected earlier in the record, use the horizontal scroll bar to move to the desired point. 
Alternatively, position the cursor in the horizontal scale area (where the numerical values are listed) and click the 
mouse button. This will generate the following dialog (see page 69 for details). 

 

 
Use the Time scale box to increase or decrease the amount of data that appears on the screen at any given time. In 
the sample dialog, this is set to 2 seconds per division. The divisions on the screen are indicated by the four 
vertical lines, thus displaying eight seconds at a time (two seconds per division times four divisions). By entering 
a larger value in this box, more of the record will be displayed on the screen at any given time. Conversely, 
entering a smaller value in this box will cause a shorter segment of data to be displayed on the screen.  (Above 
screenshot is from BSL PRO) 

 To display the entire waveform (in terms of duration), a shortcut is to choose Autoscale horizontal from 
the Display menu. The Autoscale horizontal command fits the entire data file into the window, regardless 
of the total length of the acquisition. 

The Initial time offset box can be used to “jump” to a different point in the time display. Changing the value in 
this box allows the display data beginning at a certain point in the record. For example, to see the data at the 
beginning of the record, enter an initial offset of 0 seconds, which would result in the following: 

As observed tell from the time 
scale, the first data displayed 
(at the left edge of the screen) 
was collected at the beginning 
of the acquisition. Also, the 
scroll box has moved to the 
left, indicating that the data on 
the screen represents data 
collected earlier in the record. 
After clicking the horizontal 
scale area again, the same 
dialog will appear. This time 
the value in the start box 
should have changed to reflect 
the new section of data being 
displayed on the screen. 
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BSL PRO also allows customization of the vertical scaling, or amplitude, of each waveform. Clicking the vertical 
scale area produces a dialog (see page 71 for details).  

Use the vertical scale dialog to change the range of 
amplitude values displayed (scale) and set the value that 
appears in the center of the vertical scale (midpoint).  
The midpoint and apparent magnitude of each waveform 
can be changed by modifying the values in each box. By 
changing the value in the scale box, a smaller value has 
the effect of increasing the apparent amplitude. Entering 
a number about half the current value will cause the 
amplitude of the wave to appear to double. 

• Scale—In the sample dialog, the units are set to 
25 mV per division. As with the horizontal 
scale, there are four divisions on the vertical 
axis, so this setting should show 100 mV range 
of data. 

• Midpoint—The box below this controls the midpoint of this range. In this case, the midpoint is set to 0 
mV, which means that this channel will display the range from - 50 mV to + 50 mV 

As with the time scale, BSL PRO can automatically apply the best fit in terms of midpoint and units per division. 
To do this, select  “Autoscale Waveforms” or “Autoscale Single Waveform” from the Display menu, and the 
amplitude and offset of each wave will be adjusted to fit their sections. 
Any modifications to rescaling (either horizontal or vertical) will only affect the way data is displayed, and will 
not change the basic characteristics of the data file. 
Selecting a waveform 
Although all four waves are displayed at once, it may be preferable to operate on only one channel at a time. To 
do this, the desired channel muse be selected by clicking inside its boundaries on the graph. Selecting a channel 
allows highlighting of all or part of that waveform, and enables transformations to be performed on a given 
channel. 
In the upper left corner of the graph window there is a series of boxes that represent each channel of data. The 
numbers in the boxes correspond to the channel used to acquire the data (the specifics of setting up channels are 
discussed on page 103. In the sample waveforms shown previously, ECG channels are represented by channels 1 
and 2, with respiration on channel 4 and blood pressure on channel 5. 
To select one of these channels 

• position the  cursor over the channel box  that corresponds to the desired channel and 
click the mouse, or  

• position the  cursor on the waveform of interest and click the mouse. 

Show/Hide Channel 
To “hide” a waveform, press ALT for Windows or OPTION for Mac and click the channel box. 
To view a hidden waveform, repeat the appropriate key-click combination. 
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Collapsing Channels 
In BSL PRO 4.1.1 and higher, individual or multiple channels may be quickly “collapsed” by simply clicking the  

 button appearing in the upper left region of each channel. When a channel is collapsed, all data is retained but 
hidden from view, and the button status changes to   while collapsed. Collapsing a channel allocates more 
vertical space to remaining channels, enhancing the view of visible data.  

 
Channel “Collapse” button 

NOTE: In certain operating systems, the  or   buttons may instead appear as  and  characters. See below 
example showing Channel 2 collapsed. Note that when a channel is collapsed, the channel label appears in a gray 
horizontal bar indicating the channels’ location. 

 
Channel 2 collapsed 

To expand (unhide) the collapsed channel simply click the  or  button, or double click the collapsed channel’s 
label.  

NOTES: 

• Collapsing or expanding channels is supported in Chart or Stacked Plot mode only. 

• Pressing the Alt/Option key while clicking any button will collapse or expand all visible channels 
with the exception of one. (A minimum of one channel must remain uncollapsed. It is not possible to 
use the collapse or expand button on graphs with single channels.) 

• Collapsed channels are retained when a graph is saved and reopened. 
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Zoom 
Another way to examine data is to use the “zoom” tool. The zoom tool allows any portion of any wave to be 
selected and magnified. To use the zoom tool, click the  icon in the lower right portion of the screen. As the 
cursor is moved into the graph area, note that it changes from an arrow  to a crosshair (+). Start by positioning 
the cursor in one corner of the box, holding down the left mouse button, and dragging the crosshair horizontally, 
vertically, or diagonally to form a “box” which encompasses the zoom area. Upon releasing the mouse button, 
BSL PRO automatically adjusts the horizontal and vertical scales. To “unzoom,” choose Zoom back (or Ctrl-) 
from the Display menu. 

Select an area 
Once a channel has been selected, data in that channel can be edited by selecting a section of the waveform. 
Avaliable options include cutting, copying, and pasting sections of waveforms. Transformations and Analysis can 
be applied to entire waveforms or specific sections of waveforms only. 
For any of these functions, select (or highlight) an area to be operated on. To select a section of a waveform, 
position the cursor over the  icon in the lower right hand corner of the screen and click the mouse. Now move 
the cursor to the first point in the area to be selected. When moving the cursor into the graph area, note that it 
changes from an arrow cursor to an I-beam editing tool. 

To highlight a section of a waveform, position the  cursor at the left edge of the desired area and hold down 
the mouse button. Now move the mouse to the right until the desired area has been selected. The selected area 
will have a darkened appearance. 

To select more than one screen of data, position the  cursor at the left edge of the section to be highlighted, 
then click and hold the mouse button. Use the scroll bars to move to a different point in the record, and when 
reaching the desired endpoint (right edge) of the selected area, hold down the Shift key while positioning the 
cursor and click the mouse. Selecting an area this way will also allows fine tuning of the selected area to include 
only a specific range of data. 
Once a channel has been selected and a section of that area highlighted, that particular section of the waveform 
can be edited or modified. The editing commands behave much the same way as the editing functions in a word 
processor. Copy, delete or paste sections of data as defined by the selected area. If necessary, an edit can be 
reversed by choosing Undo from the Edit menu, or by using the standard undo shortcuts CTRL + Z for Windows 
or +Z for Mac. 
Selecting a portion of a waveform also allows transformations to be applied to a particular area, rather than the 
entire area or all waveforms. Selecting an area also allows snap measurements to be taken for parameters such as 
Delta T, Mean, Standard Deviation, Frequency, and so forth. The measurement options are discussed in the next 
section. 
In BSL 4.1 and higher, the selection tool has been extended to select appended segments. To select an appended 
segment, double-click on the segment with the selection tool active. To select multiple appended segments, hold 
the Shift key down while double-clicking. 
The Selection Palette (Display > Show > Selection Palette) can also be used to select an area. 

Keyboard data selection 
Keystroke combinations can similarly used to select or deselect graph data on a sample-by-sample basis. This 
helps add an enhanced level of precision to the selection operation. See data selection keyboard shortcuts on the 
following page. (BSL PRO and higher) 

Keyboard Shortcut Description 
Windows: Shift + Ctrl + Left Arrow 
Mac: Shift + Command + Left Arrow 

Subtracts one sample interval from the right edge of the selection. If the selection is 
empty, no action is performed.  

Windows: Shift + Ctrl + Right Arrow 
Mac: Shift + Command + Right Arrow 

Subtracts one sample interval from the left edge of the selection. If the selection is 
empty, no action is performed. 

Shift + Left Arrow Adds one sample interval to the left edge of the selection. 
Shift + Right Arrow Add one sample interval to the right edge of the selection. 
Left Arrow Moves the selection one sample to the left, constructs a zero width selection. 
Right Arrow Moves the selection one sample to the right, constructs a zero width selection. 
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Transform data 
BSL PRO includes a library of functions to transform data or perform mathematical 
calculations on waveform data. All of these options can be found under the Transform 
and Analysis menus, and are discussed in detail in the Analysis section beginning on 
page 283.  
When performing transformations 

• If a section of a waveform is highlighted, the transformation will apply to 
that section. 

• If no area is selected, BSL PRO will always select a single data point. 
• If the transformation can only be performed on a selected area (digital 

filtering, for instance) and a single point is selected, the entire waveform 
will be used (and the transform entire wave option will be disabled; close 
out of the dialog and select an area if desired). 

Focus Areas 
Focus areas are comprised of selected time ranges within the graph. The purpose of the “Focus on” tool is to 
easily isolate selected areas within the graph window for discrete analysis. This can be useful for identifying areas 
of interest within a larger data set by highlighting, naming and storing them permanently in the graph. When a 
focus area is assigned, that portion of the graph will appear shaded with borders appearing at the edges. The 
assigned focus area label will be displayed vertically in the shaded area. (See following page for example.) Focus 
areas may also be defined via the “Focus on” toolbar above the graph, and in the Find Cycle Analysis feature. 

• Focus areas are graph level data, similar to events. Defining a focus area in one data view defines it for all 
data views, etc. 

• Focus areas are drawn only for graph windows in chart, stacked plot, or scope mode. They are overlaid on 
top of data and events but underneath text annotations and selections. 

• Focus areas may overlap.  
• Each focus area is required to have a unique name. 

Creating Focus Areas 
To create a focus area: 
1. Select an area of interest in the graph data using the I-beam tool or selection palette. 

2. Create the focus area using one of the following methods: 

• Click on the “add”  button to the right of the “Focus on” toolbar. 

• Choose “Display > Create Focus Area.” 

• Right-clicking in the graph and choosing “Create Focus Area” from the contextual menu. 

3. Name the focus area by typing into the label field. 

 
The new focus area label will appear in the “Focus on” toolbar field. 

 
The new focus area and label will appear in the graph. 
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Multiple and overlapping focus areas can be created by selecting additional data and using the “add”  
button.  

Navigate quickly to a focus area time selection in the horizontal axis by selecting its label from the “Focus 
on” toolbar field. 

 
To remove a focus area, use the “minus” “Focus on” toolbar button.  

TIP: To remove multiple focus areas at once, hold down the Ctrl key (PC) or Option key (Mac) and click the 
“minus” focus area toolbar button.  (A confirmation dialog will appear before focus areas are removed.) 

To rename a focus area, use the “ellipses” toolbar button.   

To highlight the current focus area, click the “highlight” button.  

Focus Areas in Specialized Analysis 
Most Specialized Analysis tools can be limited to running analysis on a focus area by choosing the “focus 
areas only” option in the setup dialog. 

 
Printing Focus Areas 

Focus areas can be included or excluded from a printed graph by selecting or deselecting the “Print focus 
areas” option in Print Setup. 

 
Focus area preferences can be modified by using Display > Preferences > Focus Areas. For further details see 
page 341. 

For Find Cycle focus area options, see the Find Cycle section on page 289. 
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The pop-up channel selection calculates a measurement either for the selected channel (SC) or from a numbered 
channel in the graph. To switch between the channel options, click in the channel window. The pop-up menu 
shows the channel numbers and labels for all channels in the file. By default, each measurement will reflect the 
contents of the selected channel. 
The pull-down measurement menu allows selection between different types of measurements. To choose a 
measurement, click the measurement popup menu and select a measurement from the list. 

• Some measurements (such as Time or Value) look at only a single data point whereas other measurements 
(such as mean and delta T) examine a range of data on the selected channel. 

• Some of the measurements that depend on a selected area (such as delta T) look at differences in the 
horizontal axis measurement whereas other range measurements (such as peak-to-peak) use the vertical 
scale information in calculating measurements. 

For a complete description of each of the measurement functions, turn to page 87. 
The final component of a measurement window is the measurement result. 

• When an area is selected (or if the selected area is changed) the measurement result automatically updates 
to reflect the change. 

Events (Markers) 

 

In many instances it is useful to have the software mark an occurrence 
or event during an acquisition so it can be referenced later. For 
example, it’s often helpful to note when a treatment began or when an 
external event occurred in order to examine any possible reaction. 
Events, or Event markers, are used to note these areas of interest. 

Event markers can be pre-established and automated. Event icons and labels appear at the top of the graph 
window, and can be edited, displayed, or hidden from view. 
Event markers can be added during an acquisition by pressing the Esc key. This will insert an event at the exact 
time the key is pressed and will activate the text line entry so a comment can be associated with the event. 
For a detailed description of event markers and event marker functions, including options to pre-establish event 
labels and set function keys for different labels, see Set Up Event Hotkeys (page 193). 
See also: Text Annotation, page 58. 

Measurements 
Measurements appear in the row of 
boxes across the top of the graph 
window. The number of visible 
measurement boxes and the display 
precision can be specified in the 
“Preferences” dialog of the Display 
menu. Each measurement consists of 
three parts: (a) the channel selection, (b) 
the measurement function, and (c) the 
result or actual measurement value. 

 
For example, the results for “SC, Selected Channel” is: 
Time  23.64800 sec 
Delta T  9.44000 sec 
Freq  1.05932 Hz 
BPM  63.55932 BPM 
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Grids 

  
Grid superimposes a set of horizontal and vertical lines on the graph window. The grid is designed to allow for 
easy measurements, since the grid lines correspond to horizontal and vertical scale divisions. The grid can be 
locked (analysis, printing) or unlocked (visual aid). 

To activate the grid display, choose Display > Show > Grid or click the  toolbar icon. 

 To display minor grid lines, use Ctrl- . 
 To customize grid line and color and optimize the display and print features, choose Display > Show > Grid 

Options. 
For more information about using and printing grids, see page 75. 
Note: The Scale dialogs change when grid lines are locked. See page 69 for details on Horizontal Scale and page 

71 for details on Vertical Scale. 
Horizontal Split View 
Horizontal Split View is a tool for “splitting” the data in a single graph into two simultaneously viewable areas 
and displaying them side-by-side for convenient viewing. Split View is available for data plotted in scope, chart 
or stacked plot modes. Both views can contain independent time scales, initial offset and autoscroll settings. This 
can be useful for making side-by-side comparisons of data at different time ranges, or for reviewing the same 
section of data in two separate time scales for more detailed examination. Split View configurations and scalings 
can be saved and restored in the graph. 

Split View can be activated via the following methods: 
 Choosing Display > Split View.  
 Clicking the Split View toolbar button.  

Either method divides the graph into two equal regions with independent time scales, and the bar in the center can 
be dragged to the desired location. 

 
In the above example, the view in the left pane was rescaled independently of the view of the same data on the 
right pane. This enables a closer view of an area of interest while maintaining the original data display. If a Split 
View encompasses any events, annotations or focus areas, these will be visible in both panes.  
 Note that events, annotations, selected areas and focus areas appearing in the Split View are duplicate 

displays of the same items. If any of these items are added, modified or deleted in one view, this change 
will also be applied to the other view. 
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 Split View is not supported in XY mode. 
 Printing of Split Views is not currently supported within the BSL application. If printing is desired, save the 

graph in *.jpg format or use standard operating system screen capture utilities. 
To exit Split View, uncheck the Display > Split View option or drag the Split View bar back to its home position 
at the left of the horizontal scale. 
 
Autoscroll Horizontal Axis Controls 
During data acquisition, three plotting modes are offered. These are normally accessed via the MP menu, but can 
be more easily dialed in by using the button in the lower right of the horizontal axis region. This button 
toggles between the following modes, and the button display changes to reflect the plotting type selected. 

Status Icon Description 
Manual  Horizontal axis is not modified by application during data acquisition. Only manual 

adjustments affect the data plot. Equivalent to unchecking both MP > Autoplotting and MP > 
Scrolling. 

Sweep  Data is plotted until it reaches the right edge of the graph. At this point the data is scrolled, 
clearing data display and showing the newly acquired data starting at the left edge. This 
mimics the “sweep” of an oscilloscope. Equivalent to checking MP > Autoplotting and 
unchecking MP > Scrolling. 

Autoscroll  New data is plotted at the right edge of the graph. When new data is acquired, existing data is 
scrolled to the left, creating space to plot new data. Equivalent to checking both MP > 
Autoplotting and MP > Scrolling. 

Journals 
The Journal is a general-purpose text editor built into BSL PRO that works like an “electronic notepad” for 
recording notes and data and saving text and/or numeric values for later review. The Journal can be used at the 
same time data is being acquired. Every graph file has a graph-specific Journal file permanently linked to it. There 
is also an option to generate independent Journals for data view, use with multiple graphs or protocols.  

 

Graph-specific journal—Journal is saved with 
graph; preferable for retaining notes and 
analysis within a graph file. Display settings 
are independent. To save a graph-specific 
Journal independent of its graph, use File > 
Save Journal Text As option. 

Independent Journal—Journal is saved into its 
own file, separately from graphs; preferable 
when performing analysis on multiple graphs 
at the same time. Independent journals allow 
multiple journal windows to be open at the 
same time (each graph view can have its own 
journal associated with it), but only one 
Independent Journal can be used at a time.  

For more information on using Journals, see Journal Details on page 80. 
Saving data 
Once data has been collected, it can be saved as a file and opened later. The data file can be moved, copied, 
duplicated and deleted just like any other computer file. By default, files are saved as BSL PRO (.ACQ) files, 
which are a proprietary format designed to store information in a format as compact as possible. Although these 
files can only be opened from within BSL PRO, the data in these files can be exported either as a text file or as a 
graphic image. 
Exporting data to a text file allows data to be examined using other programs, such as a spreadsheet or statistical 
analysis package. Saving data as a graphic (.JPG) enables working with the data in graphic format. 
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One of the most useful applications of this is the ability to edit and place BSL PRO data as it appears on the 
screen. This feature can be used to paste graphs into word processors, drawing programs, and page layout 
programs. To learn more about these options, turn to the Save As section beginning on page 237. 

Format change warnings 
When a file save function requires a format change for compatibility or alters file content, a prompt will be 
generated to require the user to confirm the option to update format or convert and save.  
 

 
Created with a previous version of BSL PRO 

 

 
Saving as a “Graph Template” will erase all data 

 
Print 

BSL PRO supports high-resolution hard copy plots of graphs 
much as they appear on-screen. 

• To print a file, choose Print from the File menu. This 
will print the contents of the screen on the selected 
printer. 

• To print the entire file, choose Autoscale Horizontal 
from the Display menu first.  

• Printing a Journal uses a separate command from 
printing a graph file. 

The contents of a file can be printed across several pages by 
entering a value in the “Fit to” box. For example, entering 
“4” in this box will place the length of the page evenly across 
four pages when printing. 
Print options are available clicking OK in the initial File > 
Print dialog; see page 246. 
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Chapter 3  User Interface & Context Menu Features 

 

 
 Toolbars 
 Keyboard Shortcuts 
 Mouse Controls 
 Custom toolbars for transformations and analysis 
 Toolbar position retention and changes 
 Event tool enhancements 
 Typed event label drawing improvements 
 Button Transparency 
 Transformation History 

 Customizable Chart Track Dividers 
 Plotting Background Colors 
 Vertical axis scaling buttons 
 Long channel labels and units 
 Graph window tooltip improvements 
 Menu item tooltips 
 Channel Info 
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Toolbars 

Many of the most commonly used features in BSL PRO can easily be 
executed with a mouse click. The toolbars contain shortcuts for some of the 
most frequently used BSL PRO commands. Click an icon to activate it; icons 
are grayed out when they are not applicable. 
Toolbar position—Toolbars for Measurements, Channel number, and 
Hardware revert to the default location when a file is opened (position is not 
retained). 
By default, a minimal toolbar configuration is presented when AcqKnowledge 
is first launched. The default toobars will appear as follows: 

 
The default toolbars consist of: 

• Start/Stop button 
• Cursor Toolbar (Arrow, I-beam and Zoom tools) 
• Main Toolbar (Grid, Toolbar Display, Preferences and Customize Toolbar buttons) 

The full range of available toolbars can be displayed by enabling the checkbox options in the Toolbar 
Display shortcut button , or via Display > Show and enabling the desired options. Once the toolbar 
options have been selected, this will be the default toolbar display for all new graphs. All toolbars can be 
deselected and hidden with the exception of the Start/Stop button and the Cursor Toolbar (Arrow, I-beam 
and Zoom tools). 
Saved graphs created with different toolbar configurations will open with those toolbar options displayed.  
Toolbar position—Toolbars can be dragged and repositioned to any border of the graph window, or 
floated on top of a graph. Toolbars retain the last position they were left in after the application is closed 
and a new graph reopened. 
Restoring the default toolbar position – The default toolbar positions can be restored by going to 
Display > Preferences > Other and selecting “Reset toolbar positions.” The application must then be 
closed and relaunched for the reset to take effect. 

 
NOTE: The “Reset toolbar positions” option restores the default toolbar locations only; it does not hide 

toolbars or restore the default minimal toolbar configuration displayed upon first launch. To 
return toolbars to the default minimal configuration, it is best to deselect unwanted toolbars in the 
toolbar display menu. (Use the Toolbar Display shortcut button or Display > Show.) 

 The toolbars can be reset to the default minimal configuration by holding down the Shift key 
while launching BSL PRO but this is a “nuclear” option.” Choosing this option will reset ALL 
program defaults to the factory configuration. Do not choose this option if the configuration 
contains custom settings that need to be saved. 
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Main, Display and Scaling Toolbars 

 
Main Toolbar 

 
Display Mode Toolbar 

 
Scaling Toolbar 

TOOLBAR ICONS FUNCTION 

 
Show/Hide gridlines in the graph window. Click and hold the mouse to display 
various grid preset options. 

 
Opens popup menu for showing/hiding individual toolbar options. 

 
Opens the Preferences dialog. 

 
Opens the customize toolbar menu. 

 
Change display to scope mode. 

 
Change display to chart mode (default). 

 
Change display to X/Y mode. 

 
Toggle Stacked Plot (overlap segment) mode; see page 36. 

 
Horizontal Split View; see page 49. 

 
Create Data View; see page 40. 

 
Autoscale selected waveform only. 

 
Autoscale waveforms along the horizontal axis. 

 
Show all data in graph by autoscaling both horizontally and vertically. See page 
330 for details. 

 
Center waveforms vertically in the active window. 

 
Center waveforms horizontally in the active window (X/Y mode only). 

 
Adjusts vertical scale of selected channel to display full range of data. See pages 72 
and 329 for more details. 

‘Connect to’ Hardware toolbar 

 
The ‘Connect to’ hardware toolbar displays connection information and allows quick access to adding or 
switching hardware. The Hardware toolbar reverts to the default location when a file is opened (position 
is not retained). 
To switch the hardware unit associated with a graph window, click the “Connect to” box and select an 
available unit or choose ‘Add New Device.’ Different hardware types may be added and consolidated in 
the list by selecting ‘Add New Device’.  
Choose ‘No Hardware’ to run BSL PRO in analysis mode only. 
Using ‘Connect to’ to run Multiple Hardware 
BSL PRO can be used with multiple data acquisition units to: 
 Control multiple, independent experiments on one computer 
 Increase the total number of channels used for a single experiment (e.g., 32-channel EEG) 

To synchronize the Start of multiple units, use the Trigger function. 
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To show/hide the “Connect to:” information, toggle the Show/Hide Hardware icon in the Toolbar. 

  

To switch the hardware unit 
associated with a graph window, click 
the “Connect to” box and select an 
available unit. To add new hardware, 
choose ‘Add New Device.’  
Once added, the new hardware type 
will appear in the ‘Connect to’ list. 
Choose ‘No Hardware’ to run BSL 
PRO in analysis mode only. 

 
 

Each graph window can support a 
different MP unit. To add an MP unit 
for acquisition, open a New Graph 
(not a Data View). 

 
If more than one hardware type has 
been connected via ‘Connect to’, 
subsequent new graph windows will 
contain a hardware selection menu. 
For additional control of hardware 
types and connections, see MP > 
Manage Hardware Connections on 
page 222. 
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Cursor toolbar 

 
Cursor tools are used in many of the on-screen functions described below, including editing, 
measurements, and the amount of data displayed. 
NOTE: The four rightmost icons on the Cursor toolbar (Event tool, Zap tool, Jump tool, and Annotation 
tool) do not become visible until data has been acquired, or a graph containing data has been opened. See 
below for full description of all toolbar button functionality: 
CURSOR TOOLBAR 

 
This is a general-purpose”arrow” cursor tool, used for selecting waveforms, 
scrolling through data, and resizing the chart boundaries between waveforms 
when in chart mode. All other cursors default to this mode when the cursors are 
moved outside the graph area. Use Alt-click to step through the channels; each 
click makes a new channel “active.” The arrow cursor can also be activated by 
the Ctrl+B keystroke. 
In BSL PRO and higher, holding down the left mouse button with the arrow tool 
positioned over a graph channel will activate a single data point, which displays 
as a solid black vertical line. This is known as “spot measurement” mode. 
Dragging the mouse will then update selected measurement values to the new 
horizontal locations of the arrow’s position in the graph. The mouse button 
should be depressed for approximately 0.5 seconds in order for spot measurement 
mode to become active. Releasing the button restores the arrow cursor to its 
normal status.  

 
This is a standard “I-beam” editing tool. This tool is used to select an area of a 
waveform (or waveforms) to be edited or transformed. To select it, click the 
middle button in the lower right hand corner of the screen. Now move the cursor 
toward the waveform. Note that the cursor changes from an arrow to an I-beam 
when placed over the graph area. Using this tool to edit data is analogous to 
editing text with a word processor.  
When this cursor appears, an area of data can be selected by holding down the 
mouse button and dragging the mouse to either the left or right. Extend the 
selected area to include data not visible on the screen by positioning the cursor at 
the left edge of the area to be selected and clicking the mouse button. Next, use 
the scroll bars to scroll through the data until the desired data appears on the 
screen. Hold down the shift key while positioning the cursor to select the right 
edge of the area to be selected. Click the mouse button to select the area. To 
extend the selection, hold the Shift key and move the cursor or the arrow keys. 
The I-beam cursor can also be activated by the Ctrl+I keystroke. 
Clicking and holding on the I-beam tool will generate a pop-up menu for 
displaying the Selection Palette or linking selections between Data Views. 

 

 
When “Link Selections Between Data Views” is selected, the standard I-beam 
cursor icon will change to one with a link appearing across it. When enabled, any 
area selected in a Data View or source graph will also be applied to any other 
associated data view. For more details, see Data Views on page 40. 
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This is a standard “zoom” tool. The zoom tool is used for selecting and 
magnifying any portion of any waveform. Click the  icon (in the lower right 
portion of the screen) to use the zoom tool. As the cursor is moved into the graph 
area, note that it changes from an arrow  to a crosshair (+). Start by positioning 
the cursor in one corner of the box, then hold down the (left) mouse button and 
drag the crosshair horizontally, vertically, or diagonally to form a “box” that 
encompasses the area of interest. When the mouse button is released, the 
horizontal and vertical scales will be re-adjusted. To “unzoom,” choose “Zoom 
Back” from the Display menu or use the Ctrl – keystroke.  
Hold the “Alt” key to change the zoom mode to zoom out (“– “in the magnifier). 
The zoom tool can also be activated by the Ctrl+G keystroke. 

Grid 
Control 

 

Adjust the grid lines horizontal and vertical. Hold the option key for locked grids 
to drag to the end. 

Event 
Definition 

 

Inserts an event at the mouse click location. See page 199 for Event details. 
 On a plot, the horizontal location matches the ‘x’ coordinate of the click 
 In Chart mode, the event will be placed on the channel track where the 

click took place. 
 In Scope mode, the event will be defined on the active channel. 

 Within the event bar, clicks define global events. 
When Event Definition is active, the cursor changes to a flag and the cursor 
includes a downward pointing arrow to indicate where the event will be defined. 
The Event Definition tool is disabled in X/Y mode and if events are not visible. 

Event 
Removal 
“Zap” 

 

Deletes event(s) from a graph with the mouse. It allows for quick editing to 
eliminate misclassified events found through visual inspection. 
 If the user clicks on a single event, that event will be removed from the 

graph.  
 If the user clicks and drags to define a rectangular area (similar to the zoom 

tool), all events between the left and right edges of the area will be removed; 
the event icon does not need to lie vertically within the bounded area in order 
to be removed. 

When Event Removal is active, the cursor changes to a lightning bolt. 

Jump-to 

 

Data views and advanced analysis output display multiple representations of the 
same data at the same time. Sometimes this association may be abstract or 
difficult to visualize. The Jump-to tool is a green arrow, and is available in all 
display modes and during acquisitions. 
Use the “Jump-to” tool to correlate data. 

• Click the Jump tool on a data point to “jump”all of the open data views 
for that graph to the same time. 

• Click the Jump tool on a point in an X/Y plot to jump data views in chart 
or scope mode to the point in time corresponding to the point in the X/Y 
plot. This can be useful for correlating PV loops back to other acquired 
signals. 

• Rate analysis output graphs will jump back to the corresponding point of 
source data at the start of that cycle. 

• Clustering scatterplots will select the appropriate segment of the source 
graph corresponding to the chosen data point. 
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• Change the active segment in Stacked Plot mode; once a trace is selected 
the display will adjust to show the new active segment. 

Text 
Annotation 

 

Use Text Annotation to add floating text notes on top of data in a graph; the text 
notes move and scale with the data. During report or figure preparation, it is nice 
to be able to add additional textual information on top of signals to help clarify 
signals for readers or draw their attention to particular areas of visual interest. 
BSL PRO provides a text annotation facility to assist in figure preparation. 
Click the A icon and then click in the graph window to generate the Text 
Annotation Contents dialog. Drag the red “handles” from the annotated text to 
add connector lines to connect the text to the data.  

 
Text 
Annotation 

 
continued 

 
 

 

 

 

 
Connector handles 

 
Add a range 

 
Resize a range 

 
Move a connector 
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Text annotations are short pieces of text that float above channel data and can be 
used to draw visual attention to particular areas of interest in a graph. These text 
annotations can be simple outlined text, can have a connector from the outline 
boundary to a specific sample point on the waveform, or have a range indicator 
of a specific width. Each text annotation is tied to a sample of data in a channel; 
when the data is moved by coping, pasting, or other waveform editing operations, 
text annotations remain fixed to their corresponding sample positions, similar to 
channel events. 
Although text annotations are tied to horizontal locations like events/markers, 
they are displayed in a relative fashion. The relative pixel distance between the 
text annotation outline boundary and the sample of data remains the same under 
zoom and autoscaling operations. 

• For example, an annotation that is 20 pixels above a T-Wave peak 
position will continue to be drawn 20 pixels above regardless of zoom. 
This allows for flexible data viewing while maintaining text annotation 
visibility. 

Text annotation controls 
Create Insert using the text annotation cursor tool. With the tool 

active, click in the graph to define a new annotation. 
Select Click an annotation once to select it. 
Reposition Drag a selected annotation to reposition it. 
Add Connector Connectors or range indicators can be added to selected 

annotations by using the editing handles on the edges of the 
selected annotation. 

Edit Connector If the selected annotation has a connector to a data point of the 
graph, an editing handle will appear on the end of the 
connector. The connector can be moved to a different data 
sample of the graph by dragging the editing handle on the end 
of the connector to the new position in the channel. To 
remove the connector, grab the editing handle on the end of 
the connector and drag the mouse inside the text annotation. 

Range Indicator If the selected annotation has a range indicator, editing 
handles will appear at both ends of the range indicator. To 
resize the range indicator, grab an editing handle and move 
the mouse. To remove the range indicator, grab an editing 
handle and move the mouse back inside the text annotation. 

Autoposition Resizing windows or adding channels may reposition text 
annotations outside of the visible area. Click and hold down 
the text annotation tool to activate the text annotation popup 
menu. The “Autoposition Hidden Annotations” option 
automatically repositions all annotations so they are visible. 
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Clear all Click and hold down the text 

annotation tool to activate the 
text annotation popup menu. 
The “Clear all annotations” 
option will clear all annotations. Since this action cannot be 
undoe, a prompt will appear confirming the selection.  

 
Selection palette 

 
Many of the tools within the BSL PRO environment are based around the selection. The selected range of 
data in the graph is used as the source for measurements, waveform editing, transformations, and other 
operations. The Selection Palette is a floating dialog that can be used to precisely enter the selection. See 
page 335 for Selection Palette guidelines. 

Start/Stop toolbar 

toggles to   

Channel Number toolbar 
Toggles the display of channel number and label region. The 
Channel Number toolbar reverts to the default location when a file 
is opened (position is not retained). 

 
 

Events toolbar 

 
Select a event to enable the toolbar. Use the arrows to move 
forward or backward through all event marker types. Click the 
event palette icon to generate the event palette. 

Focus Area toolbar 

 
Use the Focus Area feature to isolate portions of data that are of 
particular interest within a graph. Focus Areas can be defined, 
added, labeled and deleted within any portion of the graph. For 
more details on creating and using Focus Areas, see page 46. 

Measurements toolbar 
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Click the down arrow for quick access to measurement preset functions, including pre-loaded options for 
organizing measurement rows and columns. Or create and save custom measurement display presets by 
choosing New Preset, entering a name for the preset, and clicking OK. 
Right-click in the measurement bar for quick access to options for copying measurement and using linear 
interpolation. The Measurements toolbar reverts to the default location when a file is opened (position is 
not retained). 

Custom toolbars for transformations and analysis 
BSL PRO and above allows users to construct new toolbars 
for triggering transformations and analysis. An arbitrary 
number of toolbars may be created and populated with 
buttons that can trigger any menu item in the Transform 
and Analysis menus. The contents of the text-only buttons 
match the menu item title. These toolbars will persist for 
each user and their positions and visibility within the graph 
window will be retained. 

 Transformation toolbars may be accessed via the 
"Customize Toolbars" button next to the rewind button.  

 
 
 
 
Toolbar position retention and changes 
Toolbars can be rearranged within the graph 
window or detached and turned into floating 
tool windows. Any modifications made by 
the user to the position of most toolbars 
within the graph window will be stored as an 
application preference and used for new 
graph windows as they are created and graph 
files that are opened from disk; however, 
toolbars for Measurements, Channel number, and Hardware will revert to the default location when a file 
is opened (position is not retained). Default toolbar positions have changed to move the Start button and 
cursor tools to the top of the graph window; users preferring the ordering in previous versions may 
manually reposition the toolbars. Toolbar Tooltips may be deactivated when toolbars are detached from 
a graph.  

Axis Controls 

 

If axis controls interfere with scale values,  

  
adjust the opacity slider in Preferences > Graph 

 
to hide the icons until the cursor passes over them 

. 
 

 
A “scaling” button acts as a shortcut for opening the grid and visible range dialog, similar to 
double-clicking the axis. If a channel corresponds to an analog channel that has calibration steps, a 
calibration wrench button be displayed and will open the hardware calibration dialogs. This allows 
visual access to commonly used operations for channels. 
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Module dependent: Generate the scaling or calibration dialogs for the channel input or calculation. 
Analog inputs will open to the scaling dialog and channels that require calibration will initiate a 
repeat calibration routine.  

 

 
Use Display > Channel Info or use the channel’s contextual menu to display the Channel 
Information. 

 
Toggle the lock icon at the right edge of the window to change the lock state of the grid for 
horizontal axis or the channel. Unlocked is open (latch to right); locked is closed. 

 
Enable cursor tools during acquisitions 
Enables access to cursor tools while recordings are in progress. (Display > Preferences > Graph) 

Button Transparency 
Scaling, calibration, transformation history, and grid lock buttons may be made semi-transparent to allow 
units, axis values, and other information underneath the buttons to remain visible. The Preferences > 
Graph panel includes an “Axis controls” slider to change drawing from fully transparent to fully opaque.  
When the mouse is within the buttons, they will be drawn fully opaque regardless of transparency setting. 
The transparency is shared by the scaling, calibration, transformation history, and grid lock buttons and is 
the same for all open graphs as this is an application-level preference. 

Customizable Chart Track Dividers 
Users may change the color used to draw the dividers between channels tracks The Preferences > Graph 
panel contains "Chart Track Divider Appearance" options.  

Plotting Background Colors 
Customizable background colors for individual graph channels are available in Preferences > Graph > 
Plotting Background Colors. 

Spectrum Analyzer Palette 
The Spectrum Analyzer Palette provides a dynamic display of the 
frequency decomposition of data, in real time or post-acquisition.  

See page 338 for details.   
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Keyboard shortcuts  
Menu Option Windows OS Mac OS  

Program info Help > About Biopac Student 
Lab 

Help > About Biopac 
Student Lab 

Start/Stop Acquisition Ctrl + Spacebar  + Spacebar 
File menu   

New  Ctrl + N  + N 
Open Ctrl + O  + O 
Open Recent Ctrl + 1, Ctrl + 2, etc.  + 1,  + 2, etc. 
Close Ctrl + W  + W  
Save Ctrl + S  + S 
Print Ctrl + P  + P 
Quit Ctrl + Q  + Q 

Edit menu   
Undo (when applicable) Ctrl + Z  + Z 
Cut Ctrl + X  + X 
Copy Ctrl + C  + C 
Paste Ctrl + V  + V 
Clear Last Segment Use Rewind toolbar button Use Rewind toolbar 

button 
Clear All Segments Ctrl + Rewind toolbar button  + Rewind toolbar 

button 
Duplicate Waveform Ctrl + D  + D 
Select All Ctrl + A  + A 
Clipboard 
 > Copy Measurements 
 >  Copy Wave Data 
> Copy Acquisition Settings 

 
Ctrl + K 
Ctrl + L 
Ctrl + U 

 
 + K 
 + L 
 + U 

Journal 
 > Paste Measurements 
 > Paste Wave Data 
  > Paste Acquisition Settings 

 
Ctrl + M 
Ctrl + / 
Ctrl + J 

 
 + M 
 + / 
 + J 

Transform Menu   
Recently Used Ctrl + Shift + 1, Ctrl + Shift 

+ 2, etc. 
 + Shift + 1,  + Shift 

+ 2, etc. 
Analysis menu   

Recently Used Ctrl + Alt + 1, Ctrl + Alt + 2, 
etc. 

 + Alt + 1,  + Alt + 2, 
etc. 

Find Cycle Ctrl + F  + F 
Find Next Cycle Ctrl + E  + E 
Find All Cycles Ctrl + R  + R 

Display menu   
  Autoscale Single Waveform 
  Autoscale Waveforms 

Ctrl + Shift + Y 
Ctrl + Y 

 Shift +  Y  
 + Y 
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Menu Option Windows OS Mac OS  
  Autoscale Horizontal Ctrl + H  + H 

Zoom Back 
Zoom Forward 
Show  
> Selection Palette 

Ctrl + - (minus key) 
Ctrl + = (equal key) 
 
Ctrl + Shift + = (equal key) 

 + - (minus key) 
 + + (plus key) 

 
 + Shift + = (equal 

key) 
Cursor Style 
> Arrow 
> Selection 
> Zoom 

 
Ctrl + B 
Ctrl + I 
Ctrl + G 

 
 + B 
 + I 
 + G 

MP36/MP35/MP46/MP45 menu   
Autoplotting Ctrl + T  + T 
Exit Playback Mode for all graphs Ctrl + Exit Playback Mode  + Exit Playback 

Mode 
Window menu 

Select Next Tab 
Select Previous Tab 

 
Ctrl + Tab 
Ctrl + Shift + Tab 

 
 + Tab 
 + Shift + Tab 

Horizontal Scroll Location 
 

 

In chart, scope, or stacked 
plot mode (i.e., all but X/Y) 
these keyboard shortcuts can 
be used to scroll to various 
parts of the graph. 

-- 

Home Jumps to t = 0 (i.e., places 
first sample of data flush 
with left of graph window) 

-- 

End Jumps to the end of the 
currently selected waveform 
(i.e., places last sample of 
data of the selected 
waveform flush with right of 
graph window) 

-- 

Page Up Scrolls backward in time one full screen (i.e., places 
leftmost sample of previous visible area at the right of the 
new visible area). 

Page Down Scrolls forward in time one full screen (i.e., places 
rightmost sample of previous visible area at the left of the 
new visible area). 

Analog Channel Shortcuts 
Force Recalibrations 

 
Shift + Rewind button 

 
Shift + Rewind button 
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Mouse Controls 
Contextual menu items correspond to the BSL PRO main menu state. 
Application menu customization has a corresponding effect on contextual menu display. If a contextual 
menu item does not have a corresponding application menu item, the menu customization file identifier 
will begin with “IDM_CM.” 
The following options can be accessed with a right-click for Windows or Control-click for Mac.  

 Mac OS  only: If the mouse is over a portion of the graph that has a context menu available, the 
cursor will change to an arrow with a menu. 

Graph window 

 

Journal window 

 
 

Horizontal Scroll 

 
Vertical Scroll 

 

Measurements 

 

Events 
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Mouse Scrollwheel Support 
The scrollwheel operates on whatever window is underneath the mouse; this window does not need to 
be the topmost window. Many third-party mice include scrollwheels, scrolling balls, or trackpads to 
allow for quick access to navigating through a document. Mice may provide two separate controls, 
one for scrolling vertically and one for scrolling horizontally. 

BSL PRO supports horizontal and vertical scrolling using the scrollwheels on the mouse. Scrolling is 
supported in graph windows, journal windows, the event list in the event palette, and a number of other 
dialogs and windows that contain scrollable lists. A dynamic zoom operation can easily be performed in 
an BSL PRO graph channel by holding down the Ctrl key (PC) or the Option key (Mac). Scroll ‘up’ to 
zoom in and ‘down’ to zoom out. (Zoom operation supported in BSL PRO and higher) 

Mac OS: To increase the scroll speed, hold down the “Option” key while using the scrollwheel. 

Transformation history 
Transformation history functionality provides the ability to track transformations that are performed on 
channel data. This gives a visual indicator of whether transformations have been applied to a channel 
and a record of the sequence of transformations and the parameters for the transformation. The history 
for the channel is viewed in the "Channel Info..." dialog. This dialog is accessible via the Channel Info 
option of the context menu or the Display > Channel Info menu item. This dialog replaces the 
"Statistics" dialog used in earlier versions.  

Cancelling Transformations & Transformation Progress Bar 
In BSL 4 and higher, transformation cancel support was restored to the software to offer Cancel 
buttons in progress dialogs that indicate the completion status of threaded transformations. Progress 
dialogs have also been enhanced so the textual message includes a graphical progress bar with the 
percentage that is completed. If the progress message does not contain a percentage, an indeterminate 
progress bar will be displayed.  
BSL 4 and higher extends the analysis package to display dialogs while analysis routines are in 
progress. This progress dialog contains a cancel button which may be used to terminate the analysis 
before it is complete.  
The event tool allows events to be inserted on a graph with the mouse. When performing event 
editing, three new context menu shortcuts have been added to help make the process quicker:  

  
 Assign Current Event Type: Right-click an area with no data to set the type of event that will 

be inserted on the next left-click of the mouse. 

 Event Palette: Toggles event palette displays. 

 Edit event: Right-click a specific event to open the event palette to Selected Event controls 
for the event that was right-clicked. 
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Typed event label drawing improvements 
The Event system has been enhanced to allow different drawing options for channel-specific events 
when they are drawn in the data plotting area. These drawing options are applied to event labels, 
event amplitude markings, and event time location text. The following drawing options may be 
customized:  
 
 Font (including family, size, italic/bold, and other options)  

 Rotation angle of text baseline  

 Text alignment (left, center, right)  

 
Channel label and units length and tooltips 
Character length limitations for channel label and units have been expanded: labels may now be up to 
1032 characters and units may be up to 511 characters. Tooltips have been added to display the full 
channel units when the vertical axis is moused over. Tool tips do not wrap, so long labels may extend 
beyond the visible viewing area of the computer monitor. 

 
Graph window tooltip improvements 
Several of the toolbar buttons and the Start/Stop button in the graph window are associated with keyboard 
shortcuts that may be used instead of the buttons. Tooltips for these toolbar buttons display the 
corresponding keyboard shortcuts. Toolbar Tooltips may be deactivated when toolbars are detached 
from a graph. 

 
Menu item tooltips 
Starting with BSL PRO, menu item tooltips will display informational text about how menu items may be 
used. (Similar text was displayed in earlier versions of BSL PRO for Windows in the status area and in 
earlier versions of BSL PRO for Mac as Balloon Help). Analysis menu tooltips have been expanded to 
provide more detail regarding the types of analysis that are performed by the selected item. 
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Chapter 4  Editing and Analysis Features 
Overview 
This section provides a brief overview of some of the most frequently used BSL PRO features and 
functions. For more detailed information about specific features, turn to Chapters 9 through 13.  
In the Startup Wizard, select “Open a graph file” and “Sample data file.” Then from the PRO option, 
select the “4Channel.acq” file. The screen should look like this: (NOTE: Position of toolbars may vary, 
as these are user-configurable.) 

 

Edit menu functionality during acquisition 
The following Edit menu functions may move or alter memory and cannot be performed during 
acquisition: Undo, Cut, Clear, Clear All, Paste, Insert Waveform, Duplicate waveform, and Remove 
Waveform. 
 
Scroll bars 
Note that here are four channels of data in this file (ECG, PPG, Stethoscope, Resp). Although this record 
is 23 seconds long, only a few seconds are displayed on the screen at one time. Browse to different 
locations in the record by dragging the scroll box at the bottom of the screen. Dragging the box left moves 
to earlier points in time, and moving right displays events closer to the end of the record. Clicking the 
arrows at either end of the horizontal scroll bar allows movement to different points in time at smaller 
increments. 
A vertical scroll bar is on the right side of the screen, and. Clicking the scroll arrow at the top of the box, 
note that one waveform appears to move down within its “track” on the screen. Moving this scroll box 
changes the amplitude offset of a selected channel. As with the horizontal scroll bar, either move the box 
or click the arrows. 
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Scaling 
Horizontal axis 
Click the horizontal scale (above the scroll bar) to generate a dialog where values can be entered for 
units per division and horizontal scale offset.  

 
Time Scale 

The time interval (units per division) between the on-screen grid marks. There are four vertical 
divisions per screen, and the default is 2.00 seconds per division, so eight seconds of data will be 
displayed on the screen display. Entering a larger value will display more of the record, and entering a 
smaller value will display less. 

Initial offset 

 The time corresponding with the first data point displayed. For example, to display the middle 1/3 of 
the data file (assuming the record is 30 seconds long), set the offset to 10 seconds and the seconds per 
division to 2.5 seconds. 

Precision 

Controls number of decimal places following whole units appearing in the horizontal axis. 

Hold Relative Position for Append acquisitions 

This option is active in Append acquisition mode only. When checked, the display for appended 
acquisitions will show the same relative position with respect to the start of acquisition. This is 
convenient when performing short-duration; high-speed acquisitions where a user needs to zoom in 
on a signal of interest and have the relative position (from the start of acquisition) stay the same.  

When zooming in on a section of data within a recording segment, the next appended segment will 
“hold” its relative horizontal position (start and end times with respect to the start of each segment).  

When using the I-beam tool to select a sub-section of the data, this sub-section will hold its relative 
position and update the measurement values on each subsequent appended segment. 

If the selected data area falls within two or more appended segments, this feature is not implemented. 

Example of Hold Relative Position feature: 

Action Potential setup: 100,000 samples/sec, 50 millisecond recording length, Append mode and 
stimulator set to output 19 milliseconds after the start of the recording.  

After the first recording segment, the zoom tool is used to expand the area of interest (top figure 
below). The I-beam cursor is used to select a measurement area around the nerve response. The “P-P” 
measurement shows the nerve response amplitude. After clicking Start and recording the next 
segment, the relative position of both the horizontal time scale and the measurement selected area, 
with respect to the start of recording is maintained (bottom figure below). This makes it very easy to 
measure the changes in the amplitude of the nerve response with changes in stimulus level. 
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Global Grid Settings 

Opens dialog for applying master grid settings for all channels. For more details, see Grids on page 
75. 

Channel Grid Settings 

Opens dialog for selectively applying grid settings to one or more channels. For more details, see 
Grids on page 75. 
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Vertical (Amplitude) axis 

   
Clicking the mouse in the vertical scale area (where the amplitude of each channel is displayed) 
generates the Set Screen Vertical Axis dialog, where values can be entered for units per division and 
vertical scale offset. 

Scale  
Determines the limits of the viewable vertical axis scale (usually Volts). BSL PRO divides each 
channel into four vertical divisions. When data is displayed in chart mode, each “track” is divided 
into four divisions. When data is displayed in scope mode (or if there is only one channel of data) 
the entire screen is divided into four intervals. To increase the apparent amplitude for a given 
channel, set this value to a smaller number; entering a larger number will cause the waveform to 
appear to have less variability. 

Midpoint  
Refers to median displayed value for a particular channel. A checkbox to the left of each of these 
options allows these scaling options to be applied to all channels. By default, the selected scaling 
options will apply only to the channel indicated in the dialog. To apply to all channels, click all of 
the checkboxes. 

Precision 
Controls number of decimal places following whole units appearing in the vertical axis. Can be 
applied to selected or all channels. 

Apply to all channels 
 Applies settings selected in the various dialog options to all channels. 



72  BSL PRO Manual 

Visit the online support center at www.biopac.com 

Range Guide 
The Range Guide is a green bar that runs along the vertical scale in the graph 
window for analog channels (see right). 
It displays the maximum signal range for the Gain established for that channel. 
The Range Guide can be used as a visual aid to establish the proper Gain. 
The MP hardware measures the actual input voltage and compensates for the 
Gain. As Gain increases, the peak-to-peakof a waveform stays constant but the 
resolution increases.  
Proper Gain will have a smoothing effect on the signal.For the best resolution, 
establish Gain such that, allowing for baseline drift (if applicable) and the 
maximum peak-to-peak of the signal, the maximum signal display is close to the 
maximum range. If the signal is clipped (Fig. 1), lower the Gain. If the signal is too small compared to the 
range (Fig. 2), increase the Gain to improve signal resolution. Gain settings create a trade-off between 
range and resolution.  

  
Fig.1: “Clipped” signal   Fig 2: Signal too small compared to range 
Different gain settings applied to the same signal source show that 
Higher Gain = better resolution + lower range (Figure 3, top)  
Lower Gain = worse resolution + higher range (Figure 3, bottom) 
To display the full range (Fig. 2 vs. Fig. 3, for example), adjust the 
Vertical Scale. 
The Range Guide will always reflect changes made to the channel 
Scaling. 
To quickly see the total range of each input channel, select 
Optimize Ranges from the Display menu. This will automatically 
adjust the upper and lower viewable limits of the Vertical Scales 
for all channels. Fig. 3 
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Adaptive Scaling 
Adaptive scaling uses the data to automatically determine the appropriate visible range for the 
data. As the data changes or the baseline shifts, the visible area shifts along with the data to 
ensure that data will always be plotted on the screen. Rather than limiting data visibility to a fixed 
voltage range, the range adjusts for factors such as background noise, electrode movement, EMG 
interference, disconnection, etc. 
Adaptive scaling can be applied to channels individually and can be unique for each Data View. 
A “settings” button is activated when to “Use adaptive scaling” is enabled.  

 
Scaling changes will be applied whenever the domain of the plot area is changed. This includes 
manual changes to the horizontal scale, horizontal scrollbar use, horizontal auto-scrolling when 
dragging out a selected area, auto-scrolling or auto-plotting during acquisition, initial enabling of 
adaptive scaling and auto-scrolling when executing Find Cycle/Peak functions.  

Show Textual Value Display 
This option enables a real-time display of the most recently acquired values on a channel-by-
channel basis, providing amplitude information akin to clinical monitoring displays. This can be 
useful for obtaining a quick visual numerical summary of incoming data while a recording in 
progress. 

 
In post-processing, the value display can be seen by performing a “spot measurement” (clicking 
the arrow cursor on a single data point).  



74  BSL PRO Manual 

Visit the online support center at www.biopac.com 

 
Textual value display in spot measurement mode 

Textual value display can be customized for font, color and style, and positioned at the top left, 
bottom left, top right, or bottom right of any selected channel. These options can be configured 
independently per channel or applied to all channels. 

• In chart and stacked chart modes, the value display will appear for all enabled channels. 
• In scope mode, the value display will appear only if the selected channel has the value display 

option enabled. 
• Textual value display is not supported in XY mode. 
To enable textual value display: 
Click on the vertical axis area to open the setup dialog and enable the “Show textual values display” 
checkbox. Use the Settings button to set the font style, size and color.  

  
Channel Grid Settings 

Opens dialog for selectively applying grid settings to one or more channels. For more 
information, see Grid Details on page 75. 
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Grid Details 
Grid display can be customized in a number of ways. 

 
Grid Lock/Unlock 
Each scale has a small padlock in the lower right hand corner that displays the current state of the grid 
lock for that axis and channel. Click the padlock to change the lock state. 
  Unlocked grid—the number 

of grid lines and their pixel 
spacing on screen is kept 
constant through zoom and 
scaling operations 

  Locked grid—the grid lines 
themselves are maintained at 
constant values through 
zoom operations, e.g. a grid 
line which is located at .753 
volts when the grid is locked 
will continue to be located at 
.753 volts regardless of 
changes in scale. 

Grids can be locked and unlocked on individual channels.  
 The lock for the horizontal axis is shared by all channels. 
 The vertical scale can be locked and unlocked independently. 

The lock state of the grid can also be changed through the axis dialogs displayed when the mouse is 
clicked on the axis scale values in the graph window. 
  Click the “Lock units/div” checkboxes. 

 
 
NOTE: All grid screenshots are from BSL PRO. 
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Grid Scaling 
When the grid is locked, the scaling factors controlling how much data is visible on the screen (the 
distance between consecutive major lines of the grid and a fixed location for one of the lines of the grid) 
are specified differently. When the grid is unlocked, these scaling factors do not affect the grid. 
 The Grid Spacing option specifies the scaling factors and whether or not to “Show minor divisions” on 
the grid display. Changing these values only affects the grid display, not how the waveform is scaled. 

   
 Vertical grid: the total range of vertical units displayed per track is specified (Major division) along 

with the first value that should be displayed (First grid line). 
 Horizontal grid: the scaling factors are specified in how many seconds of data should be visible on 

the screen (Major division) and the time offset of the left hand side of the display (First grid line).  
 Settings can be applied to a selected channel or all channels. (Controlled by checking or 
unchecking ‘Apply to all channels”). 

Adjust Grid Spacing 
To modify the horizontal and/or vertical grid spacing, choose “Display > Adjust grid spacing.” This will 
generate the aforementioned dialog for modifying the locked axes of the selected waveform. (“Lock 
vertical grid” and “Use channel specific horizontal grid” must be enabled in order for the gridline fields to 
become active). Enter the desired values and click OK. 
 Settings can be applied to a selected channel or all channels. (Controlled by checking or unchecking 

‘Apply to all channels”). 

The following Grid items can also be selected by right clicking with a graph channel and using the 
contextual menu. 

 

 

Grid: Toggles Grid display on and off. 
Adjust grid spacing: Use to change Grid 
spacing for one or all channels (divisions 
between gridlines and position). 
Grid Options: Use to change Grid display for 
one or all channels (Color, width, style, dash 
length, dash spacing, and scale adjustment 
position). 

Grid Preset: Use to create /save custom Grid 
presets and organize them in a list. (left) 
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Example of channel specific horizontal grid 

 

 
Note in figure on left, the horizontal time scale division 
is one second per division in the graph channel, but two 
seconds per division in the horizontal axis. (Green bar 
area) 
 
 
 
 
 
 

 
Horizontal Axis Grid Controls 

 
 Global Grid Settings: Brings up dialog specifying grid settings used in the shared Horizontal Axis 

of the graph. 
 Channel Grid Settings: Brings up the ‘Adjust grid spacing dialog’ referred to on previous page. 

Individual channel-specific grid settings take priority over the Global Grid Settings. If no channel-specific 
grid setting exists, the Global settings are applied. 
Grid Tool 

 
The Grid Tool allows divisions of the grid to be specified with the mouse. This tool has four states: 

  Inactive The cursor changes to a circle with a line running through it. The grid 
cannot be adjusted since both the horizontal and vertical axes are 
unlocked. 

  Horizontal axis locked The cursor changes to a horizontal line. A mouse click and drag will 
change the location of the horizontal lines of the grid. 

   Vertical axis locked The cursor changes to a vertical line. The tool can be used to adjust the 
vertical spacing of the grid. 

  Both axes locked The cursor changes to a crosshair. The rectangle of a full grid division 
can be drawn over the data. Adjust the spacing of locked grid lines 
underneath the waveform. 

If the “Alt” (PC) or “Option” key (Mac) is held down for the Grid Tool in any of the active 
modes, an ellipsis will appear under the cursor. After a mouse click or drag, a Grid Settings 
dialog will be generated. This dialog is functionally similar to the grid dialogs accessible via the 
axis settings dialogs. 
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 Based on lock status, the dialog will allow adjustment of Horizontal, Vertical or combined settings. 
 The values displayed in the dialog correspond to the grid ranges that were just drawn out on the 

screen with the grid tool if a mouse drag occurred. 
 If the mouse was simply clicked, the current grid settings are displayed. 
 This dialog allows the grid drawn out with the grid tool to be made more precise. 

Grid Reset 
To return to the original grid, choose “Display > Reset grid.”  
This will reconstruct the default, unlocked grid of four divisions per screen with solid light gray grid 
lines. 
Grid Options 
The major and minor grid lines can be further customized with spacing, number of divisions, and different 
colors and dashing styles. These are modified under the dialog generated via Display > Show > Grid 
options.  

 
Line color Click the color well to generate a color chooser. 
Line width Adjust the corresponding slider. 
Dash style Select a style (solid or broken) from the pop-up menu. 
Dash length Adjust the corresponding slider (for any dash mode that is not a solid line). 
Spacing Adjust the corresponding slider (for any dash mode that is not a solid line). 
# of Divisions Enter a value in the text field to set the maximum number of minor grid lines 

to be displayed in a single major grid division. 
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Apply visual settings to all channels 
 When checked, the visual settings for major and minor grid lines are applied to 

all channels. When unchecked, the settings will be applied to the selected channel 
only. 

Scale Adjustment 
 Select whether to use Start/End or Range/Midpoint parameters to determine 

horizontal and vertical scale adjustments. Applied only when grids are locked. 

 
10 sec. Horizontal Scale adjustment set to ‘Start/End’ parameters 

 
10 sec. Horizontal Scale set to ‘Middle Point/Range’ parameters 

To undo any selections and return to the original grid, choose “Display > Reset grid.” This will 
reconstruct the default, unlocked grid of four divisions per screen with solid light gray grid lines. 

 
Friendly Grid Scaling 

Too much precision can create numbers that are difficult to quickly interpret, so “friendly” grid 
scaling adjusts the range to the nearest possible whole numbers. For example, it’s easier to 
comprehend 4.1000000 than 4.1427385. Unlocked grids always restrict precision to the minimum 
needed for a given magnitude. This produces a “friendly” scale that makes it easier to determine the 
range between the gridlines when data is formatted for display or printing. 
With unlocked horizontal grids, the horizontal scale values printed on a graph may not match the 
horizontal scale values displayed on the application screen. For example, horizontal scale values 
 Displayed in the application: 0.00000   7.50000   15.00000   22.50000 

  Printed:    0.00000   7.50125   15.00250   22.50375 
The precision will only match when using the “Visible area” print option. With selected area or 
entire graph options, the precision will not match when grids are unlocked because friendly grid 
scaling is applied on screen, but is not used during printing where the range is fixed to fill the entire 
page. 
Note that the Zoom tool and vertical autoscale may produce different results. To accommodate the 
grid precision, the Zoom result may be slightly more than specified in the zoom box. For precise 
correlation from selected area to result, lock the grids (horizontal and vertical). Precision is not 
restricted for locked grids or display ranges manually entered in the axis setting dialogs. 
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Journal Details 
To create a journal, choose File > New > Graph-Specific Journal or Independent Journal, or choose 
Display > Show > Journal. Or after opening a new journal choose Edit > Journal > Show Journal. A 

Journal may also be opened by using the  toolbar button and selecting Journal from the pop-up 
menu. 
Once a Journal is open, text and data can be entered. To enter text, just begin typing when the journal is 
open. BSL PRO will automatically “wrap” the text to fit the screen width. 
In addition to File and Edit menus, there are Time Stamp, Date Stamp and Auto Time 
functions available in the journal window.   

• Time and Date stamps refer to the computer’s clock to record the time and date, respectively, 
directly into the Journal.  

• Auto Time function records the time at the instant the carriage return is pressed, which is useful 
for tagging commands as data is collected.  

Measurements and data may also be pasted into an open Journal. To paste measurements into an open 
Journal, select an area and choose “Paste measurements” from the Edit > Journal menu. Paste to 
Journal functions only work if a Journal is open and vary for each journal type: 
 Graph-specific journals can only receive measurements and wave data from their associated 

graph view 
 Independent Journals can receive measurements and wave data from any open graph. Results will 

be put into both the graph-specific journal and the independent journal. Use Journal Preferences 
to auto-paste to an independent journal if desired. 

Set the Journal Preferences (page 347) to simultaneously record measurement name and units or control 
Event (marker) paste functionality and detail.  
To paste waveform data into a Journal, select an area and choose “Paste Wave Data” from the Edit > 
Journal menu. Allow several seconds for the text file to be written. The result is a text file of wave data 
pasted into the active journal.  

TIP: When pasting a graph into a Journal: Pressing the Ctrl key (PC) or the Alt 
key (Mac) will launch a dialog allowing the image to be resized prior to 
pasting. 

A useful feature of the Journal is that it works in connection with the Cycle/Peak Detector and other 
measurement functions to paste in values from waveform data for further analysis. 
In the example above, the peak-to-peak and delta t measurements were pasted from the open graph 
window to the Journal. See the Journal paste section on page 254 for more information on how to paste 
information to Journal files. 
Use Save as/Open Journal Template to retain SOP text, or standardize lab/computer details for record 
keeping. 
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Rich Journals 
The BSL PRO Journal adds powerful rich text editing tools, offering advanced functionality common to 
most word processing programs. The following toolbar options are available within the Journal window: 

• Font family 
• Font style: bold, italic, underline 
• Paragraph alignment: left, right, center, justify 
• Font color 
The following items can be pasted or embedded into the Journal text: 

• Images 
• Numbered lists 
• Bulleted lists 
• Tables 
• Numerical statistics or expressions 
• Hyperlinks 
• PDFs 

Images must reside within a document in order to be pasted into the Journal. Pasting image files directly 
from a location such as the Desktop is not currently supported. 

Journal Toolbar Buttons 
The Journal toolbar controls all formatting functions within the Journal window. Although the settings 
customized in this toolbar are retained within a saved Journal, global default settings for subsequent 
Journals are not overridden. To change the global defaults, the overall Journal Preference settings must be 
modified. (Edit > Journal > Preferences). For more information, see Journal Preferences on page 347. 

 
A full explanation of all Journal toolbar buttons appears on the following page. 
Journal Toolbar Icon Function Explanation 

 
Clear  Clears text from Journal window 

 
Replace  Replaces Journal text with contents of external text file 

 
Save  Saves selected or full Journal text to an external text file 

 
Page Setup Opens dialog for modifying Journal text print configuration 

 
Print  Prints the Journal text to the default printer 

 
Paste 
Measurement Pastes selected measurements into the Journal 

 
Time stamp Inserts current time into Journal 

 
Date stamp  Inserts current date into Journal 

 
Time AND Date Inserts current time and date into Journal when Enter/Return key is 

pressed 

 
Font  Use to select font type and size for Journal session 

 
Text style Use to bold, italicize or underline text 

 
Text alignment Aligns paragraph text to left, center, right or justified position 
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Font color Selects color of Journal text 

 
Numbering Toggles text numbering on and off 

 
Bulleting  Toggles text bulleting on and off 

 
Increase indent Increases indent in a bulleted or numbered list* 

 
Decrease indent  Decreases indent in a bulleted or numbered list 

 
Insert link Adds hyperlink to Journal 

 
Table Inserts a table into the Journal 

 
Table row  Adds a row to the table ** 

 
Table column  Adds a column to the table  

 
Delete table row  Removes selected row from the table 

 
Delete table 
column  Removes selected column from the table 

 
Merge cells  Merges selected cells within the table 

 
Split cells  Splits selected cells within the table 

 
Dock button Docks the Journal at the right side of the graph window. 

 
Side-by-side view 
button 

Splits the Journal window into separate panes for viewing PDF and 
Journal content side-by-side. Active only when PDFs are embedded. 

 
Close button Closes the Journal view. 

*Active only when cursor is positioned within a bulleted or numbered list. 

**Additional table tools are active only when a table is present. 

NOTE: If the BSL PRO graph or Journal windows are decreased in size, the Journal toolbar will become 
truncated and some buttons may no longer be in view. Buttons no longer visible on the toolbar can be 
found in drop-down menus indicated by arrows. (See below) 
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Journal Numerical Table Tools 
The Numerical Table Tools function allows easy insertion of measurements and numerical data into a 
Journal table, which can then be computed and evaluated via basic mathematical operations and 
expressions. This eliminates the need to export data to a spreadsheet application in order to validate 
statistics gathered during the course of an experiment.  

Numerical Tools operations permitted within a Journal table: 

 Insert a single measurement value 
 Insert all measurement values 
 Insert all measurement values with header row 
 Sum, Mean and Standard Deviation statistics for table rows and columns 
 Expression evaluation 

 

Menu Item Function 
Undo Removes previous operation 

Select All Selects all cell contents 

Insert Single Measurement Value Pastes single selected measurement value into cell 

Insert All Measurement Values Pastes all measurement values into cells 

Row Statistics Performs Sum, Mean or Standard Deviation operations on row data 

Column Statistics Performs Sum, Mean or Standard Deviation operations on column data 

Evaluate Expression Performs mathematical operations and functions on cell contents  

Word Wrap Wraps text within visible Journal area. (Does not apply to table cells) 

Example of Sum, Mean or Standard 
Sum, Mean or Standard Deviation operations can be easily performed on table data. Right clicking within 
a cell opens a contextual menu containing available operations under ‘Row’ or ‘Column’ statistics. 
Choose an operation, and the result will appear in the selected cell. (See sum example below) 
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Example of Evaluate Expression: 
This feature works very much like Excel®. Simply enter the cell identifiers into an empty cell, then right-
click and choose ‘Evaluate Expression”. The formula occupying the cell will be computed and be 
replaced by the result. The mathematical operations and functions available for standard Biopac 
Expression syntaxes may be used. (Transform > Expression). Expressions can be created beforehand then 
copied and pasted into a Numerical Tools Table cell. 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
  
 
 
 
If the expression syntax used is incorrect or invalid, a warning dialog will appear. 

 

TIP: To correct a mistake, use the Ctrl+Z (PC) or Command+Z (Mac) 
keystroke to restore the previous cell data. Multiple levels of undo 
are supported. 

Adding a hyperlink to the Journal 

Use the Journal hyperlink  toolbar button to insert a link to a web address into the Journal. This 
operation is very similar to adding regular text. 

1. Click into the Journal at the desired position for the link to appear. 
2. Click on the “Insert link” toolbar button 
3. Add the web address and some text identifying the link into the URL and Text fields.  
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NOTE: For the link to be active, the http:// designation must be entered before the web address. 

 
4. Click OK, and the live link will appear in the Journal. 

 
• To format the link text, select the link and use the Journal formatting tools. 
• To edit the link text, position the cursor at the end of the link and use the arrow keys to 

navigate to the desired portion. Backspace to remove unwanted text and type in new text. 
• To delete a link, select the text and use the Delete key. 
• Once a link has been created, the URL portion cannot be edited from within the Journal, 

nor can the original “Insert hyperlink” dialog be recalled. If the URL itself needs to be 
edited, a new link must be created using the “Insert Link” button. 

Embedding PDFs in Journals 
Multiple PDF files can be pasted into a Journal as convenient tabbed windows with all formatting and 
graphics intact. To do this, simply choose Edit > Journal > Manage PDFs, browse to the location of the 
desired PDF files and choose “Embed new.”  
TIP: PDFs may also be embedded in the Journal by right-clicking in the Journal window and choosing 
“Manage PDFs” from the contextual menu. 
For more details on managing embedded PDFs, see page 255. 

 Watch the BIOPAC Journal Tutorial video for a detailed explanation of this feature. 

Select a waveform / channel 
Although multiple waveforms can be displayed, only 
one waveform at a time is considered “active.” Most 
software functions only apply to the active waveform, 
which is also referred to as the “selected” channel. 
Selecting a channel allows highlighting of all or part of 
the waveform, and enables transformations to be 
performed on a given channel. 
In the upper left corner of the graph window there is a 
series of numbered boxes that represent each channel of 
data. The numbers in the boxes correspond to the 
channel used to acquire the data (the specifics of setting 
up channels are discussed on page 103. In the sample 
file, ECG channels are represented by CH1 and PPG on 
CH2. 

 

http://www.biopac.com/video/?video_category=acqknowledge-tutorials&v=journal-features-in-acqknowledge
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To select a channel, position the  cursor over the channel box that 
corresponds to the desired channel and click the mouse button or position the 

 cursor on the waveform of interest and click the mouse button. 
Note that the selected channel box appears depressed and the channel label to 
the right of the channel boxes changes to correspond to the selected channel. 
Additionally, the channel label in the display (on the left edge of the track) will 
be highlighted for the active channel. 

 

 
 

Channel Labels 
Each channel has a label on the left and right edge of the graph window.  
The left label is used to identify the contents of each channel (ECG, PPG, etc.). 
The right label is used to denote the units for each channel’s amplitude scale 
(usually scaled in terms of volts or millivolts). 

         
When a channel is active, its label is highlighted and also 
appears by the channel boxes. 
To change the label for a given channel 
 during or before acquisition 

(including Append mode) 
revise the MP menu >  Set Up Channels label text 
 post-acquisition / analysis only 

click the left label enter the desired text in the dialog 
 

 
BSL PRO Channel label 

 

Show/Hide Channel 

 
A waveform display can be hidden without 
changing the data file. To hide a channel,  
Windows: Alt+click in channel box. 
Mac OS: Option+click in channel box. 
When a channel is hidden, the channel box will 
have a slash through it. A hidden channel can be 
viewed by holding down the Alt or Option key 
and clicking the channel box again. Channels 2, 
3, and 4 are hidden in the right example. 
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Measurements 
A convenient feature in BSL PRO is the popup measurement windows, with a wide 
variety of different measurements available for each channel . By default, BSL PRO 
displays measurements from the selected channel (as denoted by the “SC” in the 
measurement boxes). 
To select a channel for measurement, position the cursor over the part of the 
measurement window that reads “SC.” Click the mouse button and choose a channel 
number from the pull-down menu. The channel numbers in the pull-down menu 
correspond to the numbers in the channel boxes in the upper left corner of the graph 
window. 
To select a measurement, position the cursor on a measurement box and click the 
mouse button. Choose a measurement from the pull-down menu; see page 91 for 
measurement functions and the minimum samples for each (some of the values are 
single point measurements while others require at least two points to be selected). 
The measurements in the upper half of the menu reflect amplitude measurements, or 
measurements which contain information about the vertical (amplitude) scale. Other 
measurements use information taken from the horizontal axis (usually) and are found 
on the section of the pull-down menu below the dividing line. Some of the 
measurement options change (or are disabled) if units are selected for the horizontal 
scale. 

  
In some cases, the computations involved in the measurement can produce nonsensical 
results (such as dividing by zero, or calculating a BPM from a single point). In those 
cases, a measurement value like INF or **** may appear. This means the result was 
undefined at the point the measurement was taken. 
Measurement menus are tinted to match the color of the corresponding waveform. 

 
Measurement Display 

    
The number of measurement rows is set in Preferences > Measurements, as well as the precision and 
units. 
 
 
Measurement Area 
It is important to remember that BSL PRO is always selecting either a single point or an area spanning 
multiple sample points. If an area is defined and a single point measurement (such as Time) is selected, 
the measurement will reflect the last selected point. 
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 Single-point measurements 

When a single point is selected, the cursor will “blink.” The graph below shows how the I-beam 
is used to select a single point for measurements. 

 
 
 Selected range measurements 

Drag the I-beam cursor to select an area; the selected area will be highlighted. 

  
 

IMPORTANT! 
The first data point is “plotted” at zero (on the left edge of the graph); the first visible data point is sample 
point 2. The selected areas below demonstrate this concept. 
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Measurements and Measurement Presets 
Measurements are commonly used in conjunction with the cycle detector and other analysis protocols to 
perform data reduction. In complex data analysis using the cycle detector, often multiple different sets of 
measurements may be used to perform multiple extraction passes on the data. The measurement presets 
feature allows users to create multiple predefined measurement configurations and apply them to the 
graph to change between different configurations. All aspects of the measurement configuration are 
stored, including measurement functions, any parameters for the measurement, source channel, and 
number of measurement rows. For more details on this function see Measurements Toolbar section on 
page 60. 
IMPORTANT: Calculations performed within expressions or measurement channels DO NOT 
incorporate units such as milli, micro, centi, deci, etc. All calculations are performed with numbers as 
they are exhibited within the text field. Time/frequency axis measurements may have their units fixed by 
using Preferences > Measurements > Time Units/Freq Units.  Selecting “Best Match for Value” will 
change the units based upon the magnitude of the value.   

Measurement Validation 
Validate measurements with the ValidateMeasurements.acq sample file included with the software. Pay 
attention to the “Sample data file” section of the measurement definitions that begin on page 91, and 
where included, note which sample points to use for validation (i.e., the first four sample points are used 
to validate the Correlate measurement using the ValidateMeasurements.acq file). 

Measurement Info / Parameters 

 Measurements that have parameters have an “i” 
for info button next to the measurement type in the measurement bar. Click the button to generate a dialog 
to edit the parameters. To paste parameters, enable the Journal Preference via Display > Preferences > 
Journal > Measurement paste settings > Include measurement parameters. 

Measurement Interpolation 
On a down-sampled channel, the cursor can fall on a point between physical samples. In such cases, in the 
Line Plot mode only, some measurements will display interpolated values; the value is obtained by linear 
interpolation with respect to the two adjoining samples. 
 To disable measurement interpolation, uncheck the “Use linear interpolation” option in the 

Display > Preferences dialog. 
 If interpolation is disabled for Line Plot, or any time Step Plot or Dot Plot is selected, 

measurements take on the value of the first physical sample immediately to the left of the cursor 
or edge of the selection. 

 When measurements are pasted to the Journal, there is no indication of interpolated 
measurements. 

 A Calculation measurement can be an interpolated value. When a measurement uses an 
interpolated value, the result box background changes from gray to light purple. 

 The “Delta S” and “Samples” measurements are never interpolated. 
 Measurements will not be interpolated if all measurements are set to “SC” (selected channel); the 

cursor will snap to the left for the measurements.  
 Measurement tooltips will reflect measurement interpolation. 

Exporting Measurements 
One of the most important reasons to take measurements is to save them; BSL PRO allows these 
measurements to be stored and exported in different formats. 
 Copying measurements to the Journal:  

To copy measurements (exactly as they appear in the measurement windows) and paste them to the 
Journal, select Edit > Journal > Paste measurement, or Paste measurement Journal toolbar button. 
Under the default settings, only the values themselves are copied to the Journal; the settings can be 
modified to include the measurement name and other options under Display > Preferences > 
Journal. 
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 Copying measurements to the Clipboard:  

To copy measurements (exactly as they appear in the measurement windows) to the clipboard and 
paste them into a word processor or other application, select Edit > Clipboard > Copy 
measurements. Under the default settings, only the values themselves are copied to the clipboard; 
the settings can be modified to include the measurement name and other options via Display > 
Preferences > Journal. 

Measurement Definitions 
The table below explains the measurement options available and the range required for each. The default 
option is for time to be displayed on the horizontal axis, although it can be set to display frequency or 
arbitrary units (see page 333 for details on how to change the horizontal scaling options). Unless 
otherwise noted, all of the measurements described here relate to those displayed when the horizontal 
scale reflects time. 
Measurement Area Explanation  
Area Minimum area: 

3 samples 
 
Uses: 
All points of 
selected area 

Area computes the total area among the waveform and the straight line that is 
drawn between the endpoints. 
Area is expressed in terms of (amplitude units multiplied by horizontal units) and 
calculated using the formula: 
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Where: 
n—number of samples; 
i—index (i = 1.n-1); 

1, +ii xx  - values of two neighboring points at horizontal axis ( 1x – the first 

point, nx – the last point); 

( ) ( )1, +ii xfxf  - values of two neighboring points of a curve (vertical axis); 

( ) ( )1, +ii xyxy  - values of two neighboring points of a straight line (vertical axis). 

At the endpoints y( 1x )= f( 1x ) and y( nx )= f( nx ). 
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Xxi - horizontal sample interval; 

The value of a straight line can be found by formula: 

( ) bxmxy ii +∗=  

( ) 11 xmxfb ∗−= - intercept; 

X
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∆
∆

= - slope of the straight line; 

( ) ( )1xfxfY n −=∆  - vertical distance of increase at vertical axis; 

1xxX n −=∆ - Horizontal distance of increase at horizontal axis. 
Sample plot: 

 
The area of the shaded portion is the result. 

Note: The Area measurement is similar to the Integral measurement except that a 
straight line is used (instead of zero) as the baseline for integration. 
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Measurement Area Explanation  
 
 
 
 
 
 
 

 
Results: This calculation will always return a positive result. 
Units: Volts - sec. 
Sample data file: “ValidateMeasurements.ACQ” 
 Result: 0.4533 Volts - sec. 

BPM 
(Time domain 
only) 

Minimum area: 
2 samples 
 
Uses: 
Endpoints of 
selected area 

BPM (beats per minute) computes the time difference between the first and last 
points and extrapolates BPM by computing the reciprocal of this difference, 
getting the absolute value of it and multiplying by 60 (60 sec). 
The formula for calculation of BPM is: 
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Where:  

nxx ,1 - values of the horizontal axis at the endpoints of selected area. 
Note: As mentioned, this measurement provides essentially the same information 
as the Delta T and Freq measurement. 
Results: Only a positive value. 
Units: BPM. 

Calculate Minimum area: 
2 sources 
 
Uses: 
Results of 
measurements 
used in 
calculation 

Calculate can be used to perform a calculation using the other measurement 
results. For example, the mean pressure can be divided by the mean flow. 
When Calculate is selected, the channel selection box disappears. 

 
The result box will read “Off” until a calculation is performed, and then it will 
display the result of the calculation. As the selected area is changed, the 
calculation will update automatically. 
To perform a calculation, generate the “Waveform Arithmetic” dialog via 
Ctrl-Click or right mouse click the Calculate measurement type box or click the 
“info” button next to the measurement type box . 
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Measurement Area Explanation  
Use the pull-down menus to select Sources and Operand. 
Measurements are listed by their position in the measurement display grid (i.e., 
the top left measurement is Row A: Col 1). Only active, available channels appear 
in the Source menu. 

Calculation measurement Source operands are updated before a Calculation is 
performed, which means that Calculations can be based on measurements that 
are located after them in the measurement row/column ordering. 
Calculation measurements can include other Calculation measurements as their 
operands. 

• If a cyclic dependency is introduced, the result reads “Error.” 
• When interpolation is being used, a Calculation measurement can also be 

an interpolated value. 
• If either of the operands of a Calculation is interpolated, the result will be 

displayed as an interpolated value (with a light purple background). 
The Operand pull-down menu includes: Addition, Subtraction, Multiplication, 
Division, Exponential. 
The Constant entry box is activated when “Source: K, constant” is selected and is 
used to define the constant value to be used in the calculation. 
To add units to the calculation result, select the Units entry box and define the 
unit’s abbreviation. 
Click OK to see the calculation result in the calculation measurement box. 

Correlate Minimum area: 
2 samples 
 
Uses: 
All points of 
selected area 

Correlate provides the Pearson product moment correlation coefficient, r, over the 
selected area and reflects the extent of a linear relationship between two data 
sets: ix  - values of horizontal axis and ( )ixf  - values of a curve (vertical axis). 
Use Correlate to determine whether two ranges of data move together. 

Association  Correlation  
Large values with large values Positive correlation 
Small values with large values Negative correlation 
Unrelated Correlation near zero 

The formula for the correlation coefficient is: 

Correlate = 
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Where: 
n—number of samples;  
i—index (i = 1..n); 

ix — values of points at horizontal axis ( 1x – the first point, nx – the last point); 

( )ixf - values of points of a curve ( vertical axis). 
Results: 
Returns a dimensionless index that ranges from -1.0 to 1.0 inclusive. 
Units: None 
Sample data file: “ValidateMeasurements.ACQ” 
 Result: -0.74825(for whole wave) and 0.95917 (for first four 

sample points). 
Delta Minimum area: 

2 samples 
 
Uses: 
Endpoints of 
selected area 

Delta returns the difference between the amplitude values at the endpoints of the 
selected area. 

Delta ( ) ( )1xfxf n −=  
Where: 

( )1xf , ( )nxf —values of a curve at the endpoints of selected area. 
Results: 
If the data value at the starting location is greater than the data value at the 
ending location of the cursor, then a negative delta will result. Otherwise, a 
positive delta will result. 
Units: Volts 
Sample data file: “ValidateMeasurements.ACQ” 
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Measurement Area Explanation  
 Result: -2 Volts (for whole wave). This result shows the 

absolute value of change of amplitude (2) and the minus 
sign means a decrease of amplitude. 

Delta S  Minimum area: 
1 sample 
 
Uses: 
Endpoints of 
selected area 

Delta S returns the difference in sample points between the end and beginning of 
the selected area. 
Results: This calculation will always return a positive result. 
Units: Samples 
 

Delta T(time) 
Delta F 
(frequency) 
Delta X (arbitrary 
unit) 

Minimum area: 
2 samples 
 
Uses: 
Endpoints of 
selected area 

The Delta T/F/X measurement shows the relative distance in horizontal units 
between the endpoints of the selected area. Only one of these three units will be 
displayed in the pop-up menu at a given time, as determined by the horizontal 
scale settings. 

Measurement Horizontal Axis 
Delta T Time 
Delta F Frequency (FFT) 
Delta X Arbitrary units (Histogram Bins) 

The formula for Delta T/F/X is: 

Delta T 1xxn −=  
Where: 

nxx ,1 - values of horizontal axis at the endpoints of selected area. 
Results: 
If the data value at the starting location is greater than the data value at the 
ending location of the cursor, then a negative delta will result. Otherwise, a 
positive delta will result. 

For Delta T measurements with the horizontal axis format set to HH:MM:SS. 

 Values less than 60 seconds will result in a value in decimal 
seconds. 

 Values greater than 60 seconds will result an HH:MM:SS format 
value 

(See page 69 for details on how to change the horizontal scaling). 
Units:  

Delta T: Seconds (sec.)  Delta X: “arbitrary unit” 
Delta F: Hz 

Sample data file: “ValidateMeasurements.ACQ” 
 Result: 0.12 sec. (for whole wave). 
 

Evt_ampl  Extracts the value of the measurement channel at the times where events are 
defined. The measurement result is unitless. Specify Type, Location, and Extract; 
see page 204 for details. 
1. The amplitude is always taken from the measurement channel, which may be 

different from the channel on which events are defined. 
Evt_amp can be useful for extracting information such as the average T wave 
height within the selected interval.  

Evt_count   Evaluates the number of events within the selected area. The measurement 
result is unitless. Specify Type and Location; see page 205 for details. 
 

Evt_loc   Extracts information about the times of events. The measurement result uses the 
units of the horizontal axis. Specify Type, Location, and Extract; see page 205 for 
details. 

Expression  Generates the Expression transformation dialog (page 137) and offers Source 
“MC” Measurement Channel instead of “SC” Selected Channel to build recursive 
formulas, i.e. result of the expression as it was evaluated x samples ago. Data 
within the selected area is not changed. 
Evaluation rules: 
When a new selection is made, the first step in evaluation searches through the 
measurement expression for any MMT() invocations. Any measurement whose 
value is needed by MMT () is computed at this time prior to the expression 
evaluation. This behavior is similar to calculation channels and successfully 
allows measurements to the right and bottom of the expression measurement to 
be used in the expression.  
The expression is subsequently evaluated from the leftmost sample in the 
selection to the right most sample. It is evaluated at the waveform sampling rate 
of its source channel. Interpolation is not used at the boundaries to maintain a 
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Measurement Area Explanation  
consistent sample interval for the expression. After each expression evaluation, 
the result is cached in memory for potential negative MC result references. 
The rightmost value of the final expression becomes the value of the 
measurement 

Freq (time 
domain only) 
 

It is important 
to note… 

This does not 
compute the 
frequency 
spectra of the 
data. 
To perform a 
spectral 
analysis, use 
the FFT 
function (see 
page 284). 

Minimum area: 
2 samples 
 
Uses: 
Endpoints of 
selected area 

Freq computes the frequency in Hz between the endpoints of the selected area 
by computing the reciprocal of the absolute value of time difference in that area. 
The formula for Freq is: 

Freq 
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Where:  

nxx ,1 - values of horizontal axis at the endpoints of selected area. 
The information provided by this measurement is directly related to the Delta T 
and BPM measurements, and is related to a lesser extent to Delta S 
measurement. That is, if the Delta T interval between two adjacent peaks is 
calculated, the BPM and Freq measurement can be extrapolated.  
If the sampling rate is known, the Delta S can also be derived. 
In the following example, observe the Delta T, Freq and BPM measurements for 
the particular area. The Delta S can also be derived. 

 
Selected area with measurements that describe 

the same interval in different terms. 
 
Note: It is important to note that this does not compute the frequency spectra of 
the data. To perform a spectra analysis, use the FFT function (described on page 
284). 
Freq (or frequency) is only available in time domain windows. 
Results: This calculation will always return a positive result. 
Units: Hz 
Sample data file: “ValidateMeasurements.ACQ” 
 Result: 8.33 Hz (for whole wave). 

Integral Minimum area: 
2 samples 
 
Uses: 
All points of 
selected area 

Integral computes the integral value of the data samples between the endpoints 
of the selected area. This is essentially a running summation of the data. 
Integral is expressed in terms of (amplitude units multiplied by horizontal units) 
and calculated using the following formula. 

Integral = ( ) ( )[ ]
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Where: 
n—number of samples; 
i—index (i = 1.n-1); 

1, +ii xx  - values of two neighboring points at horizontal axis ( 1x – the first 

point, nx – the last point); 
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Measurement Area Explanation  
( ) ( )1, +ii xfxf  - values of two neighboring points of a curve (vertical axis); 

1−
∆

=∆
n

Xxi - horizontal sample interval; 

1xxX n −=∆ - horizontal distance of increase at horizontal axis. 
The following plot graphically represents the Integral calculation. 

 
The area of the shaded portion is the result. 

Results: The Integral calculation can return a negative value if the selected area 
of the waveform extends below zero. 
Units: Volts—sec. 
Sample data file: “ValidateMeasurements.ACQ” 

Result: 0.300 Volts -sec.(for first 6 sample points) and –
0.155 Volts -sec.(for last 6 sample points—the wave below 
zero). 

Kurtosis   Kurtosis indicates the degree of peakedness in a distribution, e.g. the size of the 
“tails” of the distribution. Distributions that have sharp peaks in their center have 
positive kurtosis; flatter distributions have negative kurtosis. A normal distribution 
has a kurtosis of 0. The following formula is used to extract kurtosis 
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Where from a signal (x) containing n points: 
Lin_reg Minimum area: 

2 samples 
 
Uses: 
All points of 
selected area 

Linear regression is a better method to calculate the slope when noisy, erratic 
data is present. 
Lin_reg computes the non-standard regression coefficient, which describes the 
unit change in f (x) (vertical axis values) per unit change in x (horizontal axis). 
For the selected area, Lin_reg computes the linear regression of the line drawn 
as a best fit for all selected data points using the following formula: 

Lin_reg = 
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Where: 
n—number of samples;  
i—index (i = 1.n); 

ix — values of points at horizontal axis ( 1x – the first point, nx – the last point); 

( )ixf - values of points of a curve ( vertical axis). 
Note: For a single point, Lin_reg computes the linear regression of the line drawn 
between the two samples on either side of the cursor. 
Results: 
If the data value at the starting location is greater than the data value at the 
ending location of the cursor, then a negative delta will result. Otherwise, a 
positive delta will result. 
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Measurement Area Explanation  
Units: Volts/sec. 
This value is normally expressed in unit change per second (time rather then 
samples points) since high sampling rates can artificially deflate the value of the 
slope. If the horizontal axis is set to display Frequency or Arbitrary units, the slope 
will be expressed as unit change in corresponding vertical axis values (frequency 
or arbitrary units, respectively). 
Sample data file: “ValidateMeasurements.ACQ” 

Result: 230.00 Volts/sec. (for 1-4 samples) and 
–170.00 Volts/sec. (for samples 4-7). 

Max Minimum area: 
1 sample 
 
Uses: 
All points of 
selected area 

Max (maximum) shows the maximum amplitude value of the data samples 
between the endpoints of the selected area. To compare peak heights, select 
each peak—observe the maximum peak values or paste the results to the journal. 
Also, since measurements can be obtained simultaneously for different channels, 
values for different channels can be easily compared. 
Note: For a single point, Max shows the amplitude value in this point. 
Units: Volts 

Max T Minimum area: 
1 sample 
 
Uses: 
All points of 
selected area 

Max T shows the time of the data point that represents the maximum value of the 
data samples between the endpoints of the selected area. 
Note: For a single point, Max T shows the time value in this point. 
Units: Seconds 

Mean Minimum area: 
2 samples 
 
Uses: 
All points of 
selected area 

Mean computes the mean amplitude value of the data samples between the 
endpoints of the selected area, according to the formula: 

Mean = ( )∑
=

∗
n

i
ixf

n 1

1  

Where:  
n—number of samples; 
i—index (i = 1.n); 

ix — values of points at horizontal axis; ( 1x – the first point, nx – the last point); 

( )ixf - values of points of a curve ( vertical axis). 

Units: Volts 
Sample data file: “ValidateMeasurements.ACQ” 

Result: 1.538462 Volts (for whole wave). 
Median Minimum area: 

2 samples 
 
Uses: 
All points of 
selected area 

Median shows the median value from the selected area. 
Note: The median and calculation is processor-intensive and can take a long 
time, so this measurement option should only be selected when actually ready to 
calculate. Until then, set the measurement to “none.” 
Units: Volts 

Median T Minimum area: 
2 samples 
 
Uses: 
All points of 
selected area 

Median T shows the time of the data point that represents the median value of the 
selected area. 
Note: The median and calculation is processor-intensive and can take a long 
time, so this measurement option should only be selected when actually ready to 
calculate. Until then, set the measurement to “none.” 
Units: Seconds. 
 

Min Minimum area: 
1 sample 
 
Uses: 
All points of 
selected area 

Min (minimum) shows the minimum amplitude value of the data samples between 
the endpoints of the selected area. 
Note: For a single point, Min shows the amplitude value in this point. 
Units: Volts. 

Min T Minimum area: 
1 sample 
 
Uses: 
All points of 
selected area 

Min T shows the time of the data point that represent the minimum value of the 
data samples between the endpoints of the selected area. 
Note: For a single point, Min T shows the time value in this point. 
Units: Seconds. 
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Moment  
 

Uses: 
All points of 
selected area 

Central Moment is a general-purpose statistical computation that can be used to 
compute central variance and other higher-order moments of the data within the 
selected area. Specify the order as an integer (generally). The central moment is 
computed using the following formula: 

( )

n

xx
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m

∑
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= 1µ  

Where: 
x—signal; 
n—points; 
m—order. 

None n/a None does not produce a measurement value. It’s useful when copying a 
measurement to the clipboard or journal with a window size in which several 
measurements are shown and only one measurement is desired. 

P-P Minimum area: 
2 samples 
 
Uses: 
All points of 
selected area 

P-P (peak-to-peak) shows the difference between the maximum amplitude value 
and the minimum amplitude in the selected area. 
Results: The result is always a positive value or zero. 
Units: Volts 
Sample data file: “ValidateMeasurements.ACQ” 

Result: 13 Volts (for whole wave). 
Rate_mean Uses: 

One sample for 
each cycle in 
selected area 

Extracts the mean value of the rate outputs within the selected area. Using this 
measurement on rate data avoids any unintentional weighting due to time 
variation in the cycles. Unlike the amplitude "Mean" measurement, this 
measurement must be used on a rate analysis or calculation channel or it will be 
undefined (****). The units of this measurement will match the amplitude units of 
the measurement channel. 

Rate_median Uses: 
One sample for 
each cycle in 
selected area 

Extracts the median value of the rate outputs within the selected area. Using this 
measurement on rate data avoids any unintentional weighting due to time 
variation in the cycles. Unlike the amplitude "Median" measurement, this 
measurement must be used on a rate analysis or calculation channel or it will be 
undefined (****). The units of this measurement will match the amplitude units of 
the measurement channel. 

Rate_stddv Uses: 
One sample for 
each cycle in 
selected area 

Extracts the standard deviation value of the rate outputs within the selected area. 
Using this measurement on rate data avoids any unintentional weighting due to 
time variation in the cycles. Unlike the amplitude "Stddv" measurement, this 
measurement must be used on a rate analysis or calculation channel or it will be 
undefined (****).  The units of this measurement will match the amplitude units of 
the measurement channel. 

Samples Minimum area: 
1 sample 
 
Uses: 
All points of 
selected area 

Samples shows the exact sample number of the selected waveform at the cursor 
position—the first data point is not displayed, but is plotted at zero. 
See page 88 for examples of selected area Samples. 
Note: When an area is selected, the measurement will indicate the sample 

number at the last position of the cursor.  
Units: Samples. 

Skew  Skew is a statistical measure of the degree of asymmetry in a distribution (away 
from normal Gaussian distribution), e.g. if the distribution is weighted evenly or 
trends toward an edge. 

• A normal distribution has a skew of 0. 
• A distribution with a prominent left tail has a negative skew. 
• A distribution with a prominent right tail has a positive skew  

The following formula is used to extract skew: 
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Where a signal (x) contains n points: 
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Slope Minimum area: 

2 samples 
 
Uses: 
All points of 
selected area 

Slope computes the non-standard regression coefficient, which describes the unit 
change in f (x) (vertical axis values) per unit change in x (horizontal axis). 
For the selected area, Slope computes the slope of the straight line that intersects 
the endpoints of the selected area, using the formula: 

Slope = 
( ) ( )

1

1

xx
xfxf

n

n

−
−

 

Where: 
( )1xf , ( )nxf —values of a curve at the endpoints of selected area. 

1x , nx - values of horizontal axis at the endpoints of selected area. 
This value is normally expressed in unit change per second (time rather then 
samples points) since high sampling rates can artificially deflate the value of the 
slope. 
Note: Lin_reg (linear regression) is a better method to calculate the slope when 
noisy, erratic data is present. 
For a single point, Slope computes the slope of the line drawn between the two 
samples: the selected sample point and the sample point to its left. 
Results: 
If the data value at the starting location is greater than the data value at the 
ending location of the cursor, a negative delta will result. Otherwise, a positive 
delta will result. 
Units: Volts/sec. (or corresponding to Freq or Arbitrary setting) 
Sample data file: “ValidateMeasurements.ACQ” 

Result: 233.33333 Volts/sec. (for samples 1-4) 
-166.66667 Volts/sec. (for samples 4-7) and 
-16. 66667 Volts/sec. (for whole wave). 
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Stddev Minimum area: 

2 samples 
 
Uses: 
All points of 
selected area 

Stddev computes the standard deviation value of the data samples between the 
endpoints of the selected area. Variance estimates can be calculated by squaring 
the standard deviation value. 
The formula used to compute standard deviation is: 

Stddev = ( )∑
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Where: 
n—number of samples;  
i—index (i = 1.n); 

ix — values of points at horizontal axis ( 1x – the first point, nx – the last point); 

( )ixf - values of points of a curve ( vertical axis); 
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 - the mean amplitude value of the data samples between 

the endpoints of the selected area. 
Results: The result is always a positive value or zero. 
Units: Volts 
Sample data file: “ValidateMeasurements.ACQ” 

Result: 3.09570 Volts (for samples 1-4), 
1.000 Volts (for samples 10-12). 

Sum Minimum area: 
2 samples 
 
Uses: 
All points of 
selected area 

Sum extracts a mathematical sum of the amplitudes of all of the samples within 
the selected area. This straight sum can be used as a building block for more 
complicated formulas. Examples of its utility include HRV measurements, various 
statistical measurements, and simple criteria for clustering. Sum is available from 
within the measurement popup menus and from analysis scripts that allow for 
extraction of measurements.  

Time Minimum area: 
1 samples 
 
Uses: 
All points of 
selected area 

See the X-axis: T measurement for explanation. 

Value Minimum area: 
1 sample 
 
Uses: 
All points of 
selected area 

Value shows the exact amplitude value of the waveform at the cursor position. 
For the selected area, Value indicates the value at the last position of the cursor, 
corresponding to the direction the cursor was moved (the value will be the left-
most sample point if the cursor was moved from right to left). 
Units: Volts 
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Part B—Acquisition Functions: The MP menu 
Overview 
The BSL PRO software adds acquisition and control capability to the complete MP System (MP36, 
MP35, MP46, or MP45). This section describes the commands and procedures used to establish the 
various acquisition parameters for the MP System including how to: 

• Set up channels for data acquisitions 
• Control acquisition parameters such as sampling rate and duration 
• Perform online calculations and digital filters 
• Set acquisitions to begin on command from a mouse click or external trigger 
• Display values numerically and graphically during an acquisition 
• Output waveforms and digital signals during an acquisition 
• Control the on-screen waveform display characteristics 

Some of the basic functions involved in setting up an acquisition were covered in Part A—Getting 
Started, but this section will cover them in more detail, as well as describe some additional features. All 
the commands covered here can be found under the MP menu. 

    
Set Up Data Acquisition > Data Acquisition Settings 
In BSL 4.1 and higher, many key setups are accessed with Hardware menu > Set Up Data Acquisition. 
This option displays the Data Acquisition Settings window, comprised of the following items: 

• Channels – all analog, digital and calculation channel setups – see page 103. 
• Length/Rate – all acquisition setup parameters for the hardware – see page 153. 
• Event Marking – for setting up hotkeys to insert custom events during acquisition – see page 

193. 
• Segment Labels – for creating custom append segment labels – see page 213. 
• Trigger – for configuring all triggering setups see page 213. (Not supported in MP46/45) 
• Sound Feedback – for setting up audio output of channel data – see page 214. 
• Clicking a listed item populates the Data Acquisition Settings window with the selected 

item’s setup dialog. At the bottom right of the Data Acquisition Settings window is a “Save 
Graph Template” button. This enables unique settings from any selected feature to be saved 
into a graph template for future use. 

User-defined default settings for new graphs can be saved by choosing Display > Preferences > Hardware 
and choosing “User-defined default channel setup.”  
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Following this, each selected parameter change must be accepted by clicking “Yes” to the resulting “save 
default settings” dialog. Once the settings are accepted, this dialog does not reappear unless the settings 
are subsequently modified. 
Acquisition is defined as data collection from an external source (such as electrodes connected to an 
amplifier). 

 Before starting an acquisition, make sure the MP data acquisition unit is turned on and connected 
to the computer. Please refer to the BIOPAC Hardware Guide for more information on 
connections. 

To begin collecting data and display data as it is being collected: 
1. Launch the BSL PRO application. 
2. Choose File > New and select document type “Graph Window.” 

 
 

 
3. Set up the specific channels to acquire before starting the acquisition. See the Set Up Channels 

chapter (page 103) or Set Up Acquisition chapter (page 153) for details. 
4. Set up the acquisition parameters (such as sampling rate, acquisition length, and data storage 

options. See the Set Up Acquisition chapter (page 153) for details. 

Edit menu functionality during acquisition 
The following Edit menu functions may move or alter memory and cannot be performed during 
acquisition: Undo, Cut, Clear, Clear All, Paste, Insert Waveform, Duplicate waveform, and Remove 
Waveform. 

NOTE: If more than one hardware type has 
been previously added via the “Connect to” 
menu, these will also appear in the “Choose 
Type” dialog (left).For details on connecting 
additional hardware types, see page 222. 
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Chapter 5  Set Up Channels 
Set Up Channels—The Basics 

Before collecting data, it’s necessary to specify how many channels data will be collected on, and at what 
sample rate data is to be collected. To enable collection on a given channel, select Set Up Channels from 
the MP menu. (The setup dialog is also presented by default when launching a new graph in the PRO 
application. 
Channel Type 
To specify the channel type—Analog, Digital, or Calculation—click its tab at the top of the dialog. 

 
Each channel has three options for channel setup: acquire, plot, and values. These options appear as boxes 
on the left side of the Input Channels dialog. 
 Acquire 

When the Acquire box is checked for a given channel that means data will be collected on that 
channel. 

To leave hardware connected to the data acquisition unit, but have the software essentially 
“ignore” the channel, leave the acquire box unchecked. For example, if an input device is set to 
Channel 3, data from that channel will not be collected unless the Acquire box is checked. 

Plot 
Determines if data will be plotted in real-time during the acquisition. If the plot box is unchecked, 
data will still be recorded, but the associated channel will remain hidden. The channel (and data) 
can be “unhidden” by positioning the mouse pointer over the channel number box and 
Alt+clicking.  
Checking this option instructs the software to plot data on the computer display. 
In most cases, checking this option is recommended. However, in large-scale acquisitions (i.e., 
many channels and/or high sampling rates) unchecking this option for some channels is useful for 
increasing the display area for important channels (see Appendix B—Hints for working with large 
files). Alternatively, use a separate data view and enable channels as desired for optimum viewing. 

Value 
The third option enables incoming data values to be displayed either numerically and/or in a “bar 
chart” format in a separate window during an acquisition. Checking this option enables access to a 
window (by selecting MP menu > Show Input Values...) that displays the numeric value for each 
input with the “Values” option checked. This option is especially useful for tracking slowly 
changing values such as heart rate, respiration rate, or concentrations of chemicals in a substance. 
For more information on how input values are displayed, please turn to page 208. 

Channel 
Click the channel number box (i.e. A1) to make that channel active (“selected”) so its settings can 
be established or edited. 

Label 
Editable “labels” may be assigned to each channel. To change the label for any channel, position 
the cursor in the area to the right of the channel numbers under the “Label” heading and text. To 
edit the label after setup, use the Set Up Channel dialog at any time, or double click the active 
channel label in the graph window to generate the Assign Channel Label dialog. 
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Preset 
The Analog channel Setup dialog features a “Preset” pop-up menu for each channel . Available 
onboard presets include pre-configured settings for a wide range of BSL transducers and hardware 
interfaces that connect to the channel inputs of the MP36/35/46/45 hardware. Choose a preset and 
the software automatically sets the gain, offset, scaling, etc. appropriate for the selected 
application.  
Upon initial Analog channel selection, the Preset setting will be displayed as “none” until a 
specific option is selected. Choosing the “Default” setting applies basic settings that can can be 
configured manually and saved as a custom preset if desired. (Any selected onboard preset can 
also be modified and saved as a custom preset by choosing the Setup > New Channel Preset 
option.)  
The following Analog channel preset options are available for current MP36 hardware. 
(Avaialable presets will vary if using earlier MP hardware types such as MP35 or MP46/45.) 

   

   

     
MP36 Analog Channel Preset options 
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Channel Sampling Rate  
The Variable Sampling Rate feature allows different channels of data to be down-sampled from 
the acquisition sampling rate; calculation channel must use sampling rate less than or equal to the 
source channel. Choosing lower sampling rates for signals where data falls below the Nyquist 
frequency of the acquisition sampling rate allows more data to be stored in memory or on disk. 
Offline operations involving multiple channels must use the same sampling rate for all Source and 
Destination channels. These operations include waveform editing, Waveform math, Expression 
calculations and Template functions; notable exceptions are “Off-line Averaging” under Find 
Cycle and “Reset via a Control Channel” under Integrate. 
When copying wave data to the clipboard or journal, data values will be inserted at the highest 
sampling rate (channels with a lower sampling rate will snap to the left). 
To set an arbitrary channel sample rate for analysis, use Transform > Resample (see page 278). 
There is no restriction on the acquisition length when using Variable Sampling Rates. 
When Variable Sampling Rates are used in conjunction with the Append mode, and the mode is 
started and stopped manually, it is statistically possible that, prior to the next pass of the Append, 
extra data points may be inserted in various data channels to “line up” the data (see sample on 
page 105). These extra data points simply replicate the last sample in any affected channel. 
To minimize the impact of the extra data points, make sure the lowest sampling rate is on the order 
of 10 Hz or higher, or don’t use Variable Sampling Rates. 

Calculation Channel Presets 
When a new Calculation channel is enabled for the first time, a setup dialog is presented to assist in 
setting the correct preset type, source channel and preset parameters.  
To set an initial calculation channel preset: 

1. Click the Calculation tab. 
2. Enable the desired Calculation channel by checking the “Acquire” checkbox. 
3. The following setup dialog will appear. Select the desired Calculation preset, analog 

source channel, Plot and/or Show input values checkboxes, and click OK. 

 
4. After clicking OK, the setup dialog for the selected preset will appear. Set the desired 

parameters and click OK. (For detailed information about setting Calculation channel 
parameters, see Chapter 6 on page 118. 

Calculation Presets are like “templates” for calculation channels. Each Preset stores: 
    a) Calculation channel type 
    b) Calculation parameters 
    c) Channel-specific scaling 
    d) Channel-specific sampling rate 
    e) Channel name 
Calculation Presets establish settings to target application-specific analysis. Presets exist for a 
broad range of analysis functions. Start with existing presets for a specific species or protocol—for 
example, human vs. small animal, or stationary vs. exercising measurements. 
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The Channel Setup dialog contains a “Preset” pop-up menu by each channel that lists the current 
Preset or, if no Preset has been selected for that channel, the Calculation type (Integrate, 
Difference, etc.). When selecting a Preset for a particular channel, the channel will be configured 
with the settings associated with that Preset.  

          
 Calculation Presets 
When selecting a Preset, the Setup dialog is updated with the corresponding information. 
 New Presets can be created from existing Calculation channels. Click “Setup” to display the 

Calculation Setup dialog and click the “New Preset” button. The settings will be applied to the 
current channel, and a prompt will appear for entering a name for the new Preset. Preset names 
cannot be duplicated, which also means that the name of a default Calculation channel type 
(Integrate, Difference, etc.) cannot be used. The new Preset will be included in the pop-up menus 
and saved with the file. 

 To reorder channel Presets (by type, use, etc.), choose MP > Organize Channel Presets and then 
use the up/down buttons as appropriate (see page 221). 

 Presets are not applicable to and therefore not selectable on Digital channels. 
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Set Up Channels—Advanced 
The previous section covered the basic options used in almost all acquisitions. In addition to the features 
described above, a number of other options are available in terms of setting up channels. These advanced 
features are also found under the Set Up Data Acquisition > Channels menu item. 
Most acquisitions involve collecting analog signals and then displaying them on screen. It is frequently 
useful, however, to collect other types of data (digital data, for instance) or to perform transformations on 
analog data as it is being acquired. Channels containing digital signals and transformed analog signals can 
be collected in addition to the 4 analog channels. 
In the upper left corner of the Channels setup dialog, note the tabs titled Analog, Digital, and Calculation. 
The general features (acquiring, plotting, and the like) are the same for each type of channel, although 
there are considerable differences between the type of data each channel is designed to handle. Analog 
channels can acquire up to 4 channels of data, Digital, 8 channels and Calculation, 16 channels. Analog 
and digital channels may be acquired in any combination, and the only requirement for Calculation 
channels is that at least one input channel (either analog or digital) must be present. 
Analog channels 
Analog channels are the most common type of acquired channel and should be used to acquire any data 
with “continuous” values. Examples of this include nearly all physiological applications where input 
devices (transducers and electrodes) produce a continuous stream of varying data. The range of values for 
analog channels is ±10 Volts. 

BSL PRO also supports rescaling of the analog channel signal to more meaningful numbers. As an 
example, imagine a temperature transducer is connected with a gain setting of 5°/Volt, and output set to 
channel 1. Ordinarily, the values from the amplifier would be read in as Volts or milliVolts. For this 
acquisition, the signal from the transducer needs to be expressed in terms of degrees Fahrenheit. To do 
this, choose “Temperature (Deg. F)” from the selected channel’s Preset list (below).  

 

To calibrate the transducer, bring it to two known temperatures. At the first temperature, take a voltage 
reading by selecting Show input values from the MP menu (see page 208 for a description of the Show 
Input Values options). 90° F, results in a reading of 0 Volts. The transducer is then brought to a 
temperature of 95° F, and yields a reading of +1 Volts. 
To scale the incoming signal to degrees F, click the Setup > Scaling… button in the Input Channels 
dialog. 
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Scaling dialog set to rescale Volts to degrees Fahrenheit and Use Mean Value Settings dialog 

The Input Volts and Map (Scale) Value boxes reflect the value of the incoming signal and how it will be 
plotted on the screen, respectively. Thus, an incoming signal of +1 Volts would be plotted as 95° F, 
whereas a signal of 0 Volts would be plotted as 90° F. BSL PRO will perform linear extrapolation for 
signal levels falling outside this range (i.e., -2 Volts will be scaled to 80° F), as well as perform similar 
interpolation for values between this range. Enter these numbers in the scaling dialog, type in “degrees F” 
for Units, and click OK. 
As a shortcut for scaling channels, use the Cal 1 and Cal 2 buttons. Click either of these buttons to read in 
the current voltage for the selected channel. In the above example, the transducer could simply be set to a 
known temperature, then Cal 1 could be clicked, and then the temperature could be entered in the Map 
(Scale) value box for Cal 1. 
Next the transducer could be brought to another known temperature that is considerably higher or lower 
than the first and click Cal 2 and the new known temperature could then be enter in the Map (Scale) value 
box for Cal 2. BSL PRO calculates the slope and offset from the two points entered. Each data sample 
from channel 1 will now be scaled according to the slope and offset calculations previously made. When 
an acquisition is performed, the amplitude scale (vertical axis) will reflect the rescaled units. 

It is important to note that Cal 1 and Cal 2 cannot be used when data is being acquired. In 
other words, a channel must be calibrated before it can be acquired. To set the calibration 
for a given channel, connect the input device to the MP data acquisition unit and power 
up the MP System, and then perform the calibration before starting data acquisition. 

The Calibrate all channels at the same time option is used when identical types of transducers or signals 
are being simultaneously recorded on two or more channels. 
If this option is selected, when Cal 1 or Cal 2 is pressed: 

• Map (Scale) Value will be updated for all active channels 
• Input Volts need to be updated for each channel individually. 

The Use mean value option is useful if the input voltage signal is noisy around a mean value. The “Input 
Volts” value returned will be the mean value over the specified number of readings. When this option is 
selected, a Settings… button is activated and generates an “Analog Channel Calibration” prompt for the 
number of readings. 
The data is read the number of times indicated in the prompt and then the readings are averaged. The rate 
of obtaining these readings is indeterminate because the rate depends on the actual hardware unit as well 
as the communication type. 
Analog channels MP36/MP35/MP46/45 
The MP analog channel scaling setup works as shown above, but additionally allows the channel gain to 
be configured directly with a variety of input ranges.  
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Gain settings are accessible via a pop-up menu in the Channel setup dialog. (MP > Set Up Data 
Acquisition > Channels) The Gain setting specifies the extent to which an incoming signal is amplified. 
The Gain is automatically set when a data type is selected from the available Presets. The preset Gain 
settings are only educated guesses and should be used as initial starting values. It may be necessary to 
adjust the gain settings depending on how the amplified signal appears once sample data is collected. 

 
Offset 
To correct the offset of an incoming analog signal, add or subtract a constant to the signal prior to 
amplification. Offset can occur if a transducer or electrode has inherent offset. By default, Offset is set to 
zero, and the allowable entry range will vary depending on the Gain and Scaling values. 

To make inputting voltages easier, the analog channel scaling dialog for the MP3X displays the input 
voltages in units that adapt to the gain setting. (x200 is the default) 

The scaling units will adjust dependent upon the gain setting as follows: 

• If the gain is set to < x1000, the Scaling input units will display as millivolts (mV).  
• If the gain is set to > x1000, the Scaling input units will display as microvolts (μV). 

 

  
Channel gain set to < x1000 displays mV input units     

 

Channel gain set to > x1000 displays μV input units 
Adjustable, user defined digital IIR Filters for MP36/35/45 
The MP unit allows up to three user-configurable, sequential, biquadratic (second order) Infinite Impulse 
Response (IIR) filters per MP unit channel. These filters are typically configured by choosing a Preset 
but can be changed manually via the Input Channel Parameters dialog (MP3X > Set Up Data Acquisition 
> Channels > Setup button).  
Each of these three filters can be uniquely set up as a low pass, band pass, high pass or notch (band reject) 
filter. 
In the “Digital Filters” section, select Filter 1, 2, and/or 3 and then adjust the Type, Freq, and Q. 
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The default setting is no filters applied. 

High Pass Hardware Filters 

These filters are implemented using resistors and capacitors in the front end circuitry of the MP3X unit. 
They are set via the “High Pass” section of the Input Channel Parameters dialog (MP UNIT > Set Up 
Data Acquisition > Channels > Setup”). 

 
High Pass Filter  Appropriate use 

0.05 Hz HP ECG 
Respiration data 

0.5 Hz HP ECG when there is a lot of motion artifact causing a shifting baseline  
EEG 
Pulse plethysmograph 
Most other types of AC Coupled data 

5 Hz HP EMG 
Heart Sounds 

Additional controls in MP3X Input Channel Parameters 
Button Explanation 

New Channel Preset Allows a custom Preset to be saved under a unique name 
Advanced Opens Advanced dialog. The Advanced dialog may be used to specify additional settings, 

requirements, and dependencies for the preset. See below for complete explanation of all 
Advanced options. 

Scaling Use to configure the value of the incoming signal and how it will be plotted on the screen 
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Advanced Preset Settings 
Click the Advanced button to open a dialog containing the following optional preset configuration 
options. 

  
Acquisition Tab Explanation 

Require minimum sampling rate When enabled, specifies that a minimum sampling rate must be selected 
in order for acquisition to continue. 

  
 Transducer Tab Explanation 

Verify connected 
transducer  

The software will check for a specific transducer according to the settings in this group 
box prior to the start of each appended segment. This option is enabled by default. 

Title Editable text field used to identify transducer name. 

SSID Indicates which SmartSensor resistor ID (SSID) will be validated for this channel prior 
to each acquisition.  The ID must be an integer between 1 and 23. This option is 
checked by default for all transducers. See page 112 for a table of BIOPAC SSID 
numbers. 

ISID Device Name If checked, indicates that the internal transducer description should be validated for this 
channel prior to each acquisition.  

Fallback on SSID if ISID 
check fails 

If the ISID device name check is unsuccessful for a connected transducer, fall back and 
check the SmartSensor resistor ID.  

Perform transducer 
verification on first 
acquired segment only 

When enabled, the validation is only performed on the first recorded segment. If 
disabled, verification is performed at the start of every data acquisition. 
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Biopac Student Lab Device SSID Table 
Device Part #  Description SSID  ISID Name 
BSLCBL3A, BSLCBL4B  Recording cable 1  
BSLCBL5 3.5mm phone plug adapter 6  
BSLCBL8, BSLCBL9 High-impedance recording cable 1  
BSLCBL14A 3.5mm phone plug adapter to MP35 Input.   6  
BSLSTMB/A 10 V setting 18  
BSLSTMB/A 100 V setting 19  
BSL-TCI13 Piezo interface cable 1  
BSL-TCI21 pH probe interface 12  
SS1L, SS2L, SS2LA Electrode lead set 1  
SS2LB Electrode lead set N/A SS2LB 
SS3LA EDA (GSR) finger electrodes 2  
SS4LA Pulse Plethysmograph finger transducer 3  
SS5L, SS5LA, SS5LB Respiration Belt (for Chest) 4  
SS6L, SS7L, SS8L Temperature transducer  5  
SS9L, SS9LA BNC Adapter 6  
SS10L Pushbutton switch  7  
SS11LA Airflow transducer 8  
SS12LA Variable range force transducer 9  
SS13L Blood Pressure (Arterial) 10  
SS14L Displacement transducer 11  
SS17L Piezo microphone 14  
SS19L Blood Pressure  cuff (with Gauge) 10  
SS19LA Blood Pressure cuff N/A SS19LA 
SS19LB Blood Pressure Cuff N/A SS19LB 
SS20L, SS21L, SS22L, 
SS23L, SS24L 

Goniometer 16  

SS25L, SS25LA Hand Dynamometer 9  
SS25LB Hand Dynamometer N/A SS25LB 
SS26L, SS26LB, SS27L Accelerometer 17  
SS28L Heel Toe Strike assembly 9  
SS29L Multilead ECG cable 1  
SS30L Stethoscope, electronic 14  
SS31L Non-Invasive Cardiac Output Module 15  
SS32L Dissolved Oxygen probe 20  
SS33L GAS – O2 (Used on GAS-System2) 21  
SS34L GAS – CO2 (Used on GAS-System2) 22  
SS35L Flow transducer 18  
SS36L Reflex Hammer 9  
SS39LA MP3X Circuit Probe and Power Cable for Breadboard 6  
SS40L, SS41L, SS42L Diff. Pressure transducer 10  
SS43L Phychological response indicator 11  
SS56L Clench Force (Bulb) transducer N/A SS56L 
SS57L EDA (GSR) with electrode pinch leads  2  
SS57LA EDA (GSR) N/A SS57LA 
SS59L Superlab Interface cable for MP35 6  
SS61L Finger Twitch transducer 16  
SS62L Microphone 14  
SS63L, SS64L, SS65L, 
SS66L 

Fixed Range Force Transducer 9  

SS67L Pneumogram transducer  10  
SS68L Ph Probe 12  
SS70L BNC Adapter (for MP35), Isolated version 6  
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Range + Grids Tab  Explanation 

Apply initial visual 
range 

The initial vertical axis range of plotted data will be set as indicated at acquisition start of 
the first data segment. 

Top Indicates the maximum vertical visual range in destination channel units.  

Bottom Indicates the minimum vertical visual range in destination channel units.  

Apply locked vertical 
grid 

Locked vertical grid settings are applied for the channel. For more details on grid setups, 
see Grid Details on page 75. 

First grid line Provides the fixed location of the origin of the vertical grid. 

Grid spacing Sets the spacing interval between major vertical grid divisions.  

Apply locked horizontal 
grid 

A channel-specific independent horizontal grid will be applied when the channel is added to 
a graph. 

First grid line Sets the origin location of the horizontal grids. 

Grid spacing Sets spacing between major horizontal grid lines based on the time domain. 

Apply grid appearance Enables options for setting grid color/appearance of major and minor grid lines. 

Major line color Allows customization of major grid line color. 

Minor line color Allows customization of minor grid line color. 

Show minor grid Shows/hides minor gridlines 

Vertical precision Indicates number of digits displayed on vertical axis. 

Num minor divisions Sets the number of minor grid divisions for the channel. 
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Calibration tab options are designed to assist in channel setup. They allow “custom” calibration prompts 
to be used to guide users through the setup/calibration process. These prompts will appear in the main 
graph window after clicking the graph’s Calibration  icon (or ‘Start’ button, if “Require calibration” is 
checked.) The ‘Calibrate’ button in the prompts are linked directly to the Cal 1 and Cal 2 input values 
found in the standard “Scaling” dialog (see page 108) and offers an alternate method of setting these 
values.  If multiple channels use the calibration option, the calibration prompts will be presented in 
sequential channel order. 

Calibration Tab Setup Example: Resulting User Prompts: 

 

Prompt 1: 

 
Prompt 2: 

 

See table for detailed explanation of calibration options. 
Calibration Tab Explanation 

Use Calibration Calibration procedure is applied after clicking the “Calibration’ icon in the graph 
channel’s vertical scale region. One (if single point) or two (if double point) 
custom prompts are presented in place of the usual ‘Scaling analog channel” 
dialog. Each prompt has a ‘Calibrate’ and “Cancel’ button, one of which must be 
responded to in order to continue. 

Require calibration 
prior to acquiring data 

The above procedure is applied, except calibration prompts are presented as 
follows when the ‘Start’ button is clicked. 

• Append mode: Calibration required at start of first segment recording 
only. 
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• Save Once or Autosave mode: Calibration required at start of first 
recording only. (Subsequent passes do not require re-calibration.) 

NOTE: The "Require calibration prior to acquiring data" option has been 
modified in BSL 4.1.2 to improve usability when using transducers that require 
calibration and the rewind mode. After initial calibration of the first data segment, 
that calibration will be retained even after rewinding the data to remove the 
segment. This allows users to perform a calibration and verification acquisition, 
and then remove that verification segment prior to the next data acquisition. 
If recalibration is desired: Press the Shift key when clicking the Rewind 
toolbar button, or right-click the rewind toolbar button and choose "Reset analog 
calibration" from the contextual menu. 

 
Calibration Type Specifies calibration option to be performed. Two types are available: 

• Single point – Useful for quickly zeroing the baseline offset or 
establishing a preload offset value.  Presents a single prompt to the 
user.  Upon click of “Calibrate”, the input voltage is set as the new 
“Cal2 Input voltage” in the Scaling dialog (equivalent to clicking “Cal2”).   
It then calculates the difference between the old and new Cal2 Input 
values then adds this to the Cal1 Input value. In other words, it 
preserves the Scaling’s slope while shifting the offset. 

• Double point – records two independent voltages in a sequence of two 
prompts and records the first as the input voltage for Cal2 and the 
second for the input voltage in Cal1 

For more details see examples below 

Prompt Use to input “custom” calibration prompt text.  Up to 500 characters can be 
entered and carriage returns can be used.  The resulting prompts will be 
dynamically sized according to the amount of text entered.  
Note: The Scaling dialogs “map values” are displayed for reference to the left of 
the Prompt field and can only be modified in the Scaling dialog. Any changes 
will be dynamically updated in the Calibration dialog. 

 
Examples of how to use the Calibration option 
Example of “Double point” calibration for the SS12LA Force Transducer: 

1. Connect the SS12LA to the MPs CH 1 input and choose MP > Set Up Channels. 

2. Select “Force 0-50 grams” from the Preset pull-down menu then click “Setup”. 

3. From the “Input Channel Parameters” dialog, click “Advanced” then click on the 
“Calibration” tab.   

4. Check “Use calibration”, “Require calibration prior to acquiring data” and choose 
“Double point” as the Calibration type. 

5. Enter the desired “First prompt” text. For example,  

“With only “S” hook attached to transducer, click “Calibrate”. 

6. Enter the desired “Second prompt” text. For example,  

“Attach 50 grams of weight, wait until swinging motion stops, then click “Calibrate”. 

7. Click OK and exit the “Input Channel Parameters” dialog. 

8. Click the Start button. The first prompt will appear: 
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9. Follow the directions and click ‘Calibrate’. The second prompt will appear: 

 
10. Follow the directions and click ‘Calibrate’. Calibration is complete and data recording 

will start. 

Note: The Scaling dialogs Map values (i.e. 0 and 50 grams) are assigned to the calibration prompts as 
follows: Cal 2 Map value is assigned to Prompt 1 and Cal 1 Map value is assigned to Prompt 2. 
“Calibrate” in Prompts Correlates to Cal buttons in Scaling dialog 
Prompt 1: “Calibrate” = “Cal 2” in Scaling. 

 
Prompt 2:  “Calibrate” = “Cal 1” in Scaling. 

  
 
Example of “Single point” calibration for the SS11LA Airflow Transducer: 

1. Connect the SS11LA to the MPs CH 1 input and choose MP > Set Up Channels. 

2. Select “Airflow (SS11LA)” from the Preset menu then click “Setup”. 

3. Click “Scaling” and change both the “Cal 2” Input and Map values to “0”, then click 
“Ok”. 
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4. From the “Input Channel Parameters” dialog, click “Advanced” then click on the 

“Calibration” tab.   

5. Check “Use calibration”, “Require calibration prior to acquiring data” and choose “Single 
point” as the Calibration type. 

6. Enter the desired “prompt” text. For example,  

“Make sure no air is flowing through the transducer and click "Calibrate".” 

7. Click OK and exit the “Input Channel Parameters” dialog. 

8. With the SS11LA held upright, click the Start button. The single prompt will appear: 

 
The recording should show 0 liters/second with no air flowing through the transducer. 
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The Signal Types tab offers advanced options or “subtypes” to add to the selected preset or signal type. 
The subtype options available are dependent upon the type of signal selected. For example, the ECG type 
contains a variety of ECG lead configurations and common ECG signals, whereas Respiration offers 
various airflow options. The subtypes are used for cases when users wish to retain specific information 
about lead configuration or other details about the signal.Also see the Analysis Shortcuts section on page 
225.  

Digital channels (Not supported in MP45 hardware) 
In contrast to analog channels, digital channels are designed to collect data from a signal source with only 
two values (0 and 1). This type of data can be useful in recording whether a switch is open or closed, and 
ascertaining if a device is on or off. Input values for digital channels have two values, +5 Volts and 0 
Volts. The MP3X interprets +5 Volts as a digital 1 and interprets 0 Volts as a digital 0. Since digital 
channels have a fixed value, the scaling option is disabled for these channels. The main function of digital 
channels is to track on/off devices such as push-button switches and/or to receive digital signals output by 
timing devices. Similarly, these channels are also used to log signals from devices that output 
auditory/visual stimulus for examination of stimulus response patterns. 

0 volts

+5 volts

Positive edge Negative edge 

(binary "1")

(binary "0") 

 
 
Calculation channels 
Compared to either analog or digital channels, Calculation channels do not collect external data, but 
transform incoming data in some way. These channels do not alter the original data, but create new 
channels (with channel numbers starting at CH40) that contain the modified data. 
Calculation channels can be used to to compute a host of new variables by applying transformations 
(including BPM, integration calculations, and math functions). The channels are set up in much the same 
way (using Acquire/Plot/Values boxes) as analog or digital channels, with the exception of the pull-down 
menu next to the Calc button and the Setup dialog. 
To acquire a Calculation channel, click the Calc button and check the Acquire box for each Calculation 
channel to be computed (the Plot and Value boxes are optional). By default, all Calculation channels have 
the label “Calculation” and entering more descriptive channel labels might prove useful, especially when 
multiple Calculation channels are being acquired. 
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Each of these functions requires some additional parameters to be specified, and these options can be set 
by clicking the Setup button in the Input Channels dialog. For any Calculation channel, it’s necessary to 
specify the source channel to be transformed and the nature of the transformation.  
Up to 16 Calculation channels can be acquired. The output of one Calculation channel can be used as the 
input for another channel, as long as the output channel has a higher channel number than the input 
channel. In other words, it’s possible for Calculation channel 3 to include the result of Calculation 
channel 1, but not the other way around. This allows for complex Calculations to be performed that 
involve two or more Calculation channels such as filtering ECG data then computing BPM. 
Although Calculation channels can be useful in many cases and indispensable in others, each Calculation 
channel acquired will somewhat reduce the maximum possible sampling rate, and add to the amount of 
memory required to store data both during and after an acquisition. Thus, it may be helpful to perform 
some of these functions after the fact if high sampling rates are needed for a particular application. 

TIP: All of the operations (except Control) that can be performed online 
can also be performed after an acquisition has been completed. 
These options are available under the Transform and Analysis 
menus.  

 
Metachannel  
Calculation metachannels provide a 
method for expanding the 16 available 
calculation channels to allow for more 
complex online analysis. The 
metachannel calculation channel type 
combines multiple steps into a single 
calculation channel so that a chained 
computation can be performed using a 
single calculation metachannel. 

• BSL PRO can display the results 
of up to 16 metachannels, 
allowing for a total of 256 
intermediate subchannel steps. 

 

 
One metachannel can contain up to 16 subchannels, each of which can be individually configured. 
Subchannels can perform any of the functions of top-level calculation channels. 
Each metachannel has one user-defined output channel. The output subchannel is the only waveform data 
that will be recorded in the graph for that metachannel. All other subchannels associated with that 
metachannel are temporary; they do not display in the graph and require no extra space in the graph file to 
compute. 
Metachannels alleviate the need to use top-level calculation channels for computing intermediate steps 
where only the final computation is desired. Metachannels also can be used as the basis of presets, 
allowing multi-step analyses to be applied with a single preset.  
Computation takes place at the lowest waveform sampling rate of all of the referenced source channels, 
and all subchannels are computed at this rate. 
Metachannels labels display in the graph as C#.# 
To have BSL PRO perform a Metachannel calculation in real time: 

1. Choose MP > Set Up Data Acquisition > Channels. 
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2. Click the Calculation tab. 
3. Check an Acquire box for the Calculation channel to contain the filtered data. Check the Plot and 

Values boxes as appropriate for each channel. 
4. Click the Preset pull-down menu and select Metachannel. 
5. Click the Setup button in the Input Channels dialog to generate the Metachannel dialog. 

Primary Source 
The primary source for a metachannel can be set to any analog, digital, calculation, or subchannel 
with a lower index (index 0-15, with 15 being lowest). 

Set Up Subchannel 
Click this button to display the calculation setup dialog for the 
selected subchannel and then set the calculation parameters 
and the source channel.  
Source channel: Each subchannel can be set to use the primary source channel as its data source or 
another channel (analog, digital, or lower-index calculation channel). When the primary source 
channel for the metachannel is changed, the source channel of each subchannel will implicitly be 
changed. 

Limitations on Subchannels 
Subchannels are allowed to take on any of the main calculation channel types. All calculation types are 
available, with some restrictions. 

• Output of reset events is not supported for Integrate and Rate subchannels. 
• For Expression subchannels, the expression language will be enhanced to allow for 

"PSC" to be typed into the expression to refer to the data of the primary source channel. 
• Unlike regular calculation channels, the actual data for subchannels is not retained in 

memory. Subchannels are only used as temporary data and the results discarded after the 
value of the output subchannel has been computed. 
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PRO Lessons 
PRO Lessons illustrate the scope of the BSL PRO System. Each lesson describes the required hardware 
and software setup (channel setup, acquisition setup, gain, scaling, etc.) and outlines the basic procedure 
necessary to record and analyze a variety of applications on human and animal subjects. 
When applicable, a downloadable template file (*.gtl) is included with the lesson to further simplify 
setup. The template file includes all the appropriate settings for the lesson — just open the file, connect 
the hardware and begin recording! 
If you have developed lessons for your course, we invite you to make your lessons available to other 
users. You will receive full credit for the lesson. Just provide us with a copy of your lesson plan and a 
sample data file. We will add your lessons to the list and other users can benefit from your efforts. Please 
don't worry about formatting issues — the important part is the lesson plan and instructions. We'll take 
care of the formatting. Human PRO Lessons graph templates are included in the BSL PRO Lessons folder 
and easily accessible from the Startup Wizard. Or visit our website or quick-click to the Lessons menu 
using Help>PRO Lessons from web for the most up-to-date listing and downloadable files. 
  

• See Higher Education > Curriculum section online for the full list of available lessons. 
 

Application Notes 
Visit the Support > Application Notes section online for the full list of available application notes. 

https://www.biopac.com/education-curriculum/
https://www.biopac.com/application-note/
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Creating a Modified Lesson 
The multi-level learning features of the BSL software full control of the material and method of each 
experiment. Use the 18 guided BSL Lessons for introductory concepts, modify them with custom lab 
procedures or analysis techniques, choose from 35+ PRO Lessons* for advanced concepts, or create 
custom lessons. BSL lesson experiments are included in a number of the leading published lab manuals 
and have been successfully used to study: 

ECG  
EEG  
EMG 
EOG  
EDA (GSR) 

Biofeedback 
Bioimpedance/Cardiac 
Output 
Blood Pressure  
Heart Sounds 

Nerve Conduction 
Pulmonary Function 
Respiration 
Reaction Time 
Temperature

By combining two of the new features it is possible to create modified lessons. The graph template function 
(described on page 231) supports saving of custom settings.  
*In BSL 4.1 and higher, 11 animal PRO Lessons are also included but are hidden by default. To enable access 
to these lessons, check the appropriate boxes in the “Show the following PRO Lessons” list in the Lessons 
Preferences. 
TO CREATE A MODIFIED LESSON: 
1) Set the required channel, acquisition, and display options.  
2) Type any comments and/or instructions for students into the Journal window. 

  To open a journal window: Select Display > Show > Journal or click the  toolbar icon. 
3) Select “File > Save as” and choose “Graph Template” from 

the file type options in the dialog. 
4) Create a new folder, and then name it appropriately for the 

lesson.  
5) Save as a graph template (.gtl) file in the new folder for the 

lesson. To further protect the file settings, set the Read-only 
attribute in the file Properties dialog. 

6) Clear the Journal window using the clear Journal icon in 
the journal tools section. 

Journal tools =   
clear journal / open file /save file /print journal 
 
  For customization details, see the Instructor’s Guide 

installed with the program to the User Support folder or 
at the root level on the BSL PRO installation CD. 

 For enhanced levels of lesson customization, see the 
BSL Curriculum Manager licensed feature chapter on 
page 360. 
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Chapter 6 Calculation Channel Presets 
 Calculation Presets establish settings to target 
application-specific analysis. Presets exist for a 
broad range of analysis functions. Start with 
existing presets for a specific species or 
protocol—for example, human vs. small animal, 
or stationary vs. exercising measurements. 
The Channel Setup dialog contains a “Preset” 
pop-up menu by each channel that lists the current 
Preset or, if no Preset has been selected for that 
channel, the Calculation type (Integrate, 
Difference, etc.). When selecting a Preset for a 
particular channel, the channel is configured with 
the settings associated with that Preset.  
The Setup dialog has a “Presets” pop-up menu 
that contains all of the Presets for the Calculation 
type being configured. To enable the Preset pop-
up menu, set at least one analog channel to 
“Acquire” (calculation channels require a source 
channel). For example, if a Difference Calculation 
channel is being configured, all Presets for the 
Difference Calculation will be listed. Just click the 
Presets head and scroll to select the desired preset.  
When selecting a Preset, the Setup dialog is 
updated with the corresponding information. 
 The Setup dialog reads “none” if the 

channel configuration doesn’t match any 
Preset. The menu will flip to “none” when 
the settings for a channel are changed 
such that they no longer match a Preset.  

 To create a new Preset from existing 
Calculation channels: Click “Setup” to 
display the Calculation Setup dialog and 
click the “New Preset” button. The 
settings will be applied to the current 
channel, and a prompt will be generated 
for entering a new Preset name. Preset 
names cannot be duplicated, nor can the 
the default Calculation channel names be 
reused (Integrate, Difference, etc.). The 
new Preset will be included in the pop-up 
menus and saved with the file. 

 To reorder channel Presets (by type, use, 
etc.), choose MP > Organize Channel 
Presets and then use the up/down buttons 
as appropriate (see page 221). 

 Presets are not applicable to and therefore 
not selectable on Analog or Digital 
channels. 
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Integrate Calculation 

      
The online Integrate Calculation offers three basic options: 

Reset via channel. Perform a real-time integration of input data over a variable number of sample points. 
This option is extremely useful for converting flow signals into volumetric equivalents. The integral of 
flow is volume. For example, when recording airflow with a pneumotach, volume can be precisely 
calculated as the flow varies in a cyclic fashion: 

a)  Real-time conversion of flow signals into volume signals (i.e., Blood flow  Blood volume; Air 
flow  Air volume). 

b)  Any processing involving a need for a cyclic, continuous integral calculated in real time. For 
example: Acceleration  Velocity; Velocity  Distance; Frequency  Number of cycles; 
Power  Energy. 

Average over samples. Perform a moving average (mean) and associated processing (Rectify; Root mean 
square) over the specified number of sample points. This option is useful to process EMG signals to: 

a)  Smooth noisy data 
b)  Display the real-time “integration” (rectified, then sample averaged) of the raw EMG data 
c)  Display the real-time “root mean square” calculation of the raw EMG data. 
d)  Return real-time windowed standard deviation. 

Timed reset. This option is available in the Integrate calculation channel and transformation. This mode 
computes a straight sum of the source data points and resets this sum after a fixed amount of time has 
elapsed. This periodic integral is used in several types of analysis, such as EMG analysis where it can 
generate an EMG signal or estimate the power in fixed time intervals. The time interval at which the 
integral resets to zero may be specified in seconds or in samples. The timed integrate reset functionality 
may also be used in calculation channel presets and by the Mac OS Integrate automator action.  

To have BSL PRO perform an Integrate calculation in real time: 
1. Choose MP > Set Up Data Acquisition > Channels. 
2. Click the Calculation tab. 
3. Check an Acquire box for the Calculation channel to contain the filtered data. Check the Plot and 

Values boxes as appropriate for each channel. 
4. Click the Preset pull-down menu and select Integrate. 
5. Click the Setup button in the Input Channels dialog to generate the Integrate dialog. 
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Destination 
Determined by the calculation channel selected when the Scaling button was pressed. 

Source 
The source channel is selected from a popup menu that includes any channels being acquired and any 
enabled Calculation channels. 

 
Reset via channel (Integrate option) 

This feature is used to integrate data over a data-dependent 
interval. Either the source channel or a different channel can 
control the integration process. 
Control channel 
Allows user to select any active channel as the integration 
control channel. 
Reset Thresholds 
The threshold is to be set at points surrounding the flow 
level. Typical values are:  
LOW: a negative value close to 0.00 HIGH: a positive 
value close to 0.00 
For airflow to volume conversion, the flow signal will vary 
positively and negatively around zero flow. 
Reset trigger  
The Reset trigger polarity determines on which slope 
(Positive ↑ or Negative ↓) the integration process will begin 
and end. 

Mean Subtraction 
This option will subtract the mean from the data evaluated during the integration period. If this option is 
selected, the integration will only proceed after all the data in the integration period has been collected. When 
collected, the mean value of all the data is subtracted from each data point in the integration period. In this 
fashion, the integral of the corrected data points will result in the integral returning to exactly zero at the end 
of the integration interval. Although this option will result in “well-behaved” integrations, the integrated data 
will be delayed by a fixed amount of time, as specified by the max cycle period. 

Online Enabling mean subtraction delays the signal by the mean cycle length. It waits for that period of 
time to pass so it can determine a mean value for the initial cycle, and it then tries to re-
compute this mean for each cycle. If the resets are too short or too long, the window expires 
and the processing halts again until a new mean can be recomputed. Online processing may 
reset from threshold crossing in the control channel or window expiration when it loses mean 
tracking. 

Offline Since all the data is available, the mean is computed from the data in the channel and the signal 
is not delayed. Also, since it isn’t doing windowed means, there are no window expiration 
events that are inserted. Offline processing may reset from threshold crossing in the control 
channel. 

Max cycle period 
The Max cycle period should be longer than the maximum time expected from trigger event to trigger event 
in the Control Channel. Typically, the default scale settings for cyclic integrated data will be fine. However, 
the units may need to be changed (i.e., liters/sec to liters) via the Scaling option. 
Output reset events—not available for metachannels 
Add Events markers to show where Reset occurred and distinguish why the channel reached zero. 
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 Threshold crossing on the 
control channel 
For example: Calculation 
channel resetting on positive 
crossings of 0V on CH 1. 

 

 
 Window expiry when mean 

removal is enabled 
For example: No threshold 
crossing within “mean cycle 
width” as specified in calc 
channel setup. Settings of 
calc channel: threshold 
crossings positive, 3V, Mean 
cycle subtraction, 1 second 
period width. First reset is 
due to threshold crossing; 
second reset is due to 
window expiry.  
 Zero value due to “true” zero 

being achieved due to 
mathematical results 
For example: Mathematical 
Source is sine wave, integral 
is cosine. Input (10V) never 
crosses threshold levels. 
Signal reaches zero 
mathematically; no reset 
events appear on output. 
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Average over samples (Integrate operation) 

Online sample averaging can be useful when there 
is a high degree of noise present in the data. At 
least some of this noise can be “averaged out” by 
pooling some number of adjacent data points 
together, taking the average of these points, and 
replacing the original values with the new averaged 
values. This process creates a “window” of moving 
averages that moves across the waveform 
smoothing the data.   

Integration used to smooth noisy data 

Since an average represents the sum of a series of data points divided by the number of data points present, 
Use the Average over samples calculation to provide the information needed to create a moving average. 
Samples 
To specify the number of data points to average across, enter a value in the Samples box. The number selected 
will depend in large part on the selected sampling rate and the type of noise present. All things being equal, 
for slower sampling rates it’s recommended to mean average across a smaller number of samples. As the 
sampling rate is increased, it’s best to integrate across more samples. As the number of samples specified in 
the samples box increases, the amount of high frequency information contained in the data will decrease. 
Parameters 

Rectify —The Average over samples calculation 
can also be used for producing an envelope of 
modulated data. For instance, EMG waveforms 
frequently contain high frequency information, 
which is often of little interest compared to the low 
frequency information also contained in the data. 
When the Rectify option is checked, BSL PRO will 
take the absolute value of the input data prior to 
summing and a plot of the waveform’s mean 
envelope over a specified number of samples will 
be obtained. 

 
Online “Average over samples” feature used as an 

envelope detector 

Typically, this option is only used for processing raw EMG and similar types of applications. The signal for 
Rectify is normalized by a factor of (# samples averaged)/(Channel sampling rate). 
Root mean square—provides the exact root mean square (RMS) of the input data (typically EMG) over the 
specified number of samples.  
Remove baseline—provides the exact standard deviation of the input data (typically EMG) over the specified 
number of samples. When the mean of the input data equals 0-0, the standard deviation and the RMS will be 
equivalent.  
Scaling… button—Since the integration values are going to be on a different scale than the original units, the 
scale of the integration channel needs to be changed to reflect the new units. Clicking the Scaling… button 
generates a scaling parameters dialog.  
The rescaling involves multiplying the “Input units” values by a factor determined by the sampling rate and 
number of samples mean averaged across. 

Map or Scale value = Input units x 
 averaged mean be  tosamples ofNumber 

 rate Sampling  

As an example, if data was being acquired at 75 samples per second, and it’s necessary to integrate across an 
interval of 10 samples, set the Integration Setup Scaling parameters so that +10 Volts corresponds to a Map 
(Scale) value of 75 and a Map (Scale) value entry of –75 reflects an Input value of –10 Volts. 
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 It is important to note that this rescaling should be performed independent of any rescaling 
performed on analog channels themselves. Even if an analog channel is being rescaled to some other 
units, the input values in the integration scaling should be set to +10 Volts (next to Cal 1) and –10 
Volts (next to Cal 2). 

  
Integrate Calculation and Scaling dialogs for 10 point averaging 

When data is averaged in this way, a portion of the data at the beginning of the record (equivalent to the 
number of samples being integrated) should be ignored, as they will reflect a number of zero values being 
averaged in with the first few samples of data. 
 
Smoothing Calculation 

The Smoothing Calculation functions online in real time and is very useful 
when trying to remove noise of varying types from a data set.  

1. Choose MP > Set Up Data Acquisition > Channels.  
2. Click the Calculation tab. 
3. Check an Acquire box for the Calculation channel to contain the 

filtered data. Check the Plot and Values boxes as appropriate for each 
channel.  

4. Click the Preset pull-down menu and select Smoothing. 
5. Click the Setup button in the Input Channels dialog to generate the 

Smoothing dialog. 
 (Off-line Smoothing is available under Transform > Smoothing.) 
Source Source is a pull-down menu of the available channels. 
Smoothing factor enter the number of samples to use as a smoothing factor. 
Smoothing method This calculation channel provides real-time Mean (default) or Median smoothing. 
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 Mean value The default is mean value smoothing. Use Mean value smoothing when noise appears in 
a Gaussian distribution around the mean of the signal. 

Use Median value Click in the box to activate Median value smoothing if some data points appear 
completely aberrant and seem to be “wild flyers” in the data set. 

  For a given sequence of wave data, x = {x1, x2,...,xn}, Median value smoothing will sort 
the sequence and extract the median equivalent to the recommended NIST (National 
Institute of Standards and Technology) formula: 
• n is odd: median is the center element of the sorted list of n items. 
• n is even: median is the mean of the center pair of elements of the sorted list of n items.  

 The smoothing calculation channel is the primary method of computing real-time median 
values using the definition of median as given above. The smoothing output at a sample 
position is the median of the window of source channel samples including the current 
sample and the previous samples in the window. 

    The size of the window is 1 at the start of acquisition and increases incrementally until 
the final window size is reached. The median extraction method shifts between even and 
odd definitions as the window size is incremented. 

Scaling Click the Scaling button for access to options that modify the units or linearly scale the 
output. 
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Difference Calculation 
The Difference calculation returns the difference between two data samples over a specified number of 
intervals and divides the Difference by the time interval spanned by the data values. The Difference 
Calculation is useful for calculating an approximation of the derivative of a data set in real time. 
To have BSL PRO perform a Difference calculation in real time: 

1. Choose MP > Set Up Data Acquisition > Channels. 
2. Click the Calculation tab. 
3. Check an Acquire box for the Calculation channel to contain the filtered data. Check the Plot and 

Values boxes as appropriate for each channel. 
4. Click the Preset pull-down menu and select Difference. 
5. Click the Setup button in the Input Channels dialog to generate the Difference dialog. 

The Difference Calculation dialog is used to specify the source channel and the number of intervals between 
samples over which the difference is to be taken/ It also includes the option of rescaling the channel to reflect 
different units. 
Click the Setup button in the Input Channels dialog to generate the Difference dialog:  

  
Source When the Source channel contains relatively high frequency data, the Difference Calculation 

may result in a very noisy response, so it’s best to use Difference on relatively smooth data. 
Sample rate This line provides the sample rate for the selected channel (may be different than the 

acquisition sample rate). 
Intervals Difference is calculated with respect to the number of intervals between points (rather than 

the number of sample points). For instance, two sample intervals span three sample points: 
POINT<interval > POINT<interval > POINT 

 A 1-interval difference transformation applied to a blood pressure (or similar) waveform will 
result in the widely used “dP/dT” waveform. 

 See page 277 for a complete description of the online Difference function. 
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Rate Calculation 

  
The Rate Calculation is used to extract information about the interval between a series of peaks in a 
waveform. This interval can be scaled in terms of BPM (the default), frequency (Hz), or time interval between 
peaks. 

 The BPM (or beats-per-minute) Rate function is used as a measure of peaks or events that occur in a 
sixty-second period. 

 The frequency rate function is commonly used to describe the periodicity of data, or the amount of 
time it takes for data to complete a full cycle (from one peak to the next peak). 

 The Interval Rate function returns the raw time interval between each adjacent pair of peaks, which 
is essentially the inter-beat interval (IBI), frequently used in cardiology research. 

These three functions essentially provide the same information in different formats, since a frequency of 2Hz 
is equal to an inter-peak interval of 0.5 seconds, both of which are equivalent to a BPM of 120. Other options 
allow recording of the maximum or minimum value of all peaks (the peak max/min option), or to count the 
aggregate number of peaks (the count peaks option).  
In order to calculate Rate information, there are two options: Sspecifying the threshold manually or having 
BSL PRO automatically compute the default threshold value. This section describes the basic parameter 
settings for typical online Rate Calculations. 

NOTE: Parallel functions can be performed after data has been acquired. A 
detailed description of the Rate Calculation options can be found in the Find 
Rate section on page 304. 

 
To perform a Rate Calculation in real time: 

1. Choose MP > Set Up Data Acquisition > Channels. 
2. Click the Calculation tab. 
3. Check an Acquire box for the Calculation channel to contain the filtered data. Check the Plot and 

Values boxes as appropriate for each channel. 
4. Click the Preset pull-down menu and select Rate. 
5. Click the Setup button in the Input Channels dialog to generate the Rate dialog. 
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Source—selected from the Source popup menu at the top of the dialog. 
Label—Use to create a label for the Rate channel 
Preset—Use to select from 17 pre-defined calculation channel presets. New presets affecting source channel, 
label and output settings can be created and saved by clicking “New Channel Preset.” 
Signal Parameters Tab 
Signal Type—Contains parameters for specific human and animal waveform morphologies. Choose from six 
pre-defined heart rate and respiration signal types, or click “New” to create and save custom setups. Unlike 
channel presets, all pre-defined and custom signal types appear in both calculation channel Rate (online) and 
analysis Rate (offline) dialogs. Signal type modifications affect settings in the Signal Parameters tab only. For 
more details on Rate signal types, see page 307. 
Peak Detect—Choose whether to look for positive or negative peaks in the signal. 
Remove baseline—provides the exact standard deviation of the input data (typically EMG) over the specified 
number of samples. When the mean of the input data equals 0-0, the standard deviation and the RMS will be 
equivalent. 
Baseline window width—Width of the window for the difference operation applied prior to peak detection. 
(E.g. the value of the source x ms previously is subtracted from the current value to generate the signal that is 
analyzed with the peak detection.) 
Auto Threshold detect—The most convenient way to calculate a Rate channel online is to have BSL PRO 
automatically compute the threshold value (the “cutoff” value used to discern peaks from the baseline). This 
is done by checking the Auto Threshold detect box. 
Noise rejection—BSL PRO constructs an interval around the threshold level when Noise rejection is 
checked. The size of the interval is equal to the value in the noise rejection text box, which by default is equal 
to 5% of the peak-to-peak range. Check this option to help prevent noise “spikes” from being counted as 
peaks. 
Cycle Interval Window—When “automatic” Rate Calculations are set, specify a minimum rate and a 
maximum rate. These parameters define the range of expected values for the Rate Calculation. By default, 
these are set to 40 BPM on the low end and 180 BPM on the high end.  
The Rate Calculation will use these values to find and track the signal of interest, assuming the input BPM 
range is reasonably well bracketed by these values. Depending on the shape of the input cycle waveform, the 
Rate window settings may be closer or further from the expected rates. 

 For ECG-type data (where the waveform peak is narrow with respect to the waveform period), the 
Rate window values will closely bracket the expected values. 

 For more sinusoidal data, with the waveform energy distributed over the waveform period (as with 
blood pressure or respiration), the Rate window will closely bracket the expected rate on the high-
end, but can be up to twice the actual measured rate at the low-end. 

Windowing Units—Use to select the unit type to be used in the rate detection. The options are Hz, BPM and 
seconds. 
Output Tab 
Function —The popup menu includes options to scale the rate in terms of Hz, BPM, Interval, Peak Time, 
Count Peaks, Peak Minimum/Maximum, Peak-to-Peak, Mean Value, or Area. 

 For more information on each of these functions, see the Calculation Channels section beginning on 
page 118. 

 Calculate systolic using the peak maximum Function, diastolic using the peak minimum Function, 
and mean blood pressure using the mean value Function. 

 NOTE: All of these Function options are available in the post-acquisition mode through 
the Analysis > Find Rate function 

Use Averaging mode—Use to average to output of the selected function. Averages can be based upon a fixed 
time window or a fixed number of cycles. The ‘Recompute on every cycle’ option will start the averaging 
output after N numbers of cycles are detected and then remain fixed until the next N cycles are detected. 
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Output reset events (not available for metachannels)—When auto threshold detection is being used, the 
minimum and maximum rates of the signal are specified in the Windowing controls. If the input signal falls 
out of this range, the value of the rate function and automatic threshold level will be reset. By enabling 
“Output reset events” a reset event will be placed on the output at the location of these window expirations. 
Rate detector is set to “Peak function, default window of 40 BPM to 180 BPM, auto threshold detect for 
positive peaks. The reset event occurs after the window expiration, approximately a full 40 BPM interval after 
the “peak” transition from 0 to 5 volts in the source signal. 

  
Show Threshold—Plots the threshold used by the Rate calculation function. This feature is useful to help the 
rate detector performance on any given data. 
Show Modified—Plots the modified data as processed by the Rate Detector. Typically, the modified data is a 
differential version of the original input data. The data will be modified if the “remove baseline” feature is 
checked in the Find Rate Setup dialog. 
Math Calculation 
The Math Calculation performs standard arithmetic calculations using two waveforms or one waveform and a 
constant. It is also possible to use other Calculation channels (such as a Rate Calculation channel) as an input 
channel for a Math Calculation channel, as long as the Calculation channel used as a source channel has a 
lower channel number than the Math Calculation channel. 

1. Choose MP > Set Up Data Acquisition > Channels. 
2. Click the Calculation tab. 
3. Check an Acquire box for the Calculation channel to contain the filtered data. Check the Plot and 

Values boxes as appropriate for each channel. 
4. Click the Preset pull-down menu and select Math. 
5. Click the Setup button in the Input Channels dialog to generate the Math dialog. 

Use the pull-down Source menus to select the source channels (Source 1 and Source 2). 
The Sample rate line provides the sample rate for the channel selected as Source; the channel sample rate may 
be different than the acquisition sample rate. 
Use the pull-down Operand menu to select a function. In the example below, analog channel 1 (Source: A1) is 
added to analog channel 2 (Source: A2). To use this summed waveform as an input for another Math 
Calculation channel. One useful application would be to divide this waveform (C0) by K, where K=2, thus 
producing an arithmetic average of source channels A1 and A2. 
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The “Constant” entry is activated when “K” is selected as a Source. 
As an alternative to creating an additional Calculation channel for dividing the summed waveform, the scaling 
function can be used to perform the same task. To do this, click Scaling… button and then set the Map (Scale) 
value for the summed waveform equal to +5 and –5 (to correspond to Input Volts values of +10 and –10 
respectively). This will effectively plot the sum of channels A1 and A2 as the arithmetic mean of the two 
waveforms. 

For additional libraries of online Calculation options, consult the sections on Function Calculation 
channels and the online Equation Generator (Expression, page 137). These types of Calculation 
channels can be used to perform more complex operations on waveforms. Although Calculation 
channels can be “chained” together (so that the output from one serves as the input for another) to 
form more complex calculations, a separate channel must be used for each function. Since only 
sixteen Calculation channels are available, not all calculations can be performed. Additionally, 
chaining more than three or four channels together can require considerable system resources. 
For complex calculations (such as squaring a waveform then adding it to the average of two other 
waveforms) the Equation Generator (Expression) is a more efficient solution. All of the features 
available online in the Math Calculation channels can also be computed after an acquisition using the 
Waveform Math option (see page 280), which will eliminate the problem of system overload. 

Function Calculation 

 

 

The Function calculation can be used to perform a variety of 
mathematical functions using two waveforms or a waveform and a 
constant. Function Calculation channels compute new waveforms 
in a manner similar to the math Calculation functions, but provide 
access to higher order functions. Like math Calculation channels, 
function Calculations can be chained together to produce complex 
functions (such as taking the absolute value of a waveform on one 
channel and Calculating the square root of the transformed 
waveform on another channel). These same functions are also 
available under the transform menu in BSL PRO for post-hoc 
operations. Many of these functions can also found in the online 
Equation Generator (see Expression on page 137 for details). 
To have BSL PRO perform a Function Calculation in real time: 

1. Choose MP > Set Up Channels. 
2. Click the Calculation tab. 
3. Check an Acquire box for the Calculation channel to 

contain the filtered data. Check the Plot and Values boxes 
as appropriate for each channel. 

4. Click the Preset pull-down menu and select Filter. 
5. Click the Setup button in the Input Channels dialog to 

generate the Function dialog. 
Other Functions are available in the online Expression calculation 
channel (see Expression on page 137). Function Calculations can 
be chained together to produce more complex Calculations, 
although it is more efficient to program complex functions using 
the Equation Generator (Expression). 
The Sample rate line provides the sample rate for the selected 
channel (may be different than the acquisition sample rate). 

Function 
Abs Returns the absolute value of each data point 
Atan Computes the arc tangent of each data point 
Exp Takes the ex power of each data point 
Limit Limits or “clips” data values that fall outside specified boundaries 
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Ln Computes the base e logarithm for each data point 
Log Returns the base 10 logarithm of each value 
Noise Creates a channel of random noise with a range of ± 1 Volt 
Sin Calculates the sine (in radians) of each data point 
Sqrt Takes the square root of each data point. 

Threshold Converts above an upper threshold to +1 while converting data below a lower threshold to 0. 
Thresholding Algorithm Assume a domain variable 

 

t ∈ tstart,tstart +1,tstart + 2,{ } 
with tstart being an integer, a real-valued signal y(t) defined for all t, and two real valued levels 
ylow and yhigh satisfying the relation 

 

ylow ≤ yhigh . 

Define the Threshold function thresh(t) function such that: 

 

thresh(tstart ) =
1 y(tstart ) ≥ ylow

0 y(tstart ) < ylow

 
 
 

    

 

thresh(t) =
0 y(t) < ylow

1 y(t) > yhigh

thresh(t −1) ylow ≤ y(t) ≤ yhigh

 

 
 

 
 

 

Filter Calculation 
The Filter Calculation channel is used for performing real time digital filtering on analog, digital, or 
calculation channels. To apply a digital Filter Calculation in real time: 

1. Choose MP > Set Up Data Acquisition > Channels. 
2. Click the Calculation tab. 
3. Check an Acquire box for the Calculation channel to contain the filtered data. Check the Plot and 

Values boxes as appropriate for each channel. 
4. Click the Preset pull-down menu and select Filter. 
5. Click the Setup button in the Input Channels dialog to generate the Filter dialog. 

                      
Filter Setup & Output Options 

In the dialog above, the signal on analog channel one (A1) is run through a low-pass filter that attenuates data 
above 50 Hz. The “Q” for this filter is 0.707, which is the default. 

One possible application of the online filtering option is in conjunction with the Show Input 
Values option (see page 208). Raw EEG data, for instance, can be filtered into distinct 
bandwidths (alpha, theta, and so forth) using one source channel and multiple filter 
Calculation channels. The filtered data can then be displayed in a bar chart format during the 
acquisition using the Show Input Values option. 

Source Set the source channel. 
Sample rate provides the sample rate for the selected channel (may be different than the acquisition 

sample rate). 
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Type (Output) Lists the filter options: low pass, high pass, band pass, band pass (low + high), band stop, and 
comb band stop. See About Filters in this section for more details on filter types. 

Frequency Fixed value—Type a value in the entry box. 
 Sampling rate—Sets the frequency to a fraction of the sampling rate and automatically 

updates when the sample rate is modified. 
 Line frequency—Uses the line frequency at which the data was recorded. 
Q coefficient The online filters are implemented as IIR (Infinite Impulse Response) filters, which have a 

variable Q coefficient. The Q value entered in the filter setup box determines the frequency 
response patterns of the filter. This value ranges from zero to infinity, and the “optimal” 
(critically damped) value is 0.707 for the Low pass and High pass filters, and 5.000 for the 
Band pass and Band stop filters. The Q can be changed if desired. A more detailed 
explanation of this parameter, and digital filters in general, can be found in Appendix B. 

About Filters 
While the technical aspects of digital filtering can be quite complex, the principle behind these types of filters 
is relatively simple. Each of these filters allows a cutoff point to be set for the low and high pass filters or a 
range of frequencies to be set (for the band pass and band stop filters). 
 A Low Pass filter is used for specifying a frequency cutoff that will “pass” or retain all frequencies 

below this point, while attenuating data with frequencies above the cutoff point. 
 High Pass filters perform the opposite function, by retaining only data with frequencies above the 

cutoff, and removing data that has a frequency below the specified cutoff. 
 Each type of Band Pass filter is optimized for a slightly different type of task. 

The Band Pass (low + high) filter is designed to allow a variable range of data to pass through the 
filter. For this filter, it’s necessary to specify a low frequency cutoff as well as a high frequency 
cutoff. This defines a range or “band” of data that will pass through the filter. Frequencies outside this 
range are attenuated. The Band pass (low + high) is actually a combination of a low pass and a high 
pass filter, which emulate the behavior of a band pass filter. This type of filter is best suited for 
applications where a fairly broad range of data is to be passed through the filter. For example, this 
filter can be applied to EEG data in order to retain only a particular band of data, such as alpha wave 
activity. 
The alternative Band Pass filter requires only a single frequency setting, which specifies the center 
frequency of the band to be passed through the filter. When this type of filter is selected, the “width” 
of the band is determined by the Q setting of the filter (discussed in detail below). Larger values for q 
result in narrower bandwidths, whereas smaller Q values are associated with a wider band of data that 
will be passed through the filter. This filter has a bandwidth equal to Fo/Q, so the bandwidth of this 
filter centered on 50 Hz (with the default Q=5) would be 10 Hz. This type of filter, although 
functionally equivalent to the band pass (low + high) filter, is most effective when passing a single 
frequency or narrow band of data, and to attenuate data around this center frequency. 

 The Band Stop performs the opposite function of a band pass. A Band stop filter defines a range (or 
band) of data and attenuates data within that band. In this case, the Band stop filter is implemented in 
much the same way as the standard Band pass, whereby a center frequency is defined and the Q value 
determines the width of the band of frequencies that will be attenuated. 

Off-line filtering 
Apart from these online filter options, similar filters can be applied after an acquisition is terminated. Many of 
the biopotential amplifiers available from BIOPAC have selectable filters, which allows the filtering of 
certain frequencies (including 50 Hz or 60 Hz electrical noise) and can reduce the need for online filters. 
Digital filtering can also be performed after an acquisition. Select various filter types by selecting Digital 
filters from the Transform menu. The filters available after the acquisition use a different algorithm but 
operate in essentially the same way. 

For more information on digital filters and filters that can be applied after an 
acquisition, turn to the Digital Filtering section on page 258 or Appendix B. 
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Expression 

 
The online Expression calculation channel is available for performing computations more complex than 
possible in the Math and Function calculations. The Expression calculation will symbolically evaluate 
complex equations involving multiple channels and multiple operations. BSL PRO can perform conditional 
evaluation, data extraction, logical operations, expressions requiring a range of samples or the results of the 
previous expression, and evaluation of generic formulas that can be expressed in a closed, recursive form. 
Unlike the Math and Function calculations—which can only operate on one or two channels at a time—the 
Expression calculation can combine data from multiple analog channels, and allows other Calculation 
channels to be specified as input channels for Equation channels. In addition, computations performed by the 
Expression calculation eliminate the need for “chaining” multiple channels together to produce a single output 
channel. 
While the Expression calculation is more powerful than other Calculation channels, each Expression 
calculation requires more system resources than other Calculations. This essentially means that acquisitions 
that utilize Equation calculations are limited to a lower maximum sampling rate than acquisitions without 
online Expression functions. When an expression is evaluated, it is actually evaluated multiple times. The 
expression is computed starting at the first sample acquired, and is then evaluated once for each successive 
acquired sample. 
BSL PRO can accept the notations SC, MC, and CHn to reference the sample at the current evaluation position 
or SC(x), MC(x), and CHn(x) for values at locations prior to the present evaluation location using an offset 
expressed in sample intervals. For example, CH1(-1) will give the previous sample of Channel 1. 
The same features that are available in online Calculation channels are also available under the Transform 
menu for evaluation of complex equations after acquisition. Thus, simple Calculations such as summing two 
channels or dividing one channel by another (and so forth) are best performed in either the Math calculation 
channels or the Function calculation channels. 
On the other hand, for complex Calculation channels, such as squaring one channel, multiplying it by the sum 
of two other channels, and dividing the product by the absolute value of another waveform, a single 
Expression calculation channel is more efficient than chaining five Math and Function calculation channels. 
Save to Calculation Channel 
To evaluate an expression and save the result to a Calculation channel in real time: 

1. Choose MP > Set Up Data Acquisition > Channels. 
2. Click the Calculation tab. 
3. Check an Acquire box for the Calculation channel to contain the filtered data. Check the Plot and 

Values boxes as appropriate for each channel. 
4. Click the Preset pull-down menu and select Expression. 
5. Click the Setup button in the Input Channels dialog. This will produce a dialog for entering the 

expression to be evaluated. 
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The different components of each expression can be entered either by double-clicking buttons from the button 
rows (sources, functions, and operators) in the setup expression dialog, or by typing commands directly into 
the Equation box. The Expression uses standard mathematical notation. 
For each expression, it’s necessary to specify at least one source, the function(s) to be performed, and any 
operators to be used. Sources are typically analog channels, although Time may also be selected from the 
source button row and BSL PRO will return the value of the horizontal axis for each sample point. When the 
horizontal axis is set to frequency (in the Display > Horizontal axis dialog), the “time” item in the source 
button row will switch to “frequency.” 
When using the online Expression calculation channel, it is important to keep in mind that while different 
channels, functions, and operators can be referenced, the Calculation cannot reference future sample points. 
That is, data from waveform one can be transformed or combined in some way with data from waveform two 
at the same point in time, although data from one point in time (on any channel) cannot be combined with 
data from another point in time (on any channel). See the section on post-acquisition expression commands 
(beginning on page 279) for ways around this limitation. 
Functions The arguments to each function are represented in the Functions table in italics and 

may be replaced by any valid expression. Each argument is separated from its next 
argument by a comma. Expressions can only contain commas within balanced 
parenthesis pairs. An ellipsis (“...”) at the end of a function description indicates that 
any number of arguments may be present provided they are in a comma separated list. 
When a function is added to an Expression, the cursor is placed between the 
parentheses.  

Conditionals Change output based upon a condition test. All of the conditionals treat the value zero 
as false and any non-zero value as true. Expressions can only contain commas within 
balanced parenthesis pairs. 

Offset Notation Offset notations take integer offsets in terms of the number of samples using the 
formation CH#(P) where CH# is the channel number and P is the number of points. For 
example, an offset of -1 will return the data point immediately to the left of the selected 
point and an offset of +1 will return the data point immediately to the right of the 
selected point. 

 To refer to previously acquired data, offsets must be negative. For notational 
convenience, offsets that result in an invalid negative sample position (e.g. no data is 
defined prior to the first sample in the graph) evaluate to zero. Any attempt to access a 
sample beyond the end of the data will result in an error. Any attempt to use a positive 
offset for an online Equation Generator (Expression calculation channel) will result in 
an error. 
CHn(x) Returns the value of channel with index n x samples away from the current 

evaluation position. 
SC(x) Returns the value of the selected channel x samples away from the current 

evaluation position. Only allowed for Transformations and Measurements; 
not allowed for Calculations. 

MC(x) When x is zero or positive, returns the value of the measurement channel x 
samples away from the current evaluation position. When x is negative, 
returns the result of the expression evaluation that occurred x steps previous 
to the current evaluation position. Only allowed for Measurement 
Expressions (see below); not allowed for Calculations or Transformations. 

Recursive notation Since transformations and calculation channels replace the source data of the channel 
with the result of the expression evaluation in sequence, negative offsets are equivalent 
to returning the final result of the expression that was evaluated a certain number of 
steps in the past. The channel where the expression results are stored can be thought of 
as a storage record of the previous evaluation steps. Negative sample offsets, therefore, 
can be used to compute any formula that can be expressed in closed recursive form. For 
example, the recursive definition of the Fibonacci sequence is: 
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Fn = Fn-1 + Fn-2 
To evaluate this as an expression transformation, use the expression: 

SC(-1)+SC(-2) 
Note that to actually get the Fibonacci sequence, the selected channel would need to 
have a constant value of one prior to the transformation. 

Expression Measurements are powerful tools for quick manual analysis and also for advanced 
Measurement  automated analysis when combined with the Cycle/Peak detector. Expression 

measurements extend measurements to evaluate simple formulas or complex data 
reduction. Each Expression measurement has an expression associated with it and the 
measurement result is derived from computing the Expression(s) on the selected data. 
Measurement expression dialog is 
generated the first time a measurement 
is set to Expression or when the 
measurement “info” button is clicked. 
Preset menu allows access to pre-
loaded commonly used expressions 
and displays user-defined custom 
presets, along with a list of recently-
used expressions. 
OK invokes a syntax check. If there is 
an error, the user will be prompted to 
correct the error and the error will be 
selected (highlighted) in the 
Expression edit field. 
Cancel discards any changes to the 
Expression measurement and reverts 
back to the previous Expression. 
Clear erases the current contents of the 
expression edit field. 

 

 

Measurement Channel 
Expression measurements can reference the “measurement channel” (MC), which refers to either the selected 
channel or a specific channel as set in the measurement channel selection box within the graph window. 
Negative sample offsets to MC are interpreted as returning the result of the Expression from a prior step. 
Transformations and calculation channels achieve this as they replace the contents of their destination 
channels sequentially. Measurements, however, do not actually replace the data of their source channels. 
Expression measurements are actually executed on a temporary copy of the channel data in memory. This 
implies that negative indicies to the measurement channel are interpreted exactly the same for measurements 
as for transformations and calculation channels even though the “transformed” data of the measurement is not 
visible. Negative sample offsets to MC that refer to the sample position prior to the leftmost sample of the 
selected area will always return zero. 
Evaluation Rules 
When a new selection is made, the first step in evaluation searches through the Expression measurement for 
any MMT() invocations. Any measurement whose value is needed by MMT() is computed at this time prior 
to the Expression evaluation. This behavior is similar to calculation channels and successfully allows 
measurements to the right and bottom of the Expression measurement to be used in the expression. 
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The expression is subsequently evaluated from the leftmost sample in the selection to the rightmost sample. It 
is evaluated at the waveform sampling rate of its source channel, with one expression evaluation per sample 
contained within the selected area. Interpolation is not used at the boundaries to maintain a consistent sample 
interval for the expression. After each expression evaluation, the result is cached in memory for potential 
negative MC result references. 
The value of the final expression, the rightmost sample, becomes the result of the measurement. 
Circularity Detection 
Expression measurements may reference other expression measurements or calculation measurements by 
using the MMT() function in the expression. This raises the possibility of circular dependencies being formed 
by the user if a measurement expression either directly or indirectly needs its own value to compute a MMT() 
invocation. Circular dependency checking will be in place at execution time and will result in an error. 
To refer an Expression measurement to its own value, use the MC notation. 
Error Reporting 
The Expression measurement result will display the text “Error” if there are syntax errors in the Expression 
measurement, errors computing measurements referenced by MMT(), or a circularity. 
Validation Tip To function correctly, BSL PRO requires real-valued data. Make sure that expression 

results are real-valued. To test if a floating point number x is a real-valued number, use 
the expression: 
 
 NOT(OR(ISINF(x), ISNAN(x))) 

Note for variable sample rate processing:  
The Expression and Waveform Math functions will constrain operations between waves of different rates as 
follows: 
If an equation is operating on two or more waves of different sample rates, the result of the operation will 
always be output at the lowest sampling rate from the waves (F low). If the destination channel for the result 
has an assigned rate other than (F low), the operation will not be permitted. If the destination channel is set to 
a new channel, the operation will always be permitted. 
In BSL PRO and higher, all sources for Expressions and Waveform Math operations must be sampled at the 
same waveform sampling rate. 
VSR data padding—If the channels are of unequal length (as a result of variable sampling rate or waveform 
editing), they will be padded for Append acquisition. Digital and Analog channels are stored as short integers 
by default; a waveform paste into a digital or analog channel, however, will result in its underlying data being 
converted to floating point. This will generate the “Abort/Replace” warning for pastes to Digital or Analog 
channels since the data format has changed since the last acquisition. 
Additionally, if an Analog or Digital channel is used as the source waveform for a Copy, it will also be 
converted to floating point and will result in the “Abort/Replace” warning being generated. 
Since Calculation channels are already floating point, pasting into them or copying from them will not change 
their data format. The channels will be padded with their last value and the append will commence. 
Waveform Cut operations do not change the underlying data format for Analog, Calculation, or Digital 
channels. If only Waveform Cut is used, no data format conversion will occur and channels will be padded 
with their last value and subsequent appends are allowed. 
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Source Description 
CH Value of the designated channel (CHn) at 

the current evaluation step. 

Primary Source 
Channel 
metachannels only 

Appears as PSC in the dialog. Refers to 
the data of the primary source channel of 
a metachannel.  

Time Time (in sec) of current evaluation step 

Sample  Sample index of evaluation step; the first 
sample in the graph will always be 
reported as a value of zero. 

Pi  Value of pi (3.141592654…) to double-
precision accuracy. 

SC  
 

Transformation and measurement only Value 
of the selected channel at the current 
evaluation step; can still back-reference 
samples points. 

True  Evaluates to the value 1 (non-zero values 
are interpreted as True) 

False  Evaluates to the value 0 

Segment Timer Used as a source for the onscreen 
Stopwatch gauge view. 

Random Generates random white noise. 

Gaussian 
Random* 

Generates Gaussian white noise for 
startle responses. Returns a random 
value from a Gaussian distribution. 

*Standard Gaussian model; useful for peak fitting.  
param(0)*EXP(-((TIME-param(1))/param(2))^2 

Operator Operation 

+ Addition 

- Subtraction 

* Multiplication 

/ Division 

^ Power 

( Open parentheses 

) Close parentheses 
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FUNCTION  RESULT 
ABS Returns the absolute value of each data point. 
ACOS Computes the arc cosine of each data point in radians. (All trigonometric functions 

use 'radians' as the unit of angle for input or output as appropriate.) 
AND(x, y, …)  Computes a logical “and” operation for its arguments. Accepts up to eight (8) 

arguments and evaluates to 
1 if all of its arguments are non-zero values. 

 0 if one of its arguments is zero. 
ASIN Calculates the arc sine of each value in radians. (All trigonometric functions use 

'radians' as the unit of angle for input or output as appropriate.) 
ATAN Computes the arc tangent of each sample point in radians. (All trigonometric 

functions use 'radians' as the unit of angle for input or output as appropriate.) 
CEIL(x) Computes the ceiling function (the closest integer larger than the value x). 
COND(T, A, B, C)  Three-way conditional takes four arguments: 

COND(test_expr, neg_test_value, zero_test_value, pos_test_value) 
Evaluates test_expr and if 

< 0, returns neg_test_value 
= 0, returns zero_test_value 

  >  0, returns pos_test_value 
COS Returns the cosine of each data point in radians. (All trigonometric functions use 

'radians' as the unit of angle for input or output as appropriate.) 
COSH Computes the hyperbolic cosine of each selected value 
EQUAL(x, y, …)  Performs a Logical equal (numerical comparison) of its arguments. Accepts up to 

eight (8) arguments and evaluates to 
1 if all of its arguments are equal. 

 0 if one of its arguments is not equal to the others. 
EXP Takes the ex power of each data point.. 
FLOOR(x) 
 

Computes the floor function (the closest integer less than the value x). 

IF(T, A, B)  
 

Two-way conditional takes three arguments: 
IF(test_expr, true_value_expr, false_value_expr) 
The conditional evaluates test_expr and if 

non-zero, returns true_value_expr 
0, returns false_value_expr 

ISINF(x)  Filters out infinities and unrepresentable numbers from data; important because 
such values can cause erratic behavior in autoscaling and other operations. Use to 
test whether any expressions have resulted in floating point overflow and have 
generated numbers too large to be represented in the computer. Evaluates to 

1 if x is inf, the floating point representation of infinity. 
0 if x is NaN or a real-valued floating point number. 

ISNAN(x)  
 

“Is not a number” can be used to test whether any expressions have resulted in 
floating point errors such as division by zero. Use to ensure that the output of 
transformations and equations does not produce numbers that BSL PRO cannot 
display. Evaluates to 

1 if x is NaN, the invalid floating point number. 
 0 if x is inf or a real-valued floating point number. 

LESS(x, y)  
 

Performs a numerical comparison of its arguments and evaluates to 
1 if x is less than y. 
0 if x is greater than or equal to y. 
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FUNCTION  RESULT 
LOG Computes the natural logarithm of each value 
LOG10 Returns the base 10 logarithm of each value 

 
MAXIMUM Returns the maximum value of all input arguments. 
MiINIMUM Returns the minimum value of all input arguments. 
MMT(row,col)  Transformation and measurement only Evaluates to the result of a measurement 

being displayed in the graph, as specified by row and column. Use to scale by a 
result without having to manually enter the result. Row and Column for a 
measurement start as 0,0 for the top left measurement box; the fourth argument on 
the first row is accessed by MMT(0,3). For this function, the required measurement 
box must be displayed in the graph. Since the values of measurements may change 
during the course of an acquisition, calculation channel expressions cannot use this 
function. 

MOD(x,y) Computes the floating-point modulus; returns integer portion of modulus. 
Example: MOD(5,2) evaluates to “1” 

NOT(x) Computes a logical negation of its argument. Evaluates to 
1 if x is zero. 
0 if x is non-zero. 

OR(x, y, …)  
 

Evaluates multiple variables; true if any are true. Computes a logical “or” operation 
for its arguments. Accepts up to eight (8) arguments and evaluates to 

1 if any one of its arguments is non-zero. 
 0 if all of its arguments are zero. 

ROUND(x) Returns an integer closest in value to the argument. For example: 
  round(2.4) = 2    round(2.5) = 3    round(-1.5) = -1    round(-1.6) = -2     

SIN Calculates the sine (in radians) of each data point in radians. (All trigonometric 
functions use 'radians' as the unit of angle for input or output as appropriate.) 

SINH Computes the hyperbolic sine for each sample point. 
SQR Performs the ‘sgn’ sign extraction function. Evaluates 1 if x > 0, -1 if x = 0, and 0 if x 

= 0. 
SQR Squares each data point. 
SQRT Takes the square root of each data point. 
TAN Computes the tangent of each sample point in radians. (All trigonometric functions 

use 'radians' as the unit of angle for input or output as appropriate.) 
TANH Calculates the hyperbolic tangent of each sample point. 
TRUNC(x) Removes the fractional part of the number and returns an integer. For example: 

  TRUNC(2.4)= 2    TRUNC(2.5)= 2    TRUNC(-1.5)= -1    TRUNC(-1.6)= -1 

Note When used with scientific notation, TRUNC(x) applies only to the fractional 
portion after the exponential factor is taken into account: TRUNC(2.93E+4) = 
TRUNC(29300) = “29300”. Since 2.93e+4 (29,300) has no fractional portion, 
the number is returned unchanged. Similarly, TRUNC(2.931245E+4) = 
TRUNC(29312.45) = “29312”. 

XOR(x, y, …)  Logical exclusive OR; true if an odd number is true. Computes a logical “exclusive 
or” for its arguments (e.g. “one or the other, but not both”). Accepts up to eight (8) 
arguments and evaluates to 

1 if an odd number of its arguments are non-zero. 
0 if an even number of its arguments are non-zero or 

if none of its arguments are non-zero. 
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Delay Calculation 

 

 
Delay setup dialog and resulting graph showing 20 sample delay 

This option allows a Calculation channel to be used to plot another channel lagged (delayed) by an arbitrary 
interval. To apply a Delay Calculation in real time: 

1. Choose MP > Set Up Data Acquisition > Channels. 
2. Click the Calculation tab. 
3. Check an Acquire box for the Calculation channel to contain the filtered data. Check the Plot and 

Values boxes as appropriate for each channel. 
4. Click the Preset pull-down menu and select Delay. 
5. Click the Setup button in the Input Channels dialog to generate the Delay dialog. 

 
The delay interval can be specified either in terms of samples or seconds. These types of plots are useful for 
producing non-linear (“chaos”) plots in BSL PRO’s X/Y display mode (see page 33 for a description). 
When a delay channel is recorded, there is a segment at the beginning of the Calculation channel (equal to the 
value of the delay) that will read as 0 Volts. This is normal and occurs because the delay channel is waiting to 
“catch up” with the original signal. BSL PRO fills this buffer with zeros until the delay channel begins to plot 
actual data. In the example below, the delay channel contains a 0.25-second interval of zeros at the beginning 
of data file.
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Control Calculation 

 
The Control function is used to output a digital pulse when the value for a specified input channel exceeds a 
certain level, falls inside a given range, or falls outside a given range. This feature is unique in that the output 
is on a digital channel (which ranges from I/O 1 through I/O 8) rather than a Calculation channel. Also, unlike 
other Calculation channels, this Control Calculation can only be performed in real time (i.e., while data is 
being acquired) and cannot be performed in post acquisition mode. 
In addition to outputting a signal on a digital channel, the Control Calculation will also plot an analog version 
of the digital signal on the specified Calculation channel. For instance, in the example below, Calculation 
channel C1 is used to perform a control function using analog channel 1 (Ch1) as an input and digital channel 
0 (D1) as an output. In addition to outputting a pulse on D1, the setup below will also produce a plot on 
channel 40 (the first Calculation channel) that emulates the signal being output on digital channel 1. Since 
Calculations are analog channels, the Calculation channel does not contain a “true” digital signal, but is a 
reasonably good approximation. To retain the physical output generated by a Control channel, the output 
digital channel should be looped back to another digital input channel of the MP unit and acquired as well as 
being connected to any external devices. The calculation channel values are not guaranteed to precisely match 
the actual digital output. 
 
To have BSL PRO apply a Control Calculation in real time: 

1. Choose MP > Set Up Data Acquisition > Channels. 
2. Click the Calculation tab. 
3. Check an Acquire box for the Calculation channel to contain the filtered data. Check the Plot and 

Values boxes as appropriate for each channel. 
4. Click the Preset pull-down menu and select Control. 
5. Click the Setup button in the Input Channels dialog to generate the Control dialog. 

 
There are four parameters that need to be specified for each Control channel: 

a) Source channel c) Type of threshold function 
b) Output channel d) Threshold level values  

“Source” refers to the input channel to be used for the Control function. As with other Calculation channels, 
the Control function can use either an analog channel or another (lower) Calculation channel as an input. In 
the previous example, analog channel 1 (Ch1) is used as the input channel. It is not possible to use a digital 
channel as an input channel for a Control Calculation. 
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The channel selected in the Output Channel section determines which digital channel the pulse will be sent to. 
The digital channels range from 1 to 8 (D1 through D8. In the sample dialog shown, the digital pulse is sent 
over I/O line D1. 
Digital channels have two levels, 0 Volts and +5 Volts. When the signal transits from 0 Volts to 5 Volts, an 
“edge” is created and since the signal is going from low to high, this is referred to as a positive edge. 
Similarly, as the signal transits back from 5 Volts to 0, a negative edge is created. These transitions or edges 
can be used to trigger external devices when an analog signal level meets certain threshold criteria. 
The Threshold Function option sets the criteria for the Control channel. Threshold conditions can be set so 
that the digital I/O line goes to +5 Volts when the conditions are met, or program the digital line to go to 0 
Volts when the threshold conditions are met. Threshold conditions can be set so that either (a) the digital line 
is switched when the value of an analog channel exceeds a specified value or (b) the digital line is switched 
when an analog channel falls within a given range. BSL PRO also supports creation of a single level threshold 
or a “wide” threshold. 

Tip  To use test conditions more complicated than simple thresholding, combine the conditional tests of 
Expression calculations with the Control channel to change digital output based on the Expression 
result. 

For example, suppose it’s necessary to set a Control channel to switch digital line 5 from low to high 
whenever the signal for Calculation channel one (C1) exceeds 85 BPM. Set the source channel to C1 and the 
output to D5. Select the upper left graph in the control dialog and set L2 and L1 to 85, as shown: 

  
Control dialog and graph showing result of BPM control example 

As shown in the preceding graph, there are a number of instances where C1 (heart rate) exceeds 85, usually 
for a short period of time. When it does drop below 85, it appears to return to a value greater than 85 within a 
second or two. In instances such as this, it might be useful to “widen” the threshold so that the digital line is 
triggered whenever the input value is greater than 85, but the signal must drop significantly below the 
threshold value before the threshold is reset. 
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As another example, the upper threshold value (L2) is set to 85 and the lower threshold (L1) is set to 83, 
which means that the threshold will not reset until the signal from the source channel drops below 83. In the 
following example, the digital line is switched from low to high (from zero to +5 Volts) when the heart rate 
channel exceeds 85, and stays at +5 Volts for several seconds even though the source channel drops below 85 
(but above 83). The digital line does not switch back to zero until the heart rate channel drops below 83 
(toward the end of the record). Once this occurs, the threshold is reset and the digital line will switch again the 
next time the source channel exceeds 85 BPM. 

  
Control dialog and graph showing control channel with “wide” threshold 

It is also possible to have the digital line switch when the source channel drops below a certain value. In the 
example below, a simple threshold is used to switch the digital line high each time the source channel drops 
below 50 BPM. Since L2 and L1 are set to the same value, this is not a “wide” threshold (as above) and the 
threshold resets each time the source channel goes above 50 BPM. 

  
Control dialog and graph showing control channel detecting source channel levels less than 50 BPM 

These examples are only a few of the possible applications of the control channel using the two threshold 
icons on the left-hand side of the Control Setup dialog. Variations of these examples not discussed above can 
be configured (i.e., switching the digital line from low to high using a wide threshold whenever the source 
channel drops below a given channel). Moreover, each of the options can be construed somewhat differently 
than presented here. For example, the previous example switches the digital line from low to high each time 
the signal on the source channel drops below 50 BPM. Conversely, it also switches from high to low each 
time the source channel value is greater than 50 BPM. This allows varying the default setting for the digital 
channels (whether the default is zero or +5 Volts) depending on what types of devices are connected. 
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In addition to setting “above and below” type thresholds, the Control channel can be programmed such that 
the digital line is switched whenever the source channel falls within a given range or outside a specified 
range. In the example that follows, digital line 15 is set to switch from zero to +5 Volts whenever the source 
channel signal falls between the values entered in the L1 and L2 boxes. In this case, I/O is switched to +5 
Volts whenever the heart rate is greater than 60 BPM but less than 80 BPM.  

  
Control dialog and graph showing control channel switching from 
low to high when source channel is between 60 BPM and 80 BPM 

The digital line can also be configured to switch from high to low when the signal on the source channel falls 
within a given range. This is equivalent to setting the digital line to shift from low to high when the source 
channel values fall outside a given range (as shown below). 

  
Control dialog and graph showing control channel switching from 
high to low when source channel is between 60 BPM and 80 BPM 
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Adaptive Filtering Calculation 

 
 See the Adaptive Filtering transform on 

page 264. 

Adaptive filtering is a signal processing technique that 
processes two different signals in relation to one another 
and can be used for noise estimation, noise reduction, 
general-purpose filtering, and signal separation. Adaptive 
filtering creates efficient high-quality filters with a 
minimal number of terms, which can be very useful in 
blocking mains interferences or other known periodic 
disturbances. 
 Useful for noise filtering where it is possible to 

acquire a signal that is correlated to the noise (similar 
to the way noise-cancelling headphones detect and 
remove outside noise). Applications include removing 
EMG from ECG or EOG from EEG. 

To have BSL PRO apply an Adaptive Filtering Calculation in real time: 
1. Choose MP > Set Up Data Acquisition > Channels. 
2. Click the Calculation tab. 
3. Check an Acquire box for the Calculation channel to contain the filtered data. Check the Plot and 

Values boxes as appropriate for each channel. 
4. Click the Preset pull-down menu and select Adaptive Filtering. 
5. Click the Setup button in the Input Channels dialog to generate the Adaptive Filtering dialog. 

The weights within an adaptive filter are modified on a step-by-step basis. BSL PRO uses the N-tap FIR 
adaptive filter, with coefficients updated using least means squares (gradient) feedback. 

Order Specify a positive integer for the number of terms to be used in the internal FIR filter. 
Step size Provides mu, the rate of adaptation of the coefficients within the FIR filter. 
Source channel The source channel will be replaced by the adaptive filter results. 
Noise channel The noise channel is the signal that is correlated with the noise to be eliminated from 

the Source; it is not modified by adaptive filtering. 
Source and Noise channels must have the same channel sampling rate (under Channel Set Up). 
 
 
Comb Band Stop Filter Calculation 
To have BSL PRO apply a Control Calculation in real time: 

1. Choose MP > Set Up Data Acquisition > Channels. 
2. Click the Calculation tab. 
3. Check an Acquire box for the Calculation channel to contain the filtered data. Check the Plot and 

Values boxes as appropriate for each channel. 
4. Click the Preset pull-down menu and select Comb Band Stop. 
5. Click the Setup button in the Input Channels dialog to generate the Comb Band Stop dialog. 

See page 135 for details. 
 
Metachannel  
See Metachannel details on page 119. 
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Rescale Calculation 

 

Rescale applies two-point linear mapping and allows users to change the measurement units (for example, to 
change temperature from Celsius to Farenheit). The text corresponding to the new units can be manually 
entered. 
To have BSL PRO apply a Rescale Calculation in real time: 

1. Choose MP > Set Up Data Acquisition > Channels. 
2. Click the Calculation tab. 
3. Check an Acquire box for the Calculation channel to contain the filtered data. Check the Plot and 

Values boxes as appropriate for each channel. 
4. Click the Preset pull-down menu and select Rescale. 
5. Click the Setup button in the Input Channels dialog to generate the Rescale dialog. 

• Use the Rescale transformation (after acquisition) to adjust forgotten calibration of analog channels or 
reverse incorrect calibrations.  

• A "Rescale" Automator action has been added to allow rescaling to be performed in workflows. 

The rescale formula is: 

 
 
Rescale Source Displays the label and number of the selected channel.  
Old Units Displays the values of the current vertical units of the channel 
New Units Allows for manual entry of the new units to be used. The new units will be displayed in 

the vertical units of the channel 
Note  When rescaling only a selected area of the waveform, the manual entry of new 

units is not available unless “Transform entire wave” is checked since it is not 
possible to display different units for different time ranges in the same channel. 
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Slew Rate Limiter  

 
Slew Rate Limiter is an effective tool for signal separating, denoising and removing motion artifact during 
and after recording. The algorithm restricts the rate of change of a signal to a specific time window or sample 
width window. The allowable amount of motion artifact over a given time/sample window can be precisely 
adjusted from a minimum allowable change to a maximum allowable change, thereby eliminating artifacts 
that exceed the selected amplitude range within a given time period.  
The Slew Rate Limiter algorithm restricts the rate of change of a signal to a specific window. If two different 
types of signals with significantly differing rates of change are mixed together, limiting the allowable rate of 
change of the mixed signal allows for signal separation by reducing the impact of a fast moving signal on a 
slow one (and vice versa). 
Assume a mixed signal y. Define a time window width w. Define the minimum allowable change in 
amplitude over the time window w as and a maximum allowable change in amplitude as where.   
The Slew Rate Limiter may be applied in real time as an online calculation channel, or in post-processing via 
the Transform menu (see page 282). As with all online and offline transformations, signal type settings can be 
saved as custom presets by clicking the “New…” button and naming the new preset. 
To have BSL PRO apply the Slew Rate Limiter in real time:  

1. Choose Hardware > Set Up Data Acquisition > Channels. 
2. Click the Calculation tab. 
3. Check an Acquire box for the Calculation channel to contain the filtered data. Check the Plot and 

Values boxes as appropriate for each channel. 
4. Click the Preset pull down menu and select Slew Rate Limiter. 
5. Click the Setup button in the Input Channels dialog to generate the Slew Rate Limiter setup dialog. 
6. Set the desired time window to apply the slew rate limiter algorithm based on seconds or samples. 
7. Set the minimum and maximum allowed change to adjust the sensitivity to motion artifact. 
8. Click OK and run the acquisition. Any artifact that falls outside the boundaries of the 

maximum/minimum allowed change setting will be eliminated from the recorded data. 
 Watch the BIOPAC Slew Rate Limiter video for a detailed demonstration of this feature. 

 

http://www.biopac.com/video/?video_category=acqknowledge-tutorials&v=slew-rate-limiter-in-acqknowledge
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Filter – FIR (BSL 4.1 and higher) 
In BSL 4.1 and higher, FIR Filters are available as an online 
calculation channel. Until recently, real-time FIR filtering during 
acquisition wasn’t feasible due to processing power limitations, but 
these constraints are no longer an issue for modern dual-core and 
quad-core processors. 
Online FIR filters are similar to their offline transformation menu 
counterparts with the exception of the following convention. 
Delay at current settings: For FIR filtering in general, a delay is 
imposed on the output signal, and this parameter shows the number of 
delay samples the current settings will introduce. If the number of 
coefficients is fixed, the delay value will equal the number in the 
“Fixed” editable field. If the number of coefficients is set to be 
optimized for sample rate and cutoff, the delay value will vary. The 
filter algorithm compensates for this delay in order to assure proper 
alignment of filter output with the acquired signal. 
When modifying the fixed number of coefficients or the frequency, 
the delay value is updated accordingly. However, it should be noted 
that a close comparison between online and offline FIR filters will 
reveal that they are not perfectly in phase, but out of phase by half of 
the imposed FIR calculation channel delay. 
As in other BSL PRO calculation channel presets, modified Filter – 
FIR setups can be saved as a custom preset by selecting “New 
Preset.” 

 
To have AcqKnowledge apply the Filter – FIR in real time: 

1. Choose Hardware > Set Up Data Acquisition > Channels. 
2. Click the Calculation tab. 
3. Check the Acquire, Plot, and Values box for the Calculation channel to contain the filtered data. 
4. Click the Preset pull down menu and select Filter – FIR. 
5. Click the Setup button to generate the Filter – FIR settings dialog. 
6. After starting acquisition, real time FIR filtering will appear in a dedicated calculation channel for the 

duration of the recording. 
 
For specific details on the various FIR filter types, windowing, and recommended settings, see the offline 
Filter – FIR Transform option on page 261. 
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Chapter 7   Set Up Acquisition 

 
Data Acquisition Basics 
Once the channels to be acquired have been selected, the next step is to set up the acquisition parameters. 
These options control the data collection rate, where data will be stored during an acquisition, and the 
duration of each acquisition. Choose MP > Set Up Data Acquisition > Length Rate to generate the dialog to 
set the following options. 
Storage Mode 
At the top of the dialog are three popup menus for configuring various aspects for storing data from each 
acquisition. 
Record/Record last allows control over whether the software saves all data or only the most recent segment 
of the data. 
 Record—the MP hardware will store data for the amount of time specified in the acquisition length 

box. This is the default and is appropriate for almost all types of acquisitions.  
 Record last—only available when acquisitions are set to 'Save Once' or 'Memory'—the MP hardware 

will acquire data continuously, but will only store the most recent segment of data equivalent to the 
duration in the acquisition length dialog. That is, if the value in the acquisition length box is 30 seconds 
and record last is selected, the MP System will acquire data continuously, but will only store the most 
recent 30 seconds of the data.  

Save once/Autosave file/Append configures how the data is saved to a file. By default, BSL PRO will save 
the data to a single continuous file. 
 Save once—BSL PRO will begin an acquisition when the mouse is clicked on the start button, and will 

stop either when the acquisition length has been reached or when the stop button is clicked with the 
mouse. 

 Autosave file —use this option to perform several acquisitions one after another, and save the data 
from each acquisition in a separate file. When the Autosave option is selected, a File button will appear 
to the left of the sample rate dialog. Click File to generate a standard Save dialog to enter the root file 
name for the data from each acquisition. After clicking Save in, another dialog is generated with 
options to append an incrementing number, time (system clock), or date (system clock) to the filename: 
Media functionality does not support the Autosave file acquisition mode.  

 Append —similar to ‘Save Once’, except that Append allows stopping and restarting acquisitions at 
arbitrary intervals. Append mode is unique in that clicking on the Stop button only pauses the 
acquisition, which can then be restarted by clicking on the Start button. 
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In Append mode, each time an 
acquisition is restarted, an append 
event is inserted with the default label 
“Segment 1, Segment 2”, etc. Although 
it’s possible to pause for any period of 
time, the application will only acquire 
data for the amount of time indicated in 
the Acquisition Length box. Data can 
be acquired in Append mode while 
being saved to memory or disk. (For 
information on customizing append 
marker labels prior to acquisition, see 
Set Up Segment Labels on page 213.  

Sample data Acquired in “Append” mode. 
Event markers indicate where Acquisition was paused. 

Appended segments can be stored to disk or memory. 
 Append to Disk: In this mode, it is usually best to record all channels at the same rate. If the user 

stops the acquisition, the length will be the same for all channels—so the next segment of appended 
data will neatly link onto the end of the existing record. If channels are sampled at different rates, 
append to disk operation will cause the software to rewrite all data files in the graph and add 
“extra” data to the “uneven” waves. This extra data will be a continuation of the same data point at 
the end of each uneven wave. This operation may take some time to complete for very long data 
files.  
 Append to existing files—just open them, change the storage mode to “Append to Disk” and 

Start the acquisition. 
 Append to disk requires BSL PRO format files. When opening any other file format, a prompt 

will appear for translating the file. 
 Append to Memory: In this mode, data is appended to the “uneven” waves in the same manner as 

described for Append to Disk. When channels are sampled at different rates, this mode will respond 
faster than Append to Disk because the data files are already in memory so the software does not 
have to rewrite all the data files in the graph. This is the default mode for acquiring data in BSL. 

 A Reset button is generated in the Set Up Acquisition dialog when Append is selected. Click 
the Reset button to erase the acquired data file and start a fresh acquisition file (this is 
essentially the same as saying yes to an “Overwrite existing data?” prompt). 

 
 

  The Rewind button on the toolbar will delete the last recorded segment. Ctrl-Rewind (Windows) 
or Option-Rewind (Mac OS) will delete all recorded segments (similar to the Reset button). 

Append plus external trigger 
An acquisition that takes place over a long period of time with brief events which are few and far between 
can be Set Up in the following manner: the researcher watches for these event, triggers the acquisition to 
start, and then lets the pre-defined acquisition length run out. When another event of interest occurs, the 
researcher triggers the next acquisition. This acquisition will be “appended” onto the end of the first 
acquisition. Memory is the only limit as to how many “appendages” can be added. 
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Append plus Variable Sampling Rates 
If the mode is started and stopped manually, it is statistically possible that, prior to the next pass of the 
Append, extra data points may be inserted in various data channels to “line up” the data (see sample on 
page 105). These extra data points simply replicate the last sample in any affected channel. To minimize the 
impact of the extra data points, make sure the lowest sampling rate is on the order of 10 Hz or higher, or 
don’t use VSR. 

Disk/Memory determines where to store data during an acquisition. Once data has been acquired and is 
stored in a file, it is stored on a hard disk or other similar device. There are a number of options for storing 
data during an acquisition. The best choice as to where data should be stored during an acquisition depends in 
large part on the nature of the acquisition itself, and the type of computer being used. 
 Memory stores data in computer memory during an acquisition. After the acquisition is completed the file 

can be saved using “File > Save As.” This usually allows for faster acquisition rates, although most 
computers have less available RAM than disk space. 

 Disk saves data directly to the computer’s hard disk during an acquisition. Disk mode is fast enough (in 
terms of maximum sampling rate) for many applications, especially when only a few channels are being 
acquired. Saving data to Disk also allows for longer acquisitions, since most computers have more hard 
disk space free than free RAM. A final advantage of saving data directly to Disk is that if there is a 
system failure (including power outage), all the data collected up to that point is saved on disk and can be 
recovered, whereas the data is deleted if it is being saved to computer memory.  

IMPORTANT—When saving files to Disk, always be sure to save files under a different name 
BEFORE starting each acquisition. Otherwise, any previous data in that file will be overwritten.  
In Memory mode, simply save the file after the acquisition. 

Acquisition Sample Rate 
The value in the box labeled “Sample rate” indicates how many samples the MP System should take per 
channel during each second of data acquisition. The sample rate can be changed by clicking on the pull-down 
menu. To allow for variable sample rates, the rate options are constrained so that channel sample rates are 
equal to or a specific power of 2 less than the acquisition rate. Sample rates can be chosen at the selected 
increments only; custom rates are not accepted. 
Depending on the nature of the data being acquired, the “best” choice in terms of sampling rate will vary. 
Technically speaking, the minimum sampling rate should be at least twice the highest frequency component 
of interest. This means that if the area of interest has frequency components of 100 Hz, it’s recommeded to 
sample at least 200 times per second. Fourier analysis (FFT) can be used to determine what frequency 
components are present in the data (see page 284 for a more detailed description of the FFT function). 

TIP: A good rule of thumb is to set the sampling rate to at least three to four times the highest 
frequency component of interest. 

In less technical terms, lower sampling rates can be used for data with slowly changing values (e.g. 
respiration, EDA), whereas higher sampling rates should be set for data where values change markedly in 
magnitude or direction (e.g. ECG, EEG, evoked response). 
The maximum allowable sampling rate will automatically adjust itself according to the storage mode, how 
many channels are being acquired in the channel setup window and the type of computer being used. This can 
be demonstrated by entering a large value (say 99, 999) in the sample rate box. Now, click the mouse button 
or press return and BSL PRO will automatically return the maximum allowable sample rate given the 
computer’s throughput and the acquisition parameters. 
If data is being stored to disk or computer memory (RAM) during an acquisition, To set a sample rate that is 
too high. The acquisition will begin normally, but BSL PRO will stop the acquisition and display a message 
indicating that the acquisition buffer has overflowed. The data up to this point has been saved, and the sample 
rate must be decreased in order to complete an entire acquisition. 
The sample ECG waveforms below illustrate the effect of different sampling rates on obtaining varying levels 
of fidelity when reproducing the data. 
 Top waveform: data is sampled relatively slowly; difficult to make out the shape of the waveform. 
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 Middle waveform: sampled at the faster rate; more samples are taken in the same period of time, which 
results in higher resolution for some components of the waveform. 

 Bottom waveform: sampled at a relatively high rate; increased resolution of the waveform. Waveform 
components that were obscured at slow sampling rates are now well defined, and measurements taken on 
this waveform would be able to better establish the maximum amplitude, time between different ECG 
complexes, etc. 

 

 
Representation of ECG waveform sampled 
with relatively few samples per second 
“True” ECG wave is superimposed over dots 
that indicate sample points. 
 

 

 

Preceding waveform as it would look if 
plotted in BSL PRO (with data points 
superimposed). 
 

 

 
 
Representation of same ECG waveform 
sampled at a relatively higher sampling rate. 
 

As shown, under-sampling completely misses the QRS complex of this waveform, although it might detect 
components of the QRS in subsequent beats. Although this is an extreme example of how under-sampling can 
affect digitally processed data, it is important to note that the rate at which data is sampled has important 
implications for the interpretation and analysis of data. 
The disadvantage of acquiring data at high sampling rates is that each sample point takes up memory, whether 
it is RAM , disk space or memory. Moreover, once the file is saved, it will require more disk space than a file 
of similar duration sampled at a slower rate. 
 

Note for variable sample rate processing: 
The Expression and Waveform Math functions will constrain operations between waves of different rates as 
follows: 
If an equation is operating on two or more waves of different sample rates, the result of the operation will 
always be output at the lowest sampling rate from the waves (F low). If the destination channel for the result 
has an assigned rate other than (F low), the operation will not be permitted. If the destination channel is set to 
a new channel, the operation will always be permitted. 
VSR data padding—If the channels are of unequal length (as a result of variable sampling rate or waveform 
editing), they will be padded for Append acquisition. Digital and Analog channels are stored as short integers 
by default; a waveform paste into a digital or analog channel, however, will result in its underlying data being 
converted to floating point. This will generate the “Abort/Replace” warning for pastes to Digital or Analog 
channels since the data format has changed since the last acquisition.  
Additionally, if an Analog or Digital channel is used as the source waveform for a Copy, it will also be 
converted to floating point and will result in the “Abort/Replace” warning being generated. 
Since Calculation channels are already floating point, pasting into them or copying from them will not change 
their data format. The channels will be padded with their last value and the append will commence. 
Waveform Cut operations do not change the underlying data format for Analog, Calculation, or Digital 
channels. If only Waveform Cut is used, no data format conversion will occur and channels will be padded 
with their last value and subsequent appends are allowed. 

Acquisition length 
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To set the duration of an acquisition, enter a number in the acquisition length box. By default, 3600 seconds 
of data will be recorded. The popup menu right of the length box allows scaling the acquisition duration in 
terms of milliseconds, seconds, minutes, hours, or samples. Changing this option will not change the length of 
the acquisition, only the units used to describe it. Thus, the same acquisition can be described as lasting 3600 
seconds, or 60 minutes, or 3,600,000 milliseconds. Scaling the duration of an acquisition in terms of samples 
is essentially the same as the time scaling options, except the length of the acquisition will be expressed in the 
total number of samples to be collected on one channel. 
Regardless of  the scale used to determine the length of acquisition, the acquisition will end when the value in 
the total length box is reached. The acquisition can also be interrupted or ended at any time by clicking the 
graph winodw’s “Stop” button. 
The application will automatically limit the maximum recording length to the amount of available memory 
(memory or disk modes). The default is to record one acquisition of the duration specified in the acquisition 
length box. The acquisition length parameter has a somewhat different interpretation in the Record Last mode. 
For more information on these features, see page 153. 
 Repeating 
The Repeat mode allows data to be acquired from repeated trials using the same parameters for each trial. 
Checking the Repeat every box at the bottom of the acquisition setup dialog enables a series of dialogs and 
popup menus at the bottom of the dialog. These allows control over how the number of times an acquisition 
will repeat as well as the interval between trials. When this is unchecked, the acquisitions will repeat as soon 
as possible (usually instantaneously, but slightly longer if data must be saved to a file between trials). 

 
Interval The entry to the right of the “Repeat every” checkbox tells BSL PRO how long to pause between 

the start of one acquisition and the beginning of the next acquisition. This can be scaled in terms 
of seconds, minutes, or hours using the second popup menu. 

 It is important to note that this value measures the interval between the start of two adjacent trials, 
rather than the interval between the end of one trial and the start of the subsequent trial. If the 
repeat interval is set for 15 minutes and the acquisition length is set to 1 minute, then there will be 
a 14-minute pause between the end of the one trial and the beginning of the next. 

Trials Set how many trials to acquire: 
for perform a finite number of trials; enter the number of trials to acquire 
forever perform an infinite number of trials. Trials will be repeated at the specified interval 

until the acquisition is stopped either by clicking on the stop button in the graph 
window or if there is not enough free memory on the target storage device. 

Regardless of which options are checked, data for each trial is acquired according to the acquisition 
parameters specified in the dialog. In the above example, each trial of data will be sampled at 50 Hz and will 
last 1 minute; the trials will be repeated every 15 minutes for a total of 8 trials. 
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Setup Channel Options 

Channel The Channel column contains the alpha-numeric channel numbers. “Analog” (or 
continuous) input channels begin with “CH” and run from CH1-CH4. “Digital” input 
channels begin with “D” and run from D1-D8. “Calculation” channels begin with “C” 
and run from C1-C16. 

Acquire When the Acquire Data box is checked for a given channel, data will be collected on 
that channel. 

Plot If Plot is also checked, data will be plotted on screen in real-time during the acquisition. 
If the plot box is unchecked, data will still be recorded for that channel, but the 
waveform display will be disabled. To display the waveform plot after the acquisition is 
over, show the channel. 

Value Checking the Value box enables the display of numeric and/or graphic values for each 
channel in real time. To display the values, select Show Input Values (via the MP36 
menu). Input values are displayed in a separate window from the main graph window. 

Default The default is to collect one channel of data on analog channel 1 (CH1), and to plot and 
enable value display for this channel 

TIP Usually, it’s recommended to check all three boxes for all channels acquiring data. 

Label The Label entry for each channel supports entry of up to 58 characters to identify the 
channel. 

Preset 

 

Clicking on the Preset button will generate a menu of available presets for the channel. 
Presets for common applications configure the hardware gain, filters, etc. 

 For a detailed summary of Analog Input channel, Digital Input channel, and 
Calculation channel options see the Presets section beginning on page 118. 

If a preset is modified prior to starting a recording in Append mode, the following prompt will be displayed. 
Choose Abort, save the data, and then change the presets to acquire as a new data file. 
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Starting an acquisition 
After setting up the channels and defining the channel parameters, the acquisition can be started. If a file 
window is not already open, choose File > New to generate a graph window. 

Note the circle to the left of the  button. This circle indicates the communication status between the 
computer and the MP data acquisition unit. The circle will be solid green wmen the MP unit is properly 
connected to the computer and powered on. If the MP unit is not properly connected, thie circle will be solid 
gray. 

Start the acquisition by positioning the cursor over the  button and clicking the mouse button or by 
selecting “Alt + Spacebar.” If no input devices (e.g., electrodes or transducers) are connected to the MP unit, 
the system will collect a small value of random signal “noise” with a mean of about 0.0 Volts. 

 For information on how to connect measurement devices to the MP36, see the BSL Hardware Guide. 
 Acquisitions can also be started  using a variety of “triggers,” which are discussed on page 213. 

 Once acquisition starts, the  button in the acquisition window changes to . The 
two opposing arrows to the right of the button indicate that data is being collected. Also, the “Busy” 
status indicator light on the front of the MP unit will illuminate, showing that data is being collected. 

Stopping an Acquisition 

To stop an acquisition at any time, click the  button in the lower right corner of the screen or select 
“Alt + Spacebar.” An acquisition will stop automatically when it has recorded an amount of data equal to the 
Acquisition Length entry. 

Rewind 

 The Rewind button to the right of the Start/Stop button allows the last recorded data segment to be 
erased and subsequent appended data to be added to the existing data file. This function will erase the last 
segment along with the Append Event  for that segment; the application will keep track of Append Event 
labels, so that the label always matches the segment number 

  
If the “Warn on Overwrite” option is active, a warning dialog will be generated before the segment is deleted.  
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Saving acquisition data 
To save a data file, pull-down the File menu and choose the Save command. 

Electrode Checker 

 
The Electrode Checker, in conjunction with the MP36 unit, measures how well electrodes are making 
contact with the surface of the skin. To use this feature: 

1) Attach the electrodes to subject. 

2) Connect the electrodes to an electrode lead set (such as the SS2LB). 

3) Instead of connecting the electrodes to one of the four analog inputs, connect the Simple Sensor end 
of the electrode lead to the Electrode Check port on the front of the MP36 acquisition unit. 

4) Click the MP3X menu and scroll down to select Electrode Checker. 

This will generate a small “thermometer-like” display. At the bottom of the display, a number with a kΩ 
(Kohms) symbol should be visible. This value describes the impedance of the electrode/skin contact, with 
lower numbers being associated with better conductivity. The better the conductivity, the “cleaner” the signal 
displayed on the screen. If the MP36 is off or no nothing is connected to the “Electrode Checker” on the 
MP36 unit, the Electrode Checker display will remain “OFF.” 

   
Poor contact Good contact  Off 

TIP While there are few absolutes as to what constitutes “good” contact, one rule of thumb is that this 
number should be below 10 kΩ, and the lower the better. 

TIP To decrease the impedance of an electrode connection, it’s recommended to “abrade” the surface of 
the skin with an abrasive pad (such as ELPAD). This removes a thin layer of dead skin cells 
and should result in a signal that has relatively little noise. 
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Timers (Stop watches and Elapsed timers) 
The Timers function allows for easy visualization and measurement of elapsed time within the 
AcqKnowledge user interface, and consists of a simple toolbar display. Timers can be helpful when actions 
need to be performed at specific intervals prior to and during an experiment. The Timers function provides an 
easy-to-read digital display in the toolbar region above the graph window, and supports the creation of 
multiple timers, which can be added or removed as needed. 

Timer Types 
There are two main types of timers, acquisition controlled (“elapsed” timers”) and independent timers (“stop 
watches”). Manual “stop watch” timers can be used at any point for tracking time independently of 
acquisition, while elapsed timers are tied to a recording in progress and unavailable unless an acquisition is 
running.  
Independent Timers (Stop watches) 
Independent timers are manually started and stopped, and have a countdown feature with an audible alarm 
and flasher. Multiple timers can be added to the toolbar region, and can be started and stopped independently. 
Pause mode is not supported. Although the timer can be stopped at any time, restarting it resets the timer back 
to 0:00:00. 
Elapsed Timers (Acquisition controlled) 
Elapsed timers start when the acquisition “Start” button is clicked and continue counting for the set duration 
of the recording, or until the acquisition “Stop” button is clicked. When acquiring in Append mode, the 
elapsed timer is reset at the beginning of each new segment. Any trigger or delay time applied between 
segments is not included in the elapsed time. Multiple elapsed timers can be added to the toolbar region. This 
mode does not support the countdown or alarm feature. 
To set up a timer: 

o Display > Show > Timers. 
o The timer toolbar will appear as shown below: 

 
o The elapsed timer option is enabled by default. If only a single elapsed timer (acquisition 

controlled) is desired, simply start the acquisition and the timer will start automatically. 
o If an independent timer (stop watch) is desired, right click on the numbers portion of the 

timer toolbar and choose “Settings.” In the Timer Settings, choose “Independent start” and 
click OK.  

To start/stop independent timers: Click on the toolbar number display to toggle start/stop, or  right click on 
the toolbar number display and choose “Start timer” or “Stop timer” (see figure below). 
To set up multiple timers: 

1. Click the Timers toolbar icon and choose the desired timer type. Repeated clicking on a timer 
option will create additional timers of that type, which will appear in the timer toolbar region. 

  
To set an alarm: 

1. Click on the Timers toolbar icon and choose “Create alarm.” 
2. Right click on the numbers display portion of the new alarm 

and choose “Settings.” 
3. Set the desired time in the “Countdown timer” field. 
4. Check “Sound alarm” and “Blink upon alarm.” 

NOTE: These settings will remain the default for subsequent alarms until the settings are changed. 
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Overview of Timer Settings 

 
 

CONTROL DESCRIPTION 
Timer name: 
 

Field for assigning name to timer. 

Start timer with acquisition: Timer will start and stop with data recording only. 
Independent start Timer is started and stopped manually, independent of acquisition 

status. 
Countdown timer Sets the countdown time duration. 
Sound alarm Selects the audible alarm option and specifies the number of times 

the alarm will sound. 
Blink upon alarm Enables the timer numbers to flash on and off when the 

countdown is complete. 
Display > Font family: > Font size > 
change color 

Selects timer font style, size and color. 

Include fractional seconds Sets option to display 1/100ths of a second in timer display. 
All parameters established in the Timer Settings are retained in saved graphs and graph templates. 
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Chapter 8 Output Control MP Menu 
 

MP36 hardware     MP 35 hardware  

The MP UNIT can output pulses or analog voltages via the Analog Out port; this port is also used to connect 
to BIOPAC’s external stimulators. The MP35 has an additional I/O Port which is used to output digital (TTL 
Level) signals. 

Parameters for output signals are set via Output Control. Access to a specific Output Control is via the MP > 
Output Control submenu. 

There are nine Output Controls for the MP36, ten for the MP35A, nine for the MP35, and two for the 
MP46/45: 

Output Control See… MP36/35 Functionality MP46/45 
Functionality 

CH# to Output page 
165 

Direct analog CH1-4 to output 

listen to signals 

Direct analog 
CH1-2 to output 

listen to signals 

Digital Outputs page 
167 

Control 8 digital outputs Not available 

Voltage page 
169 

Output Voltage Level (0 – 4 V DC) Not available in 
MP36 

Not available 

Pulses page 
170 

Use with third-party devices; software can control pulse 
width and repetition. 

Not available 

Stimulator - 
BSLSTM 

page 
170 

Use with BSL Stimulator Not available 

Low Voltage 
Stimulator  

Stimulator – SS58L 

page 
170 

Use with MP36 Analog Out port or MP35 with SS58L 
Low Voltage Stimulator; software can control pulse 
amplitude, width and repetition (-10 to +10 V) 

Not available 

Pulse Sequence Page 
171 

Available in MP35A & MP36 only. Direct analog CH1-4 
output. Allows for output of customized pulse trains. 

Not available 

Human Stimulator - 
STMHUM 

Page 
171 

Handheld user-controllable stimulator that plugs directly 
into the Analog Out port. 

Not available 

Visual Stim 
Controllable LED – 
OUT4 

Page 
175 

Use with MP36/MP35 Analog Out port. Used to present 
a visual stimulus to subject in the form of a flashing 
LED. 

Not available 
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Arbitrary Wave 
Output 

Page 
176 

Output stimulus waveforms, Square, Tone, Ramp, or 
Arbitrary waves. 

Not 
available 

Sound Sequence Page 
175 

Outputs customized sounds assignable to a user 
configurable pulse train. 

Available 

To open an Output Control, select it from the MP UNIT > Output Control submenu. A checkmark appears 
next to the submenu selection and an Output Control panel is displayed, bordered in red beneath the BSL 
PRO Toolbar in the active data window. To close an Output Control, select from the menu again (toggles 
between display and hide) or right-click in the open control panel and choose Close. 

Only one Output Control panel may be open at any time. Switching between different data files can change 
the display and operation of the control panel. 

Because some output devices can be used for stimulation on humans and can achieve voltages up to 100 
Volts, built-in software logic makes output control as safe as possible. 
See page 191 for safety notes regarding human subjects. 
 
The following applies to all Output Controls. 

The output will not operate unless its software control panel is open. 

When an Output Control panel is closed, or the BSL PRO application is closed, MP36/35 output goes to 0 
Volts, preventing the output device from sending pulses. 

When an Output Control panel is opened, output is always OFF until activated by a click of the ON/OFF 
switch in the control panel or, if parameters allow, a click of the Start button in the data acquisition window. 
(Exceptions are the Voltage Output Control, which outputs immediately, and the Digital Outputs Control 
when set to the preference “Set each output immediately.”) 

Output preference parameters are local and are saved with the data file or a graph template file. The data or 
template file holds the output parameters as established when the file was saved. (See “Save as Graph 
Template,” page 231.) Switching between other open graphs can change the display and operation of the 
control panel since the settings in each graph are independent entities. 

If desired, custom Output preference parameters can be saved as a preset for a current graph (file preset) or 
for all graphs (global preset) by using the “Save Settings” button in the Output Preferences window. A saved 
Output preference can be recalled by choosing “Organize List” and selecting the desired custom preset. 

Controlling Output Signals 
Use both the Output Control panel and its respective Preferences dialog to control the output signal. Output 
Control Preferences  dialogs establish the parameters for output. Preferences dialogs are only available when 
the corresponding Output Control panel is open and active. Voltage does not have Preferences. 

To generate the Preferences dialog, either: 
Open an Output Control panel and then right-click anywhere in it to generate a pop-up menu. Choose 
Preferences to open the dialog (Close will close the control panel). 

 or  
If a control panel entry box is grayed or disabled, its values may be established, or limited, by settings in the 
Preferences dialog. If Preferences parameters allow, enter values directly in the Output Control panel. 

   
Key into the entry boxes and then enter the value by pressing the Enter key. 
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Use the Tab key or mouse to move to another entry box. 
Click the OK button if in the preference dialog. 
Values entered into a control panel or its Preferences dialog that are outside the specifications of the output 
device, or outside the limits defined by the Preferences dialog, may change automatically to reflect either the 
closest value to that requested that the hardware can achieve, or the closest increment defined by the limits in 
Preferences. (The software does not correct inputs as they are being typed, it but may make changes after the 
value is entered.) 
For example, if a Pulse width of 5 ms is entered into the Pulses Output Control panel entry box, but 
Preferences defines a range limit of .5 to 2 ms for Pulse width, the system will automatically change the new 
entry to 2 ms.  
Saving Panel settings: 

Output Control panel settings will be retained until a file is closed or saved. If a file is closed but not saved, 
settings will be lost (defaults established); if a file is saved, panel settings will be saved. 

CH# to Output Output Control – MP36/35 

 
The CH# to Output Output Control redirects an analog input signal to the Analog Out port on the back of the 
MP UNIT. The signal from the assigned channel will continue to be record and plot data.  

This Output Control is used commonly when attaching headphones to the MP unit to listen to signals coming 
in on an analog input channel; for example listing to the Electromyogram.  

To display this control panel: 

Choose MP UNIT >  Output Control> CH# to Output to open the control panel. 

MP36/35 users may use analog input CH1-CH4. Channel 3 is the default setting. If another channel N has 
been designated, the menu will read “CH<N>.” 

Use the control panel ON/OFF Switch to start and stop output. OFF grounds the output so no signal (or 
sound) should be present. 

Preferences 

Use the Preferences to select the channel to redirect to output. Open the Preferences dialog by right-clicking 
the CH# to Output control panel region. 

  
Use the pull-down menu to select the desired channel CH 1-4 to use for the output. 

Click OK to set the output channel and return to the control panel. 

Note Only the Hardware settings (Gain, Offset, Input Coupling) from the Input Channel Parameters dialog 
(MP UNIT > Set up Channels) will be applied since output is established prior to the processing of Digital 
Filters.  
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MP36 Input > Output Scaling 
The MP36 hardware can pipe signals from any channel input to the output using the “CHX to Output” control 
panel in the BSL software—due to the difference between the input and output range, there will be a change 
in signal level (scaling). The output range depends on the output pin used as shown in the following table. 

Output Pin 
(Analog Out port) 

Pin Description Output Range 
(Volts) 

Pin 1 Headphones,  
A.C. Coupled 

-2.048 to +2.048 

Pin 2 
Low Voltage Stimulator, 
D.C. Coupled 

-10 to +10  

The input range is gain-dependent.  The table below shows the scaling (multiplying) factors to use for each 
gain setting. 

Gain Input Range 
+- millivolts 

Output Scale**—accurate to ±10% 
Factor 1 Factor 2 

Pin 1 (Headphone out) Pin 2 (Low Voltage 
Stimulator) 

x5 ± 2 V 1.024 5 
x10 ± 1 V 2.048 10 
x20 ± 500 mV 4.095 20 
x50 ± 200 mV 10.238 50 

x100 ± 100 mV 20.475 100 
x200 ± 50 mV 40.950 200 
x500 ± 20 mV 102.375 500 

x1,000 ± 10 mV 204.750 1,000 
x2,000 ± 5 mV 409.500 2,000 
x5,000 ± 2 mV 1023.750 5,000 

x10.000 ± 1 mV 2047.500 10,000 
x20,000 ± 0.5 mV 4095.000 20,000 
x50,000 ± 0.2 mV 10238.000 50,000 

Notes 

* 1: To properly measure the output signal, at least a 2K Ohm load is required. 

** 2. Input to Output scaling is accurate to within 10%. 
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CH# to Output Control – MP46/45 
The CH# to Output Control operates similarly to the MP36/35 functionality, but since the MP46/45 
hardware’s interfaces with the computer’s sound card, the computer audio properties may need to be adjusted 
properly in order to optimize the signal output. Prior to using the CH# to Output Output Control with 
MP46/45, the following steps are recommended. 

1. Open the computer’s audio properties control panel (Control Panel > Sound). 

2. Select the MP46/45 System as the Playback device and click the “Properties” button. 

3. Select the “Levels” tab and adjust the “Speakers” slider to 100 (maximum volume). 

    

For more information on MP45 audio properties, see page 23, or see the “Troubleshooting MP45 
Communications” guide in the Biopac Student Lab User Support folder. (Drive:\Program Files\BIOPAC 
Systems, Inc\Biopac Student Lab 4.x\User Support System\English – en). 

Additional MP46/45 Considerations for CH# to Output Control 
• Unlike the 4-channel MP36/35 hardware, MP46/45 supports analog input CH1 or CH2 only. 

Channel 1 is the default setting. 

 
• For MP46/45, the ON button can be pressed at any time, however sound will only be heard 

during acquisitions. The button will remain ON until manually turned OFF or until the control 
panel (or file) is closed. 

 
 
See page 394 for MP UNIT Input > Output Scaling values. 
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Digital Outputs Control — MP36/35 only 

 
 

MP46/45 Users: The Digital Outputs Control panel is not available when using an MP46/45. 

The Digital Outputs Control allows control of signal output on each of eight digital lines via the I/O Port 
connector on the back of the MP36/35. Use it to control external devices. The digital output uses standard 
TTL levels which correspond to the control panel setting as follows:  

Control Panel setting   Output Voltage level (Volts) 

0 0 

1 +5 

To display this control panel: 

Choose MP36/35>Output Control>Digital Outputs to open the Digital Outputs Control panel 

Click each digital output line to set its digital state to 0 (off) or 1 (on). 

To set Preferences for Digital Outputs, open the 
Preferences dialog by right-clicking the control panel). 

Select from the following two options: 

Set each output immediately (default) allows the state of 
each digital output line to be toggled between 0 and 1, and 
changes the state immediately. In this mode, no Set button 
is available in the control panel. Output for each line is set 
upon clicking its toggle button. 

Set all outputs when Set button is pressed allows the state of each digital output line to be toggled, but the 
states will not physically be changed until the Set button is clicked on the control panel. In this mode, a Set 
button is available in the control panel. When the Set button is clicked, all eight digital lines will update 
simultaneously. 

Click OK to set Preferences and return to the control panel. 
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Voltage Output Control 

 
The Voltage Output Control is used to output a voltage level (DC voltage) via the Analog Out port on the 
back of the MP35 to control another piece of equipment. 

Note: This option is not available in MP36 or MP46/45 hardware. 

To use this control panel: 

Choose MP35>Output Control>Voltage to open the Voltage Output Control panel. 
Enter a value manually, or use the scroll or arrow buttons to increase or decrease values. 

When using the scroll box, a change will not occur on the output until the mouse button is released. 

The display shows the value that is to be output. If an entry exceeds the voltage range limits of the MP 
Acquisition Unit, the value automatically rounds to the nearest obtainable value. 

MP35 Voltage Output 

Range 0 - 4.096 Volts 

Resolution  1 mVolt 

There are no Preferences for the Voltage Output Control. 

When multiple graph windows are open, Voltage Output stops (goes to 0 Volts) if the graphs are switched 
and the new active graph contains its own Output Control panel. When the graph containing the Voltage 
Output Control panel is made active again, Voltage Output goes back to the previously set level.  
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Pulses Output Control 
Stimulator – BSLSTM Output Control 
Stimulator – Low Voltage Output Control 
Stimulator – Human Stimulator – STMHUM Output Control 

Control panel options for Pulses, Stimulator – BSLSTM and Stimulator – Low Voltage  

 
Additional control panel options for Low Voltage Stimulator 

The BSL PRO System offers a variety of pulse output options. Exercise caution when using any of the 
options with human subjects—see the Safety Note on page 191. 

Pulses Output Control 
Select this Output Control for general pulse output, or when synchronizing to 3rd-party devices. 

Use for reaction time measurements, where a subject listens with headphones for a series of “clicks” (pulses) 
and responds as quickly as possible with a button press. Determine reaction times by calculating the time 
between the start of the pulses and the responses. 

Use to trigger another device (automatically send a pulse from the MP UNIT when acquisition starts). 

Use to control a 3rd-party stimulator. BIOPAC recommends use of the BIOPAC BSLSTM Stimulator with the 
MP UNIT and BSL PRO software. If using the BSLSTM Stimulator, use the Stimulator - BSLSTM Output 
Control instead of this Pulses Output Control. 

Stimulator – BSLSTM 
Select this Output Control  when using the BSL PRO stimulator (BSLSTM) 
Use with stimulation electrode HSTM01 for safe stimulation of human 
subjects (0 – 100 Volts), as well as lower voltage (0 - +10 Volt) general-
purpose stimulation, such is used with amphibian muscle or nerve 
preparations. 
 

Set up note Placing the BSLSTMA/B unit too close to MP UNIT hardware can result in data distortion of 
the BSLSTMA/B pulse width signal; distortion is more apparent at higher sampling rates. 

• NEVER set the BSLSTMA/B atop an MP UNIT 
• Position the BSLSTMA/B away from the MP UNIT to reduce the signal distortion 

Stimulator SS58L (MP35 Hardware) 
Select this Output Control  for low-voltage (-10 - +10 Volt), direct drive 
stimulation via MP35 Analog Out port or an MP35 with SS58L connector. 
Use with stimulator electrode HSTM01 for safe, stimulation of human subjects 
(0 – 100 Volts), as well as lower voltage (0 - +10 Volt) general-purpose 
stimulation, such is used with amphibian muscle or nerve preparations. Outputs 
through a BNC connector so it can be used with most stimulation cables (such as 

those that terminate in a needle probe). 

Low Voltage Stimulator (MP36 Hardware) 
MP36 users, please note: The MP36 has a built-in stimulator and is not compatible with/does not require the 
SS58L; use OUT3 with the MP36 for low voltage stimulus capability. 

https://www.biopac.com/product/bnc-adapter-for-mp36-built-in-stim/
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Stimulator Human Stimulator – STMHUM 
Select this Output Control to conduct stimulation studies that enable subjects to control the stimulus delivery. 

This hand-held stimulator connects directly to the MP36 Analog Out port 
and has a red button for delivering the stimulus signal. The electrodes on 
the bottom of the unit are placed directly onto the subject. The STMHUM 
functions much like the BSLSTM but with no additional hardware 
required. The voltage range is 0 – 100 volts and can be limited or locked 
to a user defined level in the STMHUM Output Control panel, which 
resembles that of the Low Voltage Stimulator. 

To use one of these control panels: 

Choose MP UNIT > Output Control and then select Pulses, Stimulator – BSLSTM, Low Voltage Stimulator, 
or Human Stimulator – STMHUM. 
Right-click the Output Control panel (or choose File>Preferences and select from the sub-menu) to generate 
the Output Preferences dialog. 

 
Set the Preferences. 
General: Number of pulses, ON/OFF, Event options — see page 182.
Advanced: Pulse width, Pulse repetition (rate), Verify transducer (STMHUM) — see page 186.
Level (Low Voltage Stimulator and STMHUM only): Pulse level — see page 189.
Reference Channel (Low Voltage Stimulator, Pulse Sequence and STMHUM only): Channel assignment, 
signal generation — see page 190. 

Once configured, Preferences may be saved using the Save Settings command, activated by pressing the 
button at the bottom of the Preferences dialog (see page 182). 
Confirm the settings in the control panel. Adjust as desired within the parameters established in Preferences. 
Entry limits: Settings entered into the Preferences dialog may establish, or limit, the values in the Output 
Control panel entry boxes. Pulse settings may be directly entered into the control panel only if parameters 
established in Stimulator Preferences are not locked to a specific value. A grayed or disabled entry box 
indicates that the values are locked. 
Initiate the pulse sequence as defined in Preferences (see page 182). 

 ON/OFF Button in Output Control Panel uses the switch in the Control panel. 

 Recording uses the Start /Stop button in the data acquisition window. 

To close an Output Control panel: 

Right-click anywhere in the Output Control panel to generate a pop-up menu and then choose Close, or select 
it (or another output control) from the MP UNIT > Output Control submenu. 
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Pulse Sequence Output Control (Available in MP36 hardware only) 
This Output Control allows sequences of pulse configurations and delays to be sent to the MP36/35A unit, 
making it possible to create more complex stimulus setups. 
NOTE: Use the OUT3 BNC adapter to output pulses to a third-party device. 
Enabling the pulse sequence output control option will display the following control panel at the top of the 
graph window: 

 
Pulse sequence configuration is performed in the Preferences dialog of this output control panel. (Accessible 
via right-click on panel shown above or from File > Preferences) When a pulse train element is selected in the 
configuration, the controls will become visible in the right hand portion of the preferences dialog. The 
configuration makes use of three basic building blocks: 
A sequence consisting of a number of delay and pulse train elements. The final configuration consists of one 
or more sequences that are outputted in order. Normally the entire configuration is outputted. There is a 
special operational mode on ‘Start with Recording’ that will take only the indexed sequence matching the 
current recording segment. 
A pulse train element consists of  Pulse count, Width and Pulse repetition, These elements can be fixed or 
randomly generated. 
A delay element that allows for the introduction of time during which no pulses will be generated. 
Each one of these building blocks also has a “repeat” count associated with it that will perform the action a set 
number of times. (Adjust by selecting the desired ‘Repeat’ and inputting a new value) Individual sequences, 
pulse trains and delays can be added, repeated and reordered as desired. In the right pane of the Preference 
dialog (shown below), fixed or random pulse counts, widths and repetitions can be configured and combined. 
As in other Output Controls, custom settings can be saved and organized in a list view. (See below for 
additional setup dialogs)  
For a full explanation of preferences and tabs common to all Output Control panels, see the “Output Control” 
section on page 181.  

 
 Preferences available in Pulse Sequence tab 

https://www.biopac.com/product/bnc-adapter-for-mp36-built-in-stim/
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Add: Displays pop-up menu for adding Sequences, Pulse Trains or Delays. 

Output: Displays the configured sequences and sequence elements for the current or saved session. 

Repeat: Editable field for setting the number of times the pulse train or pulse train element is 
repeated 

Pulse count: Fixed – a set number of pulses is generated per sequence. 
 Random – set a random number of pulses to be generated per sequence. 

Width: Fixed – each pulse width will be of a set duration, in units of microseconds, milliseconds, or 
 seconds. 
 Random – sets the pulse width duration to fall between two set time ranges. 
Pulse repetition: Fixed – sets a fixed interval between the start of one pulse to the start of the next pulse 
 Random – sets a random interval between two set values for the start of one pulse to the start 
 of the next pulse. 
Move Up/Down Delete: Selectively reorders or deletes the various pulse train elements. 
Save Settings: Saves modified settings as a custom preset for the current graph, or for all graphs. 
Organize List: Orders custom presets into a list and categorizes the custom presets for the current file or 
 globally across the application. 
 

  
Preferences available in Options tab Delay Preferences 

 
Reference Channel Preferences 
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About Delay between Pulse Trains: 
The amount of actual Delay between pulse trains will vary from the set value depending upon the pulse 
repetition value that is used. In the example sequence below, a Delay of 100 milliseconds between pulse trains 
has been set up, combined with a pulse repetition rate of 20 milliseconds. Because the pulse repetition rate is 
applied before the Delay occurs, the actual Delay between pulse trains in this case will be 120 milliseconds. If 
it is critical that a Delay reflect an exact value, it is advisable to subtract the selected pulse repetition value 
when setting up the Delay parameters. 
 

 
 Delay between pulse trains 
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Visual Stim Controllable LED – OUT4 Output Control 
This Output Control is used to set up parameters for the OUT4 LED transducer used for conducting visual 
stimulus studies, in which flashes of light of varying intensities and intervals are presented to a subject. The 
OUT4 LED transducer is connected directly to the MP36 Analog Out port.  
To use this Output Control choose MP Unit > Output Control > Visual Stim Controllable LED. 

 
The Visual Stim Controllable LED Output Control panel is identical to the Pulse Sequence control panel, but 
with the addition of an intensity control for controlling the LED brightness level. The preferences operate 
identically to those of the Pulse Sequence Output Control covered in the previous section.  

  
Pulse Sequence Tab for Visual Stim Controllable LED Options Tab for Visual Stim Controllable LED 

 
Reference Channel Tab for Visual Stim Controllable LED 

 
For specifics on the Visual Stim LED preferences set up, see the Pulse Sequence Output Control section on 
page 172. 
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Arbitrary Wave Output 
BSL 4.1.2 and higher supports signal output through one analog channel while data is being acquired. This is 
configured by using the Arbitrary Wave Output option. . In general, the Arbitrary Wave Output is used in 
conjunction with an OUT3 Low Voltage Stimulator connected to the Analog Out port (rear panel of MP36). 
Four types of signals can be output; Square waveforms, Tone waveforms, Ramp waveforms and Arbitrary 
waveforms. 
Each of these waveform types can be set to repeat signal output either Once or Continuously, and parameters 
can be set to either Relative or Absolute time scales. Like the standard graph window, the Stimulator setup 
window plots time on the horizontal axis and amplitude on the vertical axis.  
Use the Stimulator window (see following page) to create and shape waveforms for output. Adjust the 
Stimulator Sample Rate to further control the parameters of the Stimulator Output design. 
For any waveform (or stimulus) to be output, the following parameters must be specified; the type of 
stimulus, the “shape” of the signal, the output channel to be used, and how many times the stimulus should be 
output.  
The above parameters are set up from within the Stimulator Setup dialog. Regardless of the type of waveform 
selected, stimulus signals will normally be by clicking the BSL PRO graph’s “Start” button or by using the 
On/Off Output Control panel button. 
Square Waves 

Square waveforms are useful for generating pulse waveforms, which can be used as stimuli or to trigger a 
stimulus-generating device (such as a flash device or a tone generator). 
To output a square wave, choose the “Output Once” in the “Duration” section. A rectangular wave should 
appear in the window. The shape of the wave can be controlled by manipulating the various segments of the 
wave. and BSL PRO allows flexible configuration of the level (amplitude) and width (duration) of each 
segment. 
In a square wave, each of the editable segments is oriented horizontally, with vertical segments connecting the 
adjacent sections of the wave. The first segment of a pulse waveform is the segment that appears at the far left 
of the waveform section. By positioning the cursor on this segment of the waveform, observe that the box at 
the bottom of the screen that the level (vertical offset) of the first segment is 0 Volts, and the width of the first 
segment is 500 msec. 
To adjust the level of a segment, either: 

a) Enter the desired level in the Seg # Level box; or 
b) Position the cursor on the first segment of the waveform and drag it up or down using the mouse 

(segment 2 is selected in the preceding dialog, and appears in red). 
To change the duration of a segment, either: 

a) Enter a value in the Seg # Width box at the bottom of the Stimulator Setup dialog; or 
b) Position the cursor on the first vertical segment in the setup dialog, click the mouse button, and drag 

the vertical segment left or right. Moving the first vertical segment left shortens the duration of the 
first segment, whereas moving the first vertical segment right lengthens it. 

Each of the segments in the wave can be “edited” in this way. 
Tone Stimuli 

 Tone waveforms allow for the creation of pure tone signals of any duration, magnitude, and frequency. 
This option outputs a pure sine wave, which is useful for audiological and stimulus response testing.  
A tone waveform is comprised of two segments, with only the second segment being the actual tone itself. 
This allows a pre-signal delay to be included (by setting the level for Segment #1 to 0 Volts and the duration 
to a desired value). 
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To set the duration of the tone, adjust the length of segment #2 (by changing the Seg #2 Width value box or 
by clicking and dragging the segments within the window). As shown, there is an additional (uneditable) 
section of the waveform after the second section. This segment returns the last value from segment two, and 
continues to output that signal level until the acquisition is terminated (if the stimulator is set to output once) 
or until another signal is output (if the MP System is set to output continuously).  
There are three additional parameters for Tone waveforms: frequency; magnitude; and tone phase. 
 Tone frequency refers to the frequency of the second segment of the waveform. This can be set to any 

value, although the most common settings are between 20 Hz and 20,000 Hz. 
 Magnitude refers to the peak-to-peak range of the signal, which can range from ± 0 to ± 10 Volts. 
 Phase of the stimulus signal can be any value equal to or greater than 0 degrees. Phase settings of 

more than 359 degrees will be rescaled to fit the 0°-359° range. In other words, setting the phase to 
360° or 720° has the same effect as setting the phase to zero degrees. 

Ramp Wave 

 Ramp waveforms are useful for constructing a monotonically increasing or decreasing stimulus signal.  
Ramp waves are comprised of three segments and the amplitude and duration can be set discretely for all 
three sections.  
Arbitrary Waveform 

 The Arbitrary waveform option is used to to set a waveform’s shape and length using standard editing 
functions. 

 The length of an arbitrary waveform is only limited by the available memory. 
 Unlike the other types of waveforms, Arbitrary waveforms have no segments, so the “shape” of the 

waveform is determined by selecting an existing waveform and the only parameters that can be set 
are Scaling, Repeats, and Trigger. 

 Maximum continuous output is 20 kHz. 
To set up the Arbitrary Wave Output: 

1. Select MP36 > Output Control > Arbitrary Wave Output. 
2. Right click the Arbitrary Wave Output Control panel and choose “Preferences” to launch the 

Stimulator setup window. 

 
3. Set the desired waveform type and stimulator options in the Stimulator window. (See following 

page.) 



178  BSL PRO Manual 

Visit the online support center at www.biopac.com 

 
Stimulator Icons  
Waveforms: 

 
Square wave 

 
 

Tone (sine) wave 

 
 

Ramp wave 

 
 

Arbitrary wave 

Parameters: 
 

Reset the display (use after adjusting the time scale) 

 
 

Scaling (rescale Stimulus signals to different units) 

 
 

Set time base to relative 

Output: 

 

Sets Stimulator to be active when “Start” button is 
clicked OR when toggled via the ON/OFF button on 
the Arbitrary Wave Output control panel. 
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Sound Sequence Output Control (MP36/35/45) 
Sound Sequence Output Control offers users the option of configuring and customizing sounds to be 
outputted for aural stimulus experiments. The control panel and Preferences dialogs used for Sound Sequence 
closely resembles that of Pulse Sequence. (Substitute “Sound” for “Pulse” and “Pause” for “Delay.”) The 
built-in sound resource (a default “click”) may be used, or any other file in *.WAV format can be substituted 
via the “Sound file” and “Browse” button. The “Duration” and “Sound repetition” values are dependent upon 
the duration of the sound file selected for output. The “Test” button will output an audio sample of the 
selected sound resource. 
 

 
 

 
 
The option all sequences means that each configured sound sequence (regardless of number) will be outputted 
within the same segment. If "Once" is selected in the "Output entire pulse sequence" option, a configured 
sequence will be heard one time only. If "Continuously" is selected, the first Sound Sequence will be repeated 
after the last one has completed, looping the pattern repeatedly until the recording is stopped. 
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The option one sequence only means that each sound sequence will be outputted on a segment-by segment-
basis only. For example, if one Sound Sequence is configured, it will only be heard during the first recording 
segment, but not during the second recording segment). If two Sound Sequences are set up, the first one will 
be heard during the first segment and the second one during the following segment. If no additional Sound 
Sequences have been configured, nothing will be heard during the third segments and beyond. (Exception: If 
"Save Once" acquisition mode is used, the Sound Sequence will be repeated when the recording is 
overwritten during subsequent passes). 
 

 

Delay before first 
Pulse 

Initial delay from start of acquisition to start of first pulse. 

Number of pulses Number of successive pulses that will be sent out at the specified Pulse Width, 
Repetition and Level. Set for Single (1), Multiple, or Continuous (Cont). 

Pulse Level Amplitude of the pulse, expressed in Volts. 

Note: The output of the BSLSTM is 0 Volts when the pulse is not active. 

Pulse Repetition 

Also called — 
Events per second 
Pulse frequency Pulse 
sequence  
Pulse train 
Repetition rate 
Sample train 

Can be expressed as Period (ms) or Rate (Hz). 

Period: Time between pulses; measured in milliseconds from the start of one pulse to 
the start of the next pulse. 

Rate: Number of pulses that occur in a one-second interval; measured in Hertz. 

Rate relates to Period as: Rate (Hz) = 1000 / Period (ms) 

Pulse Width Time that the pulse is in the non-zero or active state. 
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Output Control Panels 
The Output Control panels for Pulses, Stimulator – BSLSTM and Low Voltage Stimulator work in 
conjunction with Preferences to control pulse output. Control panel functions are detailed here: 

OUTPUT CONTROL PANELS 

General Notes Pulse parameters can interact with each other. 
For example, the pulse repetition period cannot be set to a value less than the pulse 

width. 
In order to simplify the interaction, the Pulse width entry overrides other entries as 
required; it is the priority parameter. 
For example, if the pulse width is changed such that it exceeds the pulse repetition 

period, the pulse repetition period will be automatically adjusted to 
accommodate the new pulse width entry.  If, however, the pulse repetition period 
is changed such that it is less than the pulse width, the repetition period will be 
changed, upon attempted entry,  to the closest value that can be achieved without 
changing the pulse width.  

Entries are checked and rounded (not truncated) as necessary to meet limitations of 
the hardware or the Preferences. 
When a file is opened, the output device will not turn ON automatically. A user must 
manually press either the “Record” button or the “Start” button. 
The exceptions are the “Voltage Output” control panel and the “Digital Outputs” 

control panel if “Set each Output immediately” is selected; these settings will 
output values immediately. 

Output control settings are “local,” which means that they are stored at the data file 
level, not the program level. Use the save as graph template (File > Save As) option 
to use existing Preferences in new data files. 
If a file is saved with an Output Control panel visible and then closed, the panel will 
be visible when that file is re-opened. 

Preferences Right-click a control panel to generate the Preferences dialog, and then select a tab 
for the settings requiring adjustment. 

 
The File>Preferences menu option can also be used to generate the Preferences 
dialog. 

Output Settings 

 

 

Displays the name of the current Preferences setting. The pull-down menu lists the 
names of all output Preferences saved using the Save Settings button (see page 182). 
The pull-down menu is not accessible when an output pulse train is in progress. 
If no settings configurations have yet been saved, when the Output Control panel is 
first opened and no parameters are changed, the Output Settings box displays 
“Default.”  
When output settings are saved, the Output Settings box displays the name of the last 
selected setting. Use Organize List to change the display order of the menu, rename, 
or delete items (see page 182). 
When a saved setting is selected from the pull-down menu, the Output Control panel 
and all Preferences dialog options will be updated. 

For Reference Channel—Low Voltage Stimulator; Human Stimulator; Visual Stim 
Controllable LED (OUT4) and Pulse Sequence only. All Output Settings must use 
the same reference channel assignment; other parameters can be unique for each 
setting. 
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Once configured, Preferences may be saved using the Save Settings button at the 
bottom of the Preferences dialog. Save Settings generates a dialog to name and save 
a defined configuration of Stimulator output settings. Saved configurations are 
accessible via the Output Settings pull-down menu in the Output Control panel. 
When a setting is selected from the menu, all current output parameters are updated 
to reflect the saved settings. 
Multiple configurations can be saved as long as each has a unique name; the Save 
button will be inactive if the entered name is not unique.  
Settings can be saved locally (to a specific file) or globally. The data file or template 
file holds the output parameters as established when the file was saved plus any other 
named configurations of Output Settings. 

 

 
Use the Organize List button at the bottom of the Preferences dialog to order, 
rename or delete saved Preferences settings. The up or down arrows are only 
available if two or more settings have been saved. Select a setting and then click the 
up and down arrows to set the position, or choose rename or delete. If “Delete All” is 
selected, all saved settings will be deleted and the default and Custom options will be 
reactivated. 

GENERAL TAB (OUTPUT PREFERENCES) 

General Tab 

The General tab is 
available when using 
Pulses, Low Voltage 
Stimulator, 
Stimulator-BSLSTM 
and Human 
Stimulator-
STMHUM. 

 

Number of Pulses 

 

Indicates the number of pulses to be output. When the Output Control panel is 
closed, the pulse output will be immediately stopped. 

Single will establish a single pulse for outputting. All pulse repetition options, 
entry boxes and scroll bars in both the control panel and preferences windows will 
be disabled (grayed). 

Multiple will establish a specific number of pulses for outputting. The selection 
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will activate an entry box where any value from 1-254 pulses can be entered. 

When this option is selected, the Pulse Repetition scroll bar is activated in the 
Output Control panel. 

Continuous will establish a continuous pulse train for outputting. When this 
option is selected, the Pulse Repetition scroll bar is activated in the Output Control 
panel. 
If “Initiate pulse sequence with ON/OFF button in Output control panel” is set, the 
pulse sequence will be stopped prior to acquisition and will have to be manually 
turned back on after the recording. 

Initiate pulse 
sequence with… 

ON/OFF Button 

 
OFF (red) 
 

 
ON (green) 
 

 
AUTOMATIC 
START (yellow) 

 

Controls the start and stop of pulses. Changes to Pulse Width and Repetition Rate 
can be made in the Output Control panel entry boxes during a pulse sequence, and 
during a recording, if all other Preferences parameters allow it. Any change in the 
pulse output will occur immediately. This allows the stimulator output to be 
changed “on the fly.” 

When “Initiate pulse sequence with ON/OFF button” is selected: 
The ON/OFF button controls pulse output independent of the acquisition status. 
OFF is always available. 
The ON/OFF button reflects the current output state, with one exception: if the 
pulse sequence lasts less than 0.5 seconds, the button will remain in the “ON” state 
for at least 0.5 seconds to indicate that the ON state occurred. 
When the Number of Pulses selected is Multiple, ON/OFF acts as a momentary 
switch. Press the ON (green) button to start pulses; 
it will automatically turn OFF (red) at the end of the specified pulse train. 

The switch defaults to OFF. Saving a data file or saving as a Graph Template will 
save all stimulator preferences except the status of the pulse switch, which will 
always be saved in the OFF position. 

Recording 

 
Start button 
 

 
Stop button 

When “Initiate pulse sequence with Recording” is selected: 
If the preference setting “Initiate pulse sequence with: ON/OFF button” is active, 
the control panel changes will take effect immediately. If settings are changed 
during a pulse train, changes do not take effect until the next time the stimulator 
starts. 
Pulse output turns ON and OFF corresponding to the Start and Stop of the 
recording.  

When in this mode, and not recording, the ON button will display as yellow, 
indicating that pulse output will automatically begin at the “Start” of the recording. 

Pulse outputting can be turned OFF during a recording, but it cannot be turned 
back ON until the end of the recording. 

When a Repeat sequence is running, pressing the OFF button will turn OFF the 
output for the entire recording sequence and the button will display as OFF until 
after the last sequence, when the switch will display as yellow ON (automatic 
start) indicating that pulse output will begin again at the “Start” of the next 
recording sequence. Pulse outputting cannot be turned back ON during a repeated 
recording sequence. 

When the acquisition stops, all stimulator pulses will cease, regardless of the 
Output Control panel settings. 
The pulse output will stop concurrent with the end of the acquisition, even if the 
specified pulse output is not completed before the acquisition ends.  
When a new acquisition is started, the pulse output will start from the beginning. 
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In this mode, no changes can be made in the Output Control panel until the 
recording stops.  
Changes made after recording stops will take effect when a new recording is 
started. 
When a pulse is sent out, the event label and indicator arrow will be generated (if 
the event preference is turned ON and events are displayed). 

After initial delay 

(Applicable to 
Pulses, Stimulator - 
BSLSTM, Low 
Voltage Stimulator 
and Human 
Stimulator-
STMHUM only) 

After initial delay of … is enabled only when “Initiate pulse sequence with 
Recording” is chosen. Specify a delay interval from the start of recording to the 
start of the first pulse. This is useful for viewing data prior to the stimulus pulse. 
The BIOPAC output device determines the delay range. 

INITIAL PULSE DELAY MP36/35 BSLSTM 

 Range 0 - 100 milliseconds 0 or .5 - 100 milliseconds* 

 Resolution 10 microseconds 1.953 microseconds 

*Entries greater than 0 milliseconds must be at least 0.5 milliseconds. 
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Pulse 
Events

 

 
An advantage of using the BSL PRO software for output signals is that information 
regarding the pulse is automatically recorded along with the data. The amplitude 
reflects the output pulse level. 

• Events can be automatically inserted and labeled for each Reference 
pulse or change in pulse train. The label will contain the Pulse width 
and Pulse rate (and system time stamp if selected). 

• Events reflect setting changes made during an acquisition.  

• All output pulse information is automatically recorded and archived 
with the saved data. 

Set the event option by clicking in the box to “Create event when output is 
changed.” 

Set the “Include time/date” option in the global Preferences (MP36R > Set Up 
Data Acqusition > Event Marking) 

 
The event label accurately captures pulse data, but the event arrow may not always 
line up exactly with the leading edge of the pulse; this typically is not a problem 
because the recording will include the actual stimulus pulse which can be used for 
timing measurements. 

Depending on the acquisition Sample Rate, the leading edge of the pulse in the 
recording may not correspond to the exact time the pulse was sent—it may be off 
by as much as one sample period. If the event precision is critical for the recording, 
increase the Sample Rate. 

To display events, use the toolbar icon or Display>Show>Events. 

The Range switch on the front of the BSLSTM stimulator should be set to 10V or 
100V prior to recording and should not be changed during recording; if using a 
Preset, the corresponding Preset should also be selected prior to recording. The 
pulse level can then be determined by moving the decimal to the right or left 
depending on how the range was switched.  
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ADVANCED TAB (OUTPUT PREFERENCES) 

Advanced Tab 

(Applicable only to 
Pulses, Stimulator - 
BSLSTM, Low 
Voltage Stimulator 
and Human 
Stimulator-
STMHUM) 

 
Pulse Width 

 

Indicates the Pulse Width setting, which determines the maximum Pulse Rate 
frequency. A Pulse Width value can be entered, unless limited by Preferences. 

The entry is activated when the value is changed and the Tab or Enter key is 
pressed; it does not require a stimulator restart to take effect. 

The Pulse width entry overrides other entries as required. 

An entry may be automatically changed if any of the following conditions apply, 
in which case the closest possible value will be selected: 

It falls outside the allowable range. 

It is rounded to .01 millisecond increments (MP36/35 resolution). 

Width has been limited by the Pulse Width: Limit Entry settings of Preferences. 

Allow any entry Pulse width is limited to the output capabilities of the BIOPAC MP device. This 
option allows any entry within the allowable range specified below: 

PULSE WIDTH RANGE MP36/35 unit    

Range  .050 – 100 milliseconds  

Resolution 10 microseconds  

Lock entry to This entry locks the width to a single, specified value (within the allowable 
range). No other value can be entered. 

Pulse Repetition 

 

Indicates the Pulse Repetition period (Hz or ms). 

The Pulse period must be greater than the Pulse width. See “TBPMIN” in the 
Output Preference > Advanced Tab Limits table on the next page. 

The full range of acceptable Pulse Rate values is from .2 to 6,667 Hz. 

The maximum Pulse rate (PRPMAX) depends on the Pulse width setting: 

Pulse width 100 ms  maximum Pulse rate = 9 Hz 
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Pulse width .020 ms  maximum Pulse rate = 3333 Hz 

The formula for pulse width vs. pulse repetition is PRPMIN = PW + TBPMIN 
Where: PRPMIN = the Minimum Pulse Repetition Period allowed. 
 PW = Pulse Width setting 
 TBPMIN = Minimum Time (in ms) between successive pulses 
       for the output device (see device specifications) 
If “Limit changes from ___ to ____” is selected in Advanced preferences, then 
PRPMAX will be determined by the formula above or the specified limit, 
whichever is greater. 

An entry may be automatically changed: 

• If it falls outside the allowable range. 

• To round it to .01 Hz increments (resolution of system). 

• To make it at least 0.1 millisecond greater than the Pulse width. 

• By the Pulse Repetition Rate: Limit entry Preference. 

• By the Pulse Repetition: Adjust entry increments Preference. 

Any pulse width value can be manually entered, but when using the scroll bar or 
arrows, entries will be constrained by the “Adjust entry increments” Preference 
setting. 

Pulse Repetition 
Scroll Bar 

The Pulse Repetition Scroll Bar adjusts rate or period by the increment of change 
and limits established in Preferences. With each click of the scroll bar arrows, the 
rate will be increase by the specified increment. 

When “Initiate pulse sequence with ON/OFF button in Control Panel” is 
selected, changes take effect upon release of the scroll box as long as the 
stimulator is running. 

The scroll bar is disabled when Number of Pulses is set to “Single” or Pulse 
Repetition is set to Lock Entry to...” 

Display as Pulse repetition can be displayed as 

Pulse Rate (expressed in Hz), or 

Pulse Period (inverse of Pulse Rate, expressed in milliseconds). 

Pulse Repetition Rate relates to the Pulse Repetition Period as: 

Pulse Rate (Hz) = 1000 / Pulse Period (milliseconds) 
The “Display as” units selection is also used for: 
Pulse repetition entries in the control panel. 
Scroll bar increments. 
The Pulse Repetition Rate: Limit entry Preference. 
The Pulse Repetition: Lock entry Preference. 
The Pulse Repetition: Adjust entry increments Preference. 

When units are changed from Rate in Hertz (Hz) or Period in milliseconds (ms), the 
limits of the Pulse Repetition range will be converted by the formula: 
Period increment in ms = Round to nearest whole number [Period Range * (Rate 
increment in Hz /Rate Range in Hz)] 

For example, if the Range was 1Hz to 10 Hz with an adjustment increment of 
1Hz, the proportional calculation would be Period increment = 900 ms (1Hz / 9 
Hz) = 100 ms 
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Allow any entry Pulse width is limited to support the output capabilities of the BIOPAC output 
device. See Output Preference > Advanced Tab Limits table for allowable range. 

Limit entry Establishes minimum and maximum values that can be manually entered or 
changed with the scroll bar. 

Lock entry Locks the Repetition to a single, specified value (within the allowable range). No 
other value can be entered in the control panel. 

Adjust entry Controls the scroll bar or scroll arrow increment; does not apply to manual entry. 
Output Preference > Advanced Tab Limits 

 Pulses 
MP36/35 

BSLSTM 
MP36/35 

SS58L 
MP35 Only 

Low Voltage 
Stimulator  
MP36 

STMHUM 
MP36 

Pulse width  
 Range (ms): 0.05 - 

100 
0.05-100 0.05- 

100 
0.05 – 100  0.1-1  

 Resolution 
(ms): 

0.01 0.01 0.01 0.01 0.01 

Pulse Repetition      
 Rate range 

(Hz): 
0.2-  
6,667 

0.2 -689 
 

0.2- 
10,000 

0.2- 10,000 0.2-6667 

 Period range 
(ms) 

.06-  
5,000 

0.5-  
5,000 

0.1- 
 5,000 

0.1-5,000 
 
 

0.15-5,000 

 TBPMIN 
Minimum time  

 between Pulses  
(ms): 

0.01 0.450 0.05 0.05 0.05 

 Resolution 
(ms): 

0.01 0.01 0.01 0.01 0.01 

Initial Pulse Delay      
 Time range 

(ms): 
0-100 
 

0-100 0-100 0-100  0-100 

 Resolution 
(ms): 

0.01 0.01 0.01 0.01 0.01 
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LEVEL TAB (OUTPUT PREFERENCES) 

About Level 

 

Low Voltage Stimulator and Human Stimulator-STMHUM allows the software to 
specify the pulse amplitude.  The amplitude can be set to any value within the 
limits of the stimulator; the range is -10 to +10 Volts for the Low Voltage 
Stimulator and 0-+100 V for the Human Stimulator-STMHUM 

Pulse Level 

Low Voltage only 

 

The Level entry box allows the user to 
manually enter any value within the limits 
of the system, or within the limits of the 
Preference settings from the Level tab. 
The Level entry box will be inactive 
(grayed) if: 
The Level preference “Lock entry to” is 
active. 
If “Initiate pulse sequence with Recording” is active (from the General tab) and a 
pulse sequence is in progress or “wait for trigger” is in progress. 
 
Use the entry box or the scroll bar to set the Pulse level. When a value is entered 
which is out of range, the value will be rounded to the closest value obtainable 
after the “Enter” or “Tab” key is pressed. 
If “Initiate pulse sequence with ON/OFF button in control panel” is active (from 
the General tab), then values entered during a pulse sequence will take place 
immediately. 
If “Initiate pulse sequence with Recording” is active (from the General tab), any 
entry made between acquisitions will take place on the next “Start” of acquisition. 

Allow any entry The level is limited to the output capabilities of the stimulator. This option allows 
any entry within that range.  

Limit entry This entry reduces the range of the stimulator’s output capabilities. 

Lock entry This entry locks the level to a single specified value (between -10 and +10 V). 

Adjust entry This setting affects the scroll bar or scroll arrow increment only; it does not apply 
to manual entry. 

The smallest increment is 5 mV, as limited by the MP36/35. The specified 
increment is used to round manual entries to the closest obtainable value. 
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REFERENCES TAB (OUTPUT PREFERENCES) 

Reference Channel 

 

 
This option allows monitoring of  the output signal on one of the analog or digital 
input channels without making any physical connections. This is an internal, 
hardware/firmware, feature that recreates the output signal and allows recording 
in “real time.” The assigned reference channel will override any “real” input 
signal. 
The reference signal is not the real signal, but is a very accurate “estimate” of the 
real signal. The pulse timing accuracy will be within 100 microseconds. If an 
analog input channel is used as the reference channel, the pulse level will be 
accurate within 5%. If the stimulation encounters a load that reduces or distorts 
the pulse output, the reference signal will not reflect this amplitude distortion. 
If a digital input channel is used as the reference channel, only a digital 
representation of the pulse will be generated; 0 to 5 volts. 

Channel Assignment Use the pull-down menu to choose which analog or digital input channel will be 
used as the output reference channel. 

When a new reference channel is assigned, a warning will be generated indicating 
that this setting will overwrite the existing Channel Setup parameters for the 
selected channel. 

 
For example, if CH1 is set up for ECG data and then selected as the Reference 
Channel, the ECG parameters will be replaced. If another channel is then selected, 
CH1 will be reestablished with the default analog input parameters, and the ECG 
settings would need to be recreated via presets or manual entry. 

The reference Channel label should read: (Selected Output) - Reference Out”. 

When an Analog Input Channel is assigned as the Reference channel, that channel 
(as viewed from MP UNIT > Set Up Data Acquisition > Channels) will be in a 
locked mode and the Preset pull-down menu will be disabled. The assigned 
reference channel will be inactive for “real” inputs until the Reference Channel 
Preference is changed to “None” or another channel.  

Once the control panel with an assigned Reference channel is closed, the data 
Acquisition Settings > Channels will automatically update to the default settings. 
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Generate using Specifies how the Reference signal should be shown. 

If using analog input from CH1 - CH4, an actual or fixed (max) amplitude and 
actual pulse or fixed pulse width can be selected. Fixed pulse widths are useful 
when the pulse width is much smaller than the sample interval (1/sample rate) is 
used. 

For example, Frog muscle stimulation uses a 1 ms pulse width and a sample rate 
of 2000 samples/second to capture the muscle response. At this sample rate, the 
stimulus pulse cannot be reliably recorded. By using the  fixed width of 15 ms, the 
pulse should be recorded. 

If using digital input from D1 - D8, select actual or fixed (15ms) pulse width. 

 
Usage Guidelines & Setup Summary for BSLSTM Output Control 

HUMAN SUBJECT SAFETY 
Before using the stimulator on human subjects, it is very important to limit the energy 
the stimulator outputs. For optimal safety: 
Before powering on the BSLSTM stimulator, set the voltage level to zero by rotating 
the LEVEL knob on the front of the BSLSTM fully counterclockwise. 
Use BIOPAC HSTM Series Probes. These probes MUST be used in order to limit the 
energy the stimulator can output. 
Never create an electrical path across the heart. 
Never use on subjects with pacemakers. 
Read this manual and the BSL Hardware Guide to become familiar with Stimulator 
operation. 

1. Connect the BSLSTM Stimulator to the MP UNIT and power on both units. (For instructions on how 
to connect the BSLSTM to the MP UNIT Acquisition Unit, refer to the BSL or MP Hardware 
Guides.) 

2. Connect the Stimulator Trigger cable to the Analog Out port of the back of the MP36R hardware. 

3. Connect the Stimulator Reference Output cable to an Input Channel on the front of the MP36R 
hardware. This channel will be set up in Step 8 below as the Stimulator Reference Channel. 

4. The Reference pulse has a fixed Pulse width of 15 milliseconds, so chosen so that the Sample Rate of 
the recording may be as low as 100 samples/second and still capture the Reference pulse. 

5. Before powering on the BSLSTM stimulator, set the voltage level to zero by rotating the LEVEL 
knob on the front of the BSLSTM counterclockwise all the way to the left. 

6. Open a new data acquisition graph. 

7. Confirm that Events are activated. Events are activated by default. If not activated for a given 
recording, choose Display > Show > Events. 

8. Set up the Stimulator Reference Channel. This is the Analog Input Channel on the front of the 
MP36R that receives the Stimulator Reference Output cable from the back of the BSLSTM. 
Remember, the reference channel is is generated from the stimulator and not the software. 

9. Choose MP UNIT > Set Up Data Acquisition > Channels. This will generate a Set up Channels 
dialog. 

10. Select the Acquire, Plot and Enable options for the analog channel to use as the Stimulator 
Reference Channel. 

11. Click Presets and scroll to select “Stimulator (0-10V)” or “Stimulator (0-100V)” to match the Range 
switch setting on front of the BSLSTM. 
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12. Click Setup to view or change the analog channel parameters. Review the BSLSTM Stimulator 
section (page 170) and Analog Channel Setup section (page 103) before modifying channel/preset 
parameters. 

13. The Gain and other input parameters may be set as desired. 

14. Click OK to accept the parameters.  

15. Close the Set up Channels window.  

16. Adjust the voltage output of the stimulator by using the Level control on the front of the BSLSTM. 

17. Rotate the Level knob clockwise to increase and counterclockwise to decrease, reading the voltage in 
the BSLSTM’s digital display. 

Stimulator Safety Features 

The stimulator cannot operate unless its Output Control panel is open. 

The Pulse ON/OFF Switch on the Stimulator Output Control panel must be OFF in order to open and 
configure Stimulator Preferences. 

If the Stimulator Output Control panel (or the BSL PRO application) is closed in the middle of a pulse train 
while the stimulator is running, the stimulator will shut down and the pulses will stop. 
If another data acquisition window is activated, the stimulator will stop and remain OFF unless restarted using 
the parameters associated with the new data window. The only exception is that if the stimulator is ON and 
the data window corresponding to current stimulator parameters is acquiring data, then the stimulator will 
continue to run until the end of the acquisition. 



Part B — Acquisition Functions 193 

BSL PRO Manual 

 

Chapter 9  Set Up Event Marking 
Events (Markers) 

 

 

 

 

Event Toolbar Event Insertion Event Control 

Event (Marker) Overview 
For detailed analysis, it can be useful for waveforms to have extra information associated with them. This 
information might include waveform boundaries from ECG analyzers, spike classifications from a spike 
sorter, heartbeat classification from a PhysioBank file, or even detailed user notes. BSL PRO uses “event” 
functionality to store and manage this information. 
An event is a piece of information associated with a specific time in a waveform. An event can capture points 
of interest within a file (i.e. subject moved, dose added) or on a particular channel (i.e. T-wave onset). Once 
events are marked in the file, BSL PRO can use the event information for analysis, including measurement 
(page 207) and cycle detection (page 289). 
 An event has the following pieces of information associated with it: 

o Event type 
o Sample location: the time position in hardware samples where the event is defined. 
o Channel: the channel for which the event is relevant. 

o Some events, such as the time of the start of an appended segment, may be relevant to all of 
the channels of a graph—these are “Global” events. 

o Label: a string of text that can be entered either automatically or by the user to provide more 
information about an event. Labels can be fixed or sequential in BSL PRO and up. 

 Different event types can be entered automatically or manually. These different event types allow 
events to be filtered and also support analysis routines that key off of these events. 

o Event insertion tool 
o Set Up Event Marking (see page 195) to manually insert events during acquisitions 
o Copy/paste measurements and Copy/paste wave data operations can insert events at the 

selection boundaries; choose “Mark with events” under Preferences (see page 194) 
o Cycle Detector Output Events option (see page 289) 
o Contextual menu in Event region 
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Event Toolbar 

 
The event toolbar displays global events and provides a quick editing area for event descriptions. The right 
button toggles visibility of the Event Palette for detailed control (see page 196). The palette will “refresh” 
when events change the event configuration, such as horizontal scrolling, scale changes, changes in the 
selected event via clicking in the graph window, editing of the event label by using the event bar, 
transformations that define new events for the graph, waveform editing operations, and additions of new 
events by clicking the event bar at the top of the graph window. 
Event Tooltips 
If events are being displayed within the plotting area and tooltips are enabled, a tooltip will be associated with 
every event in the plotting area. The tooltip includes the event type description, the user-defined label (if 
present), the time location of the event, and the amplitude of the waveform at the event location. While this 
information can be drawn directly on the graph, event tooltips assist in browsing event information when the 
screen becomes too crowded and there is not enough room to display all of the times, amplitudes, and labels. 
Event tooltips are displayed under the event icon. 
 If the event is being plotted directly on the waveform, this will be the point on the waveform 

associated with the event. 
 If there is an indicator and the event icon is at the top of the indicator, the tooltip will be anchored at 

the top of the indicator. 
 If the events are being plotted at the top of each track, the tooltip is anchored at the top of the plotting 

area directly underneath the event icon. 
Event tooltips will not be displayed if tooltips are disabled, if events are only being displayed in the event bar 
at the top of the screen, if X/Y mode is in use, or if events are not currently visible. 
Event Preferences 

  
Preferences  > Event Summary and Waveform 

Use the “Event Summary” section of the Preferences dialog to set options for pasting summaries of events 
into the journal. (Preferences shown above and listed below are from BSL PRO) 
 Group events 

Sorted by type sorted by event type descriptions first 
Sorted by channel grouped based upon where they are defined (Global events appear first, 

followed by groups for each individual channel). 
 Sort Grouped events 

Sorted by time sorted in order by increasing time 
Sorted by label sorted alphabetically by label 

 Include only events visible on the screen 
Determine if the summary is generated for all of the events that are in a graph, or only for those 
events that are currently visible on the screen. If there are thousands of events in a file, this feature 
allows the list to be pared down to those of interest. 
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Event summary options will be saved with the graph if the graph has a graph journal, and can be pasted into 
the journal using “Summary in Journal” Event Palette Actions command (see page 200). 
Other event preferences are available under Preferences > Waveforms 

• Mark waveform edits with events 
• Mark selection with events in graph—create events at data selection bounds. This includes 

selection events (selection begin and selection end) for global events when measurements or 
waveform data are pasted. When selected, measurement pasting will result in an automatic 
execution of the “Mark Selection” feature manually accessible from the Event Palette. 

• Include time value— include the time value (relative to start = 0) for the paste. 
• Include timestamp—Include time and date stamps for when the paste occurred; this timestamp will 

match any timestamp pasted into the journal. When selected, any selection events added to the 
graph will have their labels set to match the timestamp. 

• Auto-paste results in independent journal (Preferences > Journal)—Selection events and time 
stamp events can be automatically inserted to an independent Journal. 

Combine these options to retain enough information to reproduce measurement results and correlate 
measurement results with specific areas of the graph; this helps verify the accuracy of measurement results 
made through manually constructed graph selections. 
Any change to these settings will be retained within a saved graph file and will become the default for newly 
constructed graphs. 
Event Marking Setup 

 

Events of different types 
can be inserted during 
acquisition, whether or 
not events are visible in 
the graph. When a hotkey 
is pressed during 
acquisition, an event will 
be inserted into the graph 
at the end of the most 
recently acquired data. 
Each hotkey can have a 
different configuration, 
adjustable through a 
dialog accessible via the 
“MP > Set Up Data 
Acquisition > Event 
Marking...” menu item.  

Hotkey Assign Escape or F1 through F9. When a different hotkey is chosen, the other controls of the 
dialog change to reflect the configuration of the new hotkey. 

Action Choose whether the Hotkey assignment creates an event or a focus area. 
Event type Lists the standard hierarchical menu of available event types; Types are detailed on page 201. 

Choosing a new type from the pull-down menu will change the type of event inserted when 
the hotkey is pressed during acquisitions. 
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Channel Contains a “Global” entry and all of the channels (analog, digital, or calculation) set to 
“Acquire” in Set Up Channels. 
 “Global” will define global events drawn in the event bar above the graph data 
 Choosing a new channel from this menu will cause events to be inserted on the 

appropriate channel of the graph when the hotkey is pressed. 
Label Edit field for label text and toggle optional inclusion of time stamp and/or date stamp. Stamps 

correspond to the time of the system clock when the key was pressed, that is, the time of the 
event insertion in “real clock time.” 
 Fixed - Provides a fixed label from text entered into the label field to the right. This label 

is used every time the assigned hotkey is pressed. (BSL PRO and higher) 
  Sequential - Labels for events will iterate sequentially through the entries in the table 

index when the assigned hotkey(s) is pressed. The area under ‘Label’ is editable for 
entering text. (BSL PRO and higher) 

 
Additional Controls Function 
Add Adds an editable label field to the list.  
Rename Allows renaming of the existing segment label. 
Delete Deletes a selected custom label. 
Delete All Deletes all custom labels. 
Up Incrementally moves a selected label up the list. 
Down Incrementally moves a label down the list. 
Top Moves a selected label to the top of the list. 
Bottom Moves a selected label to the bottom of the list. 
Include time Adds timestamp to labels when checked 
Include date Adds current date to labels when checked 

Create/Toggle Focus Area Action 
Selecting the ‘Create/Toggle Focus Area’ action presents a similar setup dialog, but dictates that hotkeys 
setups will be assigned to defining Focus Areas instead of inserting events.  

 
When this option is chosen, pressing an associated hotkey during a recording will initiate a focus area in the 
graph. Toggling the same hotkey will conclude the focus area. The focus area will appear highlighted and 
outlined in the graph following the second (termination) keystroke. As with events, multiple hotkeys and 
labels can be assigned.  
Example for setting up a Focus Area Hotkey: 

 Choose the desired hotkey from the Hotkey list. 
 Under Action, select ‘Create/toggle focus area’. 
 Assign the focus area a label by typing it into the ‘Base focus area label’ field. 
 If additional focus area hotkey assignments are desired, choose another hotkey 

from the list, and repeat steps 2 and 3. 
 When focus area hotkey assignments are completed, click OK. 

 If the same hotkey combination is repeated to create subsequent focus areas, the base focus area 
label will remain the same but with incrementing numbers appended to the title. 
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 If a different hotkey combination is used for subsequent focus areas, unique base focus area 
names will be used as assigned.  

 Starting a focus area assigned to one hotkey and then starting another focus area assigned to a 
different hotkey will terminate the original focus area and start a new one. 

 Focus areas can be created and toggled while a recording is in progress. 
Event Palette 

  

 
 

 

The Event Palette is a floating window 
that provides a quick summary of events 
for the active graph and can used to 
examine, search, and modify events. 
Events can be extracted in a time range 
for a specific event type and specific 
channels. 
There is only one visible event palette 
for the entire application. The palette 
consists of four sections: event list, 
selected event, display, and event 
actions. Each section can be shown or 
hidden by toggling the disclosure button 
next to its title. 
 Event List, see page 197. 
 Selected event, see page 198. 
 Display, see page 198. 
 Actions, see page 200. 

o See the Event Journal 
Summary enhancements. 

Event List 

 

The event list provides an expandable, scrollable, 
hierarchical view of the events in the topmost graph. 
Events are grouped by their channel on the top level. 
The event list has three columns of information: 
 Events: the readable type for each event 
 Location (Time): the time location for each event 
 Label: the user defined description for the event. 

Sort the contents in ascending or descending order on each column by clicking the column header. Events and 
Description will sort in standard alphabetical order, Location will sort based on the numerical sample location 
of each event. 
Select a single event from the event list by clicking on a single event. The event will be selected in the graph 
window and made visible if it is not currently displayed. 
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List visible events only toggles the checkbox to switch between the two display modes. 
 When enabled, the event list will display only those events that are being displayed on the plotted 

portions of the graph. As the user navigates through the graph with the scrollbars, horizontal scale, or 
other means of changing the amount of visible data, the event list will continually refresh to contain the 
new set of visible events. 

 When disabled, the event list will display all of the events for the entire graph. This can allow for easier 
navigation through graphs with hundreds of events, such as PhysioBank files. 

Selected Event 

 

 

 
Event type options are 
detailed on page 201. 

When a single event is selected, the type, channel (or “General” for global events), user-defined label, and 
location of the event will be filled in and can be edited. The controls can display information about only one 
event at a time; if no event is selected, the controls will be grayed out. 

Event Location 
“Location defines the position where the selected event occurs, relative to the first sample in the file. To 
change the location of an event, change the position entered in the Location box. Precision matches the 
horizontal axis setting. 
Events may also be repositioned using the mouse. Option-click the event icon in the graph and hold down the 
mouse while dragging; the event will be repositioned at the horizontal position where the mouse button is 
released. 
 

Display 

  
 Event display location Event display detail 
Display controls determine the location and detail of events to be drawn in the frontmost graph. 
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 Location—Choose one of the five display methods (described on page 199). 
 Detail—the three checkboxes to establish how much information to include with events. 
 Indicator length—Set the slider to shorten or lengthen the indicator line. This option is only active if 

the display mode is “On waveform, with indicator” or “At top, with indicator.” 
 Font – Align – Selects font style and alignment of Event labels. 
 Angle – Determines the angle in degrees that the Event text can be displayed in the graph. Value can 

be positive or negative. 
 Set as defaults – Saves the selected display settings. 

 
Location & Display Description 

In event bar 

 

Event icons are displayed in the global event bar located on top of the plot area in the 
graph window. This does not allow for distinguishing what channel a specific event 
belongs to. 
 To select the event, click the icon in the event bar. 

On waveform 

 

Event icons are displayed above or below the actual sample in the source channel 
corresponding to the location of the event. 
 To select the event, click the event icon on top of the waveform. 

Top of plot 

 

Event icons are displayed at the top of the channel track, either on top of the grid or in 
a channel-specific event bar. 
 To select the event, click the icon at the top of the channel track. 

On waveform, with 
indicators 

 

Event icons are displayed above the data with a vertical line of configurable length 
running through the data sample of the source channel at the event’s location. 
 To select the event, click the event icon or the indicator line. 

Top of plot, with 
indicators 

 
 

Event icons are displayed at the top of the channel track with a vertical line of 
configurable length running through the data sample of the source channel at the 
event’s location. 
 To select the event, click the event icon or the indicator line. 

Detail When an event is being plotted within a graph, either on the top of a channel or 
floating above the data, the event's location, description, and amplitude of the 
waveform at that location can optionally be displayed along with the event icon. 
Plotting of additional information can be used for graphical annotations on the data 
and for clarifying event location for hardcopy or presentation. 
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Actions 

     
Actions Button Description 

Find It is easy to create many more events then one can easily scroll through and locate 
in a list. Find controls the automatic location of events based on established search 
criteria. 
Click the Find button to generate the Event search criteria dialog, and then 
combine or restrict information to define desired events: event type, specific 
channel location, or label search. 
Click “Find First” to search for the first event in the graph that matches the 
criteria. If found, the event will be selected and made visible in the graph window. 

Find Next Finds the next single event that matches the established search criteria until no 
remaining events match the search criteria. 

Cut Selected Event Active only when an event is selected, removes the selected event from the graph. 

Clear 
Clear all 

Generates a search criteria dialog (identical to the Find dialog) and removes all 
matching events from the graph. There is also an option to clear events defined 
within a focus area without affecting the remaining events, or to clear events 
defined outside of a focus area while leaving events within the focus area intact. 
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Summarize in 
Journal 

Displays a dialog with controls that affect which events are included in the 
summary. 
Events can be filtered by visibility on the screen. Creates a textual summary of all 
of the events in the journal. 
 See “Event Preferences” on page 194 for more information about 

modifications to the traditional event summary. 

Event Journal Summary Enhancements 

 
Events to be included in the summary can be filtered using the same criteria as 
Find... in the Event Palette. By adding the ability to summarize only events 
matching specific criteria, textual reports of arrhythmias or other infrequently 
occurring events of interest can be generated with ease. Events defined within or 
outside of focus areas can also be included or excluded from the summary. 

When “Summarize in Journal” is clicked on the event palette, a dialog will be 
displayed with controls that affect which events are included in the summary. 
If no Journal is open for the current graph, a prompt will be displayed to create 
one. 

 
Mark Selection Defines two new Global events in the graph at the precise time locations of the 

currently selected area (the highlighted wave data section). If there is no selection 
in the graph, this button has no effect. The events that are inserted will have the 
“Selection Begin” and “Selection End” event types. 

Restore from 
Snapshot 

 This feature not available in BSL PRO. (Used in AcqKnowledge Research 
software only). 

 
Event Type Options 
Event Types are pre-defined options for assigning event information. The Event Type is for marking purposes 
only and does not imply any analysis has or will occur for the event. 
Once Event Types are defined, some analysis functions can be automated, including measurement (page 207) 
and cycle detection (page 289). 
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Event classifications: 

 

Event classifications group similar event types together into a logical category. Event 
classifications present event types in a hierarchical fashion and allow other event 
classifications to be contained within them. 
For example, the “Hemodynamic”event classification includes a “Beats” sub-class 
with pre-ventricular contraction and escape beat event types. 

Event type Classification 
Global This is the same as ‘untyped’ markers from BSL PRO 3.6 or earlier. Unrecognized event types will 

be classified as global events. 

Append Automatically inserted by the program on append operations. Custom Append labels can be created 
in MP > Set Up Data Acquisition > Segment Labels. (See page 213.) 

Notes Annotation event to add notes on the data. 

User-defined Hotkey insertion for user-specific events; 9 types can be inserted via the keyboard during 
acquisition. 

Pharmacology Basic pharmacological events: baseline, washing, and dosing. 

Waveform Edits Automatically inserted by the program on cut or paste operations in a graph file. The description 
consists of the edit operation performed and a timestamp. 
Insertion of waveform edit events is off by default, but can be turned on for GLP purposes. 

Selections Used to mark boundaries of selected areas. 

Classification Pre-defined Event Type Options 

Default “Esc” key inserts global event. 

General Waveform onset or end  Recovery   
Change in signal quality or rhythm Stimulator 
Maximum or minimum   Reset  
Communication lost begin and end 

Hemodynamic 
 >  ECG 
Complexes 
 

QRS onset, peak, and end U-wave peak 
T-wave onset, peak, and end PQ junction 
P-wave onset, peak, and end J-point 
Q-wave peak ST segment change 
S-wave peak T-wave change 

Hemodynamic 
 >  Beats 

Normal Nodal premature 
Paced Supraventricular premature 
Fusion of paced and normal Premature ventricular contraction 
Unclassifiable R-on-T premature ventricular contraction 
Left bundle branch block Fusion of ventricular and normal 
Right bundle branch block Atrial escape 
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Bundle branch block Nodal escape 
Atrial premature Supraventricular escape 
Aberrated atrial premature Ventricular escape 

Hemodynamic 
 >  Blood 
Pressure 

Systole End systolic pressure 
Diastole End diastolic pressure 

Hemodynamic 
 >  Impedance 

A-point  X-point 
B-point  Y-point 
C-point O-point 

Hemodynamic 
 >  Monophasic 
AP 

Plateau Upstroke 

Hemodynamic 
 >  Other 

Start of ventricular flutter Pacemaker artifact 
Ventricular flutter wave Isolated QRS-like artifact 
End of ventricular flutter Non-conducted P wave 

Notes Arrow—short, medium, or long Star 
Flag 

Pharmacology Baseline Wash 
Dose 

User-defined User Type 1-9 

Waveform Edits Cut Paste end 
Paste begin  

Selections Selection begin Selection end 
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Event Measurements  
Measurements are a quick way to extract information from a graph. Three measurements extract information 
from events. When combined with the Cycle/Peak Detector (page 289), they are also powerful data reduction 
tools. These event measurements can provide quick summaries of event information, compute mean intervals 
between event types, and detail other operations. 

 evt_ampl Event Amplitude Measurement (see below) 
 evt_count Event Count Measurement (see page 205) 
 evt_loc Event Location Measurement (see page 205) 

 
Event Amplitude Measurement 

 

evt_amp Extracts measurement results where events 
are defined. Note that the amplitude is always taken from 
the measurement channel, which may be different from the 
channel on which the events are defined. Useful for 
extracting information such as the average T wave height 
within the selected interval. The measurement result is 
displayed without units (matching Value and other 
amplitude events). 
Select Event Amplitude or click the measurement info 
button to generate the settings dialog. 

Event Type Determines the type of events that will be processed; Types are detailed on page 201. 
Location Determines where the processed events need to be defined. The menu options are: 

 Measurement channel only—Only extracts amplitude values for events that are defined on 
the channel specified in the measurement channel pull-down menu. Global events and other 
channel events are not included. 

 Global events only—Only extracts amplitude values for events that are defined as global 
events appearing in the event bar; changing the measurement channel will not affect the 
measurement result. Channel events are not included. 

 Anywhere—Extracts amplitude values for events defined on any channel and also global 
events; changing the measurement channel will not affect the result 

Extract Determines what processing will be performed on the amplitude values extracted from events 
that match the Type and Location settings. The processing options are: 
 Amplitude at first event only—The value of the measurement channel at the time of the 

first matching event in the selected area. 
 Amplitude at last event only—The value of the measurement channel at the time of the 

final matching event in the selected area. 
 Sum of amplitudes at all events—Computes the sum of the value of the measurement 

channel from each matching event in the selected area. 
 Mean amplitude from all events—Computes the average amplitude value of the 

measurement channel from all of the event locations in the selected area. 
 Minimum amplitude from all events  
 Maximum amplitude from all events 
 Median value of amplitude from all events—Computes the median of the set of 

measurement channel amplitudes at all events. 
 Peak to peak interval of the set of amplitudes from all events—Takes the peak-to-peak 

difference from the set of measurement amplitudes at all events (max - min). 
 Standard deviation of amplitudes from all events—Computes the standard deviation of the 

set of measurement channel amplitudes at all events. 
If there are no matching events of the selected type in the selection, the measurement result will be zero. 



Part B — Acquisition Functions 205 

BSL PRO Manual 

Event Count Measurement 

 

evt_count Evaluates the number of events within the 
selected area. The measurement result is unitless. 
Select Event Count or click the measurement info button to 
generate the settings dialog. 

Event Type Determines the type of events that will be counted; Types are detailed on page 201. 
Location Determines where the counted events need to be defined: the pull-down menu options are: 

 Measurement channel only—Only includes events that are defined on the channel 
specified in the measurement channel pull-down menu; global events and other channel 
events are not included. 

 Global events only—Only includes events that are defined as global events appearing in 
the event bar; channel events are not included. Changing the measurement channel will 
not affect the measurement result. 

 Anywhere—Includes events defined on any channel and also global events. Changing the 
measurement channel will not affect the measurement result. 

If there are no matching events of the selected type in the selection, the measurement result will be zero. 
 
Event Location Measurement 

 

evt_loc Extracts information about the times of events. 
The measurement result will take on the units of the 
horizontal axis; if specific units were set for time or 
frequency via Preferences, those units will be used. 
Select Event Location or click the measurement info button 
to generate the settings dialog. 

Event Type Determines the type of events that will be processed; Types are detailed on page 201. 
Location Determines where the processed events need to be defined. The menu options are: 

 Measurement channel only—Only extracts the time of events that are defined on the 
channel specified in the measurement channel pull-down menu; global events and other 
channel events are not included. 

 Global events only—Only extracts the time of events that are defined as global events 
appearing in the event bar; channel events are not included. Changing the measurement 
channel will not affect the measurement result. 

 Anywhere—Extracts the time of events defined on any channel and also global events. 
Changing the measurement channel will not affect the measurement result 

Extract Determines what will be extracted from events that match the Type and Location settings:event 
 First event location only—The measurement will equal the time at which the first matching 

event in the selected area is defined. 
 Last event location only—The measurement will equal the time at which the final event 

within the selected area is defined. 
 Sum of all event locations—The times at which all matching events are defined are added 

together to produce the measurement result. This sum of times can be combined with Event 
Count measurements to compute average intervals over the selected area. 

If there are no matching events of the selected type in the selection, the measurement result will be zero. 
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Printing Events 
When a graph is printed and events are displayed onscreen for the graph, event icons will print as they are 
displayed. Event icons will be scaled, depending on the printer's DPI, to be proportional to the vertical scale 
plotted on the screen. If events are located at linearly interpolated positions, event icons will be dimmed on 
the printout (see the Variable Sample Rate section). 

Event display 
setting 

Printed result 

Global events Global events are drawn above and outside of the data plotting rectangle in the 
printout. If the event labels are close together, their alignment will be staggered 
to show separate lines of label text. 

In event bar All events are drawn above the data area of the printout. Only labels may be 
drawn with the events. 

Top of plot or 
Top of plot, with 
indicator 

Channel-specific events are drawn at the top edge of their channel’s track. No 
indicator lines are drawn. Depending on the display settings of the graph, the 
event label, amplitude of waveform at the event location, and Time of the event 
may be printed below the event icon  

On waveform or 
On waveform, with 
indicator 

Channel-specific events are drawn immediately above the position of the 
waveform sample at their location and will appear to be printed immediately 
above the data of the waveform. No indicator lines are drawn. The vertical 
printing position of an event icon will be identical for “On waveform” and “On 
waveform, with indicator” displays. Depending on the display settings of the 
graph, the event label, amplitude of the waveform at the event location, and time 
of the event may be printed above the event icon. 

“Draw vertical divider at event locations” option in the Print Setup dialog. 
 Enabled: draws a dashed vertical line at the precise time location of each event. Vertical divider lines for 

the event type will extend  
Global Through all channels of data 
In event bar Through all channels of data 
Top of plot From the top to the bottom of the relevant channel track 
On waveform From the top to the bottom of the relevant channel track 

 Disabled: prints only the event icon, label, amplitude, and time. No indicator lines will be printed for the 
event display. The vertical divider can be used in place of indicator line drawing. 

 
Event Selection 
Individual events can be selected according to click locations.  
When an event is selected, the event icon will be drawn based on the graphic type: 
 Specific “selected” graphic—the selected graphic is drawn or if none, an inverted global graphic. 
 No associated graphics—the global event graphic will be used. 

 
Events and Graph Selections 
When an event on a waveform plot occurs within a selected area of the graph, the event icon and indicator 
line (if present) will be inverted along with the grid, background, and wave data. Event types that don't have a 
selected graphic will appear as global events if the events are selected events and they are contained in an I-
beam selection. 
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Events and Waveform Editing 
Waveform editing will adjust event locations for channel-specific events. Waveform editing will never alter 
the time values for Global events (not associated with any specific channel, such as append events). 
Copy  When a portion of a waveform is copied the channel events will also be copied to the clipboard.  
Cut When a portion of a waveform is cut, any channel events within that selected area will be removed 

and channel events to the right of the removed area will be shifted to the left. 
 If waveform editing event insertion is active, a waveform edit event will be inserted at the 

location of the edit operation indicating a “Cut” operation in its description. 
Paste When the waveform is pasted from the clipboard, the channel events will appear at their same 

locations and any channel events to the right of the end of the pasted segment will be shifted by the 
length of the pasted segment. 
 If waveform event insertion is active, a waveform event marker will be inserted at the beginning 

and at the end of the pasted segment. 
Constructing Graph Selections from Events 

 Graph selections can be defined from events (in addition to the I-beam tool). Holding down the 
Command/Open-Apple key (Alt on PC) while double-clicking an event icon in the graph window 
will place a cursor at the event location; this is a zero-width selection, equivalent to single-clicking 
with the I-beam tool without dragging. 

 To create a graph selection from events, hold down the Command (Alt on PC) key and select an event by 
clicking on the event icon in the graph window or its entry in the event list. 

 To align the boundaries of the graph selection with the time of the previously selected event location and 
the time of the newly selected event, hold the Command (Alt on PC) key when selecting the new event. 

 To make a graph selection match the time between two events, click to select the first event, hold down 
the Command (Alt on PC) key, click again to select the second event. On this second click, the selected 
area of the graph will change to align with the two events. 

Event Plotting and Variable Sampling Rate 
Event positions are defined in terms of the hardware sampling rate. The Variable Sampling Rate feature can 
generate waveforms with a sampling rate lower than the hardware sampling rate. Through explicit event 
definition, waveform downsampling, or other operations, events on a downsampled channel may not align 
with an actual waveform sample, but rather occur at a hardware sample position in between waveform 
samples. These events will be drawn using linear interpolation when applicable, and only if the waveform is 
being drawn in line plot mode. In step plot and dot plot modes, regular event drawing routines will be used 
with the vertical position and amplitude of the nearest waveform sample to the event’s left. 
When an event is to be drawn on an intermediate position on a waveform, the linearly interpolated value will 
be calculated for the hardware sample location. The interpolated value will be derived from the closest 
waveform sample to the left and to the right. The vertical position on the waveform of the event and indicator 
line will match the vertical position of the linearly interpolated sample amplitude. This will place it 
immediately above the line connecting the two waveform samples on screen. 
If an event is being drawn using linear interpolation 
 Event icons will be dimmed, regardless of their display position (on waveform or top of the plot). 
 Indicator lines will be drawn on the waveform at a linearly interpolated position and the indicator line will 

be a gray dashed line instead of a solid black line. (Indicator lines are never printed.) 
 Amplitude labels, if included with the event, will correspond to the linearly interpolated amplitude at the 

event location and the linearly interpolated amplitude will be drawn in italicized text. 
 Watch the Event Marking Tutorial video for a detailed explanation of this feature. 

 

http://www.biopac.com/video/?video_category=acqknowledge-tutorials&v=event-marks
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Chapter 10  Other MP Menu Commands 
Show Input Values 

             
The Show Input Values option of the MP menu generates an Input Values window, which displays channel 
values in real time, whether an acquisition is in progress or not—which allows values to be displayed prior to 
or after an acquisition.  
The Input Values display can be set to numeric, horizontal or vertical bar graph format, and it can be resized 
and moved to any position on the screen. To set the display mode, use the “Mode” menu generated via the 
“Options” button.  

Note The Input Values window only displays values for channels that were Set Up with the “Values” box 
checked (see page 31 for more information). 

Hold Regardless of the display options selected, the display can be “frozen” at any point in time by 
clicking the Hold button. Clicking this icon will hold the values at their level(s) when the icon 
was pressed. The window will remain frozen until the icon is clicked again. Once the values 
are “unfrozen,” the values will return to the standard real time display mode. 

Options  
 
 

Mode controls the format of the values display. 
• Numeric Values—displays the voltages of the appropriate channels numerically. 
• Bars: Horizontal bars or Vertical bars—the range of values of the bar graphs 

corresponds to the range for that channel in the graph window. To see the bar “bounce” 
less for a particular channel, increase the units per division; to fill more of the window 
space, decrease the units per division in the graph window.  

Font and Size determine text display from computer-installed fonts. 
Precision controls the total number of digits displayed. 
Show controls the amount and type of information displayed regarding each channel. Click in 
the box next to each option to activate it. 

• Channel Numbers will display the channel numbers (A1 for the first analog 
channel, for example). 

• Units will display the units for each channel (as indicated in the main graph 
window). By default, each channel’s display units are scaled in terms of Volts, 
but this can be changed by clicking in the amplitude scale units area in the graph 
window. 

• Labels will display the channel labels (ECG 1, Respiration, etc.) along with the 
input values. This feature is especially useful when values from multiple 
channels are being displayed simultaneously. 

• Min/Max will display the range of values associated with the data. This range 
corresponds to the upper and lower display limits for each channel as it appears 
in the graph window. 

• Values will display number values along with the horizontal or vertical bar chart. 
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Set Up Linked Acquisitions 
This MP36 hardware menu option allows acquisitions to be recorded simultaneously from multiple hardware 
devices types into separate graphs. (For example, acquisitions can be simultaneously linked to two or more 
MP36 units.) The linked acquisitions can optionally be merged into a single graph for easy analysis. 
NOTE: Linked acquisitions are supported in the following hardware combination only in BSL PRO: 

• MP36 to other MP36 hardware devices (Excludes MP36R) 
Other hardware devices, such as MP46 or MP45, are not supported, nor are linked acquisitions supported 
between hardware types aside from MP36. 
In order to use linked acquisitions, a minimum of two graphs must be connected to different hardware units. If 
two or more graphs are connected to the same hardware unit, linked acquisition sessions are not supported. 

Configuring New or Open Graphs for Linked Acquisitions 
As stated above, Linked Acquisitions are supported only when two or more graphs are open, and only when 
two or more hardware devices are connected. Linked acquisitions can also be configured while BSL PRO is 
running, and graphs/devices added as desired.  

• If multiple data acquisition devices are connected and powered on, these devices will be listed in a 
pop-up menu in the initial BSL PRO startup window.  

• Choosing “All Devices” automatically creates a separate graph for each connected device. This acts 
as a shortcut for setting up graphs for linked acquisitions. 

 
Adding or changing hardware types with BSL PRO running: To add or change the hardware device for 
graphs that are already open, click the “Connect to:” pop-up menu and select or add a new device from the 
menu. (To be visible, the “Connect To” menu must be enabled via Display > Show > Hardware.)  

 
 
The linked acquisition can output recorded data into the separate graphs, or optionally, merge the data into 
one graph. If the latter option is chosen, data from the separate graphs will be contained in separate labeled 
channels within the merged graph. 

To access Linked Acquisitions setup, select MP36 menu > Set Up Linked Acquisitions to open the 
following window. Any open graphs are displayed in the “Acquire data into the following graphs” pane. 
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Top Column Description 

Graph Title Displays the titles of the available graphs. 

Acquire Includes or excludes graphs from linked acquisition. 

Hardware Status Shows current status of hardware. (“No Acquisition” or “Acquiring Data.”) 

Hardware Name Identifies hardware device linked to graph. 

Refresh button Applies any settings that were changed (acquisition setup, etc.) 

 
“The linked acquisitions session will be automatically stopped after:” This indicator displays the selected 
length of the shortest-duration graph in the group. Multiple graphs set to different durations will default to the 
length of shortest duration graph. 
For more options to adjust merge settings, go to Display > Preferences > Hardware.  

 

Graph Start/Stop button behavior: After linked acquisitions setup, Start/Stop buttons for all graphs display 
an “(L)” to the right of the button. Linked graphs can be simultaneously started and stopped by toggling the 
Start/Stop button of any graph. To Start/Stop linked graphs separately, hold down the Ctrl+Alt/Option keys 
while clicking the button. 

  
Alternatively, the linked acquisitions setup dialog can be opened via the MP36 menu  > Set Up Data 
Acquisition > Length/Rate window. (Note the “Setup Linked Acquisitions” button in this window.) 

Linked Acquisitions Preferences 
Global preferences for linked acquisitions can be accessed and set up via Display > Preferences > 
Hardware. 
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Tile floating graph windows automatically on start of linked acquisitions 
This preference arranges linked acquisition graphs vertically when a recording is started. 
Use linked acquisitions whenever possible: Use this option to automatically set up linked acquisitions if 
multiple hardware and multiple graphs are detected.  
NOTE: If the global preference is set to “Use linked acquisitions whenever possible,” the “Merge results into 
new graph at the end of acquisition” Setup Dialog option will not be available. 
Merge data automatically: Automatically merges data from multiple acquisitions into a single graph using 
the Resample and Data alignment options selected in the Preferences. Note that if this option is selected, 
recording modes are limited to Save Once to Memory or Save Once to Disk modes. 
If these preferences are not selected, linked acquisitions must be set up manually in the linked acquisitions 
dialog (MP menu > Set Up Linked Acquisitions). 
For complete Hardware Preferences information, see page 347. 

Limitations on Linked Acquisitions synchronization methods 
Synchronization Mode Description Criteria 

Any method Minimum number of selected 
graphs 

2 

Minimum number of analog 
channels 

1 

Minimum length of acquisition 12 sec. 
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when B-Alert device is used 

Incompatible Acquisition Mode Warning 
If an incompatible acquisition mode is used for any graph (such as append mode), the following dialog will 
appear: 

  
Choosing “Change Mode Now” reverts graphs to a compatible acquisition mode. Selecting “Cancel” will exit 
the linked acquisition and leave acquisition modes unchanged. 

The sample rates can vary between the linked acquisition graphs, but all  

Limitations on Linked Acquisition Recording Modes: 

If the “Merge data automatically” option is selected in the Linked Acquisitions Preferences, recordings are 
limited to Save Once to Memory or Save Once to Disk mode.  

Additional acquisition modes Append, Autosave, and Auto-repeat modes are supported in linked acquisitions 
if the “Merge data automatically” option is not selected. 

Linked Acquisitions and “Warn on Overwrite” dialog: 
Compatible record modes for linked acquisitions are Save Once to Memory or Save Once to Disk. Rerunning 
acquisitions in these modes normally results in a warning that data will be overwritten.  
If data output is not being merged into one graph, the warning will be displayed. The warning can be 
suppressed in this circumstance by deselecting the “Warn on Overwrite” option in the hardware menus.  
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However, if the “Merge results into new graph” option is selected, the “Warn on Overwrite” dialog will not 
be displayed. 
 
 
Segment Labels 
Selecting Segment Labels from the MP >Set Up Data Acqusition menu launches a setup dialog for assigning 
user-defined labels to append event segments. The Segment Label options are applied to the active graph 
only. The selected settings will be saved with the graph, but will not be applied globally to existing or 
subsequent graphs. 

 

   
 
 Add  Adds a segment number to index. Segment text can be edited under ‘Label’. 
 Rename Used to rename an existing segment label. 
 Delete  Deletes a selected segment from Index. 
 Delete All Deletes all segments from Index. 
 Top/Bottom Moves selected segment to top or bottom of Index. 
 Up/Down Incrementally moves a selected segment up or down the Index. 

Enabling checkboxes below the   icons adds time/date stamps to the segment label. 

Trigger (Not supported in MP46/45 hardware) 
Using a trigger allows an acquisition to be started “on cue” from a trigger connected to an analog input 
channel (CH1 to CH4). By default, the trigger is off, and during a normal acquisition, the MP UNIT will 
begin collecting data following a mouse click the  button in the lower right hand corner of the screen. 
When Triggering is used, acquisition will begin when the established trigger level is reached. 

To begin an acquisition with a trigger: 

1)  Select MP > Set Up Data Acquisition > Trigger to generate the Triggering dialog: 

   
2)  Choose a channel from the Source pull-down menu. Select CH1, CH2, CH3, CH4 (MP UNIT front 

panel), Digital Channels D1-D8, or an external Trigger (MP36/35 back panel). 

External Trigger requires a TTL signal from a third-party device such as a stimulator, pump, presentation 
program or force plate. 
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External Trigger Note: Due to processor limitations at sampling rates of 25 kHz and higher there may be an 
occasional delay of up to 40 milliseconds between detection of an External Trigger and the start of data 
acquisition. Use either an analog or digital channel as a trigger when acquiring data at 25 kHz, 50 kHz or 100 
kHz, if accurate timing of the start of acquisition is required. 
3)  Choose Pos Edge or Neg Edge from the menu to select whether a positive or negative edge will trigger 

the acquisition. Look at the nature of the signal to determine which is most appropriate. 
 A Positive edge occurs when the signal begins below the threshold and crosses above it. 
 A Negative edge occurs when the signal begins above the threshold and drops below it. 

4)  Set the Trigger level by entering a value or by moving the scroll bar to adjust the threshold value. 

When setup is complete, close the setup window and click the  button to begin acquisition as soon as 
the trigger is activated. 

The setup shown above is set to start acquisition when a level of 25 mV is reached on analog Channel 1. 

Sound Feedback 
Sound Feedback generates a setup enabling acquired data to be redirected to the computer’s default audio 
output device. This feature can be used to monitor waveform data as sound through the computer speakers or 
headphones.  

 
Access Sound Feedback via MP > Set Up Data Acquisition > Sound Feedback. 
 

SOUND FEEDBACK 
CONTROLS 

FUNCTIONS 

Sound enabled Turns sound feedback of data on and off. 

Output Sampling Rate Selects from available sampling rates of the default audio device. 

Source Channel Selects the analog, digital or calculation channel from which the audio will be acquired. 

Reset Adaptive Gain Control Resets gain control to adapt to the current level of the signal. Use after sound feedback 
has started to re-adjust the level after accidental spikes or large artifacts. 

Enable low pass filter Applies a low pass filter at the Nyquist frequency (50% of the acquisition sampling rate). 
This IIR filter can help smooth out transition artifacts due to upsampling of data to the 
audio sampling rate. (Enabled by default) 

Median removal controls 
(Window width, 
Recomputate) 

Removes baseline offset from the output signal. 

Window width Sets width of median removal window (in seconds). Must be a positive value. 

Recompute every Provides the time duration (in seconds) after which the median of the data is regenerated 
from the raw source data. Must be a positive value. 
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Gauge  

 

The Gauge is 
accessed via MP > 
Show Gauge. The 
optional “Gauge” 

display shows one 
channel of data in a 
gauge/dial indicator 

format. 

The Gauge displays 
as a separate 

window, viewed 
simultaneously with 

graph and other 
windows. 

The Gauge Window: 

• Will display one  channel of data: analog or calculation 
• Updates and displays simultaneously with the graph window. For analog channels only, the display 

will update when the recording is stopped, but at a slower rate when recording is running. 
• Can update during and in between acquisitions for all MP devices; display may be updated at a rate 

slower than the sample rate and may display a value that represents the average of several samples.  
• The background image (BMP, JPG or TIFF), indicator origin, range, length, thickness and color are 

all user-configurable. An optional range band overlay can also be enabled. 
• Selectable gauge bitmaps include Blood Pressure Cuff, BPM or Stopwatch 
• All window preferences as well as the window visibility, size and position will be saved with the file. 
• Window sizing is “fixed” to the size of the background image, meaning it will have a 1 to 1 

correspondence with the monitor pixels 
 
Gauge Preferences 

Gauge Preferences are accessed by right-clicking over the gauge and using the 
contextual menu. There are four tabs for setting the various Gauge parameters. 

 
Background is the default tab presented in Gauge Preferences and contains options for setting the 
Background image. 
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Channel  Provides a pop-up menu for assigning any one of the ENABLED analog or calculation 
channels. 

Background Image  Displays the path and file name of the current background image. The default image is 
a blue blood pressure gauge sized at 451 x 451 pixels.  

Browse  Allows alternative background images in different directories to be used in place of the 
default gauges. The Browse location will default to the file path used by the currently 
selected background image. To change the background image, click the “Browse” 
button and locate the desired file. After the background image is specified, the pixel 
Width and Height will be updated. The Width and Height fields are not editable.  

Use Default  Displays a menu of available default background images. (Pressure, Stopwatch and 
BPM). 

Indicator  
The “indicator” or “needle” is a simple line vector drawn from an assigned center point to an endpoint 
calculated according to the “Length” parameter. The indicator always rotates around the origin from low to 
high values in a “clockwise” fashion.  
 

 
Origin  Is the center point of the indicator line referenced from 

the top left of the image not the top left of the window meaning neither the frame of window 
nor the title bar is included. The “X” parameter specifies the horizontal distance in pixels and 
the “Y” parameter the vertical distance. “X” cannot exceed the Width of the background 
image and “Y” cannot exceed the image Height. The default values are: Origin: X: Width/2, 
Y: Height/2. Note that the pixel count starts at “0” so a 225 pixel square image will have 
its center point at 112 pixels. 

Length  Specifies indicator span in pixels starting from the “Origin”. Default is the smallest of the 
Length or Width dimensions divided by 2. 

Thickness  Specifies the indicator width in pixels, with a selectable range between 1 and 10. The default 
is 1 pixel. 

Color  Specifies color of the indicator “needle” as Black (default) or White. 

When recording is stopped  

If the source channel is a Calculation channel, no gauge 
updating will occur when the recording is stopped. Under 
this circumstance, the “When recording is stopped” 
options become available. This allows the user to specify 
whether the indicator should not be displayed, should be 
reset to zero, or should retain the last value. 
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Mapping 

For setting up two point mapping: Input to Angle   

      
    

Input  Defines the input values in the scaled units. The units shown in the example are volts, but 
would reflect the units of the source channel (mmHg, psi, etc.). The Input mapping of the 
upper scale value is set to a default of 50 of the source channel unit type. 

Angle  Any angle can be entered, but 0, 360, 720, etc degrees means that the indicator will always be 
pointing straight down.  

When assigning mapping angles: Because the indicator “needle” must rotate clockwise, the 
first value should be the lower angle. The first value also defines the indicator’s starting angle 
but does not to need to be 0 degrees. For example, the Stopwatch Gauge’s starting angle 
should be 180 degrees (pointing straight up). If half-circle gauges are used, the starting angle 
may be 90 degrees.  

Indicator is limited to specific mapping  

If this option is enabled, and the indicator needle reaches its mapped upper limit, it will stop 
rotating and turn red. If this preference is not selected, the needle will not change color if the 
defined mapping limits are exceeded and the needle will just continue in a clockwise 
rotation.  

Range Band (Default OFF) 
Use the Range Band as an optional feature to highlight a specified area of the Gauge View. 
 

  
 

Start/End  Defines a “pie” shape (defined by Mapping values) sourced from Gauge center and 
superimposed over the background image.   

Color  Clicking on the color bar will bring up a color palette, which allows any color to be selected. 
The default color is green. 

Opacity  Used to adjust the transparency of the Range Band. 100% means the background image will 
be fully obscured behind the range band, and 0% means the Range Band itself will not be 
visible. The default setting is 50%.  
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Segment Timer “Stopwatch” option  
In addition to the standard Gauge described above, the Segment Timer Gauge option offers an analog 
“Stopwatch” view of an acquisition in progress. As the recording progresses, a circular onscreen stopwatch 
gauge displays the elapsed time with a sweep-second indicator. All customizable parameters shown above for 
the default Gauge view are applicable to the Stopwatch view. A custom mapping for the Stopwatch view can 
be created, or use the pre-configured “Segment Timer Gauge” graph template in the Sample Data folder. 
 
Using the Segment Timer graph template – open the sample template in the following directory:  

Main drive\Program Files\Biopac Systems, Inc\Biopac Student Lab 4.1\Sample Data\English-
en\PRO\Segment Timer Gauge.gtl 

Clicking ‘Start’ will show the Stopwatch in progress. The template is setup to record ECG Lead II on CH 1 
and is tied to a new Segment Timer calculation channel. However, no connections are needed to verify the 
segment timer and the template can be customized as desired. To change parameters, choose Preferences from 
right contextual menu with mouse positioned over the gauge window. When the recording is stopped, timer 
indicator will also stop. When the next recording segment begins, the segment timer will reset to 0. (This 
default can be changed in the Gauge Preferences). 

 
 

To configure a new Segment Timer Stopwatch view: 

1. Set up desired acquisition parameters and channels. 

2. MP menu > Set Up Data Acqusition > Channels > 
Calculation tab and choose the Segment Timer preset. 

3. MP menu > Show Gauge and open Preferences by right-
clicking the contextual menu over the Gauge window. 

4. In the Gauge Preferences, choose “C0 – Segment Timer” 
for the Channel and “Stopwatch”, as shown on right. 

5. Choose the “Mapping” tab, enter the following Input to 
Angle mapping values and click OK: 
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6. Start the acquisition. Note the Stopwatch view will accurately reflect the time scale of the recording 

in progress. 

Autoplotting and Scrolling 
Autoplotting, Scrolling and Sweep Display Modes 
The Autoplotting, Scrolling and Sweep options controls how data is displayed on the screen during an 
acquisition. By default, AcqKnowledge displays the most recently collected data first, and if more than one 
screen of data is to be collected, then the time scale will “scroll” so that the newest data is always on the right 
edge of the screen. 
When Scrolling is disabled and Autoplotting is enabled, the screen will be cleared when the data reaches the 
right edge of the screen, and plotting is redrawn from the left. 
When both Scroll and Autoplot are unchecked, the incoming data will be plotted until the screen is full. Once 
the screen is full, data will continue to be collected, but only the first screen is displayed. By default, the 
hardware will display the first eight seconds of the data record, but this can be reset manually by changing the 
horizontal scale. To toggle Autoplot ON or OFF in the middle of an acquisition: 

 select Ctrl+T (Windows) or Command+T (Mac OS) on the keyboard, or 
 Choose the MP menu and enable or disable “Autoplotting” 

Sweep display mode is similar to an oscilloscope sweep display in which data is plotted left to right, 
but old data remains visible on the screen while new data is incoming. This type of display is also 
seen in some clinical devices. 
In order for Sweep display to function: 

 Autoplotting must be enabled 
 Scrolling must be disabled 
 Sweep must be enabled 

In this configuration the old data remains visible while incoming data in the 
form of a black vertical line “sweeping” across the old data from left to right. 
The old data and horizontal time scale are redrawn with once the line sweeps 
across its axis. 
The sweep will be reset if scale modifications that affect the vertical or 
horizontal scale are performed. This includes: autoscaling, zoom, window 
resizing, end of acquisition. Sweep can be toggled from the hardware menu 
during acquisition and is data view independent. The sweep state is saved in 
graph files and templates. 
Sweep mode is applicable in Scope, Chart, Stacked Plot, and Split View modes. It is not supported 
in XY mode. 
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Manual,  Autoscrolling and Sweep options can also be accessed via the , , or  button in the lower 
right region of the horizontal axis region. For full details on this tool, see Autoscroll Horizontal Axis Controls 
on page 50. 
 
Warn on Overwrite 
Selecting the “Warn on overwrite” option from the MP menu will generate a prompt each time a new 
acquisition is started: 

 
Clicking “Yes” will erase the current file and overwrite with a new acquisition. If the currect file needs to be 
saved, click “No” and open up a new file. 
This prompt will appear at the beginning of each acquisition when the MP System is in Repeating/Autosave 
mode, so it’s recommended to uncheck the “Warn on Overwrite” under the MP menu. 
Organize Channel Presets  

 
The Organize Channel Presets option controls the channel presets (established or new) in the MP > Set Up 
Channels dialog. Presets can be added, rearranged or deleted. Organizing Presets are useful for placing the 
most frequently selected Presets at the top of the menu, or grouping related Presets, such as established ECG 
Presets and newly-created channel Presets. 
Click a Preset description to select it, and then use the buttons to organize the Presets.  
Up and Down buttons move the selection one space at a time. 
Top and Bottom buttons jump to the start or end of the list. 
 Rename a Preset by typing in a new description and clicking OK. 

Any name currently used by a Preset or any name that matches a Calculation type (Integrate, Rate, 
etc.) cannot be used. 
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Delete a Preset by selecting that option. The Default Analog Input preset cannot be delted. When deleting a 
Preset, a confirmation dialog will appear because it is an irreversible action.   

 
Add Separator adds a new Separator entry to the Preset list and is useful for dividing different Preset types. 
If a Preset is currently selected in the list, the Separator will be added below it. (See diagram above) If no 
preset is selected, the separator will be added to the end of the list. Separators can be rearranged or deleted in 
the same manner as Presets. The default location for Preset files is Computer > Local Disk > ProgramData > 
BIOPAC Systems, Inc > Biopac Student Lab 4.0 > Presets. 

Exit Playback Mode 

This option is enabled when Open File for Playback (see page 39) has been selected. Select to resume 
acquisition functionality (changes Playback menu to MP menu, Replay button to Start button). 
Manage Hardware Connections 
 

 
The Manage Hardware Connections option enables easy connection and disconnection of new hardware on a 
global level, and allows switching from one particular hardware unit (or hardware type) to another. The 
following controls are available: 
Connect New Hardware 
Choosing ‘Connect New Hardware’ opens a dialog for selecting and adding additional hardware units. Once a 
new hardware unit added, it will be available for use in the application, and will appear in the connected 
hardware list. The example below shows connection of two additional MP units. 

 
To connect new hardware: 

1. Make sure the new hardware type is powered on and plugged into a computer USB port. 
2. Click the arrow at the lower right of the “Connect New Hardware” button. 

 
3. Select the new hardware type from the list.  
4. Choose the desired hardware from the “Connect Hardware > Work with” list and click OK. 
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Disconnect 
Click the Disconnect button to remove from any available hardware from the list. 
Playback from Graph 
Use as a shortcut to enter Playback Mode. For more information on Playback Mode, see page 39.
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Part C—Analysis Functions 
Overview 
This section describes how to analyze data; in most cases, analysis is performed after the data has been 
collected. This involves creating, managing, and saving files, as well as editing data, performing mathematical 
transformations, and displaying data in various ways. Many of the functions covered here are also discussed 
in Part A—Getting Started. Features that can be computed during an acquisition (primarily transformations 
and calculations) are discussed in Part B—Acquisition Functions. 
For general information about sections of the graph window, and to become familiar with the “look and feel” 
of BSL PRO, turn to the Editing and Analysis Features chapter. Descriptions of functions can be found in the 
chapters describing each menu. All of the commands discussed here can be found under the File, Edit, 
Transform, or Display menu items. 
 

Menu See… Type of Commands 

File Page 227 General file management commands, including opening, saving, and 
closing files. Export data files. 

Edit Page 248 Cut, copy, and paste between and within files. Export data files. 

Transform Page 257 Operations that primarily modify the data in the graph. 

Analysis Page 283 Operations that primarily derive data and measurements from the graph. 

Display Page 326 Control how data appears on the screen either during or after an 
acquisition. 

Media Page 355 Capture and Playback controls to synchronize video/audio with data. 

 
Toolbars 
Many of the most commonly used features in BSL PRO can easily be executed with a mouse click. The 
toolbar contains shortcuts for some of the most frequently used BSL PRO commands; icons are grayed out 
when they are not applicable. Custom toolbars can be created by clicking the Customize Toolbars icon.  
Click Display > Show > Tool Bar to view the icons. Click an icon to activate it. 
See page 53 for Toolbar icon definitions. 
 
Shortcuts 
Keyboard shortcuts are detailed on page 63. 
Mouse shortcuts are detailed on page 65, including contextual menus. 
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Analysis Shortcuts 

 
In BSL PRO 4.1.3 and higher, Analysis Shortcut buttons are available within individual graph channels. 
Analysis Shortcuts offer quick access to common Specialized Analysis options. Clicking the shortcut presents 
a pop-up menu containing analysis options relevant to the signal type present in the selected graph channel. 
This feature is helpful for avoiding the confusion of having to scroll through a lot of unrelated Analysis menu 
items when wishing to apply a transformation.  

The Analysis Shortcut appears as a small button in the upper right corner of the graph channel . In order 
for this button to become active, one of the following configurations is necessary: 

• A specific preset signal type must be configured under the hardware menu (MP  > Set Up Data 
Acquisition > Channels > Presets or MP36  > Channels > Setup > Advanced > Signal Types) and data 
acquired under those parameters. 

• Or post-acquisition, a specific signal type (ECG, EMG, etc.) can be assigned in the Channel 
Information dialog. This will activate an Analysis Shortcut corresponding to the assigned signal type. 

1. Choose Display > Channel Info…(or right click in a graph channel and choose “Channel 
Info” from the contextual menu.)  

2. Choose the appropriate signal from the “Type:” pop-up menu. See page 341 for more 
information about the Channel Information dialog. 
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Creating Custom Analysis Shortcuts 
Custom transformations and analysis routines can be added. To add a custom item: 

1. Right click the Analysis Shortcut button and choose “Customize.” (The “Customize” item will only 
appear if the button is right clicked. 

 
2. Choose an option from the “Actions” list and click the right-pointing green arrow to add the item to 

the shortcut. (Any number of custom items can be added.) Click OK. 

 
 
 
 
 
 
 
 

 
 

3. Custom shortcut items will be present in the graph’s Analysis Shortcut list for the selected signal 
type. (ECG for the above example.) Items can be removed via the “Clear” button or by selecting an 
item and clicking the left-pointing green arrow. 
TIP: Using the Alt or Option key in combination with the left-pointing green arrow will remove all 
shortcut items. 



Part C — Analysis Functions 227 

BSL PRO Manual 

Chapter 11 File Menu Commands 
Overview 

 
Most of the items in the File menu are standard menu items and follow the standard Windows conventions 
(for MPWSW) or Macintosh conventions (for MPWS). By default, all files are created and saved in the BSL 
PRO file format, a proprietary format used to store binary data. Data can be read in from either text files or 
BSL PRO files, and can be saved in text, graphic, or binary format. As a rule, storing data in the BSL PRO 
format saves information in the most compact format possible and takes up less disk space than other file 
formats. Normally, the most common format is working with graph windows and saving data in the BSL PRO 
format. 
BSL PRO also supports an online journal that can be used to store waveform data (in numeric format) or to 
make notations and comments in a text file. 
New 

Graph Window 
In many cases, it’s necessary to create a new graph window before 
beginning an acquisition. When a new graph window is created, any 
of the window parameters can be modified, including horizontal scale, 
vertical scale, window size and position. In addition, the acquisition 
parameters for sampling rate, number of channels, and acquisition 
length can be reset. These settings take effect once an acquisition 
begins.  
New > Graph-specific Journal 
Creates a graph-specific journal; see page 50 for details. 
 

New > Independent Journal 
Creates an independent journal; see page 50 for details. 

New > Data View 
Creates a new Data View for the active (frontmost) graph, and names the new window “Data View of 

‘Filename’”. . For Data View details, see page 40. 
New > Batch Acquisition 

Use the Batch Acquisition feature to configure advanced experimental setups and acquire data from a 
sequence of templates. Each template in the Batch may have different acquisition settings, channel 
configurations, and stimulator setups. Use a Batch for long duration experiments with hardware setting 
changes across segments, to automate routines, or to run multiple experiments on the same experimental 
setup in succession. 
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 For example, if an experiment has a preparatory period, a stimulus period, and a response period, 
three graph templates could be batched: 
 A template to acquire for the length of the preparatory period 
 A second template with a stimulator configured for the stimulus period 
 A third template to acquire the response period without stimulation 

All three templates could be added in sequence to a single Batch Acquisition, which would then acquire 
all of the data for all three templates with a single start. 
To create a new batch, choose File > New > Batch Acquisition to generate the Batch dialog. 

 

The Templates controls at the top allow addition, 
removal, or re-ordering of the templates. 
 Double click a template in the list to open the 

output graph from the most recent acquisition. 
 Batch acquisition cannot combine acquisitions that 

do not end, so the acquisition storage mode for 
template files cannot be set to “Save last,” 
“Autosave”or “Repeat forever.” 

 

Status 
N/A No status is available for the template, no batch acquisition has been performed. 
In Progress Data is currently being acquired for the template. 
Waiting A batch acquisition is in progress but has not yet reached the step where the template is used. 
Complete Data acquisition for the template has been finished successfully and has been saved to disk at 

the batch output location. 
Error A batch acquisition was aborted manually or due to communication errors. The data for the 

template may not have been saved or may be unreliable. 
Batch Errors 
Misconfigured templates and misconfigured averaging templates may generate the Adjust 
Length/Adjust Latency/Abort Acq warning prior to the start of acquisition. Clicking “Abort” 
will halt the batch acquisition. Misconfigured templates may result in those rare cases where 
data was acquired into a graph template with a different hardware configuration prior to 
saving the template to disk. 

Saving to: 
Use the “Change” button to specify the 
directory where the acquisition output should 
be saved. 

 
Acquire data from: 
Specify the MP unit that should be used for the 
Batch Acquisition. 

This menu lists all of the available hardware units. 
Entire menu dimmed out while batch acquisitions are in 
progress. 
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Start/Stop Acquisitions  

Toggles to starts and stop batch acquisitions; dimmed 
when the specified MP unit is being used to acquire 
data unless it is a batch acquisition that is in progress. 
Batch acquisitions may be terminated by using either a 
control in the batch user interface or by clicking the 
“Stop” button in the graph window actively acquiring 
data for the current template of the batch. During the 
execution of an individual template acquisition, errors 
may occur that abnormally terminate that acquisition 
(i.e., communications errors with the MP unit, errors in 
calculation channel, disk errors, etc.). When the 
acquisition in progress is terminated due to an error, the 
batch acquisition will be halted as well.  

 If a batch acquisition is aborted early, the 
batch output directory will contain the full 
result graphs for all of the templates that 
were previously completed successfully. It 
will also contain a partial graph file for the 
template that was being used at the time the 
acquisition was aborted. Templates that 
were not used will not have any associated 
graph files. 

Resume  
When a batch acquisition is terminated prematurely, the 
acquisition may be restarted from the first template in 
the sequence or from where it was stopped (e.g. the 
template with the error status). 

Batch Acquisitions can be saved for use at a later time using File > Save Batch 
Acquisition As. Batch Acquisition files retain all of the settings for their 
individual templates and can be used even if the original templates used to 
configure the batch no longer exist or have been moved. Each template is 
acquired and saved into an output graph file that can be opened at a later point in 
time to examine the results.  
To open a Batch Acquisition, use File > Open and select type “Batch 
Acquisition.” 
When a batch acquisition is started, the templates will be executed in the order indicated in the batch to 
acquire data from the specified MP unit. Files are autosaved before the next acquisition is started. 

 If the batch acquisition completes successfully, the batch output directory will contain all of the 
graph files that were created during the acquisition. Each output graph is saved into a user-
specified directory and is titled “Batch n - template name” where n is the order in the acquisition 
sequence. 
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Open 
The File > Open command generates the standard file open menu, and supports a variety of different file 
formats from the popup menu at the bottom of the dialog.  

 
Multiple files 

To open multiple files in a single dialog, hold the Shift key down and select multiple files. The 
Command-A key combination will “Select All” files in the dialog. BSL PRO can only recognize one 
Journal file at a time, so multiple selection is disabled when the file type is set to Journal or Journal 
Template. 

Graph The default file formats (*.acq) is referred to as “BSL PRO” files. The BSL PRO file 
format is the standard way of displaying waveforms in BSL PRO. These files are stored 
in a compact format that retains information about how the data was collected (i.e., for 
how long and at what rate) and takes relatively little time to read in (compared to text 
files, for instance). BSL PRO files are editable and can be modified and saved, or 
exported to other formats using the Save as command. Format options for the graph file 
include 

• Graph—BSL PRO 
• Windows AcqKnowledge 3 Graph—previous release AcqKnowledge format 
• Macintosh AcqKnowledge 3 Graph—previous release AcqKnowledge 

format 
• BSL PRO 3—previous release BSL format 
• Lesson Files—opens files in BSL Lessons format 
 
BSL File Import Notes 

BIOPAC produces two different software lines, the AcqKnowledge software 
for research and the BSL software for higher education. These two 
applications use different file formats, making it difficult to analyze data 
recorded in one with the other.  

Hardware and calculation channel settings are also imported. This allows for 
the migration of some older BSL PRO templates.  

Importing is limited to graph files created with BSL 3.6.6 or higher. It is not 
possible to import files created with earlier versions of BSL. To import from 
earlier BSL versions, those files must first be opened with BSL 3.6.6 or higher 
and re-saved to disk to update the file format. The updated files can then be 
imported directly into BSL PRO. 
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When saving files, BSL PRO must save using the BSL PRO graph file format 
or another available export format.  

Template Graph Template files (*.GTL)  
This powerful feature allows for creation of a template file with predefined experiment 
parameters. Simply click “Start” to run the experiment.  
The Graph Template option creates a copy of a master file so frequently-used master 
settings can be maintained. Graph template files open to previously saved setup 
parameters (as established under the MP menu) primary graph window size.  
This feature can be especially useful for recreating protocols in the laboratory. Set up an 
experiment and save it as a Graph template, then simply open the Graph template file 
and click the Start button to acquire data under the same settings. 
When a Graph template file is opened: 

a) The graph window will not contain any data. (Since no data is saved in the 
template, arbitrary waveform output setups, which require a source date file, 
will not function in a template.) 

b) The journal window will contain text entered and saved with the template—
this is a handy way to place instructions or information about the experiment 
for future reference. 

BSL PRO) PRO Lessons files are available for over 30 applications. Just open the graph 
template file to establish appropriate settings for the selected application, and then click 
Start. PRO Lesson files were installed to the PRO Lessons folder and can be used to 
establish the settings required for a particular experiment. PRO Lesson procedures are 
included in a sub-folder in the PRO Lesson directory, (Main drive:\Program 
Files\Biopac Systems, Inc\Biopac Student Lab 4.0\PROLessonsSupport\all lang), or 
accessible from the lesson’s Help menu. 

Text .TXT. Text files are a convenient way of transferring information between applications, 
and most spreadsheet and statistics programs are capable of importing or exporting data 
in a text file format. BSL PRO assumes that the text file contains numeric data laid out 
in columns and rows, and that there is some delimiter between each column. It also 
assumes that each column represents a distinct variable or channel of data. Normally, 
the values in each row represent the state of each variable at different points in time. 
When a text file is opened, the numeric values will be plotted as waveform data in a 
standard graph window and non-numeric values will be ignored. Each column of data is 
read in as a separate channel. 

 Options 
When the Files of type: Text option is selected, an Options button is activated. Clicking 
on this button generates another dialog that allows control over the amount and type of 
data to be read in, as well as the time scale for data display. 

N
O
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Read Line 
 To control how much data is read in, enter a value in the read line box at the top of 

the dialog. This tells BSL PRO which row contains the first data point in the series. 
By default, this is set to 1, although it’s possible to set it to another value since 
some applications (usually spreadsheets) generate a “header,” or text information at 
the top of a file. A limited amount of data can be read in by entering a value in the 
box to the right of the line box. This value indicates the last line to be read in as 
data. By default, text files will be read in starting at line one and data will continue 
being read in until the end of the file is reached. 

Interval 
 To control the horizontal scale (usually time) for the text file after it is displayed in 

the graph window, change the Interval between sample points, which can be 
expressed either in terms of time or frequency. For example, if data was collected 
at 50 samples per second, there is an interval between sample points of 0.02 
seconds. BSL PRO would then assume that there is a 0.02 second “gap” between 
the data point in row two and the data point in row three (and all subsequent pairs 
of adjacent rows). Likewise, if a data file spans 10 seconds and has 100 rows of 
data, the interval between sample points will be 0.01 seconds. 

 Most files contain time domain data, although some applications generate 
frequency domain data (the results of a spectral analysis, for example). The 
principle here is the same as with time data, that there is some interval between 
different frequencies. If a text file contains 20 sample points covering the range 
between 0 and 60 Hz, then the interval would be set to 3Hz per sample. 

Column Delimiter 
 This setting tells BSL PRO what characters indicate a “gap” between two columns. 

This can be set to tab, comma, or space. All text files must have some sort of 
column delimiter, unless there is only one channel of data present. 
 Tab delimited text files —the most common type— have a tab between each 

column for every row of data. These files are most often generated by 
spreadsheets and similar packages. 
 Comma delimited files place a comma between each column of data for each 

row, much the same way as a tab delimited file. Statistics programs such as 
BMDP and SAS frequently create these types of files. 

Journal *.JCQ—Opens an independent journal; see page 50 for details. 
Open the journal file from the File Menu (File > Open > Journal); right-clicking or 
double-clicking a saved Journal file will open a blank application window. 

Jrnl 
Temp 

*.JTL—Opens a journal template; see page 50 for details. 
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  Space delimited files are also commonly created by statistics packages, and 

place some number of spaces (usually two) between each column of data for 
every row which contains information. 
 None. If unsure of which delimiter to use, select auto and BSL PRO will 

automatically select a delimiter. 
When either tab or comma is selected, BSL PRO will read in a new column each 
time it sees a delimiter, even if there are no numeric values between delimiters. For 
example, the following text file will read in three channels of data, although the 
channels will be of different lengths. 

0.301424, 0.276737, 0.045015 
0.338723, 0.808811, 0.542627 
0.354271, 0.506313, 0.715995 
0.001325, 0.762115 
946207, 0.894992 
0.926409, 

 Sample text file 
The first channel will contain six data points, the first being 0.301424 and the last value 
being 0.926409. The next channel will contain three data points, starting with 0.276737 
and continuing through 0.506313. The software considers that there are no other data 
values for channel two. The third channel starts with the entry 0.045015 and the last 
data point for this channel is 0.894992. There are only five data points in the last 
channel. 

PhysioNet PhysioBank is a public service of PhysioNet and offers downloadable archives of 
gigabytes of “standard” data for cardiac arrhythmias, gait analysis, and other types of 
physiological signals. BSL PRO can use PhysioBank data directly and can be integrated 
with other software tools that understand this interchange format. 
A PhysioBank file is usually comprised of several files, including a header file (usually 
“*.hea”), and all of the files must be located in the same directory for the PhysioBank 
record to open successfully. Open using the header file. 
Opening a PhysioNet file will import data and annotations into a new graph window. If 
“atruth” annotations exist, they will be translated into appropriate events on the 
appropriate channel. All annotation types are retained except LEARN annotations, 
which are treated as UNKNOWN. 

MAT MATLAB® format BSL PRO can open files created as a MATLAB work space. 
 Windows™ can open MATLAB v6 compatible MAT files, including MATLAB 7 

if the “v6” flag is specified in MATLAB before saving. 
 Mac™ can open MATLAB v7 compatible MAT files, including V7 format. Only 

ASCII text is supported; Unicode text within MATLAB v7 is not supported. 
 Interoperability with earlier versions of MATLAB is not guaranteed. 

Uses the “MAT-file” binary format to load numerical and textual information. If the 
MAT-file is properly formatted with the following arrays, BSL will reconstruct the 
graph with appropriate sampling rate, channel labels, units, and data: 

data units labels isi isi_units start_sample 
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 MATLAB files open with 
no Start button. 

 If the MAT file is missing 
any of the expected 
variables or contains extra 
variables, only one two-
dimensional array variable 
can be imported into a 
graph. A MATLAB Import 
Options dialog will be 
generated. Choose which 
variable data is stored in, 
what dimension maps to 
samples, channel indices, 
and sample rate, and then 
click OK to open the file. 

 If BSL PRO can’t 
recognize the file format, 
an error prompt will be 
generated and a blank 
graph window will be 
opened. 

 

 

 

Raw This low-level data exchange option interprets all data at a single sample rate; variable 
sample rates are not supported. All of the data will be unscaled when opening 
(importing) files. That is, a value of 0 will be imported as a zero voltage. Scaling will 
need to be manually applied to the data. Options to open (import) raw data: 

Data type: 32-bit or 64-bit IEEE floating point format or 8-, 16-, and 32-bit 
integer formatted data 

# of channels: Enter the number of channels stored in the data file as a positive 
integer less than or equal to 60. 

Layout: Packed sequential: All of the data for an individual file is located in 
a single block of the file and multiple channels follow one another. 

 Interleaved: Data is grouped into a single “frame” for each sample 
location with one data element for each channel, so data for a 
particular channel is spread throughout the file (similar to Linear 
PCM audio file format). 

Endian: Little and big endian byte ordering, matching the data formats of x86 
and PowerPC/Sparc, respectively. Set to big for Mac-Power PC 
generated raw files (default), or to little for Mac-Intel generated or 
Windows-generated raw files. 

Set to x/sample: Specify the inter sample interval of data in the file, which will be 
translated into an appropriate sampling rate. The edit field will 
accept an arbitrary floating point number. The units menu contains 
μsec, msec, sec, MHz, kHz, Hz. The edit field will be dynamically 
converted to match the units selection; no conversion will be used 
when switching between frequency and time. 
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Batch Batch files (*bcq) is the format used for a saved Batch acquisition setup. All previous 

configurations are saved in this file, so a Batch experiment can be rerun without having 
to repeat the setup. When a saved Batch file is opened, the batch setup window appears 
with previous graph templates intact. From here, the setup can modified and saved 
under the same or a different name. See page 227 for details on setting up Batch 
Acqusitions. 

Igor Pro Igor Pro Experiments (compatible with Igor Pro 3.1, 4.0, and 5.0). 
The waves contained in an Igor Pro packed experiment can be opened (imported) in 
BSL PRO provided that the packed experiment files comply with the following: 
 ≤ 59 waves 
 no text waves 
 no complex waves 

 all waves in Version 2 or Version 5 format (Igor defaults) 
 all waves one-dimensional (vectors) 
 all waves multiples of the same fundamental inter sample interval 

If the wave has an associated wave note, it will be used as the channel label. 

WAV WAV files containing 60 channels or less can be imported. When this format is chosen, 
the list of available files will be filtered such that only files ending in the “.wav” 
extension or having the “WAVE” type are shown. When a WAV file is selected, it will 
be analyzed to determine if it is compatible with the BSL PRO application. 
If the file is compatible, a new graph window will be created displaying the data 
contents of the WAV file. 

• Each channel will be numbered “Channel n” where n is an increasing digit. 
These channels will be unitless in amplitude. 

• All of the data will be converted into the 64 bit floating point format for storage 
in memory and in the ACQ formatted files on disk. 

• The horizontal axis of this graph will be set to time and the sampling rate set to 
match the rate as specified in the WAV file headers. 

• This graph will be marked as an imported graph into which data cannot be 
acquired. 

• This will dim the start button and any appropriate hardware menu entries that 
would be used to access the invalid hardware settings. 

EDF Opens files with .eeg and .edf extensions saved in European Data Format (EDF). Data is 
imported entirely into memory in a newly created graph window titled after the 
filename, similar to other file import routines. All scaling factors will be applied to the 
data as it is imported, and it will be converted to double precision floating point format. 
Since EDF format includes data that is not used by BSL PRO, only the following items 
are imported: 

• channel data 
• channel labels 
• units 
• sampling rate (taken from maximum sample rate of all channels) 

All other information stored in the EDF file will be discarded when the file is imported. 
Only 60 channels of data can be imported from an EDF file. Channels will be imported 
starting with the graph file index 1. If there is a 60th channel, it will be placed into the 
channel with index 0. If an EDF file contains more than 60 channels, only the first 60 
channels will be imported and a prompt will advise that not all of the channels could be 
imported. 

Lessons 
Files 

Lessons Files is the file format created when running BSL Lessons. These are similar in 
appearance to BSL PRO *.acq graphs and can be opened in the PRO application when 
this format is selected. 
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Open Recent 
The File > Open Recent command generates a list of recently used files. These files can be opened directly 
from the list or with a Ctrl (PC) or Command (Mac) keystroke combination. 

  
The listed files appear in the order they were opened, with the most recently-opened file appearing at the top. 
Default number of files appearing in the list can be modified in the Preferences. (Display > Preferences 
>Other) 

 
Open Sample Data File 
The File > Open sample data File command provides a shortcut to the Biopac Student Lab Sample Data 
folder. Open the “PRO” folder, select the desired sample data file and click OK. The file format is set by 
default to PRO sample data files (*.acq format). To open BSL Lesson sample data files, choose “Lesson 
Files” from the file format menu and click OK. To open sample graph templates (*.gtl files), choose “Graph 
Template” from the file format menu and click OK. 

 
 
Open for Playback 
The File > Open for Playback command generates a standard file open dialog; see page 39 for Playback 
details.  
Close 
This File menu command will close the active file window and prompt to save if necessary.  

 
Close without saving 

 Windows—click the  in the upper right corner of the file window 

 Mac OS—click the  in the upper left corner of the file window 
Click “No” in the save changes prompt.. 

Close during acquisition 
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Close multiple data views 

Set the level of close functionality under Display > Preferences > General. 

  

Save 

  
This menu command will save any changes made to a file. If more than one file is open, this command only 
applies to the active window. For untitled files, a name file prompt will appear for saving under a unique title. 
The file will remain open after saving, allowing work on the file to continue.  

• The Save menu is dynamic and corresponds to the type of file being saved, i.e. Save Graph, Save 
Journal. 

Files should be less than 2 GB, except BSL 3 “Graph” files on the Mac, which can be larger if not 
compressed. Data files greater than 2GB can be opened, but edit, transformation and analysis operation 
cannot be performed. 

To save data in another format (such as a text file), use File > Save 
As. 
Save As 
Choosing File > Save As produces a standard dialog that allowing 
data to be saved in a variety of different formats and to any location.  
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Graph BSL PRO  format 

The default file format for the File > Save as command is to save files as a BSL PRO 
4.0 *.acq file, which is designed to be as compact as possible. These files can only be 
opened by BSL PRO, but data can be exported to other formats once it has been read 
in. 

• To save in the previous release format, choose Windows AcqKnowledge 3 
Graph. When a file is saved in AcqKnowledge 3 format, the following 
calculation channel types will revert to Integrate: Band Stop Comb Filter, 
Adaptive Filter, Rescale and Metachannels. 

GTL Graph Template 
This feature can be especially useful for recreating protocols in the laboratory. An 
experiment can be set up and saved as a Graph template. Then simply open the Graph 
template file and click the Start button to acquire data under the same settings.  
The Save As Graph template option saves the setup parameters established under the 
MP menu and retains the size of the primary graph window. In general, the minimum 
file size for graph templates is 700 K-800 K; file size may increase as setup options are 
enabled. 
When a file is saved as a Graph Template: 

a) No graph data will be saved. 
• Since no data is saved in the template, arbitrary waveform output 

setups, which require a source date file, will not function in a 
template. 

• In order to save the data the graph must be saved as “File of type 
.ACQ.” 

b) Journal text will be preserved. Any entered text will be saved to the 
Journal window and stored with the template—this is a handy way to 
place instructions or information about the experiment for future 
reference. 

 

TXT Text  
Saves graph data in text format. When Save As Text is selected, an Options button is 
generated. Clicking on this button generates a Save Options dialog that allows control 
over how much data is saved and the format it is saved in.  

 
Header 

When the first box is checked, a “header” is included at the top of the text file that 
contains information about the sampling rate, number of channels, date created, and 
other information relating to the data.  
This information is frequently useful, but some programs will attempt to read in the 
header information as data, which could result in nonsensical results. It’s 
recommeded to include the header as it can always be edited out later using a text 
editor or the journal. 

N
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Selected Section 
Checking the second box instructs BSL PRO to save only the selected section of the 
file. This is useful for saving a brief segment of a long file. When this option is 
checked, the highlighted area of data will be saved from all channels. When only one 
data point is selected, the entire file will be saved. To save only a portion of the 
selected channel, either remove other channels or copy the data through the 
clipboard. See page 252 for more information on how to copy data through the 
clipboard. 

Horizontal Scale 
The third checkbox allows inclusion of the horizontal scale (usually time) values in 
the text file, along with the data to be saved. This is useful for producing time series 
plots in other applications, as well as correlating events to time indexes in graphing 
and statistical packages. Since a separate row is generated for each sample point, To 
exceed the limitations of programs if data is collected at a fast sampling rate (many 
spreadsheet programs are limited to about 16,000 rows). It may be helpful to consult 
the section on resampling data after an acquisition is completed (page 278 ). 

Column Delimiter 
When data is saved as a text file, each channel of data is saved as a separate column, 
with the number values for each data point saved in rows. Use the pop-up menu to 
select the delimiter to separate the columns of data in the text file. By default, a tab is 
placed between each column for every row of data; this format is called a tab-
delimited text file and almost all applications will read in tab-delimited text files. 
However, data can also be saved in a comma-delimited format or space-delimited 
format. 

Line endings 
Use to create text files that are compatible with Classic Mac OS applications 
(Mac), Unix-compatible applications (Unix), or PC-compatible applications 
(DOS). 

Precision 
Use to define the number of significant digits used for the horizontal scale 
when pasting wave data. Very high sampling rates may require more than the 
default value of 6 digits to accurately resolve the inter-sample interval. 

PhysioNet This format requires that the WFDB library is installed on the computer. PhysioBank is 
a public service of PhysioNet and offers downloadable archives of gigabytes of 
“standard” data for cardiac arrhythmias, gait analysis, and other types of physiological 
signals. BSL PRO can use PhysioBank data directly and can be integrated with other 
software tools that understand this interchange format. 
Saving a file in PhysioNet (WFDB) format will export the entire contents of the graph 
to a PhysioBank record. The record will consist of multiple files, all in the location 
specified for export. There will be a header file (*.hea) and a single data file for each 
channel of the graph (starting with “d” and ending with the base name of the header 
file). The files must not be separated for a successful move or copy. 
Export Limitations 

Precision Some precision may be lost due to differences in binary representation 
between BSL PRO and PhysioBank formats. 

Events Events will not be exported to the PhysioNet format. 
 
Channels Only 32 channels of data can be exported from a graph (the max allowed 

in a PhysioBank file). 
Rate If exporting a graph that uses variable sampling rates, all of the channels 

in the exported file will be downsampled to the lowest waveform 
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sampling rate of the source graph. 

*.MAT 
MATLAB 

MATLAB® format. Uses the “MAT-file” binary format to save numerical and textual 
information as Filename.mat. 
 Windows™ and Mac™ create MATLAB Version 6 files, which are compatible 

with both MATLAB Version 6 and MATLAB Version 7. 
 Interoperability with earlier versions of MATLAB is not guaranteed. 
The following variables will be in the workspace when the file is opened in MatLab. 

data Contains the data of the graph in floating point format, for all of the 
channels of the array. The first dimension of this array is the amount 
of data in each channel, the second dimension increments with each 
channel. Therefore, each column contains a full channel of data that 
can be accessed in MATLAB via data (1:length, [channel number]). 

units This string array contains the textual representation of the units of 
the samples stored in data, with one element per channel of data. 

labels This string array contains the labels of each of the channels, with one 
element per channel. 

isi This floating point array of one element gives the number of units of 
a single inter sample interval of the data. 

isi_units This single string array provides a units string for a single unit of isi. 
Time data will always be “ms,” frequency data will always be 
“kHz,” and other values will be represented by an Arbitrary 
horizontal axis type in an ACQ graph. 

start_sample Contains the time offset of the index 0 sample of data in isi units. 
This will be 0 for many graphs, but if only a selected area of a graph 
was exported into the MAT file, the start_sample will contain the 
offset from the original data corresponding to the start of the data 
array in the MAT file. 

Raw Options to save (export) data for low-level data exchange are: 
Data type: 32-bit or 64-bit IEEE floating point 
Layout: Packed sequential: All of the data for an individual file is located in a 

single block of the file and multiple channels follow one another. 
 Interleaved: Data is grouped into a single “frame” for each sample 

location with one data element for each channel, so data for a particular 
channel is spread throughout the file (similar to Linear PCM audio file 
format). 

Endian: Little and big endian byte ordering match x86 and PowerPC/Sparc data 
formats, respectively. To exchange with Windows applications or Mac-
Intel, set to little endian; to exchange with standard Mac applications, 
set to big endian. 

Raw Data Export Limitations 
Formats Raw export only allows data to be saved in 32-bit and 64-bit IEEE 

floating point format. 
Rates All files will be interpreted at a single sample rate; variable sample rates 

are not supported. If a graph with variable sampling rates is exported, 
channel data for downloaded channels will be padded to match the 
highest waveform sampling rate. 

Length If channels have unequal lengths, the overall file length will match the 
longest channel. Shorter channels will be padded at the end using their 
final sample value so that all channels contained in exported files will be 
equal in length. 
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Scaling When integer-valued analog channels are exported from BSL PRO to raw 
files, all relevant scaling and offset will be applied—the data in the file 
will appear the same as if the channel had been internally converted to 
floating point format before export. 

 If the value of a channel is outside the maximum/minimum value that a 
chosen export data type can represent, the value will be clipped 
accordingly. (BSL PRO uses a 64-bit data type, so this should only be a 
problem if exporting to 32-bit floating point values.) 

Igor Pro Igor Pro Experiment format. 
An BSL PRO graph will be saved (exported) to a single packed experiment file, with 
each channel saved into a separate Igor wave that preserves the channel label, 
waveform sampling rate, and unit information. Vertical units will be stored as data 
units, and horizontal units will be stored dimension units; extended units are supported. 
The scaling of each wave will be adjusted to match the waveform sampling rate. All 
data will be stored in 64-bit floating point format in a one-dimensional wave. The 
waves will be named incrementally from “wave0” and the channel label will be stored 
in the wave note field. Files will have the type/creator pair “IgsU/IGRO” and a “.pxp” 
extension will be added to the file name for compatibility with Igor Pro for 
Windows™. 

WAV This option saves the graph data into a WAV audio file for exchange with other 
applications. The “.wav” extension will automatically be added if the save as filename 
does not end with it. 
The “Selected area only” checkbox will be active for WAV export. When checked, 
only the highlighted area will be exported to the WAV file. The final sample of this 
range is not included in the export, mirroring the other file export routines of BSL 
PRO. 
All exported WAV files use the 64 bit floating point format, which preserves full 
operational precision. Most audio applications should be able to support floating point 
WAV files. Exported data will not be normalized when it is exported. Any 
normalization to audio ranges should be performed prior to exporting the data. 
WAV files are normally either one or two channels (e.g. mono or stereo). BSL PRO 
graph files, however, usually contain more than two channels. Although they can 
contain more than two channels, most audio applications may not be able to recognize 
these multiple channel files. 

• If a graph file contains only one or two channels of data, a WAV file will 
automatically be created without further interaction. 

o Graphs with a single channel will result in mono WAV files. 
o Graphs with two channels will result in stereo WAV files. 

• If a graph contains more than two channels, the user will be presented with the 
following choice: 

 
 
 
o all channels—create a multiple-channel WAV file with one channel 

per channel of data in the graph. While this WAV file may be easily 
opened by some applications, it may not be fully compatible with 
audio applications and other applications expecting two channels or 
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less. 
o selected channel only—create a single channel mono WAV file using 

only the data of the selected channel. This will be the selected channel 
in chart mode, the active channel in scope mode, or the vertical 
channel in X/Y mode. This single channel export may be useful for 
exporting audio channels that are recorded along with physiological 
data, such as heart sounds, audio stimuli, and the like. 

After a WAV file is exported, the WAV file will not be reopened; the open graph will 
be left unmodified. To view the exported file, import the WAV file. 

EDF Saves file in European Data Format (EDF). The saved file will automatically have an 
.edf extension added onto it if the user did not include it. Users will be able to save 
either the entire graph or only a selected portion of data. 
BSL PRO does not retain sufficient information to accurately complete an EDF header. 
When exporting, the following default values will be used: 

EDF Header Element Default 
subject ID Empty* 
recording ID Empty* 
recording date Set to the modification date of the graph file on 

disk. If no graph file is on disk, the current date is 
used. 

recording time Set to the modification time of the graph file on 
disk. If no graph file is on disk, the current time is 
used. 

transducer description Empty* 
filter description Empty* 
 * Empty: indicates that the field will be left blank 

All other fields will be filled with corresponding information from the graph, including 
channel titles, sampling rates, channel units, and scaling factors. Variable sampling rate 
information will be preserved as it can be expressed in the EDF format. 
EDF is used by many applications and online recording databases to store information, 
particularly EEG recordings. EDF is an open file format originally developed for sleep 
studies. It stores continuous time recordings of data in a binary format. Since its 
original proposal, EDF has been adopted by a number of open source and commercial 
tools as a supported data file format. Usage has also expanded beyond sleep studies 
into other types of recording.  
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JPG BSL PRO also supports formats for saving graphical information. Most drawing, page 

layout, and word processing programs can read .JPG files. This is particularly useful 
for writing reports. A. JPG file can be opened in any standard drawing program and 
can then be embellished or used to highlight any particular phenomena of interest.  
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When data is saved as a graphic, only the data currently on the screen is saved. For 
example, if a data file that spans eight hours has only two minutes displayed on the 
screen, only two minutes of data will be converted to a graphic file. Since BSL PRO 
uses information about the computer screen in creating the graphic file, the default 
resolution of the file will be the same as the window. Most word processors and 
graphics packages allow for some way to resize and scale graphics. 

Compressed Saves a compressed BSL PRO formatted file. The degree of compression varies based 
on data characteristics, but will generally achieve about 60% compression. Saving small 
files (less than 200K) may have little effect. Using a sample file as an example: 

 
Compressed graphs no longer allow data acquisition and will open with no Start button. 
A warning prompt will be 
generated when attempting to 
compress a graph in which 
data can be acquired (Start 
button active): 

Excel 
Spread-

sheet 

Excel Spreadsheet Export—Graph data can be saved directly to an Excel spreadsheet by 
using the Excel Spreadsheet format in File > Save As. Each channel will be placed into 
its own column of the spreadsheet. Only 65K sample points can be exported at a time, 
however, so long or high sample rate data acquisitions may not be able to be saved in a 
single spreadsheet. 

• Also available for File > Save Journal Text As, Find All Cycles journal, and 
Specialized Analysis tools. 

Note  The Excel spreadsheet option requires Excel or a compatible spreadsheet 
application that can read Excel files (OOo, Symphony, etc.). If Analysis results 
are exported to an Excel spreadsheet, and a compatible application is not 
available, results will open as a text document the data and nonsense characters.   
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Save Selection As 
To save only the data that has been selected with the I-beam tool, choose File > 
Save Selection As; this option saves the selected area to another file and does 
not affect the currently-open file. Specify file name and file type and then click 
Save. 
 
Save Journal Text As 

 
Choosing File > Save Journal generates a save dialog to save the journal text as a separate file. Specify file 
name and file type and then click Save. 

Journal 
  

Text (*.TXT) format—Saves an independent journal; see page 50 for details. 

Jrnl Temp *.JTL format—Saves a journal template; see page 50 for details. 

Excel Spread-
sheet 

Excel Spreadsheet File (*.XLS)—Journal text can be exported directly into an Excel 
spreadsheet by using the File > Save Journal Text As with the Excel Spreadsheet 
format. Each line of text in the journal will be saved as a single row with tabs 
separating columns. A selected portion of a journal can also be written to a 
spreadsheet. This export allows for textual data reduction results to be easily exported 
into a spreadsheet to allow for further analysis. 

• Also available for File > Save As, Find All Cycles journal, and, for Specialized 
Analysis tools. 

Note  The Excel spreadsheet option requires Excel or a compatible spreadsheet 
application that can read Excel files (OOo, Symphony, etc.). If Analysis results 
are exported to an Excel spreadsheet, and a compatible application is not 
available, results will open as a text document the data and nonsense 
characters.   

OpenDocument *.ODT format—Saves journal in OpenOffice/NeoOffice document format. 

File Format prompts 
When a file open or save function requires a format change for compatibility or alters file content, a prompt 
will be generated to require the user to confirm the option to update format or convert and save.  It is 
recommended that the file be opened as a Biopac Student lab 3 file and many older file types cannot be 
successfully converted to Version 4 files. 

 
Created with a previous version of BSL 

 
Saving as a “Graph Template” will erase all data 
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Send Email Attachment 
Use this feature to create an email attachment containing an image of the active BSL PRO graph, along with 
the journal contents.  

When using this feature: 

o The default email program will launch, along with a ‘compose new email’ window. 

o An Open Document (*.odt) text file containing an image of the currently opened graph and associated 
journal text will be copied to the attachment field. The formatting and images present in the journal 
should be preserved. 

o Further details can be typed into the body of the email prior to sending. 

In order to open the attachment, the email recipient must have a word processing application compatible with 
*.odt file format, such as OpenOffice, NeoOffice or Microsoft Word™. 

Copy to Dropbox – Open from Dropbox 
The Dropbox options allow for copying or opening BSL data files to or from a Dropbox account directly from 
within the BSL application. This is useful for storing files online where they may be accessed from any 
computer. In order to use this feature, access to an active Dropbox account is necessary.  
To create a Dropbox account, go to www.dropbox.com. 
To set up BSL to use Dropbox: 

1. File > Copy to Dropbox. If Dropbox is being used for the first time in BSL, or if not logged 
in to a Dropbox account, the following authorization dialog will appear.  

  
2. Click the “Authorize Button” and sign in to the Dropbox account. 

   
3. Click “Allow” to grant BSL permission to create a new Dropbox folder (above left). 
4. A confirmation dialog will appear indicating BSL is successfully connected to Dropbox 

(above right). Close or minimize the Internet browser window. 
5. Dimiss the Step 1 Dropbox authorization dialog by clicking “Login.” As long as the user 

remains logged in to the Dropbox account, this setup procedure will not need to be repeated. 
To Copy files to Dropbox: 

1. File > Copy to Dropbox. 
2. Accept the default filename or enter a new one and click OK. 

  
3. A confirmation dialog will appear indicating the file is stored on Dropbox. 

https://www.dropbox.com/
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To open files stored on Dropbox: 
1. File > Open from Dropbox. 
2. Select the desired file from the list of stored BSL files and click “Open.” 

 
NOTES: 

• If Dropbox is being used for the first time in BSL, or if are not logged in to a Dropbox account, the 
authorization dialog shown on the previous page will appear before a stored file can be accessed. 

• More than one file can be opened from the list, but must be selected individually. Multiple selections 
are not supported. 

• To log out of Dropbox from BSL, choose File > Logout from Dropbox. 
Page Setup 
Choosing File > Page Setup produces a standard printer setup dialog that allows setup for any available 
printers.  
Event Divider 
Toggle “Draw vertical divider at event locations” to enable/disable this option. See Printing Events on page 
206 for details. 
Based on the range selection, the software will make appropriate adjustments before printing. For visible area, 
friendly grid scaling will be applied, and onscreen and printed precision will match, even if horizontal grids 
are unlocked. For selected area and entire area, onscreen and printed precision will not match when grids are 
unlocked because friendly grid scaling is applied on screen, but is not used during printing where the range is 
fixed to fill the entire page. 
The automatic software adjustments before printing will set the horizontal scale as if it had been used to 
display the relevant data on the screen. When printing is completed, the scale and offset parameters of the 
graph will be restored to the previous settings. 
Print 
The File > Print menu that BSL PRO uses is similar to the standard computer print dialog; however, there are 
additional options available. 

The Print menu is dynamic and corresponds to the type of 
file being printed, i.e. Print Graph, Print Journal. 
Windows OS: Click print for more options. 
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• Print Options 
 Plots per page—Control how many plots appear per page when the file is printed. Printing more than 

one plot per page has the effect of “snaking” graphs on a page much the same way text appears in a 
newspaper. For example, if this option was selected so that two plots were printed per page, BSL 
PRO would divide the amount of data to be printed on that page into two graphs—one graph printing 
at the top of the page, the second graph printing at the bottom of the page. This option allows records 
to be printed on considerably fewer pages than standard printouts, and is most effective when only a 
few channels of data are being printed. 
 Fit to pages—Print the contents of a window across multiple pages. When a record is printed over 

multiple pages, the amount of data on the screen (the amount of data to be printed) is divided by the 
number of pages entered in the dialog. The graph on the screen is then printed across the number of 
pages specified in the Total pages box at the bottom of the File > Print dialog. These two options 
apply only to graph windows, and do not apply to Journals. 

• Draw vertical dividers at event positions 
• Print waveform data in black—Waveforms will appear black when printed, regardless of selected 

colors in graph channels. 
• Print waveform background in white—Prints white background, regardless of selected background 

colors in graph channels. 
• Print focus areas—Turns focus areas on or off for the printout. 
• Range Options—determine the range of data that will be included in the printout  
 Visible portion only synchronizes the range of data in the printout to match the range of data that is 

visible on the screen. 
 Selected portion only prints only the data that is selected in the graph. This option is disabled if there 

is no selection in the graph. When working with Journals, it is easy to generate large amounts of text 
content in the window. Only a portion of this information may actually be of interest and this feature 
allows for only portions of the text to be printed. If there is no selected text, the entire journal or 
modification log will be printed regardless of this setting. 
 Entire graph prints all of the data contained in the graph from zero to the maximum length channel. 

• Print to PDF file—generate a PDF file. 
 

Quit  
Select Quit from the File menu to exit BSL PRO software; a Save prompt will appear for open graph 
files that have been modified since last saved. 
Mac OS only—Use Quit under the BSL PRO menu (page 353) to exit the software. 
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Chapter 12 Edit Menu commands 
Overview  
 

  

One of the most useful features in BSL PRO is the ability to edit and work with data by cutting sections and 
copying sections from one window to another. To select a section of data, use the editing tool to highlight an 
area. The selection tool is used for a variety of purposes including cutting and pasting waveform data, making 
measurements and determining which portion of a waveform to save as text values. To select the tool, click its 
icon in the lower right hand corner. Note that the cursor changes into the familiar “I-beam” tool moved within 
the graph area. Click the mouse and drag to select a portion of the waveform. 

IMPORTANT 
When multiple waveforms are present, the highlighted area appears to include all of the 
waveforms, but most modifications and transformations apply only to the selected channel. 

Once a section of a waveform has been selected, many operations can be performed, such as editing, 
transformations, saving data to the journal, saving as text, and using the measurement functions. The cursor 
always selects at least one sample point; when there is no defined area, a single sample point will be selected, 
and the cursor will blink. Highlight a larger area by positioning the cursor over the first point of the area of 
interest by holding down the mouse button and dragging the cursor either left or right. This is similar to 
highlighting a series of letters or words in a document. Modify the selected area by placing the cursor 
anywhere on the graph, holding down the shift key and clicking the mouse. This feature is useful for fine-
tuning the selected area. To fine tune, first coarsely select an area. By zooming in (with the zoom tool) on 
either edge, the shift key can be used to precisely align the edges of the selected area. 
BSL PRO also allows selecting an area that spans multiple screens. To do this, first select an area that 
contains the leading edge of the area of interest in the graph. Next, use the horizontal scroll bar to scroll to the 
end of the area. Then place the mouse near the area of interest and click the button while holding down the 
shift key. While still depressing the mouse button, move the cursor to the exact position desired.  
By using the selection tool to select areas of the waveform, the Cut, Copy, Paste and Clear functions are 
designed to work in much the same manner as a word processor. These functions operate only on areas 
selected by the selection tool. 
TIP: For more precise selection of data, use the Selection Palette (Display > Show > Selection Palette). See 
page 335 for details. 
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Edit menu functionality during acquisition 
The following Edit menu functions may move or alter memory and cannot be performed during acquisition: 
Undo, Cut, Clear, Clear All, Paste, Insert Waveform, Duplicate waveform, and Remove Waveform. 
 
Undo / Can’t undo 
The Undo command allows data that was unintentionally deleted or modified to be restored. Undo applies to 
editing commands and transformations (such as digital filtering and mathematical operations). 
There are some important exceptions to the Undo command. 
First, neither Edit > Clear all nor Edit > Remove waveform can be undone. It is a good idea to make backup 
files before performing any editing, especially when using these commands. 
Second, changes in the display options (i.e., changing the horizontal scale or changing the color of a 
waveform) cannot be undone, since they are easier to manipulate and less drastic than cutting data out of a 
waveform. When modifying the screen scale (or other display parameters) it’s still possible to undo the latest 
data modification, which is much more difficult to recover than a screen parameter change. 

TIP: If a waveform has been accidentally removed or Clear All has been applied, 
one way to recover the data is to close the file without saving the changes. The 
data file can now be reopened, as it was when it was last saved; any changes 
made since it was last saved will be lost. 

Perform multiple levels of undo on a per graph basis; Journal undo remains unchanged at one step. Complex 
data analysis in BSL PRO is rarely performed with a single transformation; multiple transformations are 
frequently cascaded together to produce a result. BSL PRO will “stack” the transformations and the user will 
be able to undo one step at a time until this stack is exhausted. 

• Undo may move or alter memory and cannot be performed during acquisition.  
• Undo operations may occupy large amounts of memory, particularly for transformations that affect 

entire waveforms or multiple events. Users without large amounts of RAM or working with large data 
sets may require the available computer memory for performing transformations. To accommodate 
these users, the maximum size of the undo stack can be limited using the Levels of undo Preference 
(Display > Preferences). 

 
Cut 
When Cut is selected from the Edit menu, the highlighted portion of the active window (Graph, Journal, entry 
prompt or dialog) is removed and copied to a clipboard, where it is available for pasting into other windows. 
Cut may move or alter memory and cannot be performed during acquisition. 
 When a selected area is removed from a waveform, the data will shift left to “fill in” the deleted area. 

So, if ten sample points are deleted, all data after the selected area will be shifted over ten sample 
points. Since this alters the relationship of events to the time base, it may be helpful to consider 
alternatives to cutting sections of data—such as using smoothing, digital filtering, or the connect 
endpoints functions to transform the section of data. 
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Area selected using the 
editing tool  

 
 
 
 
 
 

Same data with selected 
area Cut out  

 
Note that the data 
after the selected 
area has shifted 
forward in time. 

 

 
Copy 
Choosing Edit > Copy will copy the selected area of the active window (Graph, Journal, entry prompt or 
dialog) to the clipboard without modifying the text/waveform on the screen. 
 Once the area has been copied, it can be inserted in another window using the Edit > Paste command or, 

for waveforms, the Edit > Insert waveform command. 
 To copy a waveform to another channel in the same graph window, choose the Edit > Duplicate 

waveform command. 
Paste 
The Edit > Paste command will take the contents of the clipboard and paste it into the currently selected area 
of the active window (Graph, Journal, entry prompt or dialog). 
 If no area is selected, the data is pasted at the beginning of the waveform in a Graph window or the end 

of the text a Journal window 
 

Note  Copy/Paste operations require BSL PRO to allocate additional memory and then load the data into 
memory; when these operations are executed on large data files, the application may crash. 

Clear 
The Edit > Clear command works much the same way as the Cut command, with the key difference being that 
data is not copied to the clipboard. This function deletes the selected area from the selected channel only. If 
the entire waveform is selected (as with the Edit > Select all command), the clear command will delete all the 
waveform data and leave an empty channel. 
Clear may move or alter memory and cannot be performed during acquisition. 
 As with the cut command, the clear function operates on only one channel, and when a portion of the 

waveform is deleted, the remaining data will shift left. If multiple channels of data are present, one 
channel will be “shorter” than the others. 

 To remove a selected area of data from multiple channels, use the Edit > Clear all command. 
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Clear all 
Choosing Edit > Clear all will delete the selected area from all channels. This is similar to the clear function 
in that data is removed and is not copied to the clipboard. The Clear all command, however, removes a 
section of data from all waveforms, whereas the clear command applies only to the selected channel. 
Clear All may move or alter memory and cannot be performed during acquisition. 
 When Edit > Select all is chosen prior to performing the Clear all function, all waveform data for all 

channels will be deleted. 
 The Edit > Undo command does not work for Clear all. 

 
Select All 
When Select all is chosen from the Edit menu, the entire selected channel becomes highlighted. For almost all 
commands, when a waveform is selected using Select all, subsequent operations apply to the selected channel 
only. 
 The exception is when Edit > Clear all is chosen after Edit > Select all. When this occurs, all data 

from all waveforms will be deleted. 
 
Insert waveform 
The Edit > Insert waveform command is useful for copying a waveform (or a section of a waveform) from 
one window to another. To do this, select the area to be copied using the cursor and the “Edit > Copy” 
command. Next open the graph window the waveform is to be inserted into and choose “Edit > Insert 
waveform.”  
 Insert waveform cannot be performed during acquisition. 
 This command cannot be undone directly, although selecting the inserted channel and choosing “Edit > 

Remove waveform” effectively undoes this operation. 
Duplicate waveform 
Choosing “Edit > Duplicate” waveform will create a new channel in a graph window and copy an entire 
waveform (or a selected area) to the new channel. When a portion of the waveform is selected, only the 
highlighted area will be duplicated. 
 Duplicate waveform cannot be performed during acquisition. 
 To duplicate the entire waveform, choose Edit > Select all and then select Duplicate from the Edit menu 

or click the right mouse button and select Duplicate from the pull-down menu.  
 
Remove waveform 
Deletes the entire selected waveform, regardless of what other options are selected. Remove waveform may 
move or alter memory and cannot be performed during acquisition. 
 The Edit > Undo command does not work for Remove waveform. 

 
Remove last appended segment 

Removes the last appended segment. Equivalent to the  Rewind toolbar icon. 

 
 Edit > Undo does not work for Remove last appended segment. 
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Clipboard 

  
All of the clipboard commands involve copying data from BSL PRO to the standard Windows clipboard, 
where the contents of the clipboard are made available for other applications. Transferring data through the 
clipboard allows data to be copied from BSL PRO to other applications even after closing the graph window 
and/or quitting the application. 
Data can be copied to the clipboard in two formats: 

Text/Alphanumeric Copy Measurement and Copy Wave Data save information to 
the clipboard in text/numeric format. 

Graphic format Copy Graph transfers the image in the window to the clipboard. 
 Copy Measurements 

Copies the contents of all visible measurement popup menus, along with the values associated with 
these windows. By default, three windows are displayed (on most monitors). This can be changed by 
increasing or decreasing the width of the window. Once the measurements have been copied, they can 
be pasted into any application that allows paste functions, including word processors, drawing 
packages, and page layout programs. A sample of measurements pasted from BSL PRO into a word 
processor follows: 

BPM = 85.714 BPM delta T = 0.700 sec p-p = 0.8170 Volts 
 Copy Wave Data 

Copies the data (in numeric form) for all channels from the BSL PRO graph into the clipboard. When 
an area is selected, only the data in the highlighted area will be copied to the clipboard. As with the 
copy measurement command, once the data is stored in the clipboard, it can be pasted into virtually 
any application. 
When multiple channels of data are copied to the clipboard, the data is stored in columns and rows, 
with data from each channel stored in a separate column. For a four-channel record, four columns of 
data will be copied to the clipboard. As with a text file, BSL PRO will insert a delimiter between each 
column of data. The default delimiter is a tab. The delimiter can be changed to either a space or tab in 
the in the File > Save as “Options” dialog. See page 231 for more detailed instructions on how to set 
the column delimiter. Transferring data through the clipboard performs essentially the same function 
as saving data as a text file (using the File > Save As command), with the obvious exception that 
transferring data through the clipboard does not save data to disk. 
Note  Using Copy Wave Data on larger files may crash the application due to the excessive number 

of text lines generated (the problem is not the data size). For instance, one large file sample 
was 300,002 lines—a 3 MB text file. 

 Copy graph 
Copies the graph window as it appears on the screen to the clipboard, where it is stored in graphic 
format. The graphic can then be placed into a number of different formats, including word processors, 
drawing programs, and page layout programs. The JPEG graphic format are common to almost all 
applications, and images saved in these formats can be edited in most graphics packages and many 
word processors. 
Using the copy graph function is similar to saving a graph window as a JPEG  (using the File > Save 
As command), except that using the file save command writes a file to disk, whereas transferring data 
through the clipboard does not save a file. 
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 Copy Acquisition Settings 

Creates a textual summary of the current acquisition settings and sends it to the clipboard, where it can 
be pasted into the journal via Edit > Journal > Paste Acquisition settings, or pasted to another program. 
The summary includes sampling rates, channel configuration, calculation channel settings, triggering 
options, averaging options, and if any stimulator is active. This is useful for retaining records for 
acquisition parameters (and for technical support, if necessary). Use this feature to keep a textual 
record or printout of the configuration of the MP unit along with the data. 

 Copy Data Modification History… 
Copies the transformation history to the clipboard for all channels or the selected channel. 
Modification history includes the transformation name, channel (analog, calculation, or digital), date 
& time, and relevant transformation parameters, including starting and ending sample position. 
Use Edit > Paste to move it from the clipboard to an active Journal window or other word processing 
application. 

 
 

 Copy Focus Area Summary 
 Copies the starting and ending position of the focus area in horizontal axis units. Summary includes 
 focus area label. 
 Copy Event Summary 
 Copies a summary of graph events to the clipboard, including event type, position on horizontal axis, 
 channel and label information. When this option is selected, a setup dialog containing searchable 
 event criteria will appear. By default, all event types will be copied. 

 
 After copying, the events may be pasted to the Journal (via Journal > Paste), or pasted to an external 
 text editor or spreadsheet. 
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Journal 

  
The Edit > Journal sub-menu options are similar to those found in the Edit > Clipboard menu. The key 
difference is that data (whether measurements or raw data) is pasted directly into the journal rather than 
copied to the clipboard. 
 Paste Measurements 

Choosing Paste Measurements from the Edit > Journal menu will cause all visible measurement 
windows to be pasted into the journal. Each time this is selected, the measurements and values are 
pasted into the journal using the precision specified in the Display > Preferences dialog. The number 
of measurements displayed is customizable. Use the Preferences menu (see page 341) to change the 
number of measurement rows or the measurement precision displayed on the screen. 
Paste Measurement shortcuts: 

 Keyboard: Ctrl + M 
 Mouse: Right-click in the Journal and choose “Paste Measurement” 

 Paste Wave Data 
Converts the selected area of the waveform to numeric format and paste it into the journal in standard 
text file format. As with the copy wave data command (in the Edit > Clipboard submenu) this will 
paste the selected area from all channels, not just the selected channel, and will place a delimiter 
between the columns when two or more channels are being pasted to the journal. By default, tab 
characters are used to separate columns; this can be changed to comma or space delimiters in the File 
> Save As > Options dialog. See the Save As section on page 237 for more information on how to 
change the column delimiter. 
Paste Acquisition Settings 
Pastes the acquisition settings to the Journal as they were copied via Edit > Clipboard > Copy 
Acquisition settings. 

 Paste Modification History… 
Use after Copy Data Modification History… to paste the transformation history from the clipboard 
for all channels or for the selected channel to an active Journal window or other word processing 
application. Modification history includes the transformation name, channel (analog, calc, or digital), 
date & time, and relevant transformation parameters, including starting and ending sample position. 
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 Paste Focus Area Summary 
 Use after Copy Focus Area Summary to paste the summary from the clipboard to the Journal. 
 Paste Event Summary 
 Use after Copy Event Summary to paste the selected event criteria from the clipboard to the Journal. 
 Manage PDFs 

Use this option to select and import (embed) PDF files into the Journal as tabbed windows. Multiple 
PDFs may be imported and each PDF appears under its own tab heading. Choose Edit > Journal > 
Manage PDFs, or right-click in the Journal and choose Manage PDFs. The following dialog will 
appear: 

 



256  BSL PRO Manual 

Visit the online support center at www.biopac.com 

 
Control Description 

Embed New Launches a “File > Open” dialog for navigating to 
the directory containing the PDFs to be 
embedded. 

Remove Removes a PDF from the list. (The actual PDF is 
not deleted.) 

Up Moves the selected PDF up the list and 
determines its tab order in the Journal. 

Down Moves the selected PDF down the list and 
determines its tab order in the Journal. 

OK Imports the embedded PDFs into the Journal 

Multiple embedded PDFs may be toggled by clicking the tabs. Clicking the Journal tab will activate 
the Journal window. Saved Journal content is not affected by embedded PDFs. 

• The Journal formatting tools are not available when a PDF is actively displayed. 
• The Manage PDFs option is only available when the Journal is displayed (Show > Journal). 

 
 Show Journal 

Toggle to display/hide the Journal window. 
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Chapter 13 Transform Menu Commands 
Overview 

  
The Transform menu contains operations that primarily modify the data in the graph. 
BSL PRO provides a number of options for post-acquisition analysis and transformations. These 
transformations perform a range of operations on data, from digital filtering and Fourier analysis to math 
functions. These options are found under the Transform menu (disabled while an acquisition is in progress.) 
Unless otherwise noted, all transformations described here apply to the selected channel only. Some options 
(such as the expression and math functions) allows a channel to be specified for applying the transformation. 
It is important to remember that BSL PRO is always selecting at least one point, and the cursor will flash 
whenever only one point is selected. Some of the transformation functions (e.g., math function, waveform 
math) can operate on a single sample point, and will transform a single sample point when only one is 
selected.  

There are two ways to apply a transformation to an 
entire waveform. 
a) For transformations that generate a dialog, check 

the “transform entire waveform” box (usually 
located toward the bottom of each dialog). This 
will transform the entire waveform, regardless of 
whether a single point, area, or the entire 
waveform is selected. 

b) For transformations that do not generate a dialog, use the Edit > Select all command prior to selecting the 
transformation. This will transform the entire waveform for all of the transformation functions. 

• Edit > Select All is not necessary when only a single point is selected prior to selecting the 
transformation because BSL PRO will automatically apply the transformation to the entire 
waveform since it is not possible to perform these transformations on a single point. 

 
Note  Transformations require BSL PRO to allocate additional memory and then load the data into memory; 

when transformations are executed on large data files, the application may crash. 
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Recently Used Transformations 
The Transform > Recently Used submenu allows quick access to a user’s most recently used transformations 
and analysis commands. The Recently Used submenu also appears at the top of the Transform submenu 
available from the context menus of waveforms.  
The submenu lists a default of five of the most recently used transformations, with the most recently executed 
at the top of the menu. To adjust the number of recent transformations displayed, select Display > 
Preferences. 

 
The recently used transformation listing is saved and restored across subsequent launches of BSL PRO. It also 
is application wide: Executing a transformation in any graph will add that transformation onto the recently 
used list. The recently used list is independent for each user account.  

 
The recently used transformations can also be launched by the keystroke combinations appearing in the menu.  

Digital Filters 

 
FIR filters are linear phase filters, which mean that there is no phase distortion between the original signal and 
filtered waveforms. 
IIR filters are not phase linear filters, but are much more efficient than FIR filters in processing data. The IIR 
filters are useful for approximating the results of standard biquadric filters of the form: 

(as2 + bs + c) / (xs2 + ys + z) 
These types of filters are commonly implemented in electronic analog circuitry. IIR filters are also used for 
online filtering (discussed on page 135). 
 See Appendix B for more information about the differences between these types of filters. 

Adaptive filtering is a signal processing technique that processes two different signals in relation to one 
another; see page 264 for details. 
To understand how digital filters work, it is important to understand the nature of analog signals and their 
frequency components. All analog signals are comprised of signals of various frequencies. A commonly used 
analogy is that of the color spectra. Just as white light is made up of a variety of colors that have different 
wavelengths (frequencies), physiological signals are comprised of specific signals with unique frequency 
signatures. 
For example, an electroencephalogram (EEG) recording is comprised of several different types of signals, 
each of which has a different frequency signature. Alpha waves (one of the most studied EEG signals) have a 
frequency range of about 8 Hz to 13 Hz. This means that alpha waves go through a complete cycle (from peak 
to peak or trough to trough) anywhere from eight to 13 times a second. 
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There are, of course, signals that have other frequency signatures in EEG data. Most types of physiological 
data have a number of different frequency signatures present in the overall signal. In addition, frequency 
components besides the signal(s) of interest are often present. In the U.S., it is not uncommon for 60 Hz 
electrical noise to be acquired along with physiological signals (in other countries, AC interference is present 
at either 60 Hz or 50 Hz). 
Use digital filtering to retain only the frequency components of interest and remove other data (whether it is 
“noise” or merely physiological signals outside the range of interest). 
It is important to note that the way in which data is filtered depends in large part on the sampling rate at 
which the original data was acquired. For instance, if data was collected at 50 samples per second (50 Hz), it 
is not possible to filter out 60 Hz signals. 
In fact, data must be sampled at a rate equal to at least twice the frequency of the signal to be removed. So, if 
data is to be collected and the information between 80 Hz and 120 Hz is to be removed, the data must be 
sampled at 120 Hz*2, or 240 samples per second (or faster). Also, each channel of data is filtered separately, 
so removing one type of data from one channel will not affect any other channels. 
Digital filters can be divided into four general classes: 

low pass     band pass     high pass     band stop 
Descriptions of these four classes of filters follow, with visual examples of how these filters work. In each of 
the four examples, a single channel of data containing frequency components in three ranges (low frequency, 
mid-range, and high frequency) is acquired. 
 Low frequency data, by definition, has slowly changing values, much like respiration patterns or core 

temperature variations. 
 High frequency data, compared to low frequency data, is noticeably more “spiked,” much like an 

EMG signal. Observe that the high frequency wave repeats itself about five times in the time it takes 
the low frequency wave to repeat once. 

 Mid-range data falls somewhere in between these two extremes. 
In the examples that follow, one possible way that these data could have been collected is if respiration were 
measured, but the measurement was contaminated with high-frequency muscle movement and mid-frequency 
signal coming from AC interference. The data is then passed through a filter, where some of the frequency 
components are removed. 
Low pass filtering 
In the example below, a low pass filter attenuates the data above a given threshold, allowing only lower 
frequency data to “pass” through the filter. 

Low
Pass
Filter

Incoming data Filtered data

Low
frequency
data

Mid
frequency
data

High
frequency
data

Low
Cutoff
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High Pass Filtering 
In the example below, a high pass filter removes the low and middle range data, but allows the high frequency 
data to pass through the filter. 

Filter

Incoming data Filtered data

Low
frequency
data

Mid
frequency
data

High
frequency
data

Hipass

High
Cutoff

 
Whereas the low pass and high pass filters retain data either above or below a given threshold, the next two 
types of filters work with a range, or band, of data. 
Band pass filter 
The band pass filter, allows only the data within the specified range to pass through the filter. A band pass 
filter is useful for retaining only specific waves from an EEG record. For example, to retain alpha waves, the 
filer can be set the filter to only pass data between 8 Hz and 13 Hz. 

Band
Pass
Filter

Incoming data Filtered data

Low
frequency
data

Mid
frequency
data

High
frequency
data

Low
Cutoff

High
Cutoff

 
Band stop filter 
The band stop filter allows data to pass above and below the specified range. This type of filter is typically 
applied to remove extraneous 60 Hz or 50 Hz noise from a data record.  

Band
Stop
Filter

Incoming data Filtered data

Low
frequency
data
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High
frequency
data

Low
Cutoff

High
Cutoff
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FIR Filters 

 
Digital filter dialog  
When selecting an FIR filter type, the corresponding Digital Filter dialog will be displayed, allowing access to 
a range of filtering options. 
1. Window. The Window popup menu contains a variety of filtering 

algorithms. The filter default is set to a “Blackman” type. These 
different Windows (described in detail in Appendix D) allow fine 
tuning of the filter response. 

2. Cutoff Frequency (Hz) (or threshold). Enter a fixed value or set to a 
fraction of the sampling rate or to line frequency. 
Sampling rate—frequency is set to a fraction of the sampling rate and 
automatically updates when the sample rate is modified. 
Line frequency—frequency is set to the line frequency at which the 
data was recorded. 
Fixed at —Fixed value guidelines are as follows: 
• Low Pass Filter—data with frequency components below the 

cutoff will pass through the filter, whereas frequency components 
above the threshold will be removed. For low pass filters, the 
default cutoff frequency is the waveform sampling rate divided by 
eight and can be set to any value between 0.000001Hz and 0.5 
times the sampling rate. 

• High Pass Filter—data with frequency components above the 
cutoff will pass through the filter, whereas frequency components 
below the threshold will be removed. For high pass filters, the 
default threshold is the waveform sampling rate divided by four 
and can be set to any value between 0.000001Hz and 0.5 times the 
sampling rate. 

• Band-type Filters—a low threshold and a high threshold must be specified to define the band of data 
(the frequency range) that is either passed or stopped, depending on whether it is a Band Pass or Band 
Stop filter. In either case, the default for the low threshold is the waveform sampling rate divided by 
eight and the default for the high threshold is the waveform sampling rate divided by four. The 
threshold settings can take on any value from 0.000001Hz and 0.5 times the sampling rate, but the 
two thresholds cannot be set to the same value and the high threshold must be greater than the low 
threshold. 

3. Number of Coefficients. Enter a fixed value or enable the optimize option. 
• Fixed at—This determines how well the filter will match the desired cutoff frequency (or range). The 

minimum number of coefficients is 3 and the maximum must be less than the total number of sample 
points in the selected area. The software will truncate the maximum number of coefficients to the 
highest odd number less than the total. 

• Optimize for sample rate and cutoff—the number of coefficients is set as four times the sampling rate 
divided by the cutoff frequency of the filter. Optimize does not necessarily produce the best quality 
filter, but it takes less time. 

The recommended number of coefficients is  
4 x (waveform sampling rate/lowest frequency cutoff for the filter) 
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For every filter except the band pass, the lowest frequency cutoff is equal to the specified cutoff 
frequency for the filter; for the band pass filter, the lowest frequency cutoff is the low frequency cutoff 
setting. Filters that use a small number of coefficients tend to be less accurate than filters that use a large 
number of coefficients. Larger coefficients increase filter accuracy, but also increase the processing time 
required to filter the data.  
To see how changing the number of coefficients affects the way data is filtered, it can be useful to 
examine the filter response patterns. In the example below, data was collected at 500 Hz and the band 
stop filter was designed to remove 60 Hz noise using a low cutoff of 55Hz and a high cutoff of 65Hz. The 
same data was band stop filtered using 39 coefficients (upper waveform) and then 250 coefficients (lower 
waveform). 

 
Along the horizontal axis, the units are scaled in terms of frequency, with lower frequencies at the left of 
the screen. The values along the vertical axis are scaled in terms of dB/V and indicate the extent to which 
various frequencies have been attenuated. 
In both filter response waveforms, there is a downward-pointing spike that is centered on 60 Hz. The 
baseline of the filter response corresponds to a value of approximately 0 on the vertical axis, indicating 
that the signals significantly above or below 60 Hz were not attenuated to any measurable extent. Observe 
that the filter does not “chop” the data at either 55 Hz or 65 Hz, but gradually attenuates the data as it 
approaches 60 Hz. 
For example, the upper waveform in the filter response plot represents data that was filtered using a value 
of 39 coefficients. The slope is relatively shallow when compared to the lower waveform, which 
represents a filter response performed with 250 coefficients. Although the filter that used 250 coefficients 
took slightly longer to transform the data, the filter response pattern indicates that the data around 60 Hz 
is attenuated to a greater degree. Also, the 250-coefficient filter started to attenuate data considerably 
closer to the 55 Hz and 65 Hz cutoffs, whereas the default filter began to attenuate data below 55 Hz and 
above 65 Hz. 

TIP: A good rule of thumb is to use a number of coefficients greater than or equal 
to two times the sampling rate divided by the lowest cutoff frequency 
specified. For example, if running a low pass filter at 1 Hz on data sampled 
at 100 Hz, choose at least (2 x 100/1) or 200 coefficients in the filter. 
Additional coefficients will improve the response. 

4. Show Filter Response. When checked, this option generates a plot of the 
filter response in a new window, labeled “Frequency Response” (see 
example above).  
 Units: Select linear units or dBV. 

5. Don’t modify waveform. This option is useful in conjunction with the “Show Filter Response” option. 
When both boxes are checked, BSL PRO will produce a plot showing the filter response, but will not 
modify the waveform. This allows different filter options to be applied (without modifying the waveform) 
until the desired frequency response is achieved. 
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6. Filter entire wave. If this option is checked, BSL PRO will filter the entire wave and replace the original. 
To keep the original, duplicate it prior to filtering. 

IIR Filters 
To access the IIR filter dialog, click the Transform menu, scroll to select Digital Filters, drag right to IIR and 
drag right again for the filter options. For all filter types, the software will limit the frequency setting so it 
cannot exceed one-half the channel sampling rate. For real-time filter options, see page 135. 

  
Low Pass and High pass Pass data that falls below or above the specified standard. The Low Pass default 

is waveform sample rate/8; the High pass default is waveform sample rate/4. 
Band Pass (low + high) Pass a variable range of data. Specify a low frequency cutoff and a high 

frequency cutoff to define the range or “band” of data that will pass through the 
filter; frequencies outside this range are attenuated. For the Band Pass Low + 
High filter, the low default is waveform sample rate/8 and the high default is 
waveform sample rate/4. 
 This filter is best suited for applications where a fairly broad range of data is 

to be passed through the filter. For example, apply to EEG data to retain only 
alpha wave activity. 

Band Pass (single freq) Requires only a single frequency setting, which specifies the center frequency of 
the band to be passed through the filter. The “width” of the band is determined by 
the Q setting of the filter (discussed in detail below). Larger Q values result in 
narrower bandwidths, whereas smaller Q values are associated with a wider band 
of data that will be passed through the filter. This filter has a bandwidth equal to 
Fo/Q, so the bandwidth of this filter centered on 50 Hz (with the default Q=5) 
would be 10 Hz. Although functionally equivalent to the Band Pass (low + high) 
filter, this filter is most effective when passing a single frequency or narrow band 
of data, and to attenuate data around this center frequency. The Band Pass (single 
frequency) default is waveform sample rate/8. 

Band Stop (single freq) Defines a range (or band) of data and attenuates data within that band (the 
opposite function of a band pass). This filter is implemented in much the same 
way as the standard Band Pass, whereby a center frequency is defined and the Q 
value determines the width of the band of frequencies that will be attenuated. The 
Band Stop (single frequency) default is waveform sample rate/8. 

Q coefficient The online filters are implemented as IIR (Infinite Impulse Response) filters, 
which have a variable Q coefficient. The Q value entered in the filter setup box 
determines, in part, the frequency response of the filter. This value ranges from 
zero to infinity, and the “optimal” (critically damped) value is 0.707 for the Low 
Pass, High pass and Band Pass filters. A Q of .707 for any of these filters will 
result in a second order Butterworth response. The Q is set to a default of 5.000 
for the single frequency Band Pass and Band stop filters. For more details about 
the Q setting, see the Appendix. 

Sampling rate Sets the Frequency to a fraction of the sampling rate and automatically updates when 
the sample rate is modified. 

Line frequency Sets the Frequency to the line frequency at which the data was recorded. 
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Adaptive Filtering 

  

 
 See the Adaptive Filtering Calculation 

Channel on page 149. 

Adaptive filtering is a signal processing technique that 
processes two different signals in relation to one another 
and can be used for noise estimation, noise reduction, 
general-purpose filtering, and signal separation. Adaptive 
filtering creates efficient high-quality filters with a minimal 
number of terms, which can be very useful in blocking 
mains interferences or other known periodic disturbances. 
 Useful for noise filtering where it is possible to acquire 

a signal that is correlated to the noise (similar to the 
way noise-cancelling headphones detect and remove 
outside noise). Applications include removing EMG 
from ECG or EOG from EEG. 

The weights within an adaptive filter are modified on a step-by-step basis. BSL PRO uses the N-tap FIR 
adaptive filter, with coefficients updated using least means squares (gradient) feedback. 
Source signal 

The source channel will be replaced by the adaptive filter results. 
Noise signal 

The noise channel is the signal that is correlated with the noise to be eliminated from the Source; it is 
not modified by adaptive filtering. 
Source and Noise channels must have the same sampling rate. 

Order 
Specify a positive integer for the number of terms to be used in the internal FIR filter. 

Step size 
Provides mu, the rate of adaptation of the coefficients within the FIR filter. 
 

Comb Band Stop Filter  
Comb Band Stop filters out a fundamental frequency and its overharmonics (integer multiples of the base). 
Resonance, aliasing, and other effects may generate interference at multiples of a base frequency. The Comb 
Band Stop filter combines all the required filters instead of requiring a separate filter for each interfering 
overharmonic.  

    
 Transformation Dialog Calculation Channel Dialog 
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Resonance, aliasing, and other effects may generate interference at multiples of a base frequency. The Comb 
Band Stop filter combines all the required filters instead of requiring a separate filter for each interfering 
overharmonic. Comb Band Stop filters remove a fundamental frequency and its overharmonics (e.g., integer 
multiples of the base frequency) from a signal, and are useful for removing noise. BSL PRO approximates a 
Comb Band Stop filter by cascading a series of IIR Band Stop filters, and is limited to removing frequencies 
and overharmonics. The number of filters used can be fixed at a particular number (e.g., limiting the number 
of harmonics to filter out) or configured to automatically remove all possible harmonics for any given 
sampling rate. 

• Mac OS — Use the "Comb Band Stop Filter" Automator action to integrate Comb Band Stop 
filters into Workflows. 

For a given base frequency  and quality factor Q, the comb filter approximation will be given by the set of 
following formulas: 

( )( )xFFFFy kωωωω  ⋅⋅⋅= 32  

where F  represents a standard two-tap IIR band stop filter for the frequency  with coefficients 
computed using the quality factor Q. 
The number of overharmonics of the base frequency to be removed is given by the integer value k. 
The maximum allowable number of overharmonics may be automatically determined given the 
sampling frequency f s: 














=

ω2max

f
k s  

This limits the maximum overharmonic frequency to be less than the Nyquist of the sampling 
frequency. 

After the first comb filter is performed, the most recently used settings for the comb filter will be displayed, 
(except for “Transform entire wave,” which will be reset each time the dialog is opened). 
Textual export will include the source channel, base frequency, quality factor, and number of harmonics. 
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Comb Band Stop Filter Dialog 

number of samples Width of the selection. 

@ samples/sec Waveform sampling rate of the source channel. 
• The channel sampling rate of the calculation channel can not exceed the channel sampling 

rate of the source channel. Downsampling will be applied to the source channel prior to 
comb filter processing, if required, and all Nyquist frequency restrictions will be determined 
from the calculation channel sampling rate. 

Frequency Fixed—The comb filter will remove this base frequency and integer multiples of this frequency. 
• Must be positive and less than the Nyquist frequency (half the sampling rate). 

Sampling rate—Sets the frequency to a fraction of the sampling rate and automatically updates 
when the sample rate is modified. 
Line frequency—Uses the line frequency at which the data was recorded. 

Q Quality factor used when computing the coefficients of the IIR notch filters. 
• Must be positive. 

all up to Nyquist Removes all integer multiples of the base frequency. This will include all multiples of the base 
frequency that are less than the Nyquist frequency. 

Harmonics Removes the base frequency and integer multiples of the base frequency up to and including the 
multiple contained in the edit field 

• Must be an integer greater than 0 and must not exceed k max  
• The final multiple must be less than the Nyquist frequency. If it is not, the input will need to 

be corrected before the comb filter can be applied. 

OK If the settings are valid, executes the comb filter transformation. Verification of certain calculation 
channel parameters does not occur until the start of acquisition as sampling rates may be changed 
after calculation channels are configured. 
Prior to the start of acquisition, the following will be checked: 

• source channel to ensure it is still being acquired. 
• base frequency of the comb filter to ensure it is less than the Nyquist frequency of the 

channel sampling rate. 
• if the user has manually specified that a fixed number of overharmonics should be used, the 

number of overharmonics to ensure the highest used overharmonic does not exceed the 
Nyquist frequency of the channel sampling rate. 

If any of the parameters are invalid, a prompt will be displayed indicating which settings are 
incorrect and must be fixed for the acquisition to be started. 

Cancel Quits without modifying any data. 

Source All enabled analog, digital, and lower-index calculation channels. 

Label When the calculation type of a channel is changed to comb filter, the title of the channel will be 
replaced with the default label “Cn –Filter” where n is the index of the calculation channel. 

• Must be 40 characters or less. 

Preset Displays the title of any Calculation Preset currently applied to the calculation channel. 
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Math Functions 
BSL PRO supports a wide range of mathematical and computational post-
acquisition transformations. Unless otherwise noted, each of these functions 
applies only to the selected area of the selected channel. If no area is selected 
(i.e., a single data point is selected), the cursor will blink and BSL PRO will 
transform the entire wave. If a math function attempts to divide by zero, a zero 
will be returned. 
For complex transformations involving multiple functions, it may be more 
helpful to use the Expression/ Equation Generator (see page 279 for details). 
The following table describes the commands available in the Transform > Math functions menu: 
Transform > Math Explanation of Command 

Abs (Absolute Value)  Computes the absolute value of the data. All negative data values are made 
positive, with no change in magnitude. This function can be used to rectify data. 

Atan (Arc Tangent) Returns the arc tangent of each data point in radians. This rescales the data such 
that the range is from -π/2 to π/2. 

Connect endpoints 
(Connect the endpoints) 

Draws a line from the first selected sample point to the last selected sample point 
and interpolates the values on this line to replace the original data. The connect 
endpoints function is useful for removing artifacts in the data or in generating 
waveforms. 
In the example below, the “noise spike” in the data is an undesired measurement 
artifact that should be removed. The Cut operation will remove data, but the 
subsequent data will be shifted to the left. Connect endpoint preserves the time 
series of data on the horizontal axis by connecting the edges of the selected area.. 

 

 
Area selected before (top) and after (bottom) connect endpoints function 

 

Exp (Exponential) Computes the function ex, where x is the waveform data and e is 2.718281828. 
This is the base of the natural logarithms. 
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Transform > Math Explanation of Command 

Limit (Limit data values) “Clips” data outside the range specified by the set of boundaries in the limit dialog. 
This operation prompts the user for an upper and lower limit. Any data values 
outside these limits will be clipped. To limit only one boundary (high or low), set 
one edge to the desire level and the second boundary beyond the Max/Min value 
of the data within the selected area. For example to set all negative values to zero 
and leave the positive values unchanged: set the lower limit to zero and the upper 
limit to a value greater than max for the selected area. 

Ln (Natural Logarithm) Computes the natural logarithm of the selected section. The inverse of this function 
is the exponential function, Exp. 

Log (Base 10 Logarithm) Computes the base 10 logarithm of the selected section. 

In order to perform the inverse of this function, which would be 10x, use the 
Waveform Math power operator with the constant k=10 as the first operand and 
the waveform data as the second operand. 

Noise Converts the selected section into random data values between –1.0 and +1.0. 
This is mainly useful for creating stimulus signals and other waveforms. 

Sin (Sine) Calculates the sine of the selected section. The data is assumed to be in radians. 

Sqrt (Square Root) Takes the square root (√) of each data point in the selected section. 

Threshold (Threshold 
data values). 

Transforms all data points above the threshold to +1 units, and converts all values 
below the lower threshold to 0 units. Once the data crosses a threshold it will 
continue to be set to +1 for the upper cutoff and 0 for the lower cutoff, until it 
crosses the opposite threshold. The most common application of this function is to 
serve as a simple peak detector, the results of which can be used in rate or phase 
calculations. 
Threshold Algorithm 
Assume a domain variable 

 

t ∈ tstart,tstart +1,tstart + 2,{ } with tstart being an 
integer, a real-valued signal y(t) defined for all t, and two real valued levels ylow and 
ymax satisfying the relation 

 

ylow ≤ yhigh . 

Define the threshold function thresh(t) function such that: 

 

 

thresh(tstart ) =
1 y(tstart ) ≥ ylow

0 y(tstart ) < ylow

 
 
 

 

 

 

thresh(t) =
0 y(t) < ylow

1 y(t) > yhigh

thresh(t −1) ylow ≤ y(t) ≤ yhigh
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Template Functions 

  
The Template Functions are useful for comparing waveforms. Technically, the template functions provide 
correlation, convolution and mean square error transformations of a template waveform against another 
waveform. To activate the full template menu, select an area and then select set template. 
Set Template 
Use the following ECG waveform as an example and contains an abnormality. After detecting an 
abnormality, this operation can detect whether there are other (similar) abnormalities in the recording. To do 
that, it’s necessary to select the pattern to search for, and then compare that pattern to other data sets in the 
file. 
Selecting a section of a wave to be used as a template: 

1) Highlight the section to be used as a pattern. 

  
2) Click the Transform menu and choose Set template from the Template functions submenu. This 

copies the selected portion into a buffer for subsequent template functions 
3) Select the waveform and position the cursor at the beginning of the data. 
4) Choose Correlation from the Template functions submenu. The center waveform in the graph below 

shows the result of the correlation. 
Note the higher amplitude peaks where the template data more closely matches the waveform. The lower 
waveform illustrates the mean square error function, which is similar to the correlation function. 
This indicates that there are two abnormal beats in the record. The first one appears at about 3 seconds 
and is the one used as a template; the second one appears at about 11 seconds. 
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Result of correlation and mean square error functions 

5) Use the zoom tool to inspect the abnormalities more closely. 
 

Remove mean 
A drifting baseline can be problematic when comparing waveforms. The effectiveness of a comparison of a 
template or waveform with a slowly drifting baseline will be increased by applying the Remove mean 
template function. The remove mean option causes the mean amplitude value of the template and the 
compared section of the waveform to be subtracted from each other before the sections are compared. This 
way, a large baseline offset will have very little effect on the comparison. This option is toggled every time it 
is selected and is enabled when a check mark is present. 
For example, the following graph shows the original waveform at the top, the correlated waveform with mean 
removal in the middle, and the same correlation without mean removal at the bottom. Note how the mean 
removal effectively compensates for the drifting baseline in the original waveform. 

 
Correlation with and without mean removal 
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Template algorithms 
The template functions are: correlation, convolution, mean square error and inverse mean square error. 
a) Correlation is a simple multiplication and sum operation. The template is first positioned at the cursor 

position in the waveform to be correlated. Each point in the template waveform is multiplied by the 
corresponding point in the data waveform (the waveform to be correlated) and summed to produce the 
resulting data point. The template is then moved one data sample forward and the operation is repeated to 
produce the next resulting data point. The resulting data points replace the waveform to be correlated. 
The correlation function algorithm can be expressed by the following formula, where foutput(n) is the 
resulting data point, ftemplate(k) is the template waveform data points, and K is the number of data points 
in the template: 

∑
K

1 =k 
waveformtemplateoutput (n)f * (k)f = (n)f  

 
b) Convolution is identical to the correlation function except that the template waveform is reversed during 

the operation. This function is not generally useful by itself, but can be used as a building block for more 
sophisticated transformations. The convolution function algorithm can be expressed by the following 
formula, where foutput(n) is the resulting data point, ftemplate(k) is the template waveform data points, 
and N is the number of data points in the template: 

f (n) =  f (-k) *  f (n + k)output template waveform

k = -N/2

N/2 - 1

∑  

 
c) Mean square error positions the template at the cursor position in the waveform to be compared. Each 

point in the template waveform is subtracted from the corresponding point in the waveform to be 
compared. The result is squared and summed to produce the resulting data point. The template is then 
moved one data sample forward and the operation is repeated to produce the next resulting data point. The 
resulting data points replace the waveform. 
The mean square error function tends to amplify the error (or difference) between the template and the 
waveform, which makes it useful when looking for an extremely close match rather than a general 
comparison. When a match is found, the mean square error algorithm returns a value close to zero. 
The mean square error function algorithm can be expressed by the following formula, where foutput(n) is 
the resulting data point, ftemplate(k) is the template waveform data points, and K is the number of data 
points in the template: 

f (n) =  [f (k) -  f (n)]output template waveform

k = 1

K

∑
2

 

 
d) Inverse Mean square error simply inverts the result of the mean square error algorithm. Accordingly, 

when this algorithm finds a match between the template and the data, the algorithm returns the inverse of 
a value close to zero and, typically, a large positive spike will occur at the point of the match. 
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Integral 

Integral is essentially a running summation of the 
data. Each point of the integral is equal to the sum 
of all the points up to that point in time, exclusive 
of the endpoints, which are weighted by half. The 
exact formula is below, where f( ) is the data values 
and ∆Ts is the horizontal sampling interval:  

f (n) =  f (k) f (n -1) +  f (n)] / 2]* Tsoutput input

k = 1

n -1

input input∑ + [[ ∆  

The units will be (amplitude units • horizontal units). The integral function can be used to compute the area 
under the curve in a continuous fashion. For example, in data acquired by an accelerometer, the integral of the 
data would be the velocity, and the integral of the velocity would be the distance. As with all transformations, 
this function can be applied to either a selected area or to the entire waveform. 
Derivative 

Derivative calculates the derivative of the selected area of a waveform. Since 
high frequency components return nonsensical results in a derivative, a low 
pass filtering function is included in the Derivative function (see page 259 for 
more information on low pass filters). Derivative is based on an FIR filter 
implementation. 
The Filter Response for a Derivative transformation will be displayed in 
linear units or in dBv. The Derivative FIR filter frequency response will 
appear as a linearly increasing magnitude up to the point of the specified 
cutoff frequency, at which point, the filter magnitude will drop off 
sharply.  

 
Derivative can provide a more meaningful result than Difference if high frequency noise is present in the 
signal. 
Cutoff Frequency The value entered in the cutoff frequency box should be roughly equivalent to the 

highest frequency component of interest present in the time series data. The default 
cutoff frequency is 0.125 times the waveform sampling rate. 

 Sampling rate—Sets the frequency to a fraction of the sampling rate and automatically 
updates when the sample rate is modified. 

 Line frequency—Uses the line frequency at which the data was recorded.  
 # of Coefficients Fixed—The default number of coefficients is (4 x waveform sampling rate)/Cutoff 

Frequency. As the number of coefficients (Q) increases, the Derivative becomes more 
accurate. Fixed can produce better filters but may take longer to execute. 

 Optimize for sample rate and cutoff—Estimate the number of coefficients as four times 
the sampling rate divided by the cutoff frequency of the filter. Optimize does not 
necessarily produce the best quality filter, but takes less time. 
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Units Select linear units or dbV. 
 

 

TIP: A good rule of thumb is to use a number of coefficients greater than or equal to 
two times the sampling rate divided by the lowest cutoff frequency specified. 
For example, if running a low pass filter at 1Hz on data sampled at 100 Hz, 
choose at least (2 x 100/1) or 200 coefficients in the filter. Additional 
coefficients will improve the response. 

Integrate 

 

The Integrate transformation operates 
the same as the Integrate calculation—
see page 124, except it does not have a 
Max Cycle option, which is not 
relevant post-acquisition, and Reset 
via channel with mean subtraction 
enabled functions differently online 
and offline. 
 
Root mean square is implemented as:  

Sqrt(sum(x^2)/(n)) 

Reset 
Online Mean subtraction causes the online version to be delayed by the mean cycle length. It waits 

for that period of time to pass so it can determine a mean value for the initial cycle, and it 
then tries to re-compute this mean for each cycle. If the resets are too short or too long, the 
window expires and the processing halts again until a new mean can be recomputed. Online 
processing may reset from threshold crossing in the control channel or window expiration 
when it loses mean tracking. 

Offline  Since all the data is available, the mean is computed from the data in the channel and doesn't 
delay the signal. Also, since it isn’t doing windowed means, there are no window expiration 
events that are inserted. Offline processing may reset from threshold crossing in the control 
channel. 
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Output Reset 
 
Enable the 
checkbox 
option to 
create an 
Event at each 
signal reset. 

  
 

The Integrate formula is the same in the calculation (online, real-time) mode and the transformation (off-line, 
post-processing) mode; it varies only based on the parameters selected. 

Notes 

• For the first points, value of index “i” will be less than or equal to zero; it means that for 
summation the result will only contain values beginning with ( )1xf . 

o For the first point for summation: ( )1−xf , ( )0xf , ( )1xf . 
( )1−xf and ( )0xf  - don’t  exist, resulting in: ( )1xf . 

o For the second point for summation: ( )0xf , ( )1xf , ( )2xf . 
( )0xf  - doesn’t exist, resulting in: ( )1xf + ( )2xf . 

• The Integrate formula is implemented as a Standard Deviation formula (see 
mathworld.wolffram.com > Wolfram Research > equation 5 at 
http://mathworld.wolfram.com/StandardDeviation.html). 

• The Root Mean Square formula is identical to the Standard Deviation formula, but without mean 
removal; this is the n-1 definition. 

o For a window size n, to convert from the n-1 definition to the n definition, use
n

n )1( −  

• The formulas to calculate RMS are optimal 
for data with a zero mean (typical for 
biopotential data). Data with a non-zero 
mean can be rescaled with the Transform 
option Rescale. Choose Transform > 
Rescale, and then enter the following 
parameters: 

Input value    Map 
(Scale) value 

 10 7.07107 
 -10 -7.07107 

 

 
 

 

 
1. Via samples, no extra parameters selected 

( ) ( ) xxfxF
j

sji
ij ∆= ∑

+−=

*
1

 

Where: 
i - index for source values (***the real range is 1..j); 
j - index for destination values (1..n); 
n - number of samples; 

http://mathworld.wolfram.com/StandardDeviation.html
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ix , jx - values of points at horizontal axis; 

( )ixf - values of points of a curve; 
( )jxF - integrated values of points of a curve; 

s – number of samples to average across; 

1
1

−
−

=∆
n

xx
x n  - horizontal sample interval; 

1, xxn  - values at horizontal axis at the endpoints of selected area. 
 
 
 

Integrate formulas, continued…  See Notes on page 274
  2. Via samples, rectify 

 ( ) ( )( ) xxfABSxF
j

sji
ij ∆= ∑

+−=

*
1

 
Where:           
i - index for source values (***the real range is 1..j); 
j - index for destination values (1..n); 
n - number of samples; 

ix , jx - values of points at horizontal axis; 

( )ixf - values of points of a curve; 
( )jxF - integrated values of points of a curve; 

s - number of samples to average across; 

1
1

−
−

=∆
n

xx
x n  - horizontal sample interval; 

1, xxn  - values at horizontal axis at the endpoints of selected 
area. 

 

3. Via Samples, root mean square (RMS) 

 ( )
( )( )

1
1

2

−
=

∑
+−=

s

xf
xF

j

sji
i

j  

Where: 
i - index for source values (***the real range is 1..j); 
j - index for destination values (1..n); 
n - number of samples; 

ix , jx - values of points at horizontal axis; 

( )ixf - values of points of a curve; 
( )jxF - integrated values of points of a curve; 

s - number of samples to average across. 
 

4. Via samples, root mean square, remove baseline 

 ( )
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Where: 
i and m- indexes for source values (***the real range is 1..j); 
j - index for destination values (1..n); 
n - number of samples; 

ix , jx - values of points at horizontal axis; 

( )ixf - values of points of a curve; 
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( )jxF - integrate values of points of a curve; 
s - number of samples to average across. 
k - coefficient: for the first few points that have index j < s  k=j, 

for the other points with j > =s    k=s 
Integrate Timed Reset Formulas 

Given an input signal x with sampling rate expressed in Hertz to be reset every m samples, the timed reset 
integrate output O is given by the following recursive formulas indexed in terms of samples evaluated with 
data starting at a starting sample position j: 

 
The default scaling factor applied to the signal x matches the rescaling applied by the integrate reset via 
channel processing.  When acquiring the first segment of data into a graph, j is set to 0.  For subsequent 
segments, j is set to the index of the first sample of new data acquired into the graph. 
If rectification is enabled, the formula will be changed to take the absolute value of the source prior to the 
integration: 

 
Smoothing 

 
The smoothing function is a transformation that computes the moving average of a series of data points and 
replaces each value with the mean or median value of the moving average “window.” This has the same effect 
as a crude low pass filter, the advantage being that there is less change to the shape and amplitude of the 
original waveform. 
Samples BSL PRO allows the user to set the width of the moving average window (the number of 

sample points used to compute the mean) to any value larger than three. By default, this is 
set to three samples, meaning that BSL PRO will compute the average of three adjacent 
samples and replace the value of each sample with the mean before moving on to the next 
sample. For data acquired at relatively high sampling rates, it is recommended to set the 
smoothing factor to a higher value, since smoothing three sample points when data is 
collected at 1000 Hz will only average across three milliseconds of data, and will typically 
do little to filter out noise. To set the size of the window, enter a value in the Transform > 
Smoothing dialog. 

 This function is most effective on data with slowly changing values (e.g., respiration, heart 
rate, GSR) when there is noise apparent in the data record. 

Mean value Mean value smoothing is the default and should be uses when noise appears in a Gaussian 
distribution around the mean of the signal. The Mean value smoothing formula is shown 
below, where “m” is the number of points in the window and “n” is the sample number: 
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m/(k)f   = (n) f
1)/2]-[m+nk

(m/2)-n=k
inputoutput ∑

=

 

Median value Use Median value smoothing if some data points appear completely aberrant and seem to 
be “wild flyers” in the data set.  

  The Median value smoothing formula is shown below, where “m” is the number of points 
in the window and “n” is the sample number: 

[m/2]) n [m/2];-(n median   = (n) f output +  

Scaling  Generates the Scaling Parameters dialog. 
Difference  

 
The Difference function measures the difference (in amplitude) of two sample points separated by an arbitrary 
number of intervals. The difference is then divided by the total interval between the first selected sample and 
the last selected sample. 
When the difference transformation is selected, a difference interval dialog will be generated and the number 
of intervals between samples can be entered (default of 1). 
For data with no high frequency components, a 1-interval difference transformation approximates a 
differentiator. 
The formula for the difference transformation is shown below, where “m” is the number of intervals 
difference, [ ] rounds the integer down, “n” is the sample number, and ∆Ts is the horizontal sampling interval: 

foutput(n) = finput(n + [m/2])—finput(n—[(m+1)/2]) 
 (∆Ts * m) 

Example for boundary values when 
m = 3: 

foutput(0) = (finput(1)—finput(0)) / (∆Ts * m) 
foutput(1) = (finput(2)—finput(0)) / (∆Ts * m) 
foutput(2) = (finput(3)—finput(0)) / (∆Ts * m) 
 

When entering an odd number 
(K = odd): 

foutput(K) = (finput(K+1)—finput(K –2)) / (∆Ts * m) 
 

When entering an even number 
(K = even): 

foutput(K) = (finput(K+2)—finput(K –2)) / (∆Ts * m) 

 
 
Note:  The online (real-time) Difference calculation is calculated differently because projected values are not 

available. The online Difference formula is: 

foutput(n) = finput(n –m)—finput(n) / (∆Ts * m) 
 Using the default difference setting of 1 interval will produce a “∆P/∆T” waveform when the 

transformation is applied to a blood pressure or similar waveform.  
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Resample  

 
 

Variable sampling rate and the flexible acquisition speeds of MP units can create data sets that are at different 
sampling rates. For some types of data analysis, the data must be resampled to a common sampling rate. BSL 
PRO has resampling facilities with Transform > Resample Graph, and Pasting between graph windows of 
different sample rates when the “Interpolate pastings between graphs” Preference is enabled (via Display > 
Preferences, page 346). 
BSL PRO provides three interpolation methods for resampling data. Any changes made to the interpolated 
pastings between windows Preference and the interpolation method used in the Preferences dialog will be 
retained across launches of the software. 

Padding—Padding will use the closest original value of the waveform to the left of the new sample 
position for the value, constructing a padded square save as the data is resampled. Padding is desirable 
when it is imperative no new data or data approximations get introduced into an analysis. 
Linear—Linear interpolation is the default; previous software versions generated any missing data via 
linear interpolation. This method uses the sample points of the old waveform as the endpoints of a line. 
Missing data points are approximated from points lying on this linear segment. 
Cubic spline—Cubic spline interpolation will construct a spline for the entire data set and use the values 
of this spline as the new waveform values. A natural fit spline is used that keeps zero second derivative at 
the endpoints of the fit. Cubic splines are useful when the analysis requires data with a smooth derivative. 

Resample Graph 
Apply an arbitrary, user-defined sample rate to all waveforms in the file. 
 This option will adjust as needed the channel sampling rate as well as the acquisition sampling rate. 

Resample Waveform 
Resamples the active channel to a different rate. Resampling data maintains the same time scale but 
changes the number of samples per second. This option can be used to increase the number of sample 
points per interval (usually samples per second). When this is done, BSL PRO will interpolate between 
sample points to adjust to the new rate. This will add data points, although not necessarily more 
information. 
 Resampling to a lower sampling rate will “compress” a data file and information will be lost. 
 For example, a 4-channel data file sampled at 250 samples per second for 15 minutes requires 

about 1.8 MB of disk space. If these channels are resampled to 100 samples per second, the size 
of the file on disk is about 720 KB, a considerable reduction. 

 The highest rate a channel can be resampled to is the file acquisition rate (Hardware menu > Set Up 
Acquisition). 

 If data is resampled to a lower rate and then resampled again at a higher rate, the waveform will 
maintain the resolution of the lower sampling rate, only with more data points. 
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Expression 

    
The post-acquisition Expression transformation is available for performing computations more complex than 
available with the Math and Function calculations. The post-acquisition version Expression transformation 
includes all the same features as the online version described on page 137. The Expression transformation will 
symbolically evaluate complex equations involving multiple channels and multiple operations. Unlike the 
Math and Function calculations, which can only operate on one or two channels at a time, the Expression 
transformation can combine data from analog or digital channels, as well as calculation channels with a lower 
number Also, computations performed by the Expression transformation eliminate the need for “chaining” 
multiple channels together to produce a single output channel.  
To have BSL PRO solve an equation/expression and save the result to a new channel, choose Transform > 
Expression. A dialog will be generated. For each equation/expression, specify a source channel (or channels), 
the function(s) to be performed, any operators to be used, and a destination for the result. The different 
components of each equation/expression can be entered either by double-clicking items from the pop-up 
menus (sources, functions, and operators) or by typing mathematical commands directly into the expression 
box. 
Any expression can be assigned a specific name and saved as a custom preset. A pop-up menu of recently 
used expressions is also available in the Preset menu, along with a pre-loaded list of commonly used 
expressions. 
The Expression transformation can reference past and future points. 
 
Delay 
The Delay transformation allows the addition of time delays in post-processing (similar to the Delay 
calculation channel that can be used to add time delays to signals). The time delay can be added by 
introducing zero-valued samples at the start of the area to be delayed. The length of the waveform will remain 
the same; an amount of data at the end of the wave prior to the delay will be lost, with the length equal to the 
delay. The delay can be applied by using the Transform > Delay menu item. 

 
When inputting the delay amount, the units can be changed between seconds and samples. 

• Delay by samples is applied according to the acquisition sampling rate, not the channel sampling 
rate. Delay specifies the units of acquisition and graph sampling rate for samples.  

 

See the tables starting on page 
141 for descriptions of sources, 
operators and functions for the 
Expression dialog. 



280  BSL PRO Manual 

Visit the online support center at www.biopac.com 

The Automator action allows Delay to be used in Automator workflows.  

Rescale 
The Rescale transformation operates the same as the Rescale calculation—see page 150. 

 
Waveform math 

 
The Waveform math transformation allows arithmetic manipulation of waveforms. Waveforms can be added 
together, subtracted, multiplied, divided or raised to a power. These operations can be performed using either 
two waveforms or one waveform and an arbitrarily defined constant. Operate on the entire waveform by 
choosing Transform entire wave, or operate on portions of the waveform that have been selected using the 
cursor tool. If there is no selected area, only one sample point (the one selected by the cursor) will be 
transformed.  
All of the main components of a waveform math calculation can be selected from pop-up menus in the 
Waveform Arithmetic dialog. 
Source  The channels to be used in the transformation are referred to as source channels (Source 1 

and Source 2), and can be combined using any of the operators in the pop-up menu. Source 
channels allow selection of any existing channels in the current window, or a constant 
(defined by K). 

Constant The “Constant =” entry box is activated when a Source is set to “K, Constant.” 
Operand  The pop-up menu allows selection of addition, subtraction, multiplication, division or power 

functions.  
Destination  Save the results to an existing channel or create a new channel. Choose an existing channel 

from the pop-up menu or select the “New” option, which will create a new channel (using 
the next available channel). 

Waveform math can be used many ways. As one example, two waveforms can be added together. The 
following screen shows a sine wave in channel 14 and a triangle wave in channel 16. 
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To add these two waves, select Transform > Waveform Math and set source 1 to channel 14, the operator to 
addition “+”, source 2 to channel 16, and destination to New as shown here: 

 
Click OK to perform the transformation. The following screen shows the sum of CH14 and CH16 on a new 
channel. 

 
 

NOTE:  When selecting two waveforms of unequal length as sources, the length of the 
resulting waveform will be equal to that of the shortest one. Likewise, if one of the 
source waveforms extends only into a portion of the selected area, the resultant 
waveform will only be as long as the shortest source portion. If waveform math is 
performed on a selected area and output to an existing waveform that does not 
extend into the selected area, the resultant waveform is appended to the destination 
waveform. 
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Slew Rate Limiter  

 
The Slew Rate Limiter transformation is used for denoising and removing motion artifact during and after 
recording. The allowable amount of motion artifact over a given time/sample window can be precisely 
adjusted from a minimum allowable change to a maximum allowable change, thereby eliminating artifacts 
that exceed the selected amplitude range within a given time period.  
Tailor the range for a given type of artifact by modifying the Time window and Minimum/Maximum allowed 
change parameters. Parameters for various levels of artifact detection can be permanently stored by clicking 
“New…” and saving the signal type as a custom preset. 
To apply the slew rate limiter transformation in BSL PRO: 

1. Select the desired source channel in the data. 
2. Transform > Slew Rate Limiter. 
3. Select the time window using a sample interval or a time value. 
4. Set the desired minimum allowed change value. 
5. Set the desired maximum allowed change value. 
6. Click OK. 

Any artifact that falls outside the boundaries of the maximum/minimum allowed change setting will be 
eliminated from the data.  
See also: Slew Rate Limiter online calculation channel on page 151. 

 Watch the BIOPAC Slew Rate Limiter tutorial video for a detailed demonstration of this feature. 

http://www.biopac.com/video/?video_category=acqknowledge-tutorials&v=slew-rate-limiter-in-acqknowledge
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Chapter 14 Analysis Menu Commands 
Overview 
The Analysis menu contains operations that derive data and measurements from the graph. 
 
Histogram 

  
The Histogram function produces a histogram plot of the selected area. When a histogram is created, the 
sample points are sorted into “bins” along the horizontal axis that contain ranges of amplitude values. These 
bins divide the range of amplitude values into equal intervals (by default, ten bins) and the individual sample 
points are sorted into the appropriate bin based on their amplitude value. 
For instance, if a waveform had a range from 65 BPM to 85 BPM, the lowest bin would contain all data 
points with a value from 65 BPM to 67 BPM. The second lowest bin would hold all data points between 67 
BPM and 69 BPM, and so on, until the tenth bin was created. BSL PRO then counts the number of “hits” (the 
number of data points) in each bin and plots this number on the vertical axis. 
Analysis > Histogram Options: 
bins Determines how many bins the data will be divided into; the default is ten bins.  
Autorange  Fits all the data selected into a bin; the bin sizes are determined by the extent of the data and the 

desired number of lines. Automatically sets the center of the lowest bin equal to the minimum 
value of the waveform (or the selected area, if a section is highlighted), and centers the highest 
bin on the maximum value of the waveform (or selected area, if any).  

 Disable to fix the bin sizes and enter values for Highest Bin and Lowest Bin.   
After clicking OK, a histogram plot will be generated in a new window. By default, BSL PRO displays the 
frequency of occurrence for each bin on the vertical axis. To calculate the cumulative frequency, select the 
entire histogram waveform and choose Integrate from the Transform menu. 
Since the histogram function sorts sample points into a relatively small number of categories, the histogram 
window is likely to display a large number of “hits” in each bin, especially if data was collected at a relatively 
fast sampling rate. If this is the case, it may be helpful to resample the data at a lower rate (using the 
Transform > Resample function). The caveat to this is that resampling the data may cause a bias, unless the 
data was filtered to remove all frequency components that are more than 0.5 the resampling rate. 
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Power Spectral Density 

 

The Power Spectral Density (PSD) function extracts the 
power present at different frequencies within a signal and is 
useful for EMG analysis. The PSD transformation 
approximates the same result as squaring the linear FFT 
magnitude. PSD is not available when the horizontal units 
of the source graph are set to Frequency. 
BSL PRO uses the Welsh approximation algorithm to 
average signal time-sliced portions of the signal and reduce 
noise effect, and generates a two dimensional graph 
displaying the wattage of a particular frequency component 
in a signal. Windowing options are Hanning, Hamming, or 
Blackman. The graph is plotted as horizontal frequency vs. 
vertical (units)^2/Hz, where units are the vertical axis units 
of the source data.  

Use linear detrending for each window—when enabled, linear regression detrending is applied for each 
individual segment prior to the FFT computation; when disabled, windowing only is applied.  
Detrend each segment independently—becomes available when “Use linear detrending” is enabled. When 
this option is enabled, detrending is applied independently for each segment; when disabled, detrending from 
the previous segment will be incorporated into the next segment. 
FFT Fast Fourier Transformation 

 
The FFT algorithm requires that the length of the data be an exact power of 
two (i.e., 256 points, 512 points, 1024 points, and so on). 

The Fast Fourier Transformation (FFT) is an algorithm that produces a description of time series data in terms 
of its frequency components. This is related to the frequency spectrum. The FFT displays the magnitude and 
phase of the time series data selected and displays only the DC and positive frequency components; the FFT 
does not display negative frequency components. To reconstruct a signal from additive sines or cosines, it’s 
necessary to include both the positive and negative frequency components. Since it’s not physically possible 
to generate a negative frequency signal, it’s necessary to double the amplitude of the corresponding positive 
frequency component. 
The output from an FFT appears in a graph window with magnitude (vertical axis) plotted against various 
frequencies (horizontal axis). A large component for a given frequency appears as a positive (upward-
pointing) peak. The range of frequencies plotted is from 0 Hz to 1/2 the sampling frequency. Thus, if data was 
collected at 200 samples per seconds, BSL PRO will plot the frequency components from 0 Hz to 100 Hz. 
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Fourier analysis can yield important information about the frequency components in a data set, and can be 
useful in making determinations regarding appropriate data cleaning techniques (e.g., digital filtering). The 
FFT algorithm assumes that data is an infinitely repeating periodic signal with the end points wrapping 
around. Thus, to the extent that the amplitude of the first point differs from the last point, the resulting 
frequency spectrum is likely to be distorted as result of this start point to end point discontinuity. This can be 
overcome by “windowing” the data during the transformation. For more information on the windowing 
feature, see the window section that follows. 
The FFT transformation cannot be performed in real time (i.e., during an acquisition). To emulate an online 
spectral analysis, use online filters and the Input Values window. See page 208 for more information about 
real-time frequency information. 
 
Pad If a section of data is selected that is not a power of two, BSL PRO will always “pad” data up 

to the next power of two, filling in the remaining data point with either 
Pad with zeros: a zero 
Pad with endpoint: the last data point in the selected area 
In other words, if 511 data points are selected, BSL PRO will use a modified version of the 
waveform as input. The modified waveform will have 512 points, and the last point in the 
modified wave will be either a zero or equal to the 511th point of the original data. 

Show Mod. To view the modified waveform being used as input for the FFT, check the Show modified 
input box. Whenever possible, it is best to use an input waveform (select an area) that is an 
exact power of two. The waveform is modified by applying the windowing and padding 
options. Window functions diminish the discontinuities that occur at either end of the wave. 

 
Window The FFT algorithm treats the data as an infinitely repeating signal with a period equal to the 

length of the waveform. Therefore, if the endpoint values are unequal, the resulting frequency 
spectrum will contain larger than expected high frequency components due to the 
discontinuity. Windowing these data minimizes this phenomenon. For example, to apply a 
window transformation to a sine wave whose endpoints do not match up, check the box next 
to Window and choose a type of window from the pop-up menu. Each of the windows has 
slightly different characteristics, although in practice each provides similar results within 
measurement error.  

 As shown below, the frequency spectra of the windowed and non-windowed data differ 
significantly when the endpoints are unequal. When data are not windowed, the very low and 
very high frequencies are not attenuated to the same extent as when windowed. 
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Remove  Sometimes, data contains a positive or negative trend that can cause extraneous  
Trend  frequency components to “leak” into the frequency spectrum. In this case, select remove 

trend when performing the FFT, which will draw a line through the endpoints, and then 
subtract the trend from the waveform.  

For example, the 
following sine wave 
has an upward trend 
through the data 
(positive trend 
component). The lower 
graph shows FFTs of 
the skewed sine wave 
data with and without 
the trend removed. 
Note that the spectrum 
of the data without the 
trend removal has 
gradually decreasing 
frequency components, 
while the data with the 
trend removed has far 
fewer frequency 
components except for 
the single spike due to 
the sine wave. 

 

without trend removal

trend removed

 
Remove Mean  Remove mean calculates the mean of all the points in the selected area and then subtracts it 

from the waveform. This is generally useful for windowing a waveform that has a large DC 
offset. 

 As an example, start with a sine wave with a 10-volt DC offset (with a little noise added to 
broaden the spectrum), and perform spectral analysis with and without mean removal: 



Part C — Analysis Functions 287 

BSL PRO Manual 

 
 Note the large spectral components at the beginning of the top plot, without mean removal. 

This is due to the offset of the original data. The bottom plot is with mean removal. 
 Since the offset of the waveform is often an artifact of the way it was generated, the remove 

mean option provides a more accurate indication of the true spectral components. This is 
especially true for applications where low frequency components are of interest. If the data 
has a large DC offset and needs to be windowed, a more meaningful spectrum will result if 
the mean is removed prior to windowing (which is the same order the FFT uses). 

Linear By default, the FFT output is described in terms of frequency along the horizontal axis and 
dBV on the vertical axis. The Bell scale (from which dB are derived) is logarithmic, and in 
some cases it may be useful to have the output scaled in linear units. To do this, click the 
button next to linear and check OK. The other options in the dialog work as they normally do 
when the dB scaling option is selected. The relationship between log and linear units is: 
dBVout = 20 log VIN. 

Phase The standard FFT produces a plot with frequency on the horizontal axis and either dB/V or 
linear units (usually Volts) on the vertical axis. In some cases, it may be useful to obtain 
phase plots of the waveform (as opposed to the default magnitude plots). Phase plots display 
frequency along the horizontal axis, and the phase of the waveform (scaled in degrees) on the 
vertical axis. This option functions exclusive of the magnitude option—they can be checked 
independently, or checking both, two plots will be produced (a magnitude plot and a phase 
plot). 

 
Inverse FFT 

 

The Transform > IFFT menu option is generated after an FFT is 
performed. An Inverse FFT (Transform > IFFT) converts spectral 
values back to a time series waveform to reverse the FFT 
transformation. Any modifications to the original data (such as 
windowing or padding) will be shown in the resulting time series 
data. 
To obtain a meaningful IFFT result, a graph window must be open 
with at least one magnitude channel and at least one phase channel. 
With the window open, choose IFFT from the Transform menu to 
generate the Inverse FFT dialog. 

To accurately recreate the time series waveform  
1. Select the source channels for the inverse FFT in the Magnitude and Phase pull-down menus. 
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2. Select whether to express Magnitude in linear units or dB logarithmic units (decibels). To determine 
this setting, check the vertical axis units of the magnitude channel; this should correspond to the 
Magnitude scaling choice that was used when performing the forward FFT. 
 The Phase waveform must be in degrees. 

3. Click OK to perform the IFFT. 
 The result is generated in a new time domain window, labeled “IFFT of Spectral…” 

To perform an FFT, it may be helpful to start with an electroencephalogram (EEG) signal acquired when the subject 
alternated between eyes open and eyes closed. Typical results suggest that higher levels of alpha activity (activity 
with frequency components between 8Hz and 13Hz) are to be expected when a subject’s eyes are closed. 

1. The raw data, prior to FFT, is shown here: 
 Eyes

open
Eyes

Eyes
open

closed

 
2. Select Transform > FFT from the menu. 

The FFT Parameters dialog will be generated; in 
this example, the Window function chosen is 
Kaiser Bessel: 

 

 
3. Click OK. 

A frequency domain window (a graph window 
which places frequency along the horizontal axis 
rather than time) will be created and displayed, 
showing the spectrum of the input data. 
The window is named “Spectral of (the original 
window name)” and ends with the channel 
number, as shown here: 
The resulting magnitude value for each 
component is equal to the peak value of the sine 
wave contributing to that component. The entire 
pattern of frequency components is known as the 
frequency spectrum of the data. The somewhat 
erratic appearance of the spectrum is usually due 
to small-scale variations in the original waveform. 

4. Optional—This “noise” can be removed by 
applying a smoothing transformation to the FFT 
output. In the graph shown, there is a pronounced 
frequency component centered on 8Hz, which 
corresponds to the alpha wave frequency band 
(8Hz—13Hz). The frequency spectrum (0-20 Hz 
shown) used 20-point smoothing. 
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Find Cycle (Cycle/Peak Detector)  

 
Overview 
The advanced Cycle/Peak Detector combines with the powerful new Event Marking System. Use it to 
perform amplitude, time, or event-based measurements. New output options for measurements, averaging, 
events, and 3D surface (cycle data, histogram, and FFT). 
The Find Cycle detector uses three tabbed settings panels to define and automate cycle/peak detection: 

Cycles/Peaks Selection Output 
Cycle detector settings are graph-independent, which means that find cycle/peak operations can be 
performed in multiple graphs without needing to re-enter graph-specific settings for each run. By using 
multiple data views, different find cycle/peak operation can be performed on the same set of data without 
losing settings between “Find Next Cycle/Peak” operations. 
When the Cycle/Peak Detector is first opened for a graph, the dialog will be filled with the values from the 
last successfully executed find Cycle/Peak operation. Subsequently, changes to the settings will be applied 
only to that graph. 

TIP If running the cycle/peak detector multiple times and it’s necessary to put the edge back at the 
beginning of the waveform for the next pass, use the keyboard shortcuts Home, End, Page Up, 
and Page Down to quickly change edge location (see page 63). 

Cycles/Peaks tab 

  
Peaks Events 

 
Fixed Interval 
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Find Cycle controls available at bottom of dialog 

Find Next Cycle 

When selected from the Analysis menu (or select the toolbar icon or Ctrl+E), both edges will move one 
peak to the right while staying above the threshold.  
Find All Cycles in Graph 
When selected from the Analysis menu, Find Cycle setup dialog or selecting Ctrl+R,, the software will find 
all cycles/peaks through the end of the file. If the data file is very large, it may take some time to find all the 
cycles since BSL PRO loads data from disk while it scans for the cycles. 
Find in Selected Area 
When selected from the Analysis menu or in the Find Cycle setup dialog, only cycles within a selected area 
will be detected, all others will be ignored. 
Find All Cycles in Focus Areas 
If the graph contains defined focus areas, this option will limit cycle detection to focus areas only. If no focus 
areas are defined, this option will not be available. This is selectable via the Analysis menu or in the Find 
Cycle setup dialog. 
Find First Cycle 
Use this option to apply changes to the Find Cycle setup and locate the first cycle. This is selectable via the 
Analysis menu or in the Find Cycle setup dialog. 
About Find Cycle Preview 
Sometimes it can be difficult to predict exactly where cycles will be located as the detection parameters are 
changed. The Preview functionality offers an advance view of these selected areas via a separate resizable 
graph window. The overlay in the Preview updates dynamically as parameters in the Cycle Detector dialog 
are changed, and illustrates how the selected cycles would be modified during the actual Find Cycles 
operation. An additional thumbnail preview window can also be found under the Selection tab. 

 
Find Cycle Preview window 

 
Find Cycle definitions 
The Cycles/Peaks tab offers three general methods for 
establishing cycle parameters: 

 Peaks: Data driven maximum and minimum 
 Events 
 User-defined fixed time intervals 
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When the cycle location mode is switched on the “Cycles/Peaks” tab, the edge selection offsets will be 
checked. If they are non-zero, a prompt will generated to warn that that the edge adjustment offsets may not 
apply for the new cycle location mode. The user can reset the offsets to zero (default) or retain the (non-zero) 
settings used in the previous cycle location mode. 

Peaks 
Peak direction See the Peak definitions.  
Level Important usage note—Level is not set automatically when the Cycle/Peak detector is 

generated. (Automatic Level is used in previous versions of BSL PRO for Mac and current 
version for Windows.) 

Use selected... To optimize the threshold detection level for the selected area of data in the graph, click the 
“Use selected maximum/minimum” button underneath the level. If changing the source 
channel or peak direction, this option can be used to re-compute the recommended level 
based upon the new settings. 

Threshold Fixed—Keeps the threshold voltage level constant. 
 Tracking The Tracking threshold mode modifies the threshold after it finds a peak, depending upon 

the value of the new peak, and will compensate for a slowly drifting baseline. 

Hints regarding the use of Tracking Threshold Options 
• If data has a very consistent cyclical nature, either Tracking Option will work. 
• If data has spurious positive or negative peak values present, the Means Reference 

Tracking Option is probably a better choice. 
• If data has an erratic baseline, but consistently sized, positive and negative peaks, the 

Peaks Reference Tracking Option is probably a better choice. 

Tracking using mean value and % of peak value—Adjusts the threshold voltage level after 
each peak based on the average of the last cycle’s data and the specified percentage of the 
current peak voltage. The Means reference option will cause the software to determine the 
Mean Value of all the data, from peak to peak. This Mean Value establishes a variable 
reference upon which the tracking threshold operates. The software will determine the new 
threshold (NT) as follows: 

For Positive Peaks 
NT = Mean Value + (Positive Peak Value - Mean Value) x (% factor) 

For Negative Peaks 
   NT = Mean Value - (Mean Value - Negative Peak Value) x (% factor) 

 Tracking using % of peak value—Adjusts the threshold voltage level dynamically based on 
the specified percentage of the value of the most currently found peak. The Peaks reference 
option will cause the software to determine the Positive Peak Value and Negative Peak 
Value of all the data, from peak to peak. The Positive and Negative Peak Values establish a 
variable reference upon which the tracking threshold operates. The software will determine 
the new threshold (NT) as follows: 

For Positive Peaks 
NT = Neg. Peak Value + (Pos. Peak Value—Neg. Peak Value) x (% factor) 

For Negative Peaks 
NT = Pos. Peak Value - (Pos. Peak Value—Neg. Peak Value) x (% factor) 
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Events 
Event-based cycle location can extract information from events or define events based upon the output of the 
peak detector.  

Start / End Define the event; any of the predefined event types can be explicitly matched. To 
use only one event to define each cycle select the exact same event type for both 
“Start event” and End event,” and see the “Match Pairs” discussion below. 

Match pairs “Match pairs of events only” may be unchecked only when the Start event and 
End event are identical. Under this condition, if the box is checked, two such 
events are used to define one cycle. If the box is unchecked, then each event 
defines a cycle by itself. This is useful for adjusting a selection relative to an 
event, such as locating the first second prior to each event of a specific type. This 
option makes it possible to hit time periods for each event since each cycle 
consumes two events. 

Located on Specify the channel when the event must be defined, either its actual channel or 
“Global” for events not associated with any channel. Select “Anywhere” to search 
for events of specific types across channels. 

With Labels 
optional 

Toggle the “With labels containing text” checkbox to set this option. 
When checked, the matching event’s label must contain the text in the edit box to 
the right of the checkbox. 
 The text search is not case sensitive. The search must be non-empty for cycles 

to be located properly. 
When unchecked, the matching event can have any label, including none. 

The Cycle detector uses the following algorithm to search for cycles in the graph: 
1. From the starting point, find the first event matching the criteria of the Start event. This will be 

defined as the left event. If no event matches the Start criteria, no more cycles are in the file. 
2. If the Start event criteria match the Ending event criteria and zero width cycles are allowed (e.g. 

“Match pairs of events only” is unchecked), define the right event as identical to the left event and go 
to step 5. 

3. From the location of the left event, find the closest event matching the criteria of the End event. This 
will be defined as the right event. If no event matches the End criteria, no more cycles are present in 
the graph. 

4. Within the time region between the left and right events, search for any events that match the Start 
criteria. If such an event occurs, redefine the left event to be this matching event and repeat the step. 
If no event is located, then the closest pair of events has been located. 
 This step is useful for working with data that has missing portions of the sequence, as can come 

out of some classifiers. For example, if two event types A and B are used as the endpoints, a 
sequence of three events AAB will match the last two events as the cycle. This is logical in the 
case of physiological data where, if B should occur periodically in the signal, AA is an indicator 
of an abnormality or missed classification. 

5. Set the selected area to the time interval whose endpoints are the left and right events. 
6. Perform selection adjustment and output as indicated by the settings on the “Selection” and “Output” 

tabs. 
7. If “Find All Cycles” is being performed, return to step 1 and use the ending event location as the new 

starting point to find any remaining cycles in the graph. 

Fixed Interval 
See the interval definitions. 
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Selection tab 
Use the Selection tab to adjust the range of data that will be analyzed to generate any output. By default, the 
data range is set to be the entire cycle as located by the settings on the Cycle/Peak tab, but it can be adjusted 
to analyze only specific portions of the cycle. 
The controls on the Selection tab vary based on the settings on the Cycle/Peak tab 

Peak When the Cycles/Peaks location method is “Peaks,” the Selection can be adjusted based on the 
times of the peaks in the data or the times of the threshold crossings prior to the peaks. 

 
To perform analysis on the entire data within each cycle, the selection should be from the 
“previous peak” to the “current peak.” To examine fixed-width time windows located at each 
peak, use the “current peak” to “current peak” settings and adjust the two time offsets 
accordingly. Note that the settings must place the left edge earlier in time than the right edge for 
the peak detection to succeed properly. 

 
“Move Cursor To Origin” (at bottom left of screen) sets the graph data selection back to the first 
sample. Use this to reset the cursor in order to find all of the data in the graph. 

Event When the Cycles/Peaks location method is 
“Events,” the Selection can be adjusted based on 
the locations of the events that define the 
boundaries of a cycle.  
For a specific cycle, the starting event will be the 
event at the left boundary of the cycle and the 
ending event will be the event at the right 
boundary of the cycle. The starting event will 
never be located after the ending event in time. 
To analyze data over each entire cycle, use the “starting event” to “ending event” setting. To 
examine fixed-width time windows occurring within each cycle, set the left edge and the right 
edge to the same event (e.g. “starting event” to “starting event” for time windows at the 
beginning of each cycle) and adjust the offsets accordingly. Note that the settings must place the 
left edge earlier in time than the right edge for the peak detection to succeed properly. 

Fixed When the Cycles/Peaks location method is 
“Fixed time intervals,” adjust the Selection based 
on the endpoints of the time interval. 
To analyze the data over each entire interval, use 
the “previous interval” to “current interval” 
setting.  
To examine fixed-width time windows within 
each interval or only a sub-portion of each 
interval, use the “current interval” to “current interval” setting and adjust the time offsets 
accordingly. Note that the settings must place the left edge earlier in time than the right edge 
for the peak detection to succeed properly. 
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Output tab 

 

The Cycle/Peak Detector includes five Output 
options, which can be independently enabled: 
Measurements, Averaging, 3D Surface, Events 
and Focus Area. The selected output, if any, is 
listed at the top of the Output tab as Enabled 
output. 

 
Output Measurements 

 

Toggle each checkbox to enable/disable the option: 
 Paste measurements for each cycle to 

the Journal 
 Plot measurement results; display 

measurement values as channels in 
graph. 

 Save measurements to Excel 
spreadsheet file, plus output options. In 
order for spreadsheet output to be 
generated, a “Find All Cycles” operation 
is required.  

 Apply Measurement Preset – this option 
replaces the current measurement 
configuration with any of these 
selectable presets. 

NOTE: If the horizontal axis is in world time 
(HH:MM:ss), any time measurement exported to 
Excel will be reported in standard time units, such 
as seconds or minutes. 
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Output: Averaging—Offline 

 

Use Averaging Output” to perform offline 
ensemble averaging of source data or ensemble 
averaging of event locations. Specify the channel 
where the cycles/peaks are to be located in the 
“Cycles/Peaks” tab and specify the channel 
whose data should be ensemble averaged in the 
“Average” controls on the “Output” tab. 
Toggle the “Average channel events checkbox 
near the bottom of the tab to turn event averaging 
on and off. 
“Range of data average” is used to select the 
portions of data from which the averages are 
taken. 
Offline averaging can produce average locations 
of events within the defined cycle along with the 
average data. When a cycle is found, any events 
in that cycle will be noted. Events that are on the 
channel of data being averaged will be examined 
for inclusion in the average.  

Rejection Toggle the “Events must be in…” checkbox to turn rejection on and off, and specify a percentage 
for the relative number of cycles an event must appear in to be considered valid. 

Remove… When mean removal is enabled, the mean value of the data within each cycle is subtracted prior 
to including it in the overall signal average. This mean removal option is useful for: 

o Extracting signals that are “riding” on top of other signals with high DC offset (e.g., MRI 
artifact on top of skin temperature)  

o Compensating for baseline drift where there are not enough cycles present in the data for 
the baseline variation to completely cancel itself out.  

Output 3D Surface 
 

 

 

  
3D Surface Output options, 3D Surface image, and dialogs displayed if output options are not set properly 
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Toggle the “Generate a surface” checkbox at the top of the 3D tab to turn Surface Output on and off. 
1) Choose a channel to generate a 3D surface from. 
2) Confirm or establish the cycle period of interest on the channel. 

 Use the Cycles/Peaks tab and the Selection tab to adjust the threshold and cursor positions for the 
cycle period for 3D output. 

3) Choose a cross-section output format for the cycle data: cycle data, histogram, or FFT. 
 For histogram or FFT, click “Configure Transformation” to change the settings. 

4) Select surface and background colors. 
5) Set axis options. 
6) Click OK. 

Use the “Camera angle,” “x-axis range,” “z-axis range,” and “Zoom in/out” controls to manipulate the 3D 
surface image view. The x-axis and y-axis units will dynamically update as the image is re-oriented. See the 
following page for details about these controls. 

3D Output Example Compare ECG cycles in 3D Output. The following example shows how to BSL PRO 
will generate a 3D image using each cross section of ECG. 
a)  Cycles/Peaks tab: set the threshold level to identify each R-wave. 
b)  Selection tab: set the edges to 

Current Peak 
Left edge -.5 seconds 
Right edge .5 seconds 

c)  On the Output tab 
Enable 3D Output 
Specify the channel to generate a surface from. 
Choose “cycle data” for the cross-section format. 

d)  Click Find All Cycles. 
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3D Surface Controls: 
Camera angle: Controls position of 3D Surface image using four available preset angles. Allows quick 
access to the various angles. 

 Angle 1: Applies camera angle of -30/15 degrees 

 Angle 2: Applies camera angle of -120/15 degrees 

 Angle 3: Applies camera angle of 60/15 degrees 

 Angle 4: Applies camera angle of 150/15 degrees 

x-axis range: Adjusts minimum and maximum range of the vertical axis.  

 Left slider = minimum range  

 Right slider = maximum range 

z-axis range: Adjusts minimum and maximum range of the horizontal axis. 

 Left slider = minimum range  

 Right slider = maximum range 

Zoom in/out: Move the scrollbar to the left to zoom out and to the right to zoom in on the 3D Surface image. 

Click Print Preview… to access controls for printing the 3D surface image. 

Click Save As… to save the displayed image in *.jpg, *.png, or *.bmp format. 

Click Close to exit the 3D Surface view. 

Using the mouse to rotate the image: Right-click the 3D Surface image and hold to rotate the image 
vertically or horizontally. Maximum vertical rotation: 90 degrees. Maximum horizontal rotation: Unlimited. 
Selecting a sample: To select a single sample, place the mouse cursor over the 3D Surface and click the left 
mouse button. The sample selected by the mouse cursor will be highlighted with a blue sphere, after which 
the focus will switch to the graph containing the Find Cycle data. The blue sphere will be positioned at the 
selected sample and the elements of the selected sample will display below the 3D surface image.  
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3D Surface Settings: 

 
The following 3D Surface settings are available: 
Surface color… Opens a colorwell for selecting the color of the 3D 

Surface view. 
Background color… Opens a colorwell for selecting the contasting 

background for the 3D surface 
Display axis guides, units and segments per axis 
checkbox 

Shows or hides of the following elements:  
• • Axis guides: background division gridlines 
for 3D Surface view  
• • Volt and millisecond units  
• • Segments per axis is the gridline display. 
The number of visible gridlines to display can also be 
set here.  

 
If the “Display axis guides…” box is unchecked, the 
3D surface will appear as follows: 

Apply to all… Applies to the selected settings to all current 3D 
Surface views but does not change the default setting 
for subsequent views. 

Save as default… Saves the selected settings as the default for all 
current and subsequent 3D Surface views. 
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Output Events 

 

Toggle the “Output events” checkbox at the top 
of the Events tab to turn Event Output on and 
off. 
The Cycle/Peak Detector Output mode can 
define events at specific locations; a maximum 
of two events per cycle can be inserted with 
Event Output. After the Peak Detector has 
located a cycle and adjusted the selection, the 
data within that cycle can be analyzed and used 
to create new events in the graph (data-driven or 
time specific). 

Event definition 

   

 
Insertion method & 
channel selection 

Brief definitions follow, see the Event Location table on page 300 for details: 
At edge place the event directly at the specified edge (left or right). See Edge 
Adjustment on page 300. 
Percent change looks for a crossing based on a percentage of the value of the 
signal at the corresponding edge and places the event when a signal increases or 
decreases in value from the edge. 
% peak to peak change looks for a point where the signal's value has changed 
by a percentage of the maximum peak-to-peak amplitude distance over the 
selected area and places the event when a signal increases or decreases in value 
from the edge 
Minimum place events at the minimum of a specific channel's data within the 
selection. 
Maximum place events at the minimum of a specific channel's data within the 
selection 
The channel whose data should be examined is specified in the pull-down menu 
directly to the right of the insertion method pull-down menu: 

Output type For each insertion method, the “Output type” pull-down menu adjusts the event 
type of the inserted event. 

Output channel Sets the channel where the event is inserted, either “Global” for defining global 
events or specific channels. 
 None—disables any insertion for that event and all of the other controls 

will be hidden except the insertion method pull-down menu. 
 Interval start / Interval end—a pull-down menu is displayed to be used to 

change between the different offset methods 
 Minimum / Maximum  
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Output label Use this edit field to type in specific label text. Each event that is inserted will 

have its label set to this text. By default, it is empty (inserted events will not be 
labeled). 

Edge Adjustment When an “At location” method is used, options will be generated to fine-tune 
event placement relative to that (right or left) edge of the selection. 

Offset Underneath the insertion method pull-down menu, a set of controls will be 
added that allow the user to specify the percentage, choose whether to search 
for an increase or decrease, and choose the channel whose signal should be 
examined. 

 
When the offset method is “Threshold crossing,” the event will be placed when 
the signal on a channel crosses a threshold.  
There are a number of possible ways to configure the threshold crossing: 
 Fixed—The edit field may contain a specific voltage level for the threshold. 

In this configuration, an event will be placed if the value of the channel 
specified in the next pull-down menu crosses this fixed voltage value. 

 + value—The edit field may specify an offset from the value of the channel 
at an edge. The threshold voltage level is the value of the chosen source 
channel plus the offset from the edit field. To specify a threshold lower then 
the value of the channel at the edge, a negative sign can be placed before 
the offset. 

Direction of 
 crossing 

The direction of the crossing can be specified. 
 + (positive crossing)—the signal must approach the threshold from below 

and cross to above the threshold before an event is inserted. 
 - (negative crossing)—the signal must approach the threshold from above 

and cross to below the threshold before an event is inserted. 
 ± (mixed threshold)—an event will be inserted at the first positive or 

negative crossing that is encountered. 
Event Location Table 

Insertion Method Location Process 
Interval, at location Place an event at the left or right boundary of the selected area, as specified. 
Interval +/- percent 
offset 

Given a particular channel, place an event at the specified time within the 
selection when the signal increases or decreases by a specific percentage. 

Interval start + Place at the time closest to the left boundary of the 
selection. The percentage is calculated from the value of 
the signal at the left boundary of the selected area. 

Interval end - Place at the time closest to the right boundary of the 
selection. The distance between the event and the right 
edge of the selection will have an amplitude difference 
equal to the indicated percentage of the right edge’s 
value. 

If the signal does not increase or decrease by that percentage within the 
selection, no event will be inserted. 

Interval +/- percent 
peak to peak offset 

Given a particular channel, place an event at the specified time within the 
selection when the signal increases or decreases by a specific percentage of 
the peak to peak delta of the selected area. 
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Insertion Method Location Process 
Interval start + Place at the time closest to the left boundary of the 

selection. The percentage is calculated from the result of 
subtracting the minimum value of the signal over the 
selected interval from its maximum. 

Interval end - Place at the time closest to the right boundary. The 
distance between the event and the interval end of the 
selection will have an amplitude difference equal to the 
indicated percentage of the minimum value of the signal 
over the selected interval subtracted from its maximum. 

If the signal does not increase or decrease by that percentage within the 
selection, no event will be inserted. 

 
Interval +/- threshold 
crossing 

Starting at the specified boundary of the selection, determine a threshold 
value. This threshold voltage may be: 

 fixed voltage level 
 value of signal at the specified edge + offset 
 mean value in selected area + offset 

Interval start + Search for the first location where the signal on a 
particular channel crosses the threshold. 

Interval end - Examining data from right to left, search for the rightmost 
location where the signal on a particular channel crosses 
the threshold. 

If the direction of the threshold crossing matches the user specified direction, 
then an event is inserted. If it does not, then the next threshold crossing is 
located and the process repeats. If the threshold is never crossed within the 
selected area in the user-specified direction, no event is inserted. 

Minimum The event will be placed at the time location corresponding to a specific 
channel’s minimum value within the selected area. 

Maximum The event will be placed at the time location corresponding to a specific 
channel’s maximum value within the selected area. 

Output Focus Area 
Use this tool to define and highlight focus areas within the graph and include them in the Find Cycle output. 

 
Define focus areas at selection boundaries 

When checked, focus area output is enabled. Focus area selection boundaries will be defined as determined in 
the Find Cycle selection setup. 
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Label basename 

Use to assign a name or label to the cycles located in the focus area. The defined basename will appear in the 
focus area section of the graph, along with incremented numbers for each subsequent cycle. (See below) 

 

The following example details how to detect the positive spike in the QRS complex—a typical use of 
the Find Cycle (peak detection) function. 

Analysis > Find Cycle, Find next cycle, Find all cycles Icons:  Find Cycle    Find Next Cycle 
1. Select the area around a typical peak.  

 
2. Select Find Cycle. (Locate cycles from peaks). 
3. Enable “Use selected maximum” on the Cycles/Peaks tab to automatically set an appropriate threshold 

value based on the amplitude of the cycle detector. 
4. Click the Output tab and choose the desired option(s), such as paste measurement controls to update the 

journal with the measurement values from the new peak. 
5. Click a Find button. 

• Find first cycle – the cursor will blink at the first cycle point 
• To manually move through the file, click Find next 
• Or, select an area and choose Find all or Find in selected area. 
• Or, place the cursor in the data and Find all will detect cycles from that point forward. 

• Find all cycles will find all cycles from the beginning of the selected area to the end of the waveform. 
• Find in selected area will only find cycles in the selected area. 
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To use an offset 
Use the Selection controls to set a time window around the selected cycle; previous peak controls the left 
edge, Current peak has options to control the left and right edges.  
1. Use steps 1-4 above. 
2. Click the Selection tab. 
3. Set the desired edge values. 

• For example, to set the time window 0.5 seconds prior to the previous peak. 

 
To control the left and right edges, select current peak and enter the appropriate time window to define an 
interval around the cycle. 
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Find Rate 

  
The Rate Detector is critical to BSL PRO’s ability to extract information from physiological data that has a 
degree of periodicity. Physiological data that can be investigated using the BSL PRO Rate Detector includes: 

• ECG (e.g. Heart Rate or Inter-Beat-Interval recording) 
• Blood Pressure (e.g. Systolic, Diastolic, Mean, dP/dt Max, dP/dt Min) 
• Respiration (Respiration Rate measurement) 
• EMG (Zero Crossing or Mean Frequency analysis) 

The Find Rate function allows rate calculations (including BPM) to be computed for data that has already 
been collected. Although this function uses the same algorithm as the online rate detector (which uses a 
Calculation channel), it can be advantageous to perform rate calculations after the data has been acquired. 
One benefit is that off-line rate computations do not require that a separate channel (i.e., a Calculation 
channel) be acquired. Since the number of acquired channels is reduced, other data can be collected and/or 
data can be sampled at a higher rate. 
Rate detector settings are graph-independent, which means that find rate operations can be performed in 
multiple graphs without needing to re-enter graph-specific settings for each run. By using multiple data views, 
different find rate operations can be performed on the same set of data without losing settings between “Find 
Rate” operations. When the Rate Detector is first opened for a graph, the dialog will be filled with the values 
from the last successfully executed Find Rate operation. Subsequently, changes to the settings will be applied 
only to that graph. 
Modes of Operation 
The Rate Detector incorporates a significant amount of flexibility to optimize performance when extracting 
data from periodic physiological waveforms. There are three basic modes of operation for the Rate Detector: 

1) Fixed threshold detect mode 
2) Auto threshold detect mode (enables Noise rejection) 
3) Remove baseline and Auto threshold detect mode 

The Rate Detector will eliminate certain options when selecting different modes of operation. 
• The Remove baseline function always uses the Auto threshold detect mode. 
• Any cyclic measurement relating to amplitude (e.g. Peak-Peak, Maximum, Minimum, Area, 

Mean) automatically turns off the Remove baseline function. 
• If the measurement pertains directly to time (e.g. Hz, BPM, Interval, Peak Time, Count Peaks) 

the Remove baseline and Auto threshold detect modes are both operational. 
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Generally, it’s best to use the simplest Rate Detector mode that is suitable for the current application. If the 
simplest mode doesn’t work, add layers of sophistication, one at a time. For example: 

• If the Fixed threshold mode can’t or will not work, use the Auto threshold detect mode. 
• If the Auto threshold detect mode is similarly unavailable, adjust the Noise rejection or add the 

Remove baseline option (if possible). 
• If the Auto threshold detect mode is similarly unavailable, adjust the Noise rejection or add the 

Remove baseline option.  
 

If the Auto threshold detect mode is similarly unavailable, adjust the Noise rejection or add the Remove 
baseline option.  

1) Fixed threshold detect mode: 
Fixed threshold detect mode is the simplest mode of operation for the 
Rate Detector. As shown here, the Threshold Level has been set to 
0.00 Volts. If the waveform crosses 0 Volts, the Detector will begin to 
look for Positive or Negative peaks (based on the Peak detect setting). 
Not available in Fixed mode: 
• Noise rejection 
• Windowing options 
• Output reset events  
 
 
 
 
 
 
 
2) Auto threshold detect mode:  
Auto threshold detect mode is a more advanced and flexible mode of 
operation for the Rate Detector. In this case, the Rate Detector will 
create a variable threshold defined as: 
 Positive peak search 
  0.75 • (Old Peak Maximum - Old Peak Minimum) 
 Negative peak search 
  0.25 • (Old Peak Maximum - Old Peak Minimum) 
Furthermore, the Rate Detector will construct a moving file of data 
points defined by 1.5 times the number of samples that can be placed 
in the largest rate window size (defined by the Window settings). If 
the Rate Detector loses sync (no trigger event inside the window), the 
threshold is changed to the mean value of the moving file of data 
points. This operation permits successful recovery in the event 
of spurious waveform data values. 
The Noise rejection setting creates Hysteresis around the variable 
threshold. The Hysteresis level is defined as: 

Hysteresis = Noise rejection (%) • (Old Peak Maximum - Old Peak Minimum) 
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3) Remove baseline and Auto threshold detect mode: 
Remove baseline and Auto threshold detect mode is an 
advanced and flexible mode of operation for the Rate 
Detector. Primarily, the Rate Detector performs an 
automatic (and hidden) moving difference function on the 
waveform data. The difference function is performed over a 
variable number of samples defined by: 
# of points over which difference is performed = 
  0.025 • Sampling Rate 
This difference waveform is then passed through the 
variable threshold: 
Positive peak search =  
0.75 • (Old Peak Maximum - Old Peak Minimum) 

Negative peak search =  
0.25 • (Old Peak Max - Old Peak Min) 
Furthermore, the Rate Detector will construct a moving file of 
data points defined by 1.5 times the number of samples that can 

be placed in the largest rate window size (defined by the Window settings). If the Rate Detector loses sync (no trigger 
event inside the window), the threshold is changed to the mean value of the moving file of data points. This operation 
permits successful  recovery in the event of spurious waveform data values. 
 

FIND RATE OPERATIONAL SUGGESTIONS 

Option Waveform Characteristics 

Fixed threshold option • waveform data has clearly defined positive or negative 
peaks (like respiratory or air flow data), which are 
consistently higher (in magnitude) than the rest of the 
waveform. 

• waveform data has clearly defined zero-crossings (like 
EMG), and it’s necessary to determine the rate of these 
crossings 

Auto threshold detect option • waveform data has a moving baseline, but the peaks are 
otherwise larger in magnitude than other parts of the 
waveform (blood pressure). 
It may be necessary to adjust the Noise rejection 
(Hysteresis) to optimize performance. 

Remove baseline and 
Auto threshold detect options 

• waveform data has high narrow peaks (like most ECG 
leads), which may or may not be larger in magnitude than 
other (slow moving) parts of the waveform. 
It may be necessary to adjust the Noise rejection 
(Hysteresis) to optimize performance. 
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Signal type 

The Signal type menu contains parameters for specific human 
and animal waveform morphologies. All pre-defined and 
custom signal types are common to both calculation channel 
Rate (online) and analysis Rate (offline) dialogs. Signal type 
modifications affect settings in the Signal Parameters tab only, 
and do not affect the Output tab settings. 
Select from six pre-configured signal types or click “New” to 
create, name and save custom setups. This allows quick access 
to frequently used Rate detection signals without the need to 
recreate modified settings. Custom Rate signal types may be 
added or deleted in the same manner that channel presets are in other areas of the BSL PRO application. 
Peak detect 

By default, the Peak Detector searches for Positive peaks (upward pointing, such as the R-wave of an ECG signal) 
to calculate the rate of a waveform. In some instances, however, it may be necessary to base the rate calculation on 
negative peaks (downward pointing). To do this, select Negative peak. 

Remove baseline 
The Remove baseline option applies the optimal high pass filter based on the other settings. This option is useful 
when signals have a slowly fluctuating baseline. 

Auto Threshold Detect 
When the Auto threshold detect box is selected in the Find Rate dialog, BSL PRO automatically computes the 
threshold value using an algorithm that accentuates peaks and uses information about the previous peak to estimate 
when and where the next peak is likely to occur. This threshold detector is typically more accurate than a simple 
absolute value rate calculation function, and is able to compute a rate from data with a drifting baseline and when 
noise is present in the signal. (For a detailed description of how the calculation is performed, contact BIOPAC 
Systems, Inc. for the complete Application Note.) 
 When Auto threshold detect is enabled, the Noise rejection and Window options are enabled. 

Threshold level 
This option (activated when “Auto threshold detect” is not selected) 
allows entry of a threshold level to be used for a simple absolute value 
rate calculation function. 
 The Auto threshold detect option is typically more accurate.  
 

Noise Rejection 
Noise rejection (activated when “Auto threshold detect” is enabled) 
constructs an interval around the threshold level. The size of the interval 
is equal to the value in the “Noise rejection” text box. Checking this 
option helps prevent noise “spikes” from being counted as peaks. 
 The default is equal to 5% of the peak-to-peak range. 
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Cycle Interval Window (Peak Interval) 
Window is used to specify an upper and lower limit 
for the Rate calculation. Window is activated when 
“Auto threshold detect” is enabled; the Windowing 
Units pull-down menu is only activated when the 
selected Function can have variable units. 
Setting the upper and lower bounds for the “window” 
tells BSL PRO when to start looking for a peak. 

 

BSL PRO will try to locate a peak that matches the 
automatic threshold criteria within the specified window. 
If no peak is found, the area outside the envelope will be 
searched and the criteria (in terms of peak value) will be 
relaxed until the next peak is found. 
For instance, once the first peak is found, BSL PRO will 
look for the next peak in an interval that corresponds to 
the range set by the upper and lower bounds of the 
window. The interval associated with the upper band of 
180 BPM is 0.33 seconds (60 seconds ÷ 180 BPM), and 
the interval for the lower band is 1.5 seconds (1 minute ÷ 
40 BPM). If a second peak is not found between .33 
seconds and 1.5 seconds after the first peak, then BSL 
PRO will look in the area after 1.5 seconds for a 
“smaller” peak (i.e., one of lesser amplitude). 
For those rate functions that require a window interval in 
seconds, it may be necessary to enter numbers like .33 
seconds and 1.5 seconds (which correspond to the BPM 
defaults of 40 and 180). These numbers will be suitable 
for detecting the heart rate of an average subject. 

 

 
A simple peak detector uses what is called a threshold-crossing algorithm, whereby each time the amplitude 
(vertical scale) value exceeds a given value, the peak detector “remembers” that point and begins searching for the 
next event where the channel crosses the threshold. The interval between the two occurrences is then computed and 
usually rescaled in terms of BPM or Hz. This is how the BSL PRO rate Calculation functions when all options are 
unchecked. 
In the sample waveform shown here, the threshold was set to 390 mV to detect the peaks of the waveform and 
provide an accurate rate calculation. Since it only recognizes signals greater than 390 mV as a peak, this 390-mV 
threshold is referred to as an “absolute threshold.” Most waveforms are not so well behaved, however, and artifact 
can be introduced as a result of movement, electrical interference, and so forth. Combined with actual variability in 
the signal of interest, this can result in “noise” being included with the signal, as well as baseline “drift“ which can 
render absolute threshold algorithms useless. 
 

Defaults:  Min 40 BPM 
  Max 180 BPM 
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Additional Find Rate Dialog Settings, Output Tab 

  
Function 

The Rate Detector Function menu lists a variety of calculations, which are discussed below. 
Rate (Hz), Rate (BPM), Interval (sec) 

The most commonly used function is the Rate (BPM) option, which calculates a rate in terms of beats per 
minute or BPM. Rate calculations can also be performed that return a rate value scaled in terms of frequency 
(Hz) or time interval (sec). When rate is reflected in terms of a time interval, the time difference (delta T) 
between the two peaks is returned. This is sometimes referred to as the inter-beat interval (IBI). The 
frequency calculation returns the rate in Hertz (Hz), which is computed by dividing 1 by delta T. These 
measurements are perfectly correlated with the BPM calculation, since BPM is equal to 60 times the 
frequency calculation, or 60 divided by delta T. 

Peak time 
Returns the time (in seconds) at which the peak occurred. Like the other Rate functions (e.g., BPM and Hz), 
the value of the last peak time will be plotted until a subsequent peak is detected. The resulting plot will 
resemble a monotonically increasing “staircase” plot. 

Count peaks 
Produces a plot of the number of peaks (on the vertical axis) vs. time on the horizontal axis. When used with 
the delta measurements (in the measurement windows), this is a convenient way to calculate how many peaks 
occur within a selected area. 

Peak maximum/minimum 
Tracks the maximum value of the peak (the ECG R-wave). This correlates to the systolic pressure in blood 
pressure readings. To search for minimum peak values, select negative from the Peak detect section of the 
dialog.  

Peak-to-peak 
Looks at the vertical difference between the maximum and minimum values of the waveform on a cyclical 
basis—useful for determining the amplitude of the pulsatile signal. 

Mean value 
Computes the mean of a pulsatile signal on a cycle-by-cycle basis between two peaks; produces a staircase 
plot. 

Area 
Computes the area of the signal between two peaks, on a cycle-by-cycle basis.  
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Use Averaging Mode 
Use this option to average the output of the selected function using values based upon a fixed time window or a fixed 
number of cycles. If the average is taken from a fixed number of cycles, there is an additional option to recompute on 
every cycle. When unchecked, the output will be reset after the selected number of cycles are detected and remain 
fixed until the next group cycles are detected. When checked, the output will start after the first cycle is detected and 
will then be refreshed on every cycle. 
Output reset events 

This option controls the definition of reset event insertion into the graph. 
If no thresholds are found within the user-specified window width, the automatically detected threshold level will 
“reset” and tracking will start anew; the output of the rate detector function may also drop to zero. When “Output 
reset events” is enabled, a reset event will be added to the channel whenever the threshold is reset due to window 
expiration 
 This helps distinguish zero-valued output due to 

window resetting and true zero-value output. 
In the sample shown, the signal drops to zero during a 
period of analysis (e.g., due to lead clip falling off). 
Reset events indicate automatic threshold tracking was lost 
in this interval and the points where the search for a 
new level begins. 

 
Put Result in New Graph 

When this option is checked, the results from the find rate calculation are plotted in a new graph window with data 
displayed in X/Y format, with time on the horizontal axis. By default, this option is unchecked and the resulting 
transformation is placed in the lowest available channel of the current graph. 
NOTE: When put into a new waveform or used as a calculation channel, the output rate function uses padding to 
generate a signal at a continuous sampling rate. The extracted value is used for padding until the next cycle is 
detected. This padding can cause unsuitable weighting for statistical analysis. For accurate statistical analysis with 
only one value for each cycle, use the offline rate detector "show output in new window" to produce a "value" 
waveform with one output point for each cycle. This output is suitable for export to Excel or other software for 
statistical analysis. 

Find Rate of Entire Wave 
When this option is checked, the rate (or other function from the Find rate command) will be calculated for the 
entire wave (other than the selected area, if any). 

Don’t Find 
Saves dialog settings on order to close out of the dialog and select an area. When the dialog is reopened, the earlier 
settings will be retained, after which the OK button can be clicked to perform the Find Rate function. This is useful 
for setting parameters using an area of a waveform and then repositioning the cursor at another point in the record. 
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Detect and Classify Heartbeats 

 
This robust QRS detector is tuned for human ECG Lead II signals. It attempts to locate QRS complexes and 
places an event near the center of each QRS complex to identify the type of heartbeat event: 
 Normal The beat was recognizable as a valid heartbeat falling in a human heartbeat rate. 
 PVC The beat was shorter than the beats around it and may be a pre-ventricular contraction. These events can 

be found in the “Hemodynamic > Beats” submenu of the event type listing. 
 Unknown The beat wasn’t recognizable as a valid heartbeat. This may occur on the first beat prior to the QRS 

detector locking onto the signal. It may also occur if tracking is lost due to changes in signal quality. 
The Cycle/Peak detector may be used with these events to perform further cardiac analysis. 

Locate ECG Complex Boundaries 
IMPORTANT: The ECG Complex Boundaries and Heart Rate Variability algorithm requires an ECG Lead II 
waveform in order to yield accurate results. When using a Lead I / Lead III waveform as a data source, use the BSL 
PRO Find Cycle feature to output QRS peak events into the data before using Multi-epoch HRV Statistical Analysis. 

ECG Lead II configuration: Left Leg or lower left rib (RED = Vin+) and Right Arm or clavicle (WHITE = Vin-) 

   
For detailed information about ECG Lead Configurations see BIOPAC Application Note 109. 

 
Locate ECG Complex Boundaries performs ECG waveform boundary detection for human ECG Lead II signals; 
ECG signals must be sampled at 5 kHz or below to be analyzed with this classifier. It will attempt to locate the 
boundaries of the QRS, T, and P wave and will define events for each individual complex. It will attempt to insert 
the following events; all of these complex boundaries can be found in the “Hemodynamic > ECG Complexes” 
submenu of the Event Type listing. 

https://www.biopac.com/wp-content/uploads/app109.pdf
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Wave Type Event Placement & Description 
QRS Onset 

Peak 
End 

Before the beginning of the Q wave 
At the top of the R wave 
After the end of the S wave 

T-wave Onset 
Peak 

At the onset of T 
At the peak of the T wave 
Note: This may not be a positive peak if the T-wave is inverted. If the T-wave seems 

to be bi-phasic, two T-wave events will be inserted and the event description 
will indicate that the T-wave is bi-phasic. 

 End At the end of T 
P-wave Onset 

Peak 
At the onset of P 
At the top of the P wave 

Note: This may not be the absolute maximum, but rather the likely center of P. 
 End At the end of P 

The Cycle/Peak detector may be used with these events to perform further cardiac analysis. 
Please note that the algorithm was developed and tested primarily with data sampled at 1000 samples per second. 
The filters incorporated by the algorithm were designed for such data. If the algorithm is presented with data 
acquired at other sample rates, localization of ECG features or even entire cardiac cycles may not be optimal. 
Consider resampling data acquired at other rates to improve accuracy. 

Locate Animal ECG Complex Boundaries 
Locate Animal ECG Complex Boundaries optimizes the ECG waveform boundary detection for animal input. 
Smaller animals such as mice often lack a detectable T wave, so in the setup dialog the T wave boundaries are 
disabled by default. If appropriate to the experiment, T wave detection can be applied by enabling the “Define T 
wave boundaries” checkbox. The average heart rate can also be customized to reflect the normal range of a 
particular animal subject. (The default rate is 600 BPM.) 
For information about the algorithm used in Locate Animal ECG Complex Boundaries, see page 324. 

 See the Locate Animal ECG Complex Boundaries video tutorial for a detailed explanation of this feature. 
 

Heart Rate Variability 

New parameter settings for the HRV algorithm function better on shorter ECG signals 
and correspond more closely with other implementations. 

  

http://www.biopac.com/video/?video_category=acqknowledge-new-features&v=locate-animal-ecg-complex-boundaries-in-acqknowledge
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Heart rate variability is the examination of physiological rhythms that exist in the beat-to-beat interval of a cardiac 
signal. Heart rate variability assists in performing frequency domain analysis of human ECG Lead II data to extract 
standard HRV measures. The HRV algorithm in BSL PRO and above conforms to the frequency domain algorithm 
guidelines as published by the European Heart Journal. HRV processing in BSL PRO consists of three stages: 

1. The RR intervals are extracted for the ECG signal. 
 A modified Pan-Tompkins QRS detector is used. 

2. The RR intervals are re-sampled to a continuous sampling rate in order to extract frequency information. 
 Cubic-spline interpolation is used to generate this continuous time-domain representation of the RR 

intervals. 
3. The frequency information is extracted from the RR intervals and analyzed to produce standard ratios. Power 

sums are reported in units of sec2. 
 A Welch periodogram is used to generate the Power Spectral Density (equivalent to Transform > Power 

Spectral Density). 
The initial implementation of the HRV algorithm was primarily for use with long duration recordings. HRV algorithm 
improvements allow for further customizations to the algorithm:  
 Windowing type for FFTs used to construct the PSD may be changed between Hamming, Hanning, and 

Blackman  
 Overall window length for segmenting source data for individual FFTs to include in PSD average may be 

modified  
 Length of the individual FFTs in the average can be manually specified  
 Scaling has been changed for PSDs, which are now scaled relative to the sampling frequency  
 Summary of power in individual frequency bands has been changed  
 Instead of a straight sum, an average power value is now reported  
 Power at endpoints is halved (e.g. divided by 2)  
 Sympathetic/Vagal ratios may optionally include the very low frequency band in the total power estimate  
 The modifications to the HRV algorithms that affect its power spectrum estimation have also been applied to 

the PSD transformation.  
After selecting Analysis > Heart Rate Variability, choose the appropriate tab(s) and establish settings.  
Preset controls, Transform entire wave checkbox, and OK/Cancel buttons apply across all of the tabs.  

Preset—The preset menu can be used to save a variety of HRV settings, including: beat detection parameters, 
spline resampling frequency, and frequency band ranges. Choose a preset from the popup menu to apply its 
settings. To construct a new preset with the currently displayed settings, choose Add New Preset. A default preset 
for adult human subjects is supplied. 

________________________________________________________________________________________ 
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IMPORTANT—Recording good data is essential for performing HRV analysis. The protocol for data acquisition, 
filtering, artifact detection and correction in Application Note 233 results in great improvements in HRV analysis.  

“Results reveal that even a single heart period artifact, occurring within a 2-min recording epoch, can lead to 
errors of estimate heart period variability that are considerably larger than typical effect sizes in 
psychophysiological studies.” —Berntson & Stowell, 199 
• See Application Note 233 Heart Rate Variability—Preparing Data for Analysis Using BSL PRO 

(online at www.biopac.com) 
The note explains how to optimize ECG R-R interval data for Heart Rate Variability studies by using a template 
matching approach. It also explains how to identify erroneous R-R interval values caused by signal artifact and shows 
methods for correcting the errors by using the tools in the BSL PRO software. The note explains how to:  

A. Record good ECG data 
B. Prepare data for the tachogram  

1. Filter the ECG data 
2. Transform the data using Template Correlation function  

C. Create a tachogram  
D. Identify problems with the tachogram data  
E. Correct tachogram data  

________________________________________________________________________________________

http://www.biopac.com/
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RR intervals 
Select a method to locate R waves: QRS Detector or Events. 

QRS detector 

 
The heart rate variability implementation has a built-in QRS detector. The detector does not run on raw source 
data; it uses a modified Pan-Tompkins algorithm to normalize the ECG data to 1, whereby the peak amplitude of 
the highest R-wave represents 1. Use the tachogram output to examine the output of the QRS detector. 
 R wave threshold—Starting with BSL PRO, the detection threshold must be specified in terms of percentage 

of maximum R peak level; this helps to clarify the units in which this threshold is expressed. The default 
threshold level of .5 should place the threshold in the middle of the R-wave, which should function on a wide 
range of data sets. If the R-wave amplitude varies a lot, it might be necessary to adjust the threshold level. 

o R wave threshold is expressed in normalized units, which are in the range (-1, 1): positive for 
positive R wave peaks. The maximum voltage in the signal maps to 1.0 and the minimum voltage 
in the signal maps to -1.0. 
Pan J and Tompkins WJ. A Real-Time QRS Detection Algorithm. IEEE Transactions on 
Biomedical Engineering 32(3):230-236, 1985.  

Events 

 

R-wave peaks will be located using events already in the graph of the channel of data to be analyzed. This 
assumes a single event is placed at each R-wave peak and that all of the R-peak events are of the same event type. 
When using events, the buit-in QRS detector is not used; the exact positioning between the events on the channel 
is used to extract the RR intervals.  

By using events, it is possible to use other QRS detectors within BSL PRO for performing HRV analysis. It is 
also possible to apply spectral HRV-style analysis to data in other domains as long as intervals can be reduced to 
events. 

Spline resampling frequency 

For highest accuracy, set to no less than twice the topmost frequency of the very high frequency band. 
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Frequency Bands 

 
Enter the start and end of each specified frequency band to adjust the boundaries of the frequency analysis. They 
are preset to the frequency ranges recommended by the European Heart Journal. Output of derived parameters is 
presented in a dialog and may also be pasted as text to the Journal. 

 Very high frequency band, usually used in rat studies, is disabled if the spline resampling frequency is less 
than the upper bound of the very high frequency range. 

 

PSD Options 

 
PSD Options establish parameters for the power spectral density transformation used to compute the spectrum 
from the interpolated tachogram; the options contained in this tab mirror the controls of the Analysis > Power 
Spectral Density transformation. 

The use of linear detrending in each individual segment of source data prior to the windowed periodogram 
analysis can be enabled or disabled. When disabled, the algorithm may be tuned to correspond to 
implementations that do not apply linear trending, such as MATLAB, which uses windowing only. The same 
PSD options are available via Analysis > Power Spectral Density so users can regenerate the spectrum from 
either the raw or interpolated tachogram output as necessary. 

After the user modifies the parameters for the PSD transformation, those parameters will become the new 
default values each time the dialog is displayed. When the application is relaunched, the default settings will 
be used (user changes are not persistent). 
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Window Used to change the window that is applied to each segment of the source data prior to 

computing the PSD to be included in the average. Includes the following options: 
Hamming Hanning Blackman 

Window size The specified number of samples must be a power of two. Note that the window function is 
applied to the entire window width of the data; using a subset of the windowed data will not 
include the final portion of the windowed data. 

 If the FFT size is less than the window size, only a subset of the windowed sample data 
will be used.  

Automatic If selected, the window size is selected automatically depending on the size of the 
source data. For a data length of n samples, choosing this radio button will use the 
window size: 

L =
n

4.5  

Manual If selected, the window size will be input manually by the user in the associated 
edit field. The window size must be greater than three and must be less than the 
length of the data selection. Users will be warned on invalid window sizes when 
attempting to click OK. 

Overlap length After each individual FFT, the window of source samples is shifted over by a certain amount to 
compute the next FFT, so there is an overlap of source samples in successive windows of 
source for the next FFT in the average. 

Automatic If selected, the number of samples to overlap successive windows will be 
computed automatically. Given a window length L computed according to the 
window width choices, choosing this radio button will use an overlap number of 
samples:  

L
2  

Manual lf selected, the number of samples to overlap successive windows of source data. 
Overlapping reduces windowing artifacts The overlap length must be positive and 
must be less than the window size. Users will be warned on invalid overlap lengths 
when attempting to click OK 

FFT width Automatic If selected, the number of points to use for each individual FFT will be computed 
automatically. Given a window length L computing according to the window width 
choices, the number of points in the FFT will be set to: 

 
 The number of points in the FFT is set to 256 if the window width is less than 

256. Otherwise the length is set to the next power of two higher than the 
window width. 

Manual  If selected, the number of points in the FFT will be specified manually in the edit 
box to the right of the radio. The number of points in the FFT will be required to 
be a positive power of two. It is recommended that the FFT length be set larger 
than the window size. If longer than the window size, zero point padding is used. 
Users will be warned on invalid FFT number of points when attempting to click 
OK. If the user inputs a number of points for the FFT that is shorter than the 
window width, a confirmation dialog will be displayed to the user warning that the 
windowing is shorter than the requested FFT width and asked if they want to 
continue. 
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Use linear 
detrending for 
each window 

When enabled, linear regression detrending is applied for each individual segment prior to the 
FFT computation. When disabled, windowing only is applied. 

Detrend each 
segment 
independently 

This option is only available when “Use linear detrending” is enabled. When this option is 
enabled, detrending is applied independently for each segment; when disabled, detrending 
from the previous segment will be incorporated into the next segment. 

Transform 
entire wave 

When enabled, the entire waveform is delayed. When unchecked, only the selected area is 
delayed. 

 If there is no selection in the graph, the checkbox is enabled and dimmed. 

 As the selection changes in the graph with the selection palette, the state of this checkbox 
is updated. 

Output 

 
Create standard result presentation graphs or assess 
performance of the HRV algorithm. Output options 
allow access to intermediate computation data for 
algorithm validation and/or measurements.  

 
RR Interval table 

• If the combined output formula is selected, the analysis output will contain an additional line of text:  “VLF 
Ratio” with the corresponding percentage. 

Spectrum 

Displays the power spectrum density (PSD) estimation from which the PSD summations and 
sympathetic/vagal ratios are computed. 

Raw tachogram 

Plots the raw R-R intervals found by the QRS detector. Perform statistical HRV measures on the R-R 
intervals without exporting the textual R-R table to excel. 

Interpolated tachogram 

Plots the resampled R-R intervals after cubic spline interpolation is applied and extracts the PSD from 
this data. 

Unknown Author
Bug 13247
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Correlation Coefficient 

   
The correlation coefficient is a statistical measure related to the degree of variance or covariance between two data 
series. Given two data series x and y of length n, the correlation coefficient r is given by the formula: 

 (see http://mathworld.wolfram.com/CorrelationCoefficient.html) 
The square of the correlation coefficient can be used to determine the proportion of variance in common between the 
two signals. As the square gets closer to 1, the signals are a better statistical match for each other. 
To derive the correlation coefficient, two channels of data are compared against each other. 

• the channels must have the same length 
• the channels must have the same waveform sampling rate 
• A selected range of graph data for the two channels will be used to compute the correlation coefficient. 
• The entire focus area or entire waveform of the two channels can also be used to compute the correlation 

coefficient. 

Digital Input to Stim Events 

Digital Input to stim events identifies and labels stimulus events corresponding to any combination of digital inputs. A 
light bulb icon is placed in the global events bar, the event is labeled with the stimulus event type, and the mouse-over 
tag includes the event time. All event information is accessible and exportable from the Event Palette. 

 
The Digital input to stim events function works with TTL trigger information coming from applications such as E-
Prime®, SuperLab®, DirectRT®, MediaLab®, Inquisit®, and Presentation. It converts TTL data acquired on the 
digital channels of a hardware device into stimulus events. The system also works with analog and calculation channel 
signals coming from switch transducers. Unlike TTL signals, a voltage threshold level is used to determine the 
transition from low to high.  

http://mathworld.wolfram.com/CorrelationCoefficient.html
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“Specific channels only” dialog 

 

This analysis option converts TTL or switch data acquired on hardware into stimulus events. Stimulus delivery events 
are defined in the graph for each low to high transition of the digital data, the indications of stimulus delivery. The 
digital channels are interpreted as a binary number. Each stimulus event placed into the graph has the corresponding 
number included with its label. This allows further analysis to distinguish 
between different types of stimulus events by using the Cycle Detector’s 
label matching capability. 

  
Digital line decoding can be two byte (using all 16 digital lines) or single 
byte (on either the low eight or high eight digital lines). Big endian bit 
and byte ordering are used, with digital line 0 representing the least 
significant bit. 
When the stimulus labels are constructed, all numbers are zero-prefixed. 
All stimulus events will have the same number of base-10 digits with leading zeros, regardless of magnitude. This 
provides each stimulus event type with a unique label that can be used with the Cycle Detector (which uses substring 
matching). 
Some systems that trigger digital lines such as parallel ports may not be able to do so instantaneously; they may 
require a time window before the transition from one state to another is fully complete. A “transition latency” time 
window can be given to the analysis, specified in microseconds, 
milliseconds, seconds, minutes, hours, or samples. 
 If non zero, any transitions that are separated by less than this 
latency are treated as a single transition and only one stimulus 
event is inserted. The decoded value used for the transition is 
the maximum value observed during the transition latency 
window. In the following example graph, the three digital TTL 
inputs correspond to one event, as marked by the red icon in the global events bar. A transition latency of .5 seconds 
will consider all three as part of the same event since the transitions occur within .5 seconds of each other.  

 
 Watch the Digital Input to Stim Events video tutorial for a detailed demonstration of this feature. 

http://www.biopac.com/video/?video_category=automated-analysis-demos&v=digital-input-to-stim-events
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Ensemble Average 

   
Ensemble Average assists in performing offline averaging. Offline averaging produces an average waveform from 
a number of cycles, also known as an ensemble average. Averages of multiple channels can be extracted 
simultaneously and be consolidated into a single graph window showing the results. 
This option provides two methods for locating individual members of the ensemble. 
 Peaks: Data-driven peak detection with positive or negative peaks in the data. This method automatically 

derives appropriate threshold levels from a user-selected peak and is useful for constructing averages keyed 
to periodic signals with strong spikes, such as ECG. 

 Events: Place members of the ensemble surrounding events in the waveform. Events must be previously 
defined by the user, either manually or through another automated process. This method is useful for 
constructing averages keyed to any types of events in a graph. 

 

 

 

 

 

 

 



322  BSL PRO Manual 

Visit the online support center at www.biopac.com 

 
Epoch Analysis  

  
Extracts basic measures from fixed-width time segments of data. A fixed-width time segment of data is known as 
an epoch. The location of these fixed-width intervals can either be keyed off of locations of events in the graph or 
tied to regular time intervals (e.g. occurring at a constant frequency). All of the standard BSL PRO measurements 
can be extracted on an epoch-by-epoch basis with the exception of calculation measurements. 
Epoch-by-epoch measurement results can be viewed either as channels of 
data in the graph, a textual summary, or on an Excel spreadsheet; textual 
summaries include a final row with an overall average of each extracted 
measurement.  
Times output by Epoch Analysis are always expressed in seconds; all other 
units correspond to the current preferred measurement unit settings 
accessible under Display > Preferences. Measurement unit settings can be saved as presets in addition to standard 
settings. 
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Focus Areas between Events and Segments 
In addition to the standard focus area functionalities discussed on page 46, focus areas can also be used as an analysis 
tool to define areas of interest between certain event types or between appended segments.  
Define Between Events 
The parameters for defining focus areas using this method are highly customizable, and can be based upon specific 
event types or titles as well as various event locations in the graph. The following table explains the various focus area 
start and end event options. 

 

Focus area label basename: 
Use to assign a title for the focus areas. Successive focus areas will use 
the same title with the addition of incrementing numbers. 
Event type: 
Use to select the type of event for defining the focus area. 
Location: 

• Anywhere—all channel and global events are included in the 
event matching criteria. 

• Global—when selected; only global events are included. 
• Channel—when selected; only events in an individual channel 

are included. Select the desired channel from the combo box 
menu. 

Event labels must match: 
When checked, only events with labels matching the edit field text will 
be defined. When unchecked, all events of the selected type are 
matched, regardless of label. 

Define for Appended Segments 
This method simply defines the time range between appended segments as focus areas. No configurable options exist 
for this feature within the Analysis menu. 
Waterfall Plot 

   

 
Assists in configuring the Peak Detector for 3D surface generation. These surfaces showing cycle-by-cycle data of 
the graph are commonly known as waterfall plots. Cycles are located in the graph using the same sequence of 
steps as the Ensemble Average transformation script, and cross sections for the plots can be selected on the basis 
of events or peaks (see figur below).. Instead of generating the averaged graph, however, a number of 3D surfaces 
are generated. One surface is generated for each channel that is selected by the user. 
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NOTE: Controls for viewing and manipulating the Waterfall Plot are identical to those used in the Find Cycle 3D 
Surface View described on page 295. Refer to that section for full descriptions of of the Waterfall Plot view 
angles, X, Y, and Z-axis range, plot resizing, and additional settings such as font size and color. 

ECG Analysis Algorithm References 
BSL PRO software implements the open source ecgpuwave ECG boundary location software and the open source 
OSEA QRS detector and beat classification library for ECG analysis. 
Automated ECG Waveform Boundary Location 
 ecgpuwave ECG boundary location software 

BSL PRO software incorporates the ecgpuwave ECG boundary location software. Ecgpuwave is an 
implementation of a waveform boundary detection algorithm primarily developed by Pablo Laguna at the 
University of Zaragoza in Spain. This algorithm incorporates a variant of the Tompkins QRS detector, but 
contains additional rules that allow it to automatically extract the following characteristics of an ECG signal 
on a cycle by cycle basis: onset of P, P peak, end of P, onset of QRS, peak of QRS, end of QRS, onset of T, 
peak of T, and end of T. 
The algorithm is tuned to human ECGs through comparison with manual classification. Particularly, it seems 
to be within the standard deviation of human examiners for the onset and end of T waves, a particularly 
difficult feature to extract from an ECG complex. It also has the ability to take multiple ECG leads into 
account to reduce errors and misclassifications and appears to function for one to twelve lead ECGs. The 
algorithm is well documented in a number of papers. This algorithm development was sponsored by several 
government agencies including CICYT in Spain and the NIH. 
The ecgpuwave tool is distributed from the PhysioNet NIH servers (http://www.physionet.org). This is a tool 
written in Fortran that will read WFDB formatted files. It will then output a series of annotations in WFDB 
format indicating the locations of the various ECG complexes within each cycle. It also depends on another 
tool, sortann (available from PhysioNet), to perform post-processing. This software reads and writes 
PhysioBank formatted files.  
BSL PRO can automate the process of running ecgpuwave on source data and import its output back into BSL 
PRO. To run ecgpuwave on an ECG signal from within AcqKnowledge, select the ECG channel as the active 
channel and then choose “Analysis > Locate Human ECG Complex Boundaries”*. BSL PRO will execute 
ecgpuwave on that signal and read in its waveform boundary location output, placing events on the channel. 
This output will only be visible if events are shown. 
 Alternatively, save the file to PhysioBank format, run ecgpuwave manually from a Terminal, save the 

http://www.physionet.org/
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annotations to “atruth” and then reopen that PhysioBank file to see the ecgpuwave results. This is the same 
process that BSL PRO performs. 
*To apply the proper algorithm for animal subjects, choose “Analysis > Locate Animal ECG Complex 
Boundaries.” 
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Chapter 15 Display Menu Commands 
Overview 
The Display menu includes a number of features that control how the waveforms appear on the screen and how much 
data is displayed at a time. 

  

  
Display menu and Show sub-menu 

Although these options change the appearance of the data, they do not change the data itself. In other words, changing 
the color of a waveform or showing only a portion of the data on the screen will not alter the data stored in the file. 
See the following shortcut options for Display menu commands: 
 Toolbar shortcuts, page 53 
 Context-sensitive shortcuts—page 65 
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Tile Waveforms 
Tiling is an operation performed on all waveforms to visually separate them on the screen. Tile Waveforms adjusts 
the vertical offset to center waveforms in the display; if there are multiple waveforms displayed in chart mode, the 
waveforms will be centered in their “tracks.” Tiling does not adjust the scale of the waveforms; it only affects the 
midpoints of the visible portion of the waveform. Tiling does not affect the vertical scale factor previously set for each 
channel (whereas Autoscale may affect the vertical scale factor as well as the offset). 
In Scope mode, tiling staggers the midpoint of the channels to visually separate them on the screen while maintaining 
their scales. In Scope mode, waveforms are spaced evenly along the vertical axis of the screen, and each waveform is 
centered vertically in its division. 
To apply tiling only to the selected waveform, hold down the CTRL key on Windows or the Option key on Mac OS 
before selecting Tile Waveforms. In scope mode, waveforms are spaced evenly along the vertical axis of the screen, 
and each waveform is centered vertically in its division. Tiling does not affect the vertical scale factor previously set 
for each channel (whereas Autoscale may affect the vertical scale factor). 
When grids are locked, tiling will retain the appropriate heights and percentages. 
When grids are unlocked, the scale may be slightly larger in order to optimize the tick marks displayed on the vertical 
axis. 

  
Before Chart mode tiling After Chart mode Tiling 

  
Before Scope mode tiling After scope mode Tiling (red lines for illustration only)  

Note that the waveforms are centered relative to the horizontal divisions of the plotting area; the range and midpoint 
of the second waveform (blue square wave) are indicated in the figure above. 
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Autoscale Waveforms 
The primary use of Autoscale is to make all of the data of 
the channel within the current time range visible on the 
screen. 
When Autoscale Waveforms is selected, BSL PRO 
determines what the “best fit” is for each displayed 
waveform. The percentages and midpoints are identical 
whether grids are locked or unlocked. 

 

The software adjusts the vertical offset so that each channel is centered in the window (or within the channel track in 
chart mode) and adjusts the units per division on the vertical axis so that the waveform fills approximately two-thirds 
of the available area. In chart mode, the waveforms are autoscaled to fit their sections. In scope mode, the screen is 
evenly divided into horizontal “bands” and each waveform is scaled to fit the division without overlapping. 
 The autoscaling algorithm for Chart mode and X/Y mode is: 

1. Find maximum value of the channel in the time area, max. 
2. Find minimum value of the channel in the time area, min. 
3. If grids are locked, adjust scale such that max-min occupies 75% of the channel's track in Chart mode, or 75% 

of the entire plotting area X/Y mode. 
4. Adjust the midpoint so (max-min)/2 is at the vertical center of the channel's track in Chart mode, or vertical 

center of the entire plotting area in Scope and X/Y modes. 

  
Before autoscaling LVP channel After autoscaling LVP (red lines for illustration only) 

 The autoscaling algorithm for Scope mode is: 
1. Divide the plot height into m equal sections of height h each. 
2. Assign each visible channel to one of these plot sections. 
3. If grids are locked, Scale the waveform such that the range between the max and min values will occupy 75% 

of h. 
4. Place the midpoint between the max and min at the center of the waveform's section. 

In scope mode, the screen is evenly divided into horizontal “bands” and each waveform is scaled to fit the 
division without overlapping. 
Note: Autoscaling a single channel in Scope mode results in that channel occupying 1 / 
(num_visible_channels) of the overall waveform plotting area. It will be placed in the region of the graph that 
corresponds to its position in Chart mode.  
See following page for examples of autoscaling in Chart and Scope modes. 
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Autoscale Single Waveform 
Use this option to perform the above autoscaling operations on a single selected channel rather than on the entire 
graph. 

Optimize Ranges 
When Optimize Ranges is selected, the Vertical Scales will be automatically adjusted for all channels that have a 
Range Guide (green band) showing, such that the range limits are set to the upper and lower viewable limits of the 
Vertical Scales. This allows the total Range of each input channel to be displayed. This menu item is active when data 
is present AND at least one data channel has an active Range Guide. 

This item is also selectable using the toolbar icon  or the right-click mouse shortcut. When selected with the icon 
or the right-click, this item only optimizes the Range Guide of the active channel. To optimize the ranges for all 
channels using this toolbar button, hold down the Ctrl or Alt key while clicking it. 
Note:   The Range Guide is the green vertical band that appears in the Vertical Scale region for analog input 
 channels only (not for duplicated, copied/pasted, or Calculation channels); see page 72. 
 
Overlap Waveforms 
Overlapping waveforms places all of the waveforms at the same scale and midpoint so that the plotting location of a 
specific voltage on screen is at the same spot for every channel. Overlapping is useful for examining closely 
associated waveforms, such as the calculated diastolic, systolic and mean calculation channels “overlapped” with the 
raw blood pressure waveform from a continuous blood pressure signal. 
In scope mode, when Overlap Waveforms is selected, the waveforms are “overlapped” into one screen. All of the 
currently displayed waveforms are arranged in the graph window with the same vertical scale and offset so all the 
displayed waveforms will fit on the graph; their magnitude reflects their size relative to the other waveforms. The 
overall chosen scale for all the displayed waveforms will be a function of the pk-pk value of the combined waves 
Compare Waveforms 
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Compare Waveforms displays all of the channels with the same amplitude scale. Compare Waveforms automatically 
sets the vertical scale to be the same for all channels and adjusts each channel offset so that all displayed waves are 
centered in the display. The scale for all the displayed channels is determined by the channel with the largest pk-pk 
range in the display interval. Compare Waveforms is useful for gauging the relative amplitudes of a number of 
channels by placing them all on the same amplitude scale and discounting the effect of waveform offset (or baseline). 
 In Chart mode, Compare Waveforms functions on each channel in its track. 

  
 In Scope mode, the channel scaling is similar but disperses the channels through the plot area similar to 

tiling. For a graph with m channels being plotted: 

  
Autoscale Horizontal 
The Autoscale Horizontal command is a convenient way to display the entire data file (in terms of duration) on the 
screen. When this is selected, the display will be adjusted so that the duration of the entire waveform fits in the graph 
window. For long waveforms, this can take some time to redraw.  
An Autoscale Horizontal function cannot be reversed with Edit > Undo. To revert to the previous display settings, use 
the Display > Zoom back command. 
 
Show All Data 
The Show All Data command enhances the view by autoscaling first horizontally, then applies an “autoscale all 
waveforms” operation. This enables all vertical and horizontal data in the entire graph to be displayed for easy 
viewing.  
 
Show Default Scales 
This option will resets a graph’s vertical and horizontal scaling parameters to the default settings used when the graph 
was first opened. 
 
Zoom Back / Forward 
Zoom functions can affect the horizontal scale, the vertical scale, or both. Zoom restoration is functional for the Zoom 
tool, Autoscaling, and the Tile, Overlap, and Compare Waveform options. Zoom scales are stored until another zoom 
function is performed. Zoom scales are stored until another zoom function is performed. Multiple levels of Zoom are 
supported. 

 Zoom Back will restore settings one level at a time.Tthis selection can be repeated to restore the original 
zoom scales. Essentially, Zoom back acts as an “undo” command for the zoom forward command and any 
other function that changes the amount of data displayed (either in terms of time or amplitude) 

 Zoom Forward will redo a zoom function after it has been undone. This selection can be repeated to 
restore the latest zoom scales. 

Zoom functions will work without limitation, until another Zoom is performed. 
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Reset Chart Display 
The Reset Chart Display option will redistribute the chart displays evenly after changing the boundaries, so that each 
channel’s vertical size is the same. This function, which only works in Chart Mode, can be useful for expanding a 
display region for analysis and then returning to the original display. 

  
Before Reset Chart Display …and after 

Reset Grid 
To return to the original grid, choose “Display > Reset Grid.” This will reconstruct the default, unlocked grid of four 
divisions per screen with solid light gray grid lines. 
Adjust Grid Spacing 
To modify the horizontal and/or vertical grid spacing, choose “Display > Adjust Grid Spacing.” This will generate a 
dialog for modifying the locked axes of the selected waveform. See page 76  for details. 
Set Wave Positions...  
By default, channels are arranged on the screen based on their channel numbers, with the lower number channels 
being displayed at the top of the screen. The Set Wave Positions option allows waveforms to be placed in a user 
defined order. 
 In chart mode this will result in vertical ordering of the individual waveforms. 
 In scope mode this will result in vertical ordering of the individual waveforms after a tiling or autoscaling 

operation. 
It’s also possible to set any waveform to ignore the autoscaling and tiling functions. This is useful for selectively 
applying autoscaling to certain graph channels of interest while omitting others. 
The waveform positioning function is selected through the Set Wave Position in the Display menu. The following 
dialog will then appear, with a scrolling list of all stored channels:  

 
If more channels are present than those displayed, scroll through the list by clicking on the vertical scroll bar at the 
right.The list will scroll if when moving past the top or bottom and clicking and dragging the waveform positions. 
The “Tile” checkbox to the left of each channel enables tiling and autoscaling for each channel when checked. Click 
the checkbox to toggle the enable.  
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The on-screen position of the waveforms is the same as the ordering shown in the above dialog (from top to bottom). 
The waveforms can be repositioned by reordering the channel labels as they appear in this dialog. To change the order 
of any waveform, select the channel label (e.g., CH1, ECG) and then click the Move Down or Move Up button. 
Repeat this operation until the waveforms are in the desired order. 
 Click OK to apply the selected order to the display screen. 
 Click Cancel to revert all waveform positions to those set before the dialog was opened. 

 
Set Channel Visibility 
Set Channel Visiblity offers an alternate means of showing and 
hiding channels. Simply check or uncheck the channel “Show” 
checkboxes to show or hide them. All channels can be shown or 
hidden simultaneously by holding down the Alt key while 
clicking the left mouse button. See also: Show/Hide Channels 
on page 86. 
 
 
Wave Color 
Select Display > Wave Color and then set the desired color to discriminate between waveforms. In scope mode, the 
vertical scale, channel text, channel units and measurement popup menus take on the same color as the selected 
waveform. When adding new waveforms, BSL PRO assigns waveform colors in the following order: black, red, 
green, blue, magenta, burgundy, and custom. 

  
Or, click the right mouse button to bring up a menu, select Color, and then select the desired waveform color from the 
color palette menu.  

Active Slice Color 

 
To change the Active Slice Color in Stacked Plot mode (see page 36), use Display > Show > Active Slice and then 
select Drawing options. 
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Horizontal Axis 
Horizontal Axis generates the Horizontal Scaling dialog. Set the axis in 
terms of time, frequency, or arbitrary units, and set the horizontal sample 
interval (the amount of time between two sample points) and the first 
sample (sample offset).  
Time domain scaling has two options to store and display data: 

• (ss.sss) —absolute seconds; the time scale for an event occurring 30 
seconds into the record would be 30.00 seconds 

• (HH:MM:SS) —hours:minutes:seconds; the time scale for the same event would be 00:00:30. 
Set the Time Unit precision via Display > Show > Selection palette, then press Enter (return) to accept changes. 

  
The Frequency Units option plots data from a Fourier analysis or other data with a frequency base (rather than a time 
base). This option is only available when frequency units are present in the graph. As with the time options, this 
feature is typically used for importing text files from other applications. For instance, when importing a text file with 
1,000 sample points that covered a frequency range from 0 Hz to 100 Hz, set the interval to 1000 Hz/100 samples, or 
0.1 Hz per sample in the box to the left of the interval text box. Similarly, if the frequency range was 20 Hz to 100 Hz, 
set the offset to 20 Hz. Arbitrary base units can also be attached to the data (rather than a time or frequency base 
When the horizontal axis corresponds to wavelength, and the data consists of 100 samples covering a range from 1 to 
10 Angstroms, the interval should be 0.1 units per sample. 
Arbitrary units are generally useful for changing the time base (or other horizontal scale) of data that has been 
imported into BSL PRO as a text file. For instance, to analyze data imported from a text file that contains 30 seconds 
of data that was collected at 100 samples per second (100 Hz), the first step would be to open the file (following the 
directions on page 230). 
When arbitrary units are selected, two additional text boxes appear at the bottom of the dialog. The upper Units text 
box is used to provide a name for the horizontal scale units and the lower Units text box is used to provide an 
abbreviated label for the horizontal units. 
By default, BSL PRO assumes that the data was collected at 50 Hz, and would therefore plot the data so that a 60 
second record was displayed that appeared to be collected at 50 samples per second. To change this to reflect the rate 
at which data was actually collected, change the sample interval box in the horizontal scaling dialog. When data are 
displayed on a 50 Hz time base, the sample interval will read 0.02 seconds per sample. This means that there is a 0.02-
second “gap” between sample points in the record. To display data at 100 samples per second, change the interval to 
0.01 seconds per sample. 
To determine the sample interval for other sampling intervals, divide 1 by the rate at which data was sampled (in 
terms of samples per second). Thus, a sampling rate of 0.5 Hz would translate into a sample interval of 2.00 seconds 
between samples, and data collected at 100,000 Hz (100 kHz) would have an interval between sample points of 
0.00001000 seconds. 

TIP:  To confirm that BSL PRO is storing data in the same X-axis it was collected in, choose 
Channel Info from the Display menu. This will generate a dialog that describes (among 
other things) the sampling rate BSL PRO uses in analyzing the data. Once data has been 
saved as an BSL PRO file, time base information is automatically saved along with the 
data. BSL PRO also saves X-axis in Frequency (FFT) or Arbitrary (Histogram). 
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Show 
Selecting Show from the Display menu generates a submenu that allows control over a number of data display options 
and what additional information is displayed in the graph window. To enable an option, select it from the submenu; a 
bullet (•) or checkmark appears next to the menu item when it is enabled. The three display modes and the two 
plotting modes are mutually exclusive, but the remaining items can be enabled independently.   
Show Option Shortcut Explanation 
Annotations  Toggle show/hide of text annotations.  
Channel 
Buttons 

 When the Channel numbers option is selected, the channel boxes appear just above 
and below the graph area. 

Channel boxes with Channel 1 selected 
These boxes are useful for selecting channels and “hiding” channels by positioning 
the cursor over the channel box, holding the ALT key on the Windows or the 
Option key on the Mac, and clicking the mouse button. 

Channel Input 
Values 

 When enabled, adds real-time display of channel amplitude values above the graph. 
(“Show textual value display” must be enabled in the Vertical Axis settings.) 

Chart 
 

Activates the Chart display mode (see page 33). 

Display Mode 
Toolbar 

 Activates toolbar shortcuts for Chart, Scope, X/Y, Stacked Plot, Horizontal Split 
View and Data View. 

Dot plot  Dot Plot allows viewing of data in a “dot” format. This is useful for demonstrating 
the concept of discrete digital sampling by dividing the waveform up into data 
points or “dots.” 

Dot size  

 

Dot size is enabled after Dot Plot is selected. 
Dot size specifies how large each dot will be. Each dot 
is measured by the number of monitor pixels it 
occupies. 
(Each “dot” corresponds to a sample point. (For 
example, data collected at 100 samples per second 
whould display 100 dots per second.) 

Focus Areas  Enables Focus Area display. See page 46 for Focus Areas. 
Event bar  Enables Event Bar display. 
Events  Enables Event Marker region display. See page 194 for Events. 
Focus Areas  Enables Focus Area display. See page 46 for Focus Areas. 
Focus Areas 
Bar 

 Enables Focus Area Bar display on toolbar. 

Grid 
 

Superimposes a Grid on the graph window (see page 49). To change grid precision, 
use the axis scaling dialog of the horizontal or vertical axis.  

Grid Options  Activates the Grid Options dialog (see page 78 ) 
Hardware  Show/Hide Hardware “Connected to:” dialog in the graph display; includes network 

access. 
Journal   Activates the Journal (see page 50). 
Last Dot Only  Plots only the most recently acquired data point. Only available in X/Y mode. 
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Line Plot Right-click 

menu 
Connects each sample point with a line to create the waveform. Waveforms that are 
displayed in line plot mode match a true analog plot (as closely as possible). This is 
the default display mode for most waveforms, except histogram plots, which are 
displayed in Step Plot mode (see 283). Change line options by right-clicking the 
mouse, which generates a menu displaying several commonly used features. 

Line Thickness   

 

Line thickness is enabled when Line or Step plot are 
enabled. Use to specify the plot thickness in pixels.  

 
Sine wave set to thickness of 5 pixels 

Measurements  Displays the measurement popup menus and windows above the graph window (see 
pages 48 and 87).  

Scope 
 

Activates the scope display mode (see page 33). 

Selection 
Palette  

 
Many of the tools within the BSL PRO environment are based around the selection. 
The selected range of data in the graph is used as the source for measurements, 
waveform editing, transformations, and other operations. The Selection Palette is a 
floating dialog that can be used to precisely enter the selection. 

• The Selection Palette can be used to adjust the selection at times when it is 
not possible to use the selection tool in the graph window, such as when 
transformation dialogs are being displayed for the graph. 

• The selection palette offers a way to change the selected area without 
having to cancel the transformation setup and lose any parameters typed in 
the dialog. 

To display the Selection Palette, choose Display > Show > Selection Palette.  
This small floating dialog contains two edit fields displaying the location of the left 
and right edges of the selection, using the measurement units displayed in the 
horizontal axis.  

As the selection is changed, the new selection boundaries are shown. 

The Selection Palette also can be used to manually type in the edges of the 
selection. Double-clicked of the edges and type in the new horizontal position of the 
edge of the selection. Press “Return” to adjust 
the selection to that time location and update 
measurements and the visible display on the 
screen. 

When a graph is displayed in X/Y mode, the 
Selection Palette can be used to adjust the X-
axis range of data plotted on the screen. 
Limiting the time range can be useful for 
generating X/Y plots for different intervals of 
the graph that can then be compared with each 
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other, such as examining data from different time periods of a recorded signal. 

Click the small arrow in the top right of the selection palette for the following 
additional options: 

• Mark Selection—Use this option to bracket a selected area with event 
markers. 

• Paste edges in Journal—This option pastes a line of text into the Journal 
that includes the left and right edge measurements of the selection. 

• Create Focus Area—This option turns data highlighted by the selection 
palette into a labeled Focus Area.  

• Time units—Use this submenu to change the time units used in the 
selection palette. The following time units are available: Match units on 
axis; Hours; Minutes; Seconds, Milliseconds, Microseconds and Samples. 
The Time units submenu will be dimmed unless the graph displays 
time/arbitrary measures). 

• Frequency units— Use this submenu to change the frequency units used in 
the selection palette. The following frequency units are available: Match 
horizontal axis, Kilohertz, Hertz, Millihertz and Samples.  
 
The frequency submenu will be dimmed unless the graph displays 
frequency-based measures.  

Note Changing time/frequency units in the selection palette can be helpful during 
zoom operations when the units displayed in the horizontal axis may not be 
the most convenient for inputting new selection boundaries.  

• Arbitrary Units—Use this submenu to change the arbitrary units used in 
the Selection Palette display (Units or Samples). 

Spectrum 
Analyzer 
Palette 

 Provides a dynamic display of the frequency decomposition of data, in real time or 
post-acquisition. See page 338 for details. 

Stacked Plot 
Options 

 Displays options that can help visually distinguish the active 
slice from other slices being drawn in Stacked Plot mode. 
See page 37 for details. 

 

Step plot  Displays waveforms in a “step” plot, meaning that the lines connecting sample 
points are drawn either vertically or horizontally. Step plot is most useful for 
displaying histograms and similar plots, but since it displays data much as it appears 
to a digital processor (like the MP), it can also be useful for examining the effects of 
various sampling rates.  

NOTE: Step plot is mutually exclusive of line plot. 
Textual Values 

 
When enabled, adds real-time display of channel amplitude values above the graph. 
(“Show textual value display” must be enabled in the Vertical Axis settings.) 

Toolbar  Displays the toolbar (shortcut) icons across the top of the display (see page 53). 
X/Y  Activates the X/Y display mode (see page 33). 
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Customize Toolbars 

 
Use this feature to create custom toolbars for easy access to post-processing Analysis and Transform actions. Toolbars 
are dockable and custom toolbar placeholders can be named independently of toolbar actions.  

 Actions – Menu list of available Analysis and Transform functions 

 Toolbars – List view of custom toolbar placeholders 

 Current Toolbar Actions – List view of available actions from Analysis and Transform menu 

Button Function Explanation 

 
Add toolbar button Adds placeholder for new toolbar. (More than one toolbar action can 

be grouped under one placeholder). 

 Remove toolbar button Removes placeholder for toolbar. 

 Rename toolbar button Allows existing custom toolbar name to be edited. 

 
Up arrow Moves a toolbar action up the list. 

 
Left arrow Removes a toolbar action from the list. 

 
Right arrow Adds a toolbar action to the list. 

 
Down arrow Moves a toolbar action down the list. 

 
Clear button Removes all toolbars from Toolbars and Current Toolbar actions list. 

 
OK button Enforces addition or removal of toolbars from list or application 

toolbar region. 

 
Apply button Applies changes without closing Customize Toolbar window. 

 
Cancel button Dismisses any toolbar changes without applying. 
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Spectrum Analyzer Palette Details 

 

 
Spectrum Analyzer breaks time domain signals into their respective frequency components to provide a dynamic 
display of the frequency decomposition of data, in real time or post-acquisition. Spectra can be generated in real time 
based on the most recently acquired data or post-acquisition based on the selected area of a saved data file. 

• Spectrum analyzers can be useful for locating and correcting noise sources in a system as well as other 
frequency domain analysis. 

• The spectrum analyzer displays the FFT of a portion of data of a single channel. 
The spectrum analyzer applies to all graph windows displaying data in the time domain. Viewing the underlying time 
domain data at the same time as the spectral information also provides useful visual feedback with regards to signal 
quality. The palette allows for continuous availability of the spectrum analyzer across multiple graphs and for 
positioning alongside original data. The channel is always indicated by the popup menu within the spectrum analyzer 
itself. The graph whose data is analyzed will always be the topmost graph; this is the graph whose window is highest 
in the Z ordering. 
Mode: 
 Real-time Analyzes the most recently acquired data in a graph. The analyzer generates full FFT output so, in 

linear units, it is the regular FFT multiplied by two. The analyzer extracts the spectrum based on a 
sliding window of samples at the tail end of the signal and periodically refreshes the spectrum plot 
during acquisition. The analyzer uses a fixed width window size. The first spectrum will be generated 
after the number of samples needed to fill the initial window has been acquired. If no data is being 
acquired, the analyzer will not display any frequency information and will appear to be off. 

 Selection Analyzes the highlighted section of the active channel of a saved graph (post-acquisition). Select the 
channel to be analyzed from the channel popup menu. 

Palette popup  (upper right) Displays the spectrum analyzer palette popup menu for 
performing other operations on the spectrum including extracting the spectrum 
to a new graph window and copying spectrum data to the clipboard or journal. 
Options are dimmed if there is no spectrum available. 
New … New Graph with Spectrum constructs a new graph window with 

the contents of the spectrum. This allows for more detailed examination of the spectrum 
than is possible with the tools in the spectrum analyzer palette. 

Paste… Paste Spectrum to Journal makes a textual representation using the current Journal 
preferences and copies the text into the graph journal of the graph whose data is being 
analyzed. This will prompt to create a journal if none exists.  

Copy… Copy Spectrum to Clipboard makes a textual representation using the current Journal 
preferences and copies the text to the Clipboard. 
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Settings… Displays the spectrum analyzer settings dialog. Equivalent to using the Settings button at 
the bottom of the palette; see Settings below for details. 

Channel Indicates which channel of the hardware setup or graph is being analyzed. The “Channel” popup 
menu contents vary with the analyzer mode: 

 Real-time Channel popup menu lists active channels whose “Acquire” checkboxes are checked in MP > Set Up 
Channels.  

 Selected The channel popup menu matches the channel menu of measurements in the topmost graph window. 
The menu starts with “SC, Selected Channel” which, when chosen, uses the data of the active channel 
of the graph. The remainder of the menu lists the channel numbers and labels of the channels within 
the topmost graph. 

Plot display Plot of the spectrum of the corresponding data. 
 Vertical axis units match the source channel (displays either “dbV” or linear) 
 Horizontal axis displays frequency and is always displayed in “Hz.”  

 If there is a valid data selection that can be used to compute a spectrum, the spectrum will be 
displayed in this area. If there is no valid data selection, no axes will be displayed and the plot will be 
replaced with the text “Not Available”. The following conditions cause spectra to be unavailable: 
 graphs that contain no data (either no channels or only empty channels) 
 graph is being displayed in XY mode 
 graph uses either frequency or arbitrary units for its horizontal axis 

When operating in selected area mode, the following additional conditions also cause spectra to be 
unavailable: 
 selection contains no data on the active waveform 
 selection is a single-point selection (not enough data to compute FFT) 

When operating in real-time mode, the following additional conditions also cause spectra to be 
unavailable: 
 no data acquisition is in progress 

Auto Vert Click to autoscale the spectrum to fit all amplitudes within the visible spectrum plotting area. 
Auto Horiz Click to autoscale the spectrum to fit all frequencies within the visible spectrum plotting area. 
Settings 

   
 Plot color Colorwell that changes the color used to draw the spectrum in the palette. Click to display a standard 

color picker. 
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Window Width specifies the window size used when performing analyses in real-time mode. The spectrum 
will always reflect the frequency characteristics of the most recently acquired data of the graph, using 
this window size as the number of sample points to use. This popup will list various powers of two, 
ranging from 256 to 4096 samples. 

 
 FFT Options 
 Padding—used whenever the number of input points is not an exact power of two. Data can be 

padded either with zero or with the amplitude of the last data point. 
 Remove mean—Subtracts the mean value of the data is prior to frequency analysis. This helps 

remove the zero frequency component caused by DC offset. 
 Remove trend—Connects the endpoints of the data with a line and removes this linear trend from the 

data prior to frequency analysis. This can help compensate for drifting baselines. 
 Units—control whether the data is displayed using a logarithmic scale or a linear scale. 
 Window—enables the standard BSL PRO windowing options, to adjust the data to remove effects 

resulting from the discontinuities of data at the two edges. See page 284 for details about FFT. 

Value Click the crosshair icon  to display the frequency and amplitude values of the spectrum when 
moved within the spectrum display. The mouse cursor will change to a crosshair when inside the 
spectrum plot. The frequency and amplitude values corresponding to the mouse position are displayed 
above the spectral plot. Hold the mouse button down to display the amplitude of the spectrum at the 
horizontal mouse position, along with a crosshair cursor highlighting the exact location shown on the 
spectrum. If the active spectrum is compressed (that is, if multiple samples exist for a particular 
horizontal position), the value extracted will be the maximum value displayed at that pixel position. 

Zoom Click the magnifying glass  to perform zoom operations. Click and drag the mouse cursor (which 
will change to a magnifying glass) in the plot display to select the area to zoom in on. Alternately, 
click either of the axes of the spectrum palette to display a dialog used to enter display ranges 
manually. Enter the start and end points of the desired range for each axis. There are no grids in the 
spectrum analyzer palette, so the axis scaling dialogs of graphs are not applicable. Note: adaptive 
scaling will be disabled for the spectrum display when either the zoom tool or the axis endpoint entry 
dialogs are used. 

TIP: To zoom out, hold the Alt key (PC) or Option key (Mac) while clicking mouse 
over zoomed area. 
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Channel Information... 
The Display > Channel Information command generates an information dialog for the selected channel. Channel 
Information may also be displayed by right-clicking in the channel and selecting “Channel Info…” from the 
contextual menu. 

 
Line Freq Files created with BSL PRO include the line frequency (50 Hz or 60 Hz); files created in earlier versions 

will list “Unknown.” 
Channel Use this popup menu to select the desired channel for displaying information. 
Interval The time between sample points, which is the reciprocal of the sampling rate. The sampling rate can be 

modified by using the resample function (described on page 278), by changing the interval horizontal 
scale (see page 333 ), or by pasting data collected at one sample rate into a graph containing data sampled 
at a different rate. 

Length Indicates the overall length of the channel in samples and in time. The waveform length is generally the 
same for all channels, but there are exceptions: 

• Downsampling a channel during acquisition 
• Transform > Resample Waveform/Graph 
• Edit operations – Cut, Copy, Paste, Clear 

 
Min Provides the minimum value for the waveform data. 
Max Provides the maximum value for the waveform data. 
Mean Provides the mean value for the waveform data. 

The fields below the statistical information contain transformation histories, time/date stamps, parameters, and values 
for selected channels. 

Paste Selected Channel to Journal Pastes transformation modification history for selected channel to Journal. 
Paste All Channels to Journal  Pastes transformation modification history for all channels to Journal. 
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Preferences... 
To generate the Preferences dialog, select Display > Preferences on Windows or BSL PRO > Preferences on Mac. 
Use Preferences to control measurement options, how waveforms are displayed, and other BSL PRO features. Select 
an option in the list on the left of the Preferences dialog and then set the respective preferences displayed on the right. 

See 
page… 
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Measurements Preferences 
 Measurement rows—sets number of measurement rows displayed in the graph window. 
 Measurement columns—sets number of measurement columns displayed in the graph window. 

o Use Display > Show > Measurements to hide the measurements; see page 334 for details. 
 Precision—controls the accuracy of digits displayed right of the decimal (1-8) for all measurement results. For 

example, with the precision set to 3, a measurement result might be 125.187. 
 Use linear interpolation—toggle to enable/disable measurement interpolation. 
 Time/Frequency units—sets the measurement unit to use for time and frequency pop-up measurements. This 

locks the units for the measurement result display (i.e., if seconds is selected, a result of 70 seconds will display 
as “70 seconds” rather than “1.16667 minutes”). 

o Best match—Scales units to best match the interval for time and frequency based on the total file. For 
example, won’t set a 3 hour file to display in msec. 

 Include for Journal/Clipboard options 
 measurement name (i.e., BPM, Delta T, Freq, etc.) with the values. 
 measurement units (i.e., volts, mmHg, and so forth) after the numeric values. 
 measurement parameters used to compute the measurement function result, such as the location and 

operator used for Calculate measurements. 
 channel numbers at the top of each column of data. 
 timestamp—Automatically insert the time of day and the date when pasting measurements or wave 

data. This timestamp can be correlated with selection events to reconstruct the selected area.—useful 
for GLP auditing. 

 Use a separate line for each measurement in the journal/clipboard 
 Mark selection with events in graph—Automatically insert a pair of Global Selection Begin and Selection 

End events at the selection boundaries when pasting measurements or wave data. These events will be 
timestamped with the time of day and the date when the paste occurred. This timestamp can be matched to the 
result of “Include timestamp” to recreate selected areas for reconstructing measurement results or re-executing 
wave data exporting—useful for GLP auditing. 

 Journal Table Export Options – Sets the options for how multiple measurement rows are displayed in a 
Journal table. 
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o Put all values in a single table row – Extends multiple measurement rows horizontally into one table 
row. 

o Use one table row for each measurement row – Divides the measurements into multiple table rows in 
the same manner shown in the measurement toolbar. 

Waveforms Preferences 
In the center of the dialog are two options that control how waveforms are displayed on the screen. 
 Gray non-selected waves—When enabled, the active wave will be drawn in a solid color and any non-selected 

waveforms will be drawn using lighter, dotted lines (or with lighter colored dots if dot plot is in use). This can 
help emphasize the selected waveform when viewing data in Scope mode. 

 Draft mode for compressed waves—allows for some (“compressed”) waveforms to be plotted in “draft” 
mode, which results in faster plotting time, although the display is not exact. A waveform is considered 
compressed when more than three sample points are plotted per pixel on the screen. For example, on a VGA 
display that is 640 pixels wide, a compressed waveform would be any type of waveform displaying more than 
2000 samples (approximately) on the screen at any one time. Using the default horizontal scale (which plots 
eight seconds of data on the screen), any data sampled at more than 250 samples per second would be 
considered “compressed.” 

 Scaling/Transformations—These options handle the way data appears on the screen after it has been 
transformed (e.g., filtered or mathematically operated on). Neither option affects how data appears on the 
horizontal axis, although both options change how data is presented along the amplitude (vertical) axis. 

o Duplicate before transformations will create a new channel showing the data as it originally 
appeared before the transformation was applied. This will preserve the original view for comparison 
to the tranformation. 

o Autoscale after transformations will automatically rescale all waveforms after a transformation to 
provide the “best fit” along the amplitude axis. 

o Tile after transformations tiles all visible waveforms after any transformation, and is mutually 
exclusive of the autoscale command. When waveforms are “tiled” they appear to be stacked on top of 
each other. 

 Mark waveform edits with events—Insert an event at points where waveform edit commands have been 
applied. 

 Include time value—copies the horizontal scale values along with the waveform data when data is copied to 
the clipboard. This means that after pasting data from the BSL PRO screen into a spreadsheet or similar 
application, horizontal scale information is retained. 

 Include timestamp—Automatically insert the time of day and the date when pasting measurements or wave 
data. This timestamp can be correlated with selection events to reconstruct the selected area.—useful for GLP 
auditing. 

 Mark selection with events in graph—Automatically inserts a pair of Global Selection Begin and Selection 
End events at the selection boundaries when pasting measurements or wave data. These events will be 
timestamped with the time of day and the date when the paste occurred. This timestamp can be matched to the 
result of “Include timestamp” to recreate selected areas for reconstructing measurement results or re-executing 
wave data exporting—useful for GLP auditing. 

Event Summary Preferences 
For the event summary that can be pasted to the journal, choose a method to group the events (i.e., type or channel), to 
sort the events (by time or label) and indicate whether to include all events or include only visible events in the 
summary. Beginning in BSL PRO, there is an option to include a header row at the top of the summary. 
Access Event Summary preferences under Display > Event Summary; see page 194 for details. 
Graph Preferences 
 Display Style can be set to Windowed or Tabbed view. Windowed will display additional graphs in a separate 

view, whereas the Tabbed option will display all graphs in the main window. Tabbed graphs can be navigated 
by clicking on the identifying tab at the top of the application window, or by clicking Ctrl+Tab. A tabbed graph 
may be moved to it’s own window by right-clicking on the desired graph and choosing “Move Tab to New 
Window” (below right). The default display setting for BSL PRO is windowed view. When set to Windowed, 
multiple graphs apppear as separate windows, which can be positioned as desired. 
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o Interpolate pastings instructs BSL PRO to interpolate/extrapolate time base information when 

working with data sampled at two different rates. BSL PRO will interpolate data to fit the sample rate 
of the destination window. When doing this, data should be copied to a higher resolution window.  

 Maximum levels of undo—Set the maximum number of undo operations. Unlimited may be memory-
intensive, depending on the detail of each operation. 

 Link selections between data views for new graphs – automatically synchronize selected areas of data views 
between graphs for a new graph. 

 Enable cursor tools during acquisition – Allows access to cursor tools while recording is in progress. 
 Show append boundary dividers – Controls visibility of append event boundary dividers. 
 Axis controls – Controls visibility of set screen vertical axis controls. 
 Chart Track Divider Appearance – Users may change the color used to draw the dividers between channels 

tracks The Preferences > Graph panel contains "Chart 
Track Divider Appearance" options.  

 Default uses operating system specific dividers, which is a 
light color. 

 Custom activates a colorwell, allowing a solid color to be 
specified for all dividers. The preference setting and color 
are shared by all open graphs and data views, as this is an 
application-level preference. 

 Plotting Background Colors – Customizable background colors for individual graph channels are available.  
 Normal activates a colorwell for choosing background color of the non-selected channels.  
 Selected channel activates a colorwell for choosing background color of the selected channel. 

 When closing… determines the degree of closing and what prompts, if any, for multiple data views. 

  
 Recently Used—set the number of recently used Transform and Analysis options to list in the Transform > 

Recently used sub-menu; provides quick access to common options. Recently used items can also be launched 
using keystroke the combinations appearing in this menu. 

Journal Preferences 
The Journal Preferences dialog contains options for controlling data format when pasted into the journal or clipboard. 
 Change font type and size to any computer- installed font.  
 Wrap Journal text—Wraps text to window size. 
 Tabs: Specify the tab interval to make columns more readable when using a high precision setting. 

Auto-paste results—Toggle the checkbox to enable/disable the option to paste results to independent journals. 
Display Style— Choose whether Journal window is fixed, dockable on any edges of graph, or independently floating. 
Hardware Preferences 
 Always work with no data acquisition hardware connected sets the default communication for no connection 

so the connection error is not displayed each time the software is launched. 
 Line frequency is specified during software installation and can be changed here. (50 Hz for Europe and 60 Hz 

for the Americas.)Every time data is recorded, the line frequency setting is saved along with the data. If no line 
frequency data was saved, the line frequency setting for the installed/active version of BSL PRO will be used. 
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 Default analog channel display units – Use to set default channel units to millivolts or volts. 
• mV – displays in Millivolt units, visible range +/-50mV (MP36/MP35/MP46/MP45 default) 
• V – displays in Volt units, visible range +/- 10 V 
 Restore data acquisition hardware configuration on launch 

• If checked: Upon launch, application searches for the previously connected hardware unit. If a different unit is 
used, a connection warning is displayed. 

• If unchecked (default): Any supported new hardware type/unit is immediately connected upon application 
launch. 

 Data Acquisition Device Priority launches a dialog allowing the default hardware device ordering to be set. This 
ordering is used to establish hardware communication when the application is first launched or if none of the 
previously-connected MP devices are available. 
 When creating new graph windows use sets the default channel and hardware options for new graphs. 

• Minimal channel setup – new graphs will use the application’s factory default channel settings for the selected 
hardware. 

• Use default hardware and channel setup – new graphs will use the application default hardware/channel 
settings. 

• Copy hardware and channel setup of last active graph – new graphs will apply the hardware/channel settings 
from the previous graph. 

Performance Preferences  
 Use all available memory instructs BSL PRO to attempt to use all the available memory for loading data. 

Otherwise, a variable sized buffer is used to load portions of large data files. This option works best if there is 
enough free memory to load the entire data file. 

 CPU allocation sets the priority for CPU (system resource) allocation. For a data focus, move right, for a 
function focus, move left. 

• If experiencing Buffer Overloads, move toward Better data transfer for high speed acquisition. 
• To allow autoscale during acquisitions or jumping between MPs, resizing displays, or working in other 

programs, move toward. More responsive. 
Other Preferences 
 Show menu tooltips enables display of tooltips describing menu item functions. Tooltips appear when menu 

items are moused over. 
 Lock toolbars to BSL Lessons toolbar positions – toolbars cannot be repositioned and are locked to toolbar 

position used by BSL Lessons. 
 Reset toolbars—Resets toolbar configuration to default setting. 
 Create configuration file— Create default menu configuration file to customize menu display. For details on 

menu customization, see Appendix E on page 402. 
 Maximum number of files in File > Open Recent—Sets the number of files that will appear in the ‘File > 

Open Recent’ list. 
 When application is launched:—Chooses between display of Startup Wizard, new empty graph, or “classic” 

lesson choice dialog following application launch. 
 Default audio device—Use this option to select the default audio device to be used by the application. 

Window Preferences 
 Always keep the following windows on top: — Sets options for keeping any of the following windows active 

above the main application window: Input Values, Media Capture Preview, Media Capture Viewer, Media 
Playback Viewer, Gauge View. 
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Focus Area Preferences 

 
 Show background—Sets option for main graph visibility in the background of the selected focus area. 
 Color (background)—Sets background color of selected focus area. Click color square to change color of 

focus area background. (This option not active if “Show background” is unchecked.) 
 Opacity—Sets transparency level of background. (0 is transparent, 100 fully opaque.) 
 Show borders—When checked, borders will appear on both sides of the focus area. 
 Color (borders)—Click to change the color of focus area borders. 
 Width—Controls width of focus area borders. 
 Show labels—controls whether focus area labels appear at the top or the bottom of the waveform. 
 Label Position—Controls where the Focus Area labels will appear in the graph. Options are at the top part of 

the waveform or the bottom part of the waveform. 
Lessons Preferences 
 Show the following lessons—controls lessons appearing in the Startup Wizard and BSL Lessons menus.  
 Show the following PRO Lessons—controls which PRO lessons will appear in the Startup Wizard menu. 

Unchecked lessons will be hidden from view. Re-check to restore them. 
In BSL 4.1 and higher, 11 animal PRO Lessons are included but hidden by default. They may be enabled or hidden 
as desired in the “Show the following PRO Lessons” list. (These are lessons that begin with “A,” as opposed to “H” 
for the human PRO Lessons.) 
Disabling lessons in Lessons Preferences does not remove them from the application; it merely hides them from 
view. Disabling all lessons removes the ‘Record or Analyze a BIOPAC lesson’ option from the Startup Wizard 
screen. Enabling at least one lesson will restore this option. 
 Advanced Preferences—opens a dialog for modifying or adding advanced features to the BSL Lessons 

analysis mode. Additional features include the BSL PRO Transform menu, FFT analysis, Events palette, 
additional Display, Scaling, and Cursor toolbars, and other customizable functions. For more information about 
Advanced Preferences, see page 350. 

 BSL Curriculum Management System—this is a specially-licensed feature enabling an enhanced level of 
lesson customization options. For more information, see Chapter 18 on page 360. 
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Lessons > Advanced Preferences 

 
Choosing the “Lessons > Advanced Preferences” option launches the Advanced Lessons Settings setup dialog: 
 

 
 
Use the Advanced Lessons Settings options to enhance the BSL Lessons Review Saved Data mode by adding PRO 
style menus and other custom modifications to the Lesson file being analyzed. 
FUNCTION DESCRIPTION 

Transform Access in 
Review Saved Data: 

Adds the BSL PRO Transform menu and FFT functionality to BSL Lesson files opened in Review 
Saved Data mode. 

Access to File > Lesson 
Preferences: 

Controls whether students have access to the BSL Lessons File > Preferences menu item while 
running a lesson. 

Save recorded data to: Controls whether lesson files are saved to the default Data Files folder or a user-defined location. 
Choosing “Custom location” enables the “Change” button for choosing the new Save location. 

Initial location for Copy: Controls where the BSL Lessons “Copy to another location” option saves the copied file.  
“Last graph save directory” saves the copy to the most recent location the data file was saved to. 
Choosing “Custom location” enables the “Change” button for choosing a new “copy to” location. 

Default journal font: Selects the font used for all lesson journals. 

Allow e-mail as graph 
attachment: 

Controls whether students have access to the BSL Lessons “File > Email graph as attachment” 
menu item. 

Initial journal size: Sets the default Journal size to maximized or minimized for the Lesson file under analysis. 

Save a copy as… Creates a file containing a copy of all selected Lessons preferences. This file can be opened in 
Notepad or another text editor. 

Save Saves all selected settings and applies them to all BSL Lesson files opened in Review Saved Data 
mode. Note that modified settings are not applied until the BSL application is closed and relanched. 

Cancel Dismisses any modified settings without applying them. 
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Repairing corrupted preferences 
On rare occasions, the system registry used for storing persistent preferences and other information across application 
launches may become corrupted. This may result in the application not launching properly or crashing when creating 
graph windows. Should this issue occur, the BSL preferences can be reset to the factory default by holding the Shift 
key down while launching the application.  

 
A confirmation dialog will appear prior to the settings being cleared. Once the default preference settings are restored, 
the application should run normally. After resetting, the preferences may once again be modified as needed. 
Scroll options 
The Scroll options help navigate through large data files. Right-click on the 
horizontal scroll bar to generate the contextual menu with scroll options. 

 

 
Contextual menu 

Size Window... 

 

The Size Window function is useful for setting exact dimensions 
for the size of the graph window. Use this to create consistently 
sized windows for pasting into documents. The two text box fields 
are used to enter interior screen width and height, both of which are 
scaled in terms of pixels. 
 

Each operating system may add additional dimensions as necessary to put in window adornments depending on the 
appearance configuration preference of the user (e.g. extra space for title bar of the window, any additional space put 
around the edges of the window frame, etc.). 
When the “Reset chart boundaries” box is checked, the boundaries between the waveforms will be reset so that each 
channel “track” is the same size.  
When “Use as default for new windows” is checked, the user-modified dimensions are applied as the default graph 
window size. 
When “Retain current dialog settings” is checked, the dimensions used when the dialog was previously dismissed are 
applied to all subsequent graphs.  



352  BSL PRO Manual 

Visit the online support center at www.biopac.com 

Cursor Style 

 
This option allows the active cursor tool to be adjusted via the Display menu. (BSL PRO and higher) 

Split View 
This option allows the horizontal graph display to be split into two independent sections. For horizontal Split View 
details, see page 49. 

Create Data View 

 
Creates a new Data View for the active (frontmost) graph and names the new window “Data View of ‘Filename’” For 
Data View details, see page 40. 

Create Focus Area 
This option becomes available only when an area of data is selected, and brings up a Focus Area naming dialog. For 
full details on using the Focus Area feature, see page 46. 

Load All Data Into Memory 
Use with large files to improve plotting performance, measurement response, etc. Memory can hold up to two 
gigabytes of data. 
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Chapter 16 Program & OS Menus 
BSL PRO menu 

 

Mac OS only—System generated menu. Use for About, Quit, and 
Preferences. 
 

 
Window menu 
The Window menu is a standard OS 
function. See the Windows or 
Macintosh OS Guide for details. 
 
Bring All to Front 
If other programs are running, this 
command will bring all BSL PRO 
windows to the front (on top of all other 
application windows); this command 
does not change the windows size or 
position. 
Additional options become available 
when the Tabbed graph display 
preference is selected. (Right figure) 

  

Help menu 

 
Use the User Support System pdf files for online help with the software. 
When About BSL is selected from the Help menu, a screen is generated that provides information about the BSL 
software being used and the system parameters, which can be useful if technical support is required. 
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Note: For information about the MP data acquisition unit and firmware, click Help > About Biopac Student Lab.  

 
Click the System Info button for more detailed information. 

 
The Copy to clipboard button makes it easy to paste system info into an email for Technical Support. 
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Chapter 17 Media Menu 

     
Available in BSL PRO for Windows 8 and 7—Media functionality allows users to capture and playback video and/or 
audio with a USB web cam or firewire DV device and synchronize it with physiological information from an MP 
device. The key functionality is a strong link between the video and data cursor when graphs are being used in post-
acquisition mode; changing the selection in the graph window will automatically jump the video to the time 
corresponding to the cursor position. The reverse tie is also in place where erasing the video will move the data cursor 
to the corresponding data point in the graph. 

For synchronized playback of media player with BSL PRO cursor in data view, BIOPAC recommends that the users 
sample the MP unit at least as fast as the video frame rate 30Hz. In this case, any measurement errors are limited to 
the basic frame rate error window (1/30 sec). For exact match of Video and Data samples, BIOPAC recommends 
frame rate 25 fps and acquisition rate 25 samples/second (or its derivatives). 

Set Up  Establish Sources, Output and Media parameters. Set device type for audio and or/video. 
Use refresh after connecting a new device to make it a selectable option. Browse using 
standard file open/save functionality to specify media files. If desired, set a Delay between 
file segments. 

Show Capture Viewer Use for video signal directly from a video camera; this option is disabled (grayed) in the 
record mode when both the Capture video and Capture audio options in the Media Setup 
dialog are off. 

 
Show Playback Viewer Use to play back media from the disk (stored media files); this option is disabled (grayed) if 

there is no media assigned to the file. 
 
Show Capture Preview  This Media Toolbar icon toggles the preview window display state (show/hide); this option 

is disabled (grayed) in the record mode when both the Capture video and Capture audio 
options in the Media Setup dialog are off. 

Video Playback and Capture preview include a right-mouse contextual menu item “Grab bitmap” which, when 
selected, generates a Save As dialog to save the current displayed frame as a *.bmp image. 

Media Notes 

 ::  Media capture performance is improved under Windows 8 or 7 OS. If the selected camera drops frames 
because of poor performance/low quality, the degree of synchronization will be compromised. Testing 
indicated the Microsoft Lifecam NX-3000 gave reliable performance with no dropped frames. 

 :: Media functionality is not fully supported in Windows XP. 

 :: Several BSL PRO files can point (link) to the one media file.  

 ::  BSL PRO files can link to media files created by other programs. If the media file is shorter or longer than the 
BSL PRO files, just align the two files at the start. 

 ::  BSL PRO files alignment precision with the media file is user-controlled through the use of a delay function 
that allows a forward or backward time shift. 

 ::  BSL PRO files store the location (path) of the media file. This path is editable, so the BSL PRO file can link 
to other media files too. 

 :: Media functionality does not support the Autosave file acquisition mode. 
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Synchronization Tip 
Delay allows for a positive or negative time shift to be introduced between start of graph data and start of the linked 
media file, thus compensating for any data/media alignment issues that may arise. Playback synchronization is often 
necessary because there is an unknown delay between the actual start of the acquisition and the start of the first video 
frame. If precise synchronization is required, the Playback synchronization setting allows one to change the timing of 
the first video frame with respect to the first data sample.   
As an example to determine synchronization, an LED can be connected to the I/O output of the MP36/MP35 device.  
The Digital Outputs Output Control can then be set up to toggle any digital channel (D1-D8) on/off.  With the LED 
viewable in the video, simply determine when the digital output occurred in the graph and enter the appropriate 
Playback synchronization value necessary to correct the alignment. Note that one can never achieve better than 1/30 
of a second synchronization, which is the video frame rate.  

 
BIOPAC Digital LED connected to MP3x I/O port 

1) Note: Because synchronization requires a time scale value, it cannot be applied to graphs displayed in X-Y 
mode, or for FFT and Histogram windows. Once the LED has illuminated and the square wave is visible in 
the file, the channel can be hidden. 

2) After the recording is complete, use the I-beam selection tool to measure the offset between the LED 
illumination and the leading edge of the digital impulse. Use a Delta T measurement to determine the delay 
information; Delay may be positive or negative based on camera performance. Delay should be entered in the 
Linked Media row for each segment—see page 357. 
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Media > Set Up 
 
Source  

Use this dialog to select media source and select audio and video to record.  Click Refresh to update the list if a 
video or audio device is connected after the dialog was opened. When video/audio for capture is selected, an 
output file must also be selected.  Input file name and click OK; this will close the Media Setup dialog and 
automatically open the media window if the Capture option is ON.   
All video camera, audio (microphone) input parameters can be setup by user with the UI provided by camera 
manufacturer.  
All video camera, audio (microphone) input parameters can be setup by user with the UI provided by camera 
manufacturer, or use the “Configure” button for direct access to camera properties, such as exposure, saturation, 
contrast, white balance, etc. 

   
Output 

Video/audio capture requires a media file specified with full name with disk location.  *.avi or *.wmv file formats 
are supported. Users can save BSL PRO data and media streams onto separate hard drives. 

Linked Media  
IMPORTANT A BSL PRO data file must be opened before linking to a media clip.  

  
If media was captured with the data file, the Linked Media dialog will display a row for each appended 
segment in the BSL PRO data file and will list the file location of the corresponding media for each segment. The 
samples above show four BSL PRO data segments and four linked media Files. 
Click anywhere in the row (or choose the Edit button) to set a delay to synchronize the media file with the 
physiological data. Delay range: Min= 1 millisecond, Max = segment duration. 
 See Synchronization Tip on page 356. 

If media was not captured with the data file, click the appropriate row and click “Link” to browse to the 
desired media file from that segment. 
Delay—Each segment can have a distinct delay. Click in the Delay 
cell or click Edit to generate the dialog for Delay entry. 

“+” Delay places start of video file after graph start 

“-” Delay places start of video file before graph start 

The best possible synchronization can’t be better than the video frame rate (usually1/30 of a second).  
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Media > Capture 

Use Set Up to assign a Source and Output to enable the Capture menu option. There are no Preview window 
controls and the size reflects default video camera resolution. 

Playback Preview 
As the media file is manually scrolled or automatically played, the BSL PRO cursor keeps moving to reflect the 
corresponding location in the BSL PRO graph. If the BSL PRO cursor is moved, the media file is automatically 
scrolled to keep time sync with the data file.   
Media files linked to appended data segments are loaded in sequential order. After playback of the first media 
segment, the cursor will automatically advance to a still-frame view marking the beginning of the next segment. 
The Play button must be pressed in order to play back subsequent segments.  

Audio Mute button and level slider 
Video Digital indicator (time in milliseconds or frame number for the segment clip) and Horizontal slider 

(progress bar) to navigate the media file. The start point can be set from either the media clip or the data 
file. For precise selection, hold the shift key and use the forward or backward arrow keys on the media 
player or the keyboard to move single video frame (mostly 1/30 seconds) or data point.   

 Use the scroll bar to navigate to different frames.  Synchronization should be maintained with data in the graph 
window.  This should result in a single sample selection cursor shown at the time closest to the displayed video 
frame.   
The media window displays the text “No media assigned” in Playback 
Preview when the media window is visible but there is no video/audio file 
assignment for given data segment.  
During the capture or playback of audio only, the media window will be 
displayed with a static musical note image as shown at right. 
The Playback viewer uses standard media player controls. 
 

 
Go to previous segment / go to beginning of 
segment 

 Step backward a frame/sample 

 Fast backward / reverse rewind 

 

 
Play/ pause 

 Fast forward 

 Step forward a frame/sample 

 Go to following segment 

 Mute sound 
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Media Playback Example 
1. Launch BSL PRO 
2. Open a saved acquisition file.  

 

 
3. Select Media > Show Playback Viewer. 
4. Experiment with the following options: 
 Select I-beam cursor on graph and push 

“Play” button on the player.  
 Change selection with I-beam on graph 

and see the video. 
 

 
IF media is not assigned, locate the video clip 
for the appropriate segment: 

a.)  Select Media > Set Up 
b.)  Select the “Linked Media” tab  
c.)  Select Segment 1 and click “Edit. 
d.)  Click “Link” and select a saved media 

file. 
 

 
 

       
 

                    
 



360  BSL PRO Manual 

Visit the online support center at www.biopac.com 

Chapter 18 Licensed Functionality:  
BSL Curriculum Management System 

The BSL Curriculum Management System is available through optional licensing in BSL 4.1 and above only. The 
license must be authorized to use this lesson customization tool. To add a license to an existing Biopac Student Lab 
installation, please contact BIOPAC. 
Overview 
The BSL Curriculum Management System is a licensed feature that allows instructors to add customized lesson 
content and create user-defined onscreen lesson instructions for any existing BSL Lesson. It also has a built-in 
networking feature allowing instructors to easily broadcast customized content to student workstations over a local 
network. The level of control over lesson customization in the BSL Curriculum Management System goes well 
beyond the scope of standard BSL Lessons & PRO and is ideal for instructors wishing to create, edit, and modify 
content in a seamless, flexible fashion.  
This chapter is a guide to the powerful features available in the Curriculum Management System and covers:  
 How to associate custom recording procedures, analysis procedures, introductions and data reports with any 

existing BSL Lesson. (Any user-defined PDF can be substituted for the default BSL Lesson PDFs.) 

 How to edit onscreen HTML Journal content to create custom onscreen instructions. 

 How to configure Instructor (Host) and Student (Client) network settings for sharing lesson content. 

 How to share PRO Lessons and Shared Lessons over a network.  

o BSL PRO Lessons  - H01-H36 and A02-A17 
o Shared Lessons are custom lessons created by the instructor. 

Activating the BSL Curriculum Management License 
Activating the BSL Curriculum Management System license is accomplished via a BIOPAC License Key (a physical 
USB License Key containing the Curriculum Management System activation code).  
The BIOPAC License Key (USB) allows access to the BSL Curriculum Management System from any machine that 
has BSL 4.1 installed. It’s recommended to use this key on personal laptops or office computers. The key is only 
required to run the Curriculum Management portion of the BSL software. 
To Use the BIOPAC License Key (USB): 

1. Connect the Key to an available USB port. (Biopac Student Lab 4.1 must already be installed on the 
computer.) 

Register the key online at www.biopac.com/my-account/product-registration/. Registration is recommended in order 
to receive hardware support, product updates and BIOPAC License protection/replacement options.  
(If no BIOPAC account exists, a prompt will appear for creating one.) 

 
2. The USB key must remain connected in order to use the Curriculum Management System.  

Enabling the BSL Curriculum Management System on the Instructor (Host) machine 
The first step after license activation is to enable the BSL Curriculum Management System preference on the 
Instructor or “Host” machine. 

1. Launch BSL 4.1 and choose “Create/Record a new experiment” in the Startup Wizard. Click OK to create a 
new graph window. 

2. Go to Display > Preferences > Lessons and enable the BSL Curriculum Management System Host option.  

http://www.biopac.com/my-account/product-registration/
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3. Click OK and dismiss the resulting Curriculum Management System prompt. 

  

4. Close the BSL 4.1 application and relaunch it. The Curriculum Management System will now be 
present in the BSL Startup Wizard as the “Customize my lab” option. 

5. Choose “Customize my lab” for access to the Curriculum Management System customization 
options. 

 
 
 
For information on setting up the Student (Client) machines to share the Instructor machine lesson content, see page 
375. 
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Customize my lab – Accessing the BSL Curriculum Management System in the Startup Wizard 
What does the “Customize my lab” option do? The 
“Customize my lab” Startup option is a portal into 
the BSL Curriculum Management System. This 
versatile feature enables the user to substitute 
modified lesson exercise content in place of the 
default BSL Lessons materials by selecting custom 
elements from within the BSL 4.1 Startup Wizard 
options. Your customized content must be in PDF 
format for Analysis Procedures, Introductions, and 
Recording Procedures, and BIOPAC’s Journal 
(*.jcq) format for the Data Reports.  
The Curriculum Management System also includes 
the powerful BSL Visual Editor (accessed via 
“Onscreen instructions”), a flexible HTML editing 
and design tool that enables detailed modification of 
the default onscreen Journal instructions  
accompanying  each lesson recording. With the BSL 
Visual Editor, you can edit, add/format text, 
create/delete/modify tabs and details, as well as 
embed graphics and videos into every lesson segment 
ranging from setup, calibration and analysis. With 
the Curriculum Management System, implementing 
custom lesson plans becomes a simpler and more 
interactive experience. All edited content is presented 
for preview in the lower pane of the Editor and 
appears identically as in the actual lesson. 
For example, let’s say you want to modify BSL 
Lesson 1 (EMG-1) to include variations on the default exercises. Simply edit the Lesson 1 Word document source 
(Word doc sources for all lesson procedures are included on the BSL 4.1 installation DVD). Save your changes, and 
then create a PDF file of the modified lesson. (Later versions of Word or other text editors, such as OpenOffice, 
support the conversion of doc format to PDF, as will the full version of Adobe Acrobat Pro.) This modified lesson can 
then be substituted for the default lesson. The Curriculum Management System’s selectable options place the 
modified files in the Help Menu of the selected BSL Lesson where they are easily accessed by the student. 
Modified lessons can be shared from the Instructor machine (host) with any Student machines (clients) over a local 
network. Sharing lessons does not require special networking expertise. All shared content is configured in the BSL 
Curriculum Management System’s General settings via the checkbox options. 
Need to revert to the default BSL Lesson or onscreen instructions? The original Lesson procedures and instructions 
are not overwritten by creating custom lesson content. Simply uncheck the custom content boxes in the Curriculum 
Management “Lessons” settings, or click the “Change” button and navigate to a different custom lesson file.  
Custom onscreen instructions can also be reverted to the default Biopac instructions from the file menu of the BSL 
PRO application; File > Set up Curriculum Management System. On the Lessons pane of the displayed dialog, click 
the “Revert” button. 
For more details on the Curriculum Management System settings, see page 363. 
Access the BSL Curriculum Management System lesson customization options by choosing “Customize my lab” in the 
Startup Wizard.  
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Customize my Lab Radio Buttons and Controls 
Select the Lesson to customize: The first step is to select the lesson to apply your custom content to. Choose a lesson 
from the list before continuing. 

 
Select what you want to customize: Use the radio buttons to enable specific elements of your customized lesson 
content (Analysis Procedure, Data Report, Introduction, or Recording Procedure). Choose the desired option, click 
OK, and a File > Open dialog will be presented. Simply navigate to the location of your custom content and click 
“Open.” This will place your custom PDF content in the Help Menu of the lesson selected for customization and place 
your custom Data Report and Analysis Procedure into the lesson Journal. 

  
In the above example, a custom Analysis Procedure for L01 is being selected. 

Lesson customization radio button details: 
Radio Button Function 

Analysis 
Procedure 

Use the Analysis Procedure option for navigating to the directory containing the custom Analysis 
Procedure (PDF) to be used. Highlight the new file and click “Open.” This will associate the custom 
Analysis Procedure with the selected lesson and embed it as a tabbed PDF file in the lesson 
Journal. 

Data Report Use the Data Report option for navigating to the directory containing the custom Journal Data 
Report (*.jcq) file to be used. Highlight the new file and click “Open.” This will place the new Data 
Report in the Analysis Journal of the selected lesson. 

Introduction Use the Introduction option for navigating to the directory containing the custom Lesson 
Introduction (PDF) file to be used. Highlight the new file and click “Open.” This will place the new 
Lesson Introduction in the Help Menu of the selected lesson. 

Recording 
Procedure 

Use this option for navigating to the directory containing the custom Recording Procedure (PDF) 
file to be used. Highlight the new file and click “Open.” This will place the new Recording 
Procedure in the Help Menu of the selected lesson. 

On-screen 
instructions 

Opens the BSL Visual Editor, which is used to modify the default onscreen HTML Journal 
instruction content. Use this editor to edit and format text, add tabs, import pictures and videos, 
and more. See page 365 for details on using the BSL Visual Editor. 

Preview Changes 
Use the “Preview Changes” option to conduct a trial run of the modified lesson. You also have the option of changing 
other default Lesson Preferences at this time. 
More Settings 
The “More Settings” dialog presents advanced options for setting up custom lesson content. It essentially performs the 
same function as the “Customize my lab” radio buttons, but with a greater degree of control and all custom content 
options presented on a master screen. This is also where custom lesson material for broadcast from the Instructor 
(host) computer to client (student) computers is selected. (See page 375.) 
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The above Lessons settings dialog may also be accessed from the BSL PRO application via the “File > Setup BSL 
Curriculum Management System” menu option. Options and controls are as follows: 
Use custom Help menu introduction PDF: - enables option to use custom Introduction in Help menu and broadcasts 
intro to client (student) computers. 
Open – opens the selected custom introduction file for preview. 
Change… – opens a File > Open dialog for selecting a different Introduction file. 
Use custom Help menu procedure PDF: - enables options for using custom Lesson Procedure in Help menu and 
broadcasts this content to the client (student) computers. 
Open – opens the selected custom Lesson Procedure for preview. 
Change…– opens a File > Open dialog for selecting a different Lesson Procedure file. 
Use custom onscreen instructions – enables the option to show customized Journal instructional content for the 
selected lesson. If unselected, the standard default onscreen instructions are shown. 
Edit – opens BSL Visual Editor for editing the selected lesson Journal content 
Revert… – discards custom Journal instructional content in favor of the original default content. (The following 
prompt will appear when choosing this option.) 

 
Embed Data Report in data files – enables option to embed the standard or custom Data Report into the analysis 
Journal. If unselected, only the lesson segment summary will be displayed in the analysis Journal. 
Use custom Data Report Journal – the custom Data Report will be embedded in place of the standard default data 
report. If unselected, the standard default Data Report will be used. 
Open – opens the custom Data Report file for preview. 
Change… – opens a File > Open dialog for selecting a different Data Report (*.jcq) file. 
Include Analysis Procedure PDF in Data Files – when selected, the standard or custom Analysis Procedure PDF is 
embedded as a separate tab in the analysis Journal following the lesson.  
Use custom Analysis Procedure PDF: – the custom Analysis Procedure will be embedded as a Journal tab in place 
of the default Analysis Procedure. If unselected, the default Analysis Procedure will be used. 
Open – opens the selected custom Analysis Procedure for preview. 
Change…– opens a File > Open dialog for selecting a different Analysis Procedure file. 
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BSL Visual Editor 
The BSL Visual Editor is a designing and editing tool used to modify the default onscreen Journal instructions for any 
selected lesson. If a custom lesson procedure is being used, the corresponding onscreen Journal instructional content 
can be edited to match the custom procedure. 
The BSL Visual Editor is an important component in the Curriculum Management System and allows for flexible 
manipulation of onscreen Journal content of a running lesson. The Editor consists of a main toolbar area, two control 
docks, an editing window and a preview area. 
The launch BSL Visual Editor: 

• Select the “Onscreen instructions” radio button in the “Customize my lab” Startup screen. (Click OK) 
• Select “More Settings” and enable the “Use custom onscreen instructions” checkbox in the BSL Curriculum 

Management System settings window. (Click OK) 
• In the BSL PRO application, File > “Set Up BSL Curriculum Management Settings” and enable the “Use 

custom onscreen instructions” checkbox in the BSL Curriculum Management System settings window. (Click 
OK) 

The Editor can interactively modify the following areas of the lesson Journal: 
• Fast Track text, including the addition of actions, notes and other text and graphics. 
• Collapsible notes and pictures in the Details area 
• Tab name and tab title, including the addition and deletion of tabs 
• Standard text formatting tools are provided – edit font size/style/ text and background color 
• Text alignment, bulleting and numbering, increase/decrease indent 
• Create and insert tables, hyperlinks or HTML code 
• Undo, redo, cut, copy, paste, file open/save 
• Zoom forward/back text and image size 

BSL Visual Editor Window 

 
BSL Visual Editor Window 
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Main Text Editing Area 
The Main Editing Area is the workspace for modifying text and other content appearing in the Lesson Preview Area 
and appears at the center of the BSL Visual Editor screen. Simply enter standard (or HTML) text into this field, or 
modify existing text using the formatting tools (see formatting toolbar on page 367). 

 
Text Editing Area – View Source Tab  
The “View Source” tab displays the raw HTML source code for items currently selected in the Editing Area. This 
field is not editable but the content can be copied into the Editing Area and modified externally. 

 
It’s important to remember that the text in the Editing and Preview Areas mirrors the lesson text for the currently-
selected lesson Segment. Other factors affecting Editing Area content are the various elements selected in the Tab 
Constructor and Tab Interior Designer. (See explanation of these controls below.) 
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BSL Visual Editor Toolbar 
The following formatting tools are available in the Editor: 

 

Tool Description 

 
Open button. Launches a File > Open dialog for navigating to a lessons instructions file (*.xml format). 

 
Save button. Saves the current edits to the lesson instructions. 

 
Undo button. Removes the most recent editing or formatting operation. 

 
Redo button. Restores the most recent editing or formatting operation. 

 
Cut button. Cuts the selected Editor text or content. 

 
Copy button. Copies the selected Editor text or content. 

 
Paste button. Pastes the selected Editor text or content. 

 
Bold button. Toggles bold font style. 

 
Italics button. Toggles italicized font style. 

 
Underline button. Toggles underline of selected text. 

 
Strikethrough button. Toggles strikethrough of selected text. 

 
Align left paragraph button. 

 
Align center paragraph button. 

 
Align right paragraph button. 

 
Align justified paragraph button. 

 
Numbered list button. 

 
Bulleted list button. 

 
Increase indent button. 

 
Decrease indent button. 
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Tool Description 

 
Insert table button. This option displays the following table formatting options: 

 

 
Insert image button. Displays File > Open dialog for navigating to an image file. 

 
Hyperlink tool. Displays dialog for entering URL information. 

 

 
HTML tool. Displays following dialog for inputting HTML code at the cursor location. 

 

Zoom Tool 

 
There are two independent Zoom tools in the BSL Visual Editor window. The Zoom tool on the top right controls the 
sizing of the Text editing Area content and the bottom right Zoom tool controls the sizing of the Preview Area 
content.  
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BSL Visual Editor Menus 
The Editor menus display an alternate method for accessing the formatting toolbar options, plus a few additional 
controls. 

   
File > Revert   
Discards global changes made to the currently open set of instructions. 
Format > Font Name, Font Size, Text Color, Background Color 
Additional formatting tools for operations not included in the formatting toolbar.  

BSL Visual Editor Tools and Controls 
BSL Visual Editor controls are described below on a sectional basis. Refer to the above image for their default Editor 
window locations. 
Segment Viewer 

 

The Segment Viewer is used to select available lesson recording 
segments for global editing and preview display. This control is dockable 
and can be positioned anywhere in the BSL Visual Editor window. 
When a Segment Viewer entry is selected, the Lesson Preview Area 
displays all required actions for that segment in the lower half of the Editor 
screen. The Lesson Preview closely resembles the instructional Journal 
presented during the running of an actual lesson. 
 (The Lesson 1 CAL Setup segment is shown in this example preview.) 

 
Segment Viewer Limitations: The Segment Viewer menu is not editable, 
and only one segment may be selected at a time. New lesson recording 
segments cannot be added, and default segments cannot be deleted. 
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Tab Constructor (for Fast Track content) 

    
 
Tab Name and Tab Title as they appear in the 
Fast Track Preview Area. 

 

The Tab Constructor is used for editing, adding and deleting 
tabs and tab text in the Fast Track Preview Area. This control is 
dockable and can be positioned anywhere in the BSL Visual 
Editor window. 

 
The “Tab Name” and “Title” fields are directly editable. To 
change existing Tab text, click into the Tab Name or Title field to 
select and enter new text. Press Enter to accept the new edits. 
Newly-added Tabs will remain “Untitled” until new text is entered 
in the active Tab Name and Title fields. 

Use the  buttons to add new Tabs or remove existing 
Tabs.  
New Tabs will appear in the Tab Name list below the currently-
selected Tab and to the right of the selected Tab in the Fast 
Track Preview. To delete a Tab, select it and click the Tab 
Delete button. (Red “X”) 

Tab Interior Designer (Fast Track) 

 
Lesson Preview of Fast Track text. 

 

Editing Area for entering/formatting Fast Track 
text. 

 
 

Use the Tab Interior Designer to select blocks of Lesson 
Preview text for editing. This control is dockable and can be 
positioned anywhere in the BSL Visual Editor window. 
Fast Track selection: 
The default formatting for BSL Lesson Fast Track text consists 
of Actions or Notes. 
Actions are are indented and bulleted by default. 
Notes appear as standard text. 
Actions or Notes can be reformatted as desired in the main Text 
Editing Area. (See page 366.) 
To enter or edit an Action or Note: 

1. Click on the desired Action or Note item in the list to 
select it. (The selected text will be outlined in red in the 
Lesson Preview.) 

2. Type the new text into the Text Editing Area in the 
center of the Editor screen.  

3. Apply the new text to the Preview by clicking the 
Refresh Preview button.  

Tab Interior Designer “Fast Track” Tools: 

Use the  button to add a new Fast Track Action. 

Use the  button to add a new Fast Track Note. 

Use the  button to add an empty space to Fast Track. 

Newly-added Actions or Notes appear below the currently-
selected Action/Note in the Fast Track list. (Items in the list 
cannot be dragged to different locations.) 



Part D — Licensed Functionality 371 

BSL PRO Manual 

 
Tab Interior Designer (Details) 

 

Text Editing Area with Main Data selected: 

 

Example of Details with collapsible sub-text: 

 

 

Enter collapsible sub-text in Text Editing Area: 

 

Collapsible sub-text as it appears in preview: 

 
Collapsible means that clicking the underlined 
Detail text in the Preview Area will show or hide 
the sub-text. 

Use the Tab Interior Designer Details option to edit the right 
pane Preview Area content. This area is where supporting 
details, illustrations, pictures and videos are typically embedded. 
The Details option consists of a Main Data entry, which displays 
the primary content in the Text Editing and Preview areas.  
To select Main Data content for editing: 

1. Click the Main Data field. 
2. Edit content by typing into the main Text Editing Area in 

the center of the screen. Import of graphics and videos 
are also supported. (See page 367 for more Text 
Editing Area tools.) 

To add optional Details text to the Main Data: 

1. Click the  button. 
2. Highlight the newly-added “Untitled” entry and enter the 

desired text. 

 
3. Press the Enter key (or click anywhere in the Editor 

window) to apply the edit. The new Details text will 
appear in the lower right Preview area. 

 
You may also:  

• Add collapsible sub-text to the selected Detail by typing 
it into the Text Editing Area. (See left example.) 

• Edit the existing Details of any selected lesson 
segment. 

• Delete Details using the  button. 
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Additional BSL Curriculum Management System Settings 
The global settings for BSL Curriculum Management are controlled and displayed in the panels within this screen. 
Access the BSL Curriculum Management Settings by: 

• Clicking the  button in the BSL Startup Wizard’s > Customize my lab option. 
• Choosing File > Set Up BSL Curriculum Management System in the BSL 4.1 PRO application. 

Status Panel  

The Status panel displays current information about the Instructor (Host) and Student (Client) machines during a 
lesson session. 

 

Control Description 

Computer name Displays the Instructor (Host) machine name. 

Host and port status Displays whether the Host machine is running or stopped. If running, the 
Host machine’s port number is displayed. 

Connected Student 
(Client) machines 

Lists all recognized Student (Client) computers on the network using the 
configuration from the Host machine. They may not be actively 
transferring data but should still be running BSL in client mode. 

General Panel 
The General panel contains basic options for configuring the Curriculum Management System that apply at the 
application level or are shared by all lessons: 
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Control Description 

Enable BSL 
Curriculum 
Management System 

Enables the BSL Curriculum Manager, allowing it to broadcast settings and content over the 
local network.  

Host port Current port number used by the Instructor (Host) machine. Default value is 15055. 

Lesson and PRO 
Lesson Startup 
Wizard visibility 

Clients restrict the available choices for the Lessons and PRO Lessons tabs on their Startup 
Wizard to match the lesson preference settings of the Host computer. 

Lesson Preferences 
and Enabled 
Segments 

Enables Student computers (Clients) to use the settings from the Host computer for individual 
lesson preferences (File > Lesson Preferences when running a lesson) as well as any 
customizations applied to the Host computer's lesson segment display. Changes to the Host 
computer’s lesson preferences must be applied by running the specific lesson and altering the 
settings in File > Lesson Preferences. 

BSL Application 
Preferences 

Enables Clients to use the Host computer's settings for all application preferences instead of 
local preferences. This sharing is unidirectional; any changes in application preferences made 
on a Client machine do not affect the Host.  To make a permanent setting change, the Host’s 
Display > Preferences settings must be modified. 

Change Password Use this option to set up or change a password to access any Curriculum Management 
Settings. When set, the password will be required when choosing “More Settings” option in the 
BSL Startup Wizard > “Customize my lab” option, or when using File > “Set Up BSL 
Curriculum Management System” in the BSL PRO application. 

Lessons Panel 
See page 364 for explanation of Lessons Settings panel. 

Shared Lessons Panel 
Shared Lessons are graph templates with instructor-provided titles made available for use on all Clients. These graph 
template files may have their own embedded Journals and PDFs to assist in distribution of Instructor materials. This 
panel configures the specific graph template files being shared. 

 

Control Description 

Share Graph 
Template... 

Displays a dialog for navigating to the location of the graph or graph template 
to be shared.  

Rename... Displays a dialog for renaming the default title of the shared lesson under the 
“Name” field. 

Unshare…  Removes the selected lesson from the shared lessons list.  
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Setting Up Curriculum Management Instructor (Host) and Student (Client) Sharing 
The BSL Curriculum Management System allows for the sharing of default and custom lessons and other instructional 
materials over a local network, and is split into “Host” software (including configuration controls and editors) and 
“Client” software. Depending on the Host machine settings, the following information may be shared: 

• Application level preferences 
• Standard and PRO Lesson visibility 
• Shared instructor-generated PRO Lessons 
• Individual lesson preferences 
• Replacement help menu introduction and procedure lesson PDFs 
• Customized lesson HTML instructions and content 
• Replacement Data Report journal 
• Replacement analysis instruction PDF for data files  

The following Host-Client controls for BSL Curriculum Manager are found in the BSL PRO application’s Display > 
Preferences > Lessons: 

 

Control Description 

BSL Curriculum Management System Host Allows this computer to “push” all customized lesson 
content to the other computers on the local network. 

Client of Curriculum Management System Allows this computer to receive the customized 
lesson content and onscreen instructions being 
“pushed” from the Curriculum Management System 
Host computer over the local network. 

Locate Host – Automatically  Searches automatically for Curriculum Management 
System Hosts on the local network. 

Locate Host – Manually  Allows the Curriculum Management System Host to 
be identified by a fixed I.P. address and port number. 
Use this option is auto-location is not supported on 
your network. 

Require Curriculum Management System host Check to prompt on application launch if no 
Curriculum Management System Host is detected. 

Allow BIOPAC standard lessons if required host is 
missing 

Allows access to the default uncustomized BSL 
Lessons if no Curriculum Management Host is 
detected. 

Local program for working with standard lessons Use the standard BSL Lesson Curriculum.This 
setting disables the Curriculum Management System. 

NOTE: Before sharing the instructional content, enable or disable the desired lessons in the Curriculum Management 
Settings and the Display > Preferences > Lessons settings. 
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To share BSL Curriculum Management materials over the network, use the following steps: 
1. Launch the BSL PRO application on the Instructor (Host) computer. 
2. Display Preferences > Lessons. Make sure that “Run BSL application as – BSL Curriculum Management 

System Host” is enabled. 

 
3. Launch the BSL PRO application on the Student (Client) computer. 
4. Display > Preferences > Lessons. Make sure that “Run BSL application as – Client of Curriculum 

Management System” is enabled. 

 
5. Check “Locate host – Automatically.” (If your network does not support auto-location, contact your network 

administrator to obtain the correct I.P. address and port information, and use the “Locate Host – Manually” 
setting.) 

6. Click OK, and click OK to the configuration change confirmation dialog. 

 
7. Close the BSL application on the Student (Client) computer. 
8. Relaunch the BSL application on the Student (Client) computer. The following dialog will appear: 

 
9. The Student (Client) computer will connect automatically to the Instructor (Host) computer over the network, 

and all configured Host preferences and shared materials will be available to the Clients. 

Note: Although detection of multiple Instructor (Host) computers is supported, only one Host computer may be used 
at a time by a Client. If multiple BSL Curriculum Management Host computers are found on the network, the 
following message will be displayed. 
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Importing and Exporting Curriculum Management Settings  
Customized content and saved Curriculum Management System preference settings can be exported into a proprietory 
custom settings archive file called *.csp format. The Import/Export functionality allows for customized content and 
preferences to be exported to a single file that can then be transferred between computers.  
This feature is useful not only for backing up custom settings, but also offers the ability to edit content on an 
office/home computer and then easily move (import) those files to a host in the lab. 
To access this feature, launch BSL and select the “Create and record a new experiment,” then choose the File menu 
and note the two Import and Export Curriculum Management Settings options: 

 
In order to use the Import option, a saved Curriculum Management Settings archive (*.csp) file must be available. A 
saved settings file must first be created by using the “Export…” option, or a saved settings file must be available 
from another machine with BSL installed. 
To Export Curriculum Management Settings 

1. Choose the “Export BSL Curriculum Management Settings” option. This launches a File > Save As dialog. 

 
2. Name the settings archive (*.csp) file and Save it to a location of your choice. 

The following confirmation dialog will appear after the archived Curriculum Management settings are exported. 

 
To Import Curriculum Management Settings 

1. Choose the “Export BSL Curriculum Management Settings” option. This launches a File > Open dialog. 
2. Navigate to the location of the saved *.csp file, select the file and click Open. 

 
The following confirmation dialog will appear after the archived Curriculum Management settings are imported. 
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Chapter 19 Licensed Functionality: Network Data Transfer 
Network Data Transfer (NDT) functionality is available through an optional license available with BSL 4.1.2. 
The license must be authorized to access NDT functionality. To add an NDT license to an existing MP 
System, please contact BIOPAC. 

Network Data Transfer (NDT) is a real-time data transfer system that allows access to the data being acquired into a 
graph by BSL PRO for use in an external application; the BSL process and the custom application may run on the 
same computer.  
Make TCP or UDP connections to external applications and stream binary data during acquisitions. 

The NDT license  

 Allows Network Data Transfer functionality  

 Includes Network Data Transfer Preferences 

 Click for a Network Data Transfer video tutorial. 

Most of the settings for the network data transfer functionality are set by clients through control connections. Several 
settings for the BSL server may be set directly in the BSL preferences. Versions of BSL that include network data 
transfer functionality have an additional "Network" group of settings underneath their Preferences. These Preferences 
are accessed from the Display menu ( Windows) or from the Biopac Student Lab menu (Mac OS): 

 
NDT is a basic method for allowing third party applications to tap into the data stream being generated by both the 
MP unit and BSL during data acquisitions. NDT provides: 

 Networking facilities that allow for integration into a distributed application environment 

 Basic control facilities to allow external applications to query and control the BSL application state. 

The NDT system is split into two separate types of connections: data connections and the control connection.  

A. Data connections deliver data from BSL to external applications during acquisitions.  

B. Control connections are made from external applications to BSL to query application state and adjust data 
connections. 

The server refers to the BSL process and the computer on which it is running. The client refers to the custom 
application that is to receive data from BSL and the computer on which it is running.  

All connections should be made using standard network protocols, either TCP or UDP. Single system image 
architectures should make connections using the loopback interface. It is assumed that network implementations have 
appropriate IP networks in place with routing between machines that can be identified either by IP address or by 
hostname. Firewalls must be properly configured to allow network communications between the client and server. 
Appropriate network configuration is the user’s responsibility. 

Data Connections 
Data connections are used to deliver data from the BSL server to the client application. Data connections stream both 
data acquired from an MP unit and computed data from BSL calculation channels. Data connections are available in a 
variety of formats and can be configured to meet the needs of the client application and bandwidth requirements. 

https://www.biopac.com/video/?video_category=data-integration&v=network-data-transfer-demo-using-heart-rate-to-change-hand
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Data connections are created only at the start of acquisitions. It is not possible to “attach” to data acquisitions that are 
already in progress. 

XML-RPC calls for retrieving data are also described in this section. These connections are not persistent and not 
established from server to client, but rather a request made from client to server. The recommended mode of operation 
is regular TCP or UDP operation. 

Variable Sampling Rates 
BSL PRO uses variable sampling rates that allow different channels of data to be acquired at different sample rates. 
This allows fast moving signals (such as EMG) to be acquired at high sampling rates while simultaneously recording 
slow moving signals (such as respiration) at lower sampling rates. The primary use of variable sampling rate is to 
optimize storage requirements by minimizing space spent retaining slow moving data. 

In addition to the storage optimizations, variable sampling rates are also used to optimize data connections. Channels 
that are sampled at lower rates require less network bandwidth to transfer from client to server. If channels of data 
cannot be disabled and overall bandwidth is limited, variable sampling rate can be used to lower the bandwidth 
required to move data between the server and the client. 

The use of variable sampling rates requires the client to be aware of downsampled channels and handle data 
accordingly. Variable sampling rate may also affect the interpretation of the incoming data connection stream, as 
indicated below. 

Transfer Types 

Clients may choose between two different transfer types:  

 Single connection uses one data connection between the server and the client to deliver all data 

 Multiple connection uses multiple data connections delivering data simultaneously 

Single Connection 

The single connection transfer type uses a solitary connection between the server and the client to deliver data. When 
multiple channels of data are being delivered, all data is sent over the single connection in an interleaved format. The 
interleaved format mingles the data of all channels in order. For example, an interleaved representation of two 
samples from three channels of data would be: C1 C2 C3 C1 C2 C3. This is equivalent to two sample frames where a 
frame contains the data at a particular sample location for all of the channels, in this case “C1 C2 C3.” Frames are 
delivered sequentially over the data connection. 

The single connection transfer type allows for all data to be processed from a single location and uses only one 
network connection resource. Single connection transfer has drawbacks including the need for the client to demux the 
data stream as well as account for variable sampling rates. 

Variable Sample Rate Considerations 

When variable sampling rate is being used, the single connection transfer type has the characteristic where not 
all frames have the same size. If a frame occurs at a sample position where a channel is not being sampled, 
that channel will not be included in the frame. 

All downsampling within the BSL variable sampling rate environment occurs at integer divisions of the base 
sampling rate. Only frames with indexes (zero-based) that are evenly divisible by the downsampling divider 
will contain data for that channel. 

It is the responsibility of the client to compute and retain the frame index and to properly check 
channel dividers against the frame index to determine which channels are represented in that 
frame. 

Frame 0 always contains a data point from every channel. 

For example, consider a three channel acquisition. Channels 1 and 3 have a downsampling divider of 1, that 
is, they are being acquired at full speed. Channel 2 has a downsampling divider of 2, that is, channel 2 is 
being acquired at half speed. The first five frames of data in the single connection transfer type will appear as 
follows: 
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C1 C2 C3 | C1 C3 | C1 C2 C3 | C1 C3 | C1 C2 C3 

Note how frames 1 and 3 are shorter as they occur at positions where channel two is not defined. 

If variable sampling rate is being used, clients are required to perform proper frame indexing in order to 
demux the interleaved data stream. If clients cannot handle variable sampling rate correctly and are using the 
single stream transfer type, clients should check all of the downsampling dividers using the control 
connection to BSL and warn the user if the configuration cannot be supported with that client. 

Multiple Connection 

The multiple connection transfer type uses a single connection from server to client for each channel of data that is 
being delivered. Using multiple connections offers the benefit of avoiding the client having the need to demux all of 
the data from each sample. If the client is operating in a high-load environment, the elimination of the demuxing may 
be useful in reducing processor overhead. It also allows client code to be simpler if variable sampling rate is being 
used. 

The primary disadvantages of using the multiple connection transfer type are the usage of more network ports and the 
client assuming responsibility for synchronization of data across multiple channels. The data immediately available on 
one network connection may not be guaranteed to be the identical sample index of data being received for another 
channel. The client must keep track of sample index on an individual channel basis to properly synchronize data 
across multiple channels. 

Variable Sampling Rate Considerations 

Using variable sampling rate in a multiple connection transfer type is significantly easier. Each individual 
channel's connection delivers data at that channel's sampling rate. On a given connection, all samples have an 
identical length. 

Clients still must be aware of variable sampling rates. The sampling rate of information on a downsampled 
channel connection is different than the sampling rate of information on an upsampled channel connection. If 
the client is performing any time domain measurements or other computations involving the sample interval, 
the difference in inter-sample-interval must still be taken into account. 

XML-RPC 

The XML-RPC transfer type allows clients to explicitly request data from the server. Instead of data being 
automatically pushed to clients, the client must post an XML-RPC function call to the server. This allows the 
client to query the server for the most recently acquired data sample value for a particular channel. Clients 
that do not require continual data streams or interact with only slow moving data may wish to use this method 
communication method. This method returns values only; no information about sample indexes or lengths is 
returned. 

XML-RPC has significant overhead for both client and server, so this transport method cannot handle more 
than a few requests per second. If faster response time is required, the client should implement either the 
single connection or multiple connection streaming methods. 

XML-RPC is not a true data connection as it does not involve the server constructing a streaming connection 
to the client. 

Transport Protocol 
Data connections offer a choice of using either TCP or UDP as the transport protocol for delivering data to the client. 
Choice of protocol depends on application requirements. When a client is receiving data, it is assumed that all data 
connections are using the same transport protocol. 

TCP/IP 

TCP is the preferred transport protocol. As TCP guarantees reliable, ordered delivery, all data is simply transferred 
from the server to the client without any additional information. Data is streamed continuously as it becomes 
available. TCP is recommended for all clients that require a guarantee of receiving all information. It is also 
recommended for any configuration using up to two computers.  
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The port number used for data connections is specified by the client using the control connection prior to the start of 
acquisition. Once a client passes along port information, the client should begin listening for connections on that port. 

When using TCP data connections, the start of acquisition is signaled to clients by the establishment of a connection 
on an appropriate port to the client. The end of an acquisition is signaled by the termination of the connection. 

UDP 

UDP is a connectionless protocol that does not guarantee either delivery or properly ordered reception of packets by 
clients. Data connection is allowed to be switched to UDP delivery mode. The primary benefit of using UDP 
datagrams is that a single data stream can be multicast to a number of computers. Multicasting is not offered 
implicitly by the BSL data connection protocol but can be achieved implicitly by requesting a data connection be 
bound to a broadcast address. 

UDP delivery used fixed size datagrams. The default size is 512 bytes. Clients can modify this size to any fixed 
number of bytes prior to the start of acquisitions. The UDP packet size is stored in the template and is different for 
each graph. UDP clients that require a specific packet size should set that packet size prior to the start of  
each acquisition. 

Each datagram will contain the following: 

Field Data Type Offset Description 

Starting sample 
index 

unsigned long 
(four bytes, 
network order) 

0 byte This indicates the starting sample position of the first sample of data 
contained in the packet. This number is always monotonically 
increasing and can be used to reassemble datagrams that are received 
out of order. 

This field is always stored in network order. Usage of htonl()/ntohl() 
should convert from network order into host endian. 

Length of data 
section in bytes 

unsigned long 

(four bytes, 
network order) 

4 bytes Total number of bytes in the data section. Data is sent by BSL as it is 
available, so not all data packets will contain the same amount of 
data. 

This field is always stored in network order. Usage of htonl()/ntohl() 
should convert from network order into host endian. 

Data section (type and 
endian specified 
by client) 

8 bytes Data section containing the binary data that was acquired. The data is 
converted into the appropriate data as configured by the client. 

All of the data delivery is performed as data is available from the MP unit. The actual size of the data section in 
packets that get delivered to the client is dependent on the speed of data acquisition and other activity on the host 
computer. If variable sampling rates are being used, frames will not be split up. All of the data for the final frame is 
contained in the UDP packet. If a frame will not fit in the amount of space in a packet, it is sent in the next packet. 

There are no provisions for clients to request retransmissions of packets from the server. Clients should be aware that 
data may not be delivered when using UDP and should be prepared to examine sample indexes at the beginning of 
each packet and handle missing data accordingly (padding, warning user, etc.). 

The port on which datagrams is delivered is specified by the client prior to the beginning of acquisition on the control 
connection. Once the client specifies its port, it should begin listening for datagrams delivered to that port. The start of 
acquisition is signaled by the first datagram that is sent to that port. The sample index of the first datagram 
corresponds to the first hardware sample of data acquired by BSL. If the graph is initially empty, the index is zero. 

Unlike TCP connections which get explicitly disconnected at the end of acquisitions, there is no direct messaging for 
UDP delivery indicating the end of acquisitions. Datagrams will not be sent to the client after the end of acquisition. 
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Clients requiring explicit termination notification should either use TCP or implement a timeout mechanism combined 
with an XML-RPC getAcquisitionInProgress call on the control connection to locate the end of acquisitions. 

XML-RPC 

The XML-RPC “get most recent data sample” call will use standard XML-RPC connection semantics involving the 
client making an HTTP POST request to the server and interpreting the response as appropriate. Handling of XML-
RPC can be performed by a library in the client's appropriate implementation language. 

Real-time Delivery Guarantees 

No delivery time guarantees exist for any data connection. Data is delivered to the client as it becomes available. The 
overall latency of the system from physical sample time to data delivery is dependent on  a number of factors 
including network load, BSL overhead (which is variable due to calculation channel processing time, user interface 
activity, thread scheduling, and other operations), system load, and other factors. The actual sampled data itself is 
guaranteed to be accurate; the sample time of a signal acquired into the hardware unit is always accurate.  
It is only the time between the physical time corresponding to a sample and its delivery to the client application that is 
variable. 

Clients that require strict real time guarantees or more predictable latencies should investigate using the hardware API 
on their local machine. 

Data Formats 
It is assumed that the data transfer feature is used in a mixed host environment, potentially with clients running in 
environments that have restricted data types. The sampled information delivered by a data connection is allowed to be 
controlled to appear in a variety of different formats for the client: 

 64 bit floating point – This format will always be available for all channels and may be delivered in either big 
endian byte order or little endian byte order. This is equivalent to a C style double data type. 

 32 bit floating point – This format will always be available for all channels and may be delivered in either big 
endian byte order or little endian byte order. This data type is not native to BSL, so the precision of received 
data may differ from data as recorded by BSL. This is equivalent to a C style float data type. 

 Signed 16 bit integer – This format is available only for analog data channels. It may be delivered in either big 
endian byte order or little endian byte order. This is equivalent to a C style short data type. Clients receiving 
data in 16 bit integer format should use the control connection to determine appropriate floating point scaling 
factors that need to be applied to the data to convert into actual units. 

Data formats should be specified by the client prior to the start of acquisition. If left unspecified, the default data 
format depends on channel type: 

Channel Type Default Data Type 
Analog 16 bit signed integer, little endian 
Digital 16 bit signed integer, little endian 
Calculation 64 bit floating point, little endian 

XML-RPC get most recent sample requests will always return the double type of XML-RPC (in ASCII notation). 

Default Data Connection Settings 

If the client does not modify any data connection settings, the following is used: 

 Single connection transfer type 

 TCP/IP transport protocol 

 Port 15020 for single connection 

 For multiple connections, each channel type (4 analog channels, 8 digital channels and 16 calculation 
channels) is set as follows: analog channels [15020-15023], digital channels [15040-15047], calculation 
channels [15060-15075]. 
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 Default data formats for each channel type as indicated in the “Data Formats” section 

Note that no channels are enabled for delivery by default. Both data connection delivery and get most recent sample 
tracking are disabled. Clients will still need to enable channels in order to receive data. 

Locating BSL Servers 

It is possible that clients and servers may be located on networks with dynamic IP addresses or other features that 
make establishing the connection between machines difficult. In this case, a simple UDP broadcast mechanism can be 
used to locate known servers. 

BSL will listen for incoming UDP packets on port 15012. If the UDP packet contains the sequence of ASCII 
characters “AcqP Client” and only that sequence, it will send a broadcast packet containing “AcqP Server Port:” 
followed by the port number on which the server is listening for control connections. The port number is expressed in 
base 10 ASCII notation. 

It is possible to configure BSL to not acknowledge discovery requests for security purposes. 

Control Connections 
Clients connect to a BSL server using control connections. A control connection allows the client process to control 
how data is going to be delivered to it, query settings, modify settings, and perform other basic operations without 
requiring graphical interaction with the BSL environment. 

On the start of an acquisition, all data connections are established to the client that most recently established a control 
connection unless the client has modified the destination by using the  changeDataConnectionHostname command. 

It is possible to configure BSL to not respond to any control connections for security purposes. 

The majority of all control connections use XML-RPC. The XML-RPC specification can be located at 
http://www.xmlrpc.com/spec. XML-RPC consists of an HTTP POST request being assembled by the client along 
with data content expressed in the XML-RPC notation. The remote procedure call will then return with an appropriate 
response to the caller. By design, XML-RPC is client and platform agnostic. 

XML-RPC implementations exist for a number of languages. If there is no implementation in the client's language, 
hardcoded requests can be embedded or a small helper application or shared library can assist in providing the control 
connection interface. 

The URI that should be used when connecting to the server is the recommended “/RPC2” for XML-RPC. For 
example, a URL for localhost control connections would be “http://localhost/RPC2.” 

TCP Port 

Only one control connection may be opened by a client to a server at a time. The server will listen on port 15010 by 
default. As this port may conflict with other network services or may need to be modified for firewall accessibility, 
BSL will allow the server port to be modified by the user in the Display > Preferences panel. Clients should be aware 
that control connection port numbers are not fixed and should either allow users to change the port number from the 
client or use the dynamic discovery mechanism for locating BSL servers. 

Control Procedure Calls 
Control procedure calls are remote procedure calls with a set method name and response. All method names and 
strings are case sensitive. The available control calls are roughly split up into querying acquisition parameters, 
configuring data delivery, and limited calls for modifying acquisition parameters and affecting application state. 

Channel Index Parameter Structures 

Some procedure calls take a channel index structure as a parameter. This is an XML-RPC structure that consists of 
the channel type and index. The channel type is a string member named “type” that is one of the following strings: 
analog, digital, calc. The channel index is an integer member named “index” and contains a zero-based index 
indicating the channel. For example, the following channel index parameter structure can be used to refer to calc 
channel 2 (recall, in BSL calc channels are indexed from zero): 

<struct> 

http://www.xmlrpc.com/spec
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 <member> 
  <name>type</name> 
  <value><string>calc</string></value> 
 </member> 
 <member> 
  <name>index</name> 
  <value><int>2</int></value> 
 </member> 
</struct> 

Querying Acquisition Parameters 

The calls for querying acquisition parameters are intended to allow clients to request information required for them to 
fill out appropriate parameters and to verify that previous control requests have been properly applied. The following 
control calls are recognized: 

getMPUnitType 

Method name: acq.getMPUnitType 
Parameters: None 
Return value: int 

 Retrieves the type of MP unit to which the server is connected. This may be zero (indicating no unit is 
connected, e.g. “No Hardware” mode), or 36 (for MP36). 

 The client can use this value to decide between appropriate templates to download or other channel settings. 

getEnabledChannels 

Method name: acq.getEnabledChannels 
Parameters: string 
Return value: array populated with int 

 Retrieves the channels that are available for acquisition and data delivery over a data connection to the client. 
The type of channels that are to be returned are specified in the string parameter. The string parameter may be one of 
the following: analog, digital, calc. The type must be lowercase. “analog” returns information about analog channels, 
“digital” digital channels, “calc” calculation channels. 

 The enabled channels are returned as an array of channel indexes, zero-based. These are the indexes that can 
be validly used in calls for configuring data connection parameters. 

getChannelScaling 

Method name: acq.getChannelScaling 
Parameters: channel index parameter structure 
Return value: struct containing scaling 

 For channels that can be delivered in short integer format, the channel scaling provides the scale factor and 
offset used to convert the short into physical units using the formula: sample*scale+offset. The scaling is returned as a 
structure containing two double-valued members: “scale” contains the multiplication factor, “offset” contains the 
offset factor. 

 Channels that cannot be delivered as short integers cannot be scaled. If this method is called with an invalid 
type of channel, a fault response is returned. 

getSamplingRate 

Method name: acq.getSamplingRate 
Parameters: None 
Return value: double 

 Returns the current sampling rate expressed in Hz. This is the rate at which data is sampled for a channel 
whose downsampling divider is 1. 
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getDownsamplingDivider 

Method name: acq.getDownsamplingDivider 
Parameters: channel index parameter structure 
Return value: int 

 Retrieves the downsampling divider for a particular channel. A channel is sampled at the base sampling rate 
divided by this factor. This factor is also used to determine which frames contain samples for this channel. 

Data Connection Configuration Commands 

While it is possible to configure data connection parameters using BSL, frequently clients may need to alter data 
connection configurations based upon dynamic information regarding the machine on which they are running (e.g. 
port collisions with other services, unexpected endian changes, etc.). The following commands may be used to 
configure how data is delivered to the application. 

getDataConnectionMethod 

Method name: acq.getDataConnectionMethod 
Parameters: none 
Return value: string 

 Returns the method currently being used for data connections between the server and client. The string value 
is either: single, multiple. “single” corresponds to a single data connection being made between the server and the 
client with all data interleaved over that connection. “multiple” corresponds to opening an individual connection to 
the client for each channel. 

changeDataConnectionMethod 

Method name: acq.changeDataConnectionMethod 
Parameters: string 
Return value: 0 on success, or fault code 

 Changes the method used to deliver data to the client. The parameter is a string that is one of the following: 
single, multiple. “single” opens up a single data connection and sends data in an interleaved fashion. “multiple” opens 
up an individual data connection for each channel. 

getDataConnectionHostname 

Method name: acq.getDataConnectionHostname 
Parameters: none 
Return value: string 

 Returns the currently set hostname for data connections. When data connections are established on the start of 
acquisition, the IP address associated with this hostname is sent the data. Hostnames must properly resolve in order 
for data connections to be made; DNS configuration is outside of the scope of the network data transfer feature. 

 If this hostname is empty, data connections is made to the most recently connected client application. This is 
the default setting. 

 Hostnames are unique on a graph by graph basis and are saved in templates and graph files. Clients 
redirecting data to another machine should check and set the data connection hostname as appropriate prior to the start 
of acquisition. 

changeDataConnectionHostname 

Method name: acq.changeDataConnectionHostname 
Parameters: string 
Return value: 0 on success, fault on error 

 Changes the destination machine for data connections, the recipient of the network delivered data. If the 
parameter is an empty string, data connections will automatically be made to the most recently connected client. The 
empty setting is the default. 
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 If non-numeric hostnames are specified as parameters, they must be resolvable. If a hostname cannot be 
resolved, a fault is returned. Proper DNS configuration of the server is beyond the scope of the network data transfer 
feature. 

getTransportType 

Method name: acq.getTransportType 
Parameters: None 
Return value: string 

 Retrieves the transport type that is being used to deliver data from the server to the client. The transport type 
is a string that is one of the following: tcp, udp. Note that the XML-RPC data delivery method may be used in 
addition to this transport type if channels are enabled. 

changeTransportType 

Method name: acq.changeTransportType 
Parameters: string 
Return value: 0 if successful, else fault code 

 Change the transport type that is used to deliver data from the server to the client. The transport type is a 
string that has one of the following values: tcp, udp. XML-RPC last value data delivery may be used in addition to 
this type provided channels are enabled properly. 

getUDPPacketSize 

Method name: acq.getUDPPacketSize 
Parameters: None 
Return value: int 

 Returns the current size in bytes of UDP packets that is delivered to clients. Datagrams are always this fixed 
byte length although each individual datagram may contain varying amounts of data. 

setUDPPacketSize 
Method name: acq.setUDPPacketSize 
Parameters: int 
Return value: 0 on success, fault on error 

 Changes the size in bytes of UDP packets that are delivered to clients. Each individual datagram will always 
be this fixed length although the amount of data sent in specific packets may vary. 

getUDPBroadcastEnabled 

Method name: acq.getUDPBroadcastEnabled 
Parameters: None 
Return value: boolean 

 Determine if UDP packets are sent only to the client or are broadcast to the broadcast IP of the network. 
Broadcasting is supported only when the transport type is UDP. 

changeUDPBroadcastEnabled 

Method name: acq.changeUDPBroadcastEnabled 
Parameters: Boolean 
Return value: 0 if successful, fault code on error 

 Modify whether UDP packets are sent only to the client or are broadcast to the broadcast IP of the network. 
Broadcasting is supported only when the transport type is UDP. 

getSingleConnectionModePort 

Method name: acq.getSingleConnectionModePort 
Parameters: None 
Return value: integer 
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 Returns the port number on which the server will connect to the client to deliver data. This port is used only 
when the connection mode is set to “single” which interleaves all data over a single connection. 

changeSingleConnectionModePort 

Method name: acq.changeSingleConnectionModePort 
Parameters: integer 
Return value: 0 on success, else fault code 

 Modifies the port on which the server connects to the client to deliver data. This port is used only when the 
connection mode is set to “single” which interleaves all data over a single connection. 

getDataDeliveryEnabled 

Method name: acq.getDataDeliveryEnabled 
Parameters: channel index parameter structure 
Return value: boolean 

 Query whether a channel is enabled for data delivery. Channels must be enabled for data delivery in order for 
their data to be delivered to the client. Not all channels that are being acquired are required to be delivered to data 
delivery. 

changeDataDeliveryEnabled 

Method name: acq.changeDataDeliveryEnabled 
Parameters: channel index parameter structure, Boolean 
Return value: 0 for success, else fault code 

 Change whether or not data delivery is enabled for a particular channel. Data delivery can only be changed 
prior to the start of an acquisition. Changes to data delivery enabling are only applied on the next start of acquisition. 

getMostRecentSampleValueDeliveryEnabled 

Method name: acq.getMostRecentSampleDeliveryValueEnabled 
Parameters: channel index parameter structure 
Return value: Boolean 

 Query whether a channel is enabled for most recent data sample requests. If a client wishes to use the XML-
RPC calls to fetch the most recent value of data acquired of a channel, the channel must be enabled for this 
functionality prior to the start of acquisition. 

changeMostRecentSampleValueDeliveryEnabled 

Method name: acq.changeMostRecentSampleDeliveryValueEnabled 
Parameters: channel index parameter structure, Boolean 
Return value: 0 for success, else falut code 

 Change whether or not a channel is enabled for most recent data sample requests. When a channel is enabled, 
XML-RPC calls can be used during an acquisition to return the most recent sample of data acquired (or computed) for 
the channel. Any changes to the enabled state of a channel is applied on the start of the next acquisition. If a client 
wishes to use XML-RPC calls to read the value of a channel, that channel must be enabled prior to the start of the 
acquisition. 

getDataConnectionPort 

Method name: acq.getDataConnectionPort 
Parameters: channel index parameter structure 
Return value: int 

 Retrieves the port on which the server will deliver the data for the channel specified in the parameters to the 
client. Per-channel data connections are only used if the data connection method is set to “Multiple.” 

changeDataConnectionPort 

Method name: acq.changeDataConnectionPort 
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Parameters: channel index parameter structure, integer 
Return value: 0 for success, else fault code 

 Changes the port on which the individual connection is made by the server to the client to deliver the data for 
the channel specified in the parameters. This style of connection is used only if the data connection method is set to 
“Multiple.” 

getDataType 

Method name: acq.getDataType 
Parameters: channel index parameter structure 
Return value: structure 

 Returns the data type that is being used in the binary data streams for the channel's data. The return value is a 
structure with a type and endian member. The type member, named “type”, is a string and contains one of the 
following values: short, double, float. These strings correspond to their matching C-style data types. The endian 
member, named “endian”, is a string and contains one of the following values: little, big. “little” corresponds to little 
endian byte order, big endian bit order. “big” corresponds to big endian byte order, big endian bit order. 

changeDataType 

Method name: acq.changeDataType 
Parameters: channel index parameter structure, type structure 
Return value: 0 on success, or fault code 

 Changes the data type that is used for binary data streams of the channel's data. The type structure is a struct 
containing two members. The “type” member is one of the following strings: double, float, short. Each string 
corresponds to the matching C-style data type. The “endian” member is one of the following strings: little, big. Each 
corresponds to the matching byte endian. Bit order within a byte will always be big-endian. 

 Not all channels may be able to support all data types. If the channel cannot be transmitted in the requested 
data type, a fault code is returned. 

setDataConnectionTimeoutSec 

Method Name: acq.setDataConnectionTimeoutSec 
Parameters: integer of new timeout in seconds 
Return value: 0 on success, or fault code 

 Changes the timeout in seconds after which the data connections is closed when acquisitions complete. 
Clients may need to set this keep-alive timeout in order to receive the trailing data at the end of acquisitions. The 
default value is “0” seconds which terminates all data delivery connections immediately when the final sample of data 
is acquired. 

Reading Data During Acquisition 

Normally data is delivered to clients during acquisitions using data connections. Data connections are either TCP or 
UDP connections established from the server to the client over which the server streams the incoming data. In some 
languages and environments however, it may not be possible to handle continuous data streams. The following XML-
RPC commands are offered to assist these types of clients. Due to the large overhead of processing connections and 
XML-RPC requests, this data transfer type is not recommended and TCP/UDP should be used wherever possible. 

getMostRecentSampleValue 

Method name: acq.getMostRecentSampleValue 
Parameters: channel index structure 
Return value: double, or fault code 

 This procedure allows clients to read the most recent data value of a specific channel during acquisitions. In 
order for this call to be successful, a data acquisition must be in progress and the channel must be enabled for most 
recent sample value data delivery. Issue a changeMostRecentSampleValueDeliveryEnabled call prior to acquisition to 
allow this procedure to be used. 
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getMostRecentSampleValueArray 

Method name: acq.getMostRecentSampleValueArray 
Parameters: none 
Return value: array of structures with channel info and values, or fault code 

 This procedure allows clients to retrieve the most recent data values of all channels during acquisitions in a 
single call. If clients are interested in the values of multiple channels, using this method is more efficient than 
performing consecutive getMostRecentSampleValue calls (which require an individual POST request per call). 

 Only channels that are enabled for most recent sample value data delivery is returned. Issue a 
changeMostRecentSampleValueDeliveryEnabled call for each desired channel prior to acquisition in order for this to 
return the value for a channel. 

 The return value is an array of structures, one per channel. Each structure contains two members. The 
“channel” member will contain a channel index structure with members set to appropriate type and index information 
for the channel. The “value” member is a double that contains the most recent sample value of the channel specified in 
the “channel” member. 

 This procedure cannot be called unless there is an acquisition in progress and there is at least one channel 
enabled for most recent sample value delivery. 

 

Other Control Connection Commands 

Control connections will also allow for the following additional commands to be used by clients: 

loadTemplate 

Method name: acq.loadTemplate 
Parameters: base64 encoded binary BSL graph template 
Return value: 0 on success, or fault code 

 Attempts to open the passed template within the BSL environment. The parameter is a base 64 encoded BSL 
“gtl” graph template file. Only templates in Windows or Mac BSL are allowed to be used with this command. The 
parameter must include the entire contents of the template file. 

 The parameter in the XML-RPC call should be a base64 parameter with the raw binary contents of a graph 
template file. When this parameter is decoded, it should correctly provide the contents of a template file on disk. 

 This function will return 0 on success, otherwise a fault code if the template could not be loaded. Once a 
template is loaded, the hardware settings contained within that template is used for subsequent data acquisitions. 
Templates for BSL 4.1.2 and higher will retain any data connection settings that have been specified by clients. After 
loading a template, clients should re-send any configuration information for ports and data connection methods if they 
do not match the new settings from the template. 

 If the template data is corrupted or incompatible, user interaction may be required on the server computer to 
dismiss any error messages when attempting to load the template. If user interaction is required on errors, this call 
may not return until the user interaction has completed. Clients who are using XML-RPC bindings that offer timeout 
services may wish to use them with this function. 

getAcquisitionInProgress 

Method name: acq.getAcquisitionInProgress 
Parameters: none 
Return value: Boolean 

 Query whether data acquisition is currently in progress or not. A value of true is returned if data acquisition is 
occurring in any open BSL graph window. 

toggleAcquisition 

Method name: acq.toggleAcquisition 
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Parameters: none 
Return value: 0 on success, else fault code 

 Toggles data acquisition in the frontmost graph. If data acquisition is in progress, it is halted. If none is in 
progress, data acquisition is started in the graph. 

 Note that this function invocation may block if physical user interaction is required to start the acquisition in 
the graph, such as dismissing an overwrite warning, warnings on incompatibilities between different MP unit types, 
specifying a save location for acquisition to disk, etc. If the implementation of the XML-RPC binding used by the 
client supports timeout capabilities, it is highly recommended to enable timeouts for this function. 

setOutputChannel 

Method name: acq.setOutputChannel 
Parameters: channel index structure, float output value 
Return value: 0 on success, else fault code 

 Changes the voltage on the specified output channel of the MP device. For analog outputs, the value should 
be in the range (-10, 10) for the voltage level. For digital outputs, a value of 0 will turn the specified line off, a non-
zero value will turn it on. The latency of when the output line is changed is variable and non-guaranteed. Additionally, 
the output channel may be modified by other areas of the software including control channels, manual user 
intervention, configured stimulators, etc. 

The valid output channels are dependent on the type of MP device that is connected.  

 MP36 units allow no analogs and digital 0-8. 
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Part D—Appendices 

Appendix A — MP Unit Specifications 
MP Acquisition Unit 
The MP data acquisition unit is the heart of the Biopac Student Lab PRO System. The MP Unit has an internal 
microprocessor to control data acquisition and communication with the computer. The MP Unit takes incoming 
signals and converts them into digital signals that can be processed by the computer. There are four analog input 
channels, one of which can be used as a trigger input. It’s necessary to connect the MP Unit to the computer and 
connect electrodes, transducers, and I/O devices to the MP Unit. It’s recommended to take a few minutes to 
become familiar with the MP Unit prior to making any connections. 

The MP36/35 Data Acquisition System is a physiological data recorder designed for medical educational 
purposes. This system is used in medical education and research facilities. This system is not used for the 
mitigation, cure or diagnosis of disease. This device is NOT used in the home. Subject to IEC60601-1, the 
MP36/35 Data Acquisition System is CLASS II, type BF equipment. 

 
Symbols — MP36, MP35, MP46, and MP45  

Symbol Description Explanation 

 

Type BF 
Equipment Classification 

 
Attention Consult accompanying documents 

 
On (partial) Turns MP35 on assuming AC300A 

power adapter is powered by the mains 

 
Off (partial) Turns MP35 off if but AC300A power 

adapter remains powered by the mains 

 Direct current Direct current input 

 USB USB port 

 

Functional Earth 
Ground Functional Earth Ground Connection 

 
Class II Equipment Class II Medical Equipment, as 

established by IEC60601-1 

 Fuse Equipment Fuse 

Compliance 
  Safety 

The MP36/35 satisfies the Medical Safety Test Standards affiliated with IEC60601-1. The MP36/35 is 
designated as Class I Type BF medical equipment 

  EMC 
The MP36/35 satisfies the Medical Electromagnetic Compatibility (EMC) Test Standards affiliated with 
IEC60601-1-2. 
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Types of Input Devices 
There are three types of devices that connect to the MP UNIT: electrodes, transducers, and I/O devices. 

Electrodes are relatively simple instruments that attach to the surface of the skin and pick up electrical signals in 
the body. 

Transducers, on the other hand, convert a physical signal into a proportional electrical signal. 

Input/Output devices (I/O for short) are specialized devices like pushbutton switches and headphones. 

 
Simple Sensor Connectors 
Regardless of the type of device connected, every sensor or I/O device connects to the MP UNIT using a “Simple 
Sensor” connector. Simple Sensor connectors are designed to plugs only one way into the MP UNIT, so no 
worries about plugging things in upside down or into the wrong socket. 

Electrodes, transducers, and the pushbutton switch all connect to the channel input ports on the front panel of the 
MP UNIT. 

Headphones and the stimulator connect to the “Analog out” port on the back panel of the MP UNIT. 

MP36/35 only: A digital device may connect to the “I/O Port” on the back panel  

MP36/35 only: A trigger device may be connected to the “Trigger” port on the back panel. 

 
Front Panel 

 
Front Panel, MP36/35 UNIT 

The front panel of the MP UNIT has an electrode check port, four analog input ports, and two status indicators. 

Electrode Check 

 The Electrode Check port is a diagnostic tool used with the BSL PRO software to determine if the electrodes 
are properly attached to the subject. See page 160.

Input ports: CH 1, CH 2, CH 3, and CH 4  

The inputs on the MP UNIT acquisition unit are referred to as Channels. There are four 9-pin female analog 
input ports on the front of the MP UNIT. The Biopac Student Lab Lessons software will always check to see that 
the proper sensors are connected to the appropriate channel. 

Status indicators 
The Busy status indicator is activated when the MP UNIT is acquiring data and also during the first few seconds 
after the MP UNIT is powered on to indicate that a self-test is in progress. (When the MP UNIT passes the power-
on test, the Busy light will turn off.) 

The Power status indicator is illuminated when the MP UNIT is turned on. 
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Back Panel 

 
Back Panel, MP36/35 

The back panel of the MP36/35 has an analog output port, a USB port, an I/O Port, a Trigger Port, a DC input, a 
fuse holder, and a power switch, and the unit’s serial number. 

Analog Out port 
There is one 9-pin male “D” analog output port on the back of the MP UNIT that allows signals to be amplified 
and sent out to devices such as headphones. 

USB port (MP36/35 only) 

The MP36/35 connects to the computer via a USB Port, located just below the word USB. 

Uses a standard USB connector. 

Should only be used to connect the MP36/35 to a PC or Mac. 

Headphone Output (MP36/35 only) 

Accepts a standard (1/4” or 6.3mm) stereo headphone jack. 

I/O Port (MP36/35 only) 
Accepts a DB 25 Female connector. 

Input/Output port used to connect digital devices to the MP36/35. 

Trigger Input (MP36/35 only) 
Accepts a male BNC connector. 

Input port used to send trigger signals from another device to the MP36/35. 

Used to synchronize MP36/35 units when more than one MP36/35 is used. 

DC Input 

Use the DC Input to connect an AC300A power adapter or BAT100 battery to the MP36/35. 

 The power supply requirements for the MP UNIT are 12 VDC @ 1 Amp. Only use the AC300A power 
adapter with the MP36/35. The AC300A is a 12 VDC @ 1.25 Amp power supply adapter that can connect to any 
mains rated as 100-250 VAC @ 50/60 Hz, 40VA. 

The receptacle is configured to accept a “+” (positive) input in the center of the connector and a “-” (negative) 
input on the connector housing. 

 The functional earth ground on the AC300A Power Adapter is tied to Mains earth ground and accessible 
metal parts on the MP36/35 unit. 
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  The AC300A power adapter is Class II and when it is used to power the MP36/35, the MP36/35-AC300A 
combination is Class II. The MP36/35 unit also incorporates an additional level of isolation between the AC300A 
power adapter and the Subject. 

Fuse holder 

 The fuse holder contains a fast-blow fuse that helps protect the MP UNIT from shorts on its power, 
analog, and digital I/O lines. The MP36/35 uses a 1.0 A, 250 V, 3AG, fast-blow fuse and the MP30 uses a 2.0 A, 
250 V, 3AG, fast-blow fuse. 

To remove the fuse, use a screwdriver to remove the fuse cover located below the word Fuse. 

Power switch 

ON position — powers up the MP UNIT 

OFF position — cuts the flow of power to the MP UNIT 

Mains Power Disconnection 
To completely disconnect the MP36/35 unit and the AC300A power adapter from all poles of the supply mains, 
extract the power cord plug from the mains outlet. Extract the plug by grasping the plastic shell of the plug and 
pull firmly away from the mains outlet in a direction perpendicular to the face of the mains outlet. Take care not 
to touch the metal blades associated with the plug. This procedure will fully power down (de-energize) the 
MP36/35 unit and AC300A power adapter. Please note that the power switch on the back of the MP36/35 unit 
turns power ON and OFF to the MP36/35 unit only. 

Cleaning Procedures 
Be sure to unplug the power supply from the MP UNIT before cleaning. To clean the MP UNIT, use a damp, soft 
cloth. Abrasive cleaners are not recommended as they might damage the housing. Do not immerse the MP UNIT 
or any of its components in water (or any other fluid) or expose to extreme temperatures as this can damage the 
unit. 

Sterilization and Disinfection 
Disposable, sterile, single-use-only, accessories are used with the MP UNIT for educational (teaching) 
applications. Non-disposable accessories can be disinfected, if required, with Cidex® or equivalent. 

Safety Note 
BIOPAC Systems, Inc. instrumentation is designed for educational and research oriented life science 
investigations. BIOPAC Systems, Inc. does not condone the use of its instruments for clinical medical 
applications. 
Instruments, components, and accessories provided by BIOPAC Systems, Inc. are not intended for the 
cure, mitigation, treatment, or prevention of disease. 
The MP UNIT is an electrically isolated data acquisition unit, designed for biophysical measurements. 
Exercise extreme caution when applying electrodes and taking bioelectric measurements while using the 
Biopac Student Lab with other external equipment that also uses electrodes or transducers that may make 
electrical contact with the Subject. 
Always assume that currents can flow between any electrodes or electrical contact points. In case of 
equipment failure, it is very important that significant currents are not allowed to pass through the heart. 
If electrocautery or defibrillation equipment is used, it is recommended that the BIOPAC instrumentation 
be disconnected from the Subject. 
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MP36/35 Input > Output Scaling 
The MP36/35 hardware can pipe signals from any channel input to the output using the “CHX to Output” control 
panel in the BSL PRO software—due to the difference between the input and output range, there will be a change 
in signal level (scaling). The output range depends on the MP device and the output pin used as shown in the 
following table. Note that when using MP35 output pin 2, there is an additional baseline offset (2.048 V) applied. 

Output Pin 
(Analog Out port) 

Pin Description Output Range 
(Volts) 

Pin 1* - MP36/35 Headphones,  
A.C. Coupled 

-2.048 to +2.048 

Pin 2 - MP36 
 
 - MP35 

Low Voltage Stimulator, 
D.C. Coupled 

-10 to +10  

CH Data, 
D.C. coupled 

0 to +4.095 V 
(baseline offset of 2.048 V) 

The input range is gain dependant.  The table below shows the scaling (multiplying) factors to use for each gain 
setting. 

Gain Input Range 
+- millivolts 

Output Scale***—accurate to ±10% 
Factor 1 Factor 2 

Pin 1 (Headphone out) 
and Pin 2 (MP35 only) 

Pin 2 (Low Voltage 
Stimulator) – MP36 
only 

x5** ± 2 V 1.024 5 
x10 ± 1 V 2.048 10 
x20 ± 500 mV 4.095 20 
x50 ± 200 mV 10.238 50 

x100 ± 100 mV 20.475 100 
x200 ± 50 mV 40.950 200 
x500 ± 20 mV 102.375 500 

x1,000 ± 10 mV 204.750 1,000 
x2,000 ± 5 mV 409.500 2,000 
x5,000 ± 2 mV 1023.750 5,000 

x10.000 ± 1 mV 2047.500 10,000 
x20,000 ± 0.5 mV 4095.000 20,000 
x50,000 ± 0.2 mV 10238.000 50,000 

Notes 

* 1: To properly measure the output signal at least a 2K Ohm load is required. 

**  2: x5 only available on MP36 and MP46/45. 

*** 3. Input to Output scaling is accurate to within 10%. 
Example: 

MP35, input signal level = ±10 mV (20 mV- pk to pk), input gain = x100, Output on pin 2. 

Signal output level = 20 mV-pk to pk x 20.475 = 0.4095 V pk to pk. 

However there is a baseline offset of 2.048 V, so actual signal output level is:  

Lowest level = 2.048 V – (0.5 x 0.4095 V) = 1.843 V  

Highest level = 2.048 V + (0.5 x 0.4095 V) = 2.253 V 
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Calibration 
BIOPAC transducers can provide accurate “relative” measures without calibration. 
For example, the voltage output of the EDA/GSR transducer (SS3LA) will change by 1 mV given a change of 10 
micro Mhos across the electrode(s) connected to the transducer. 
For accurate “absolute” measurement, the voltage output of the transducer must be correlated exactly to a physical 
parameter (such as air flow) and must adjust for temperature, pressure, humidity, and orientation (gravity 
effects)—all of which can vary greatly. Factors beyond the transducer’s accuracy also influence “absolute” 
measurement, such as connections in the system or to the subject. While the MP36/35 is a very sensitive, DC 
stable acquisition unit, too many factors influence true “absolute” measurement to achieve it without calibration. 

Calibration Guidelines 
Calibration is required if ALL of the following are true: 

1. Precise, absolute, measurements are required. 
“Precise” is considered better than 5% accurate; some transducers may provide better than 5% accuracy 
without calibration. 
“Relative” measurements are often acceptable. Measurements on humans can vary so greatly from person 
to person that in most cases a “relative” measure of change is sufficient. 
For example, when measuring EDA with the SS3LA, the preset: “Electrodermal Activity (GSR) Change” 
is often used and no calibration is required. 

2. The transducer will be plugged into an Analog Input channel. 
3. Communication between the MP36/35 and transducers that can be plugged into the “I/O Port” on the back 

of the MP36/35 (such as the noninvasive blood pressure cuff) occurs serially; since A/D conversion is not 
used, readings will directly match the output of the connected device. 

4. The operational bandwidth of the transducer extends down to 0 Hz (DC - see page 110 for details). When 
an AC Coupled Preset is selected for a transducer, “relative” measurements are taken and calibration is 
not required. 
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Appendix B - Frequently Asked Questions 
Q: I have a large data file and it seems to take a long time to redraw the screen. Is there anything I can do to 

speed it up? 
A:    Yes. Several remedies are available for this. 

(1) The simplest solution is to check the Draft mode for compressed waves and Use all available memory 
boxes in the Preferences dialog (shown below). Checking these two boxes will cause BSL PRO to 
plot data faster (at the expense of some precision) and use as much available memory as possible. 

 

 
(2) Reduce the time interval per division, which causes less data to be displayed on the screen at one time, 

and should reduce plot time. 
 (3) Load all data into memory; see page 352 for details. 

Q: Can I use other software with the MP System? Can I use BSL PRO to control other data Acquisition 
hardware? 
A: No. The MP System was designed to work with the BSL PRO software. However, the software can read 

in previously acquired text files generated by BSL PRO or any other software. 
Q: I have a device that outputs an RS-232/RS-422 signal. Can I connect this to the digital I/O lines? 

A: No. These types of digital output devices have their own communication protocols and are more complex 
than the digital pulses that the MP System can accept as inputs. 

Q: I imported a text file and the time scale is wrong. What happened? 
A: When a text file is imported, BSL PRO assumes (by default) that the data was sampled at 100 Hz or 100 

samples per second. This is arbitrary, and there are two ways to adjust this. Both methods involve 
calculating the interval between sample points. To calculate the sampling interval, it’s necessary to know 
the rate at which the data was originally sampled. The sampling interval is calculated by dividing one by 
the sampling rate. Adjust the sampling interval to the appropriate value via the File > Open dialog before 
the data is read in, or if the data is already present, change the time scale in the Display > Horizontal scale 
dialog. 
For instance, if 20 minutes of data was originally collected at 2 Hz and is read into BSL PRO as a text 
file, the software will interpret this as data collected at 100 samples per second. To set the time scale to 
accurately reflect the data, change the sampling interval from 0.01 to 0.5 seconds per sample. 
To change this setting before data is read in, click the Options button in the File > Open dialog and 
change the value in the Sampling Interval dialog. To change the time scale after data has been read in, 
adjust the units per division in the Display > Horizontal axis dialog. If the data are time-domain data, 
adjust the seconds/sample interval at the bottom of the dialog. This value defines the interval between 
sample points, and can be changed to fit the rate at which the data was originally acquired. 
To resolve the sampling limitation, use an MP System. 
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Q: I just filtered a waveform and now my data file is huge. Why is that? 
A: When BSL PRO performs any type of transformation on a waveform (e.g. digital filtering, waveform 

math), it converts the entire waveform from integer format (two bytes per sample) to floating-point format 
(eight bytes per sample). Since each sample point in the waveform now takes up four times as much 
space, the file should be approximately four times as large. BSL PRO still saves the file as compactly as 
possible, and since some of the information stored describes the time base, the file size will not increase 
by exactly a factor of four. 

Q: My MP data acquisition unit seems to be connected, but I can’t acquire data. What should I do? 
A: This can be caused by one of several conditions: 

(a) Check to make sure that the MP data acquisition unit is ON and, if so, that all the connections to the 
MP data acquisition unit were made properly. When the MP data acquisition unit is powered up, a 
light on the front panel of the MP data acquisition unit will illuminate. If the power light will not 
illuminate, check to make sure the proper power supply is connected. The power supply that comes 
with the MP data acquisition unit is rated at 12 VDC @ 1 Amp, and using other power supplies may 
result in damage to the MP data acquisition unit. 

(b) If the proper power supply is connected but the power light still does not illuminate, disconnect the 
power supply and check the fuse in the back of the MP data acquisition unit. The fuse is a standard 
2.0 Amp fast blow fuse, and can be changed by unscrewing the fuse cap and replacing the fuse. 

(c) If the power light does illuminate, the next step is to see if the busy light (next to the power light on 
the front panel of the MP data acquisition unit) illuminates when the MP data acquisition unit is 
powered up. When the MP data acquisition unit is powered up, the busy light should illuminate for 
three or four seconds and then extinguish. 

NOTE: The busy light is normally off (except at startup), but it will remain on while data 
is being acquired and will illuminate for the duration of each trial when data is being 
acquired in averaging mode. If the busy light does not illuminate when the system is 
powered up or does not turn off after a few seconds, contact BIOPAC at one of the 
locations listed in Appendix A. 

Q: I Set Up the channels but I only seem to be acquiring noise. What’s wrong? 
A: A number of phenomena can cause this. Check to make sure that the settings in the Set Up Channels 

dialog correspond to the channel switch settings on the amplifier modules and/or direct analog 
connections to the UIM100C. When a direct analog input is set to the same channel as an amplifier, the 
resulting data will appear quite noisy or erratic. Verify that no two amplifiers are set to the same channel. 
Another possible cause is that the gain settings on the amplifiers are too low and should be increased. It’s 
recommended to select Autoscale waveforms from the Display menu. This will automatically adjust the 
waveforms to provide the “best fit” in terms of scaling the data to fit in the available window space. 
It is also possible that the electrodes/transducers themselves are the source of the noise. Proper electrode 
adhesion techniques involve abrading the skin and securing the electrode in place to reduce movement 
artifact. 

Q: What is the storage and operation accuracy of BSL PRO? 

BSL PRO performs all internal calculations to the accuracy defined by the IEEE format for double 
precision floating point numbers and stores the results of those calculations in double precision floating 
point format. This format assigns 8 bytes to all numbers involved in calculations or resulting from 
calculations. The 8 bytes (64 bits) are assigned as 52 bits to mantissa, 1 bit to sign, and 11 bits to 
exponent. The effective decimal accuracy for calculation operation or storage will be defined as [2 to the 
52] power or approximately 4.5 E15. Accordingly, the effective decimal accuracy will be between 15 and 
16 digits. 
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Appendix C - Filter characteristics 
Filter types 
BSL PRO employs two types of digital filters:  

(a) Finite Impulse Response (FIR) perform post-acquisition filtering 
(b) Infinite Impulse Response (IIR) perform filtering calculations online (during an acquisition) or post-

processing (after an acquisition)  
Although the similarities between the two types of filters outweigh the differences, some important distinctions 
remain. 

1. First, IIR filters are typically more efficient than FIR filters, which means that IIR filters can filter data 
faster than FIR filters, which is why IIR filters are used for online Calculations. 

2. Second, IIR filters tend to be less accurate than FIR filters. Specifically, IIR filters tend to cause phase 
distortion or “ringing.” When the phase of a waveform is distorted, some data points on a waveform are 
shifted (either forward or backward in time) more than others. This can result in the intervals between 
events (such as the Q-R interval or the inter-beat interval in an ECG waveform) being slightly lengthened 
or shortened compared to the original signal. In practice, however, the effect of this distortion is usually 
minimal since the frequencies which are most distorted are also attenuated the most. By contrast, FIR 
filters are phase linear, which means that the interval between any two sample points in the filtered 
waveform will be exactly equal to the distance between the corresponding sample points in the original 
waveform. 

3. Third, IIR filters have a variable Q setting that defines the filter response pattern, but FIR filters do not 
have a Q component. The optimal Q of an IIR filter is 0.707, with lower values resulting in a flatter 
response and higher values resulting in a more peaked response. The default Q for all IIR filters is 0.707 
(except for Band pass filters where Q defaults to 5), which is appropriate for nearly all filter applications. 

In the examples on the following page, the filter responses of several different types of filters are compared. All of 
the filters are 50 HZ low pass filters operating on the same data. 
The first graph shows how the number of filter coefficients in FIR filters (Q) affects the filter’s frequency 
response. Note that as the number of coefficients (Q) increases, the filter becomes more accurate. A good rule of 
thumb is to set Q ≥ 2(fs/ fc), where fs = sampling rate and fc = cutoff frequency. 

 
 FIR filter performance as a function of number of coefficients (Q) 
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The next graph shows how the pole or zero locations of the filter, as related to filter “peaking” (specified by Q), 
affect the frequency response of the filter. The “Q” in this case is not to be confused with the Q from the FIR 
filter. Note how increasing “Q” in the IIR filter case affects filter “peaking.” 

 
FIR filter performance as a function of changes in pole or zero locations 

Coincidentally, the FIR (Q = 10) and IIR (Q = 0.707) filters have very similar responses in this case. 
Technically, the coefficient setting for FIR filters determines the number of multiplies performed by the filtering 
algorithm. In practical terms, it determines how “steep” the frequency response of the filter is. Filters with a large 
number of coefficients have a steep roll-off, whereas the frequency response of filters with a smaller number of 
coefficients is not as steep. 
 
Window Functions 
Window functions are used for two purposes in BSL PRO. Windows are applied to the impulse response in the 
(FIR) digital filtering functions, and can optionally be applied as part of the FFT function. In either case, a 
window refers to a computation that spans a fixed number of adjacent data points.  
Typically, window functions are used to eliminate discontinuities that may result at the edges of the fixed span of 
points of the digital filter function (FIR filters) or the data points of the FFT. 
Digital filtering. When a window is used in digital filtering, the impulse response of the filter (rather than the data 
itself) is modified. When the impulse response smoothly approaches zero at both the beginning and end of the 
data, this works relatively well. When the impulse response is not so well behaved, edge effect occurs. Edge 
effects can be minimized by windowing, or forcing the edges of the impulse response to smoothly approach zero. 
The exact process depends on the window selected (see below). 
Another way to minimize edge effect with an FIR filter is to increase the number of coefficients used to transform 
the data. 
FFT. The FFT function also windows data, although the nature of the windowing function is somewhat different 
in the sense that the window operates on the data. One of the assumptions of the FFT is that the input data is an 
infinitely repeating signal with the endpoint wrapping around. In practice, the endpoints are almost never exactly 
equal. Check this by choosing the Delta measurement item from the measurement popup menus, which returns 
the amplitude difference between the first selected point and the last. To the extent that the endpoints differ, the 
FFT output will produce high frequency components as an artifact of the transformation. 
 BSL PRO displays only the positive coefficients of an FFT. In this FFT presentation, there is an implicit 

negative frequency component for each positive frequency component, so when looking at amplitude 
levels in a linear FFT, multiply by two (negative frequency can only be created with positive frequencies 
in the real world). 

By windowing the data, the effects of this phenomenon are greatly diminished. When data are windowed, a 
window is moved across the data, much as the smoothing function moves across the data. Whereas the smoothing 
function simply takes the average of a specified number of points, each type of window weights the data 
somewhat differently. 
The Window pull down menu offers the following options: 
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Bartlett implements triangular windowing and Rectangle does not window the data. The “shape” of the other 
windows is defined by the following formula, where n = 

0

N 1n−  and A, B, C and D are constants: 

A Bcos 2 n
N

Ccos 2 n
N

Dcos 2 n
N

− + +
π π π2 3

 

The table below details the different parameter values for each type of window. 

 Parameter Values 

Type of Window A B C D 

Bartlett n/a n/a n/a n/a 

Blackman 0.42000 0.50000 0.08000 0.00000 

Blackman -61 0.44959 0.49364 0.05677 0.00000 

Blackman -67 0.42323 0.49755 0.07922 0.00000 

Blackman -74 0.40217 0.49703 0.09392 0.00183 

Blackman -92 0.35875 0.48809 0.14128 0.01168 

Hanning 0.50000 0.50000 0.00000 0.00000 

Hamming 0.54000 0.46000 0.00000 0.00000 

Kaiser-Bessel 0.40243 0.49804 0.09831 0.00183 

Rectangle 
Windows/PC only 

n/a n/a n/a n/a 
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Appendix D - Hints for Working with Large Files 
It is not uncommon for users to generate large data files (on the order of several megabytes) through some 
combination of (a) high-speed acquisitions, (b) long acquisitions, and (c) multi-channel acquisitions. Users 
frequently encounter system limitations (such as storage space limitations) and find the files are difficult and slow 
in loading to memory. 
The software included with the MP System (MP36, MP35, MP46, or MP45) stores the data in as compact a 
format as possible. Each sample takes up roughly two bytes of storage space. When a waveform (or a section of a 
waveform) is transformed (i.e., filtered or integrated) each data point takes up roughly eight bytes of storage 
space. As a result, file size can change drastically after transforming one or more waves. 

Note BSL PRO data files greater than 4 GB can be opened, but edit, transformation and analysis operation 
cannot be performed. 3 GB of RAM is the maximum that can be allocated by the application and a 
maximum of 60 channels are supported. 

The following tips can help get the most out of the MP System when working with large data files. 
 Use virtual memory 
 Since BSL PRO runs under Windows 10/8/7 or Mac OS X 10.10-10.15, most computers are able to 

take advantage of the virtual memory feature. While this is slower than conventional memory, it will at 
least make it possible to load some files that might otherwise be impossible to load. 

 Remove waveforms 
 Since each waveform adds to the total size of the file, try removing (or copying to another file) some of 

the waveforms from a multi-channel file. This is especially true for performing transformations of some 
sort on at least one of the waves. 

 Sample slowly 
 Theoretical and methodological concerns will, to a large extent, dictate sampling rate. However, if it’s 

possible to reduce the sampling rate, choose to do so. Or, use Transform > Resample (page 278) to 
resample data after collecting it. 

 Set preferences 
 Check the “Use all available memory” and the “Draft mode for compressed waves” options under the 

Preferences menu item. This should decrease the time it takes to redraw waveforms and allow the 
software to access all available memory for storage. 

 Store to disk 
 Although slightly slower than storing to memory, acquiring data directly to disk allows recovery of data 

in the event of a power loss to the MP System. Furthermore, much larger data files can typically be stored 
directly to disk than to memory. 

 Use the Append mode 
 The Append mode allows pausing of the acquisition for arbitrary periods. This can be helpful when 

recording only a few key events that will occur randomly over a long period of time, since it will reduce 
unnecessary data.  

 Compress Files 
 Use the File > Save As > Compressed option to store or transfer data 

 
Note  Copy/Paste and Transformations require BSL PRO to allocate additional memory and then load the data 

into memory; when these operations are executed on large data files, the application may crash. 
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Appendix E - Customizing Menu Functionality 
BSL PRO now includes a powerful customization feature allows menu options to be displayed selectively. For a 
specific procedure, it may be helpful to limit the menu options to list only the functions necessary for the 
experiment, thereby reducing the chance for confusion or error. For example,  it may be helpful to remove the 
“Setup Triggering” and “Output Control” options from the MP menu, as shown below: 

   
Default MP menu     Customized MP menu 

Follow the simple procedure below to customize the menu display. 
1. With the BSL PRO application closed, navigate to the menu.dsc file: DRIVE:\ProgramData\BIOPAC 

Systems, Inc\Biopac Student Lab 4.0\menu.dsc 
2. Open the menu.dsc file in Notepad. 

 
3. Find the menu and item to be changed (scroll through list as necessary) and type “OFF” to disable the menu 

display. In the example below, the IDM_STIMULATOR option has been changed to OFF. 
 Note that ON/OFF is case-sensitive must be typed in ALL CAPS. 
 Deleting a file listing instead of typing OFF will not remove the feature; it will default to ON unless OFF 

is entered. 

 
4. Save the changes to the menu.dsc file and close it. 
5. Restart BSL PRO. 
6. Check the menu listing. 

 To reactivate a menu item set to OFF, just repeat the above procedure and type “ON” for the 
desired menu item. 

 To revert a customized menu.dsc to the factory default, choose Display > Preferences > Other 
and select “Create default menu configuration file.” After choosing “yes’ in the subsequent 
dialog, the application must be closed and relaunched in order for the change to take effect. 

Note: Application menu customization has a corresponding effect on contextual menu display. If a contextual 
menu item does not have a corresponding application menu item, the menu customization file identifier 
will begin with “IDM_CM.” 
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Appendix F — About Electrodes 
The purpose of an electrode is to act as a “connector” between the Subject’s skin (where electrical signals are 
easiest to detect) and the MP UNIT acquisition unit (via the SS2L lead cable). If an electrode makes good contact 
with the skin, the signals that are generated will be relatively accurate. 

Although they sound complex, electrodes are very simple devices that consist of a small piece of metal designed 
to make indirect contact with the skin and a larger adhesive plastic disk. Each electrode is about 1 inch (2.5 cm) in 
diameter, and is sticky on one side so it will adhere to the skin. The electrode lead (cable with connector end) is 
the interface between the electrode and the MP acquisition unit. 

 
Electrode lead connector and electrode 

Looking closely at the electrode, observe that there is a small piece of plastic mesh filled with a bluish gel. Since 
gel conducts electricity (better than skin, in fact) and is more flexible than the metal part of the electrode. Skin can 
flex and change shape somewhat without losing the electrical connection with the metal part of the electrode. 

BIOPAC disposable electrodes are standard disposable electrodes and are widely used in clinical, research, and 
teaching applications. These electrodes come in strips of ten, and it’s not advisable to remove an electrode from 
the backing until ready to use. 

The following directions will assist in obtaining the data from the electrodes by explaining how electrodes work 
and how to attach the electrodes and electrode leads to obtain the best signal. 

Electrode placement 

There are two basic methods of electrode placement: monopolar and bipolar. 

 In a monopolar recording, an active electrode is placed over the region of interest and a “reference” 
electrode is attached to a more distant part of the body. 

 In a bipolar recording, the voltage difference between two electrodes, placed over the regions of interest, is 
measured with respect to the third “reference” electrode. Leads I, II, and III are standard bipolar electrode 
configurations, and are explained in more detail when used in a Lesson. 

Preparing the Electrode Site 

One way to improve electrode connections is to gently rub the area where the 
electrode is to be placed. This is known as abrading the skin, and removes a thin 
layer of dead skin from the surface of the skin. Since dead skin doesn’t 
conduct electricity very well, removing it improves the connection between the 
electrode and the skin. An ELPAD electrode pad (included with the Biopac 
Student Lab) can be used to abrade the selected surface. 

EXCEPTION: If aquiring EDA data, never abrade the skin beforehand. 
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Attaching electrodes 

To attach an electrode, peel the electrode from its backing and place it on the area indicated in the lesson. Once in 
place, press down firmly on the electrode with two fingers and rock the electrode back and forth for a few 
seconds. This will ensure that it is adhering to the skin as much as possible.  

        
 T o help insure that the electrode will make good electrical contact with the skin, it may be helpful to 

squeeze a drop or two of electrode gel onto either the surface of the skin or onto the electrode (without 
allowing any to get on the adhesive). 

Connecting the Electrode Lead 

Each electrode lead cable is a different color and each pinch connector on the end of the cable needs to be 
attached to a specific electrode. Note that the connector is polarized and needs to be clipped on such that the metal 
extensions inside the clip are on the down side to make surface contact with the electrode. The pinch connectors 
work like a small clothespin, but will only latch onto the nipple of the electrode from one side of the connector. 
Follow the figure provided in the lesson to ensure that each lead cable is connected to the proper electrode. 
Reducing Electrode “Noise” 

If an electrode does not adhere well to the skin, the signal plotted on the screen may appear “fuzzy.” This is 
referred to as “noise,” and although it always exists to some degree, it is best to reduce noise as much as possible. 
Electrodes have no moving parts, so there is nothing that needs to be done to get an electrode to “work” but there 
are several things that are helpful for reducing noise when electrodes are connected: 

*  Place the electrodes where there is the least amount of hair and/or choose the subject with the least amount of 
hair. A common problem is that something on the surface of the skin is interfering with the electrode contact. 
If there is too much hair (for instance) between the outer layer of skin and the electrode, the electrical activity 
taking place below the surface of the skin may not be detected. 

*  Make sure that everything is connected properly. 
*  Attach the electrodes a few minutes before they are to be used. The best results are achieved by putting the 

electrodes in place about five minutes before beginning to record data. This gives the electrodes time to 
establish contact with the surface of the skin. 

*  Position the electrode lead cables such that they are not pulling on the electrodes. Connect the electrode cable 
clip (where the cable meets the three individual colored wires) to a convenient location (can be on the 
Subject’s clothes). This will relieve cable strain. 

*  The Subject should not be in contact with nearby metal objects (faucets, pipes, etc.), and should remove any 
wrist or ankle bracelets. 

Removing Electrodes 
Once the lesson has been completed, disconnect the electrode cable pinch connectors, peel the electrode off the 
skin, and dispose of the electrode (BIOPAC electrodes are not reusable). Wash the electrode gel residue from the 
skin, using soap and water. The electrodes may leave a slight ring on the skin for a few hours. This is normal, and 
does not indicate that anything is wrong. 

Electrode Check  

MP3X units include an Electrode Check port on the front panel. Use this diagnostic tool with the BSL PRO 
software to determine if the electrodes are properly attached to the subject (see page 160). 
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Acquisition Length, 31, 155 
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Troubleshooting, 388 

Adaptive filtering 
Calculation channel, 147 
Transformation, 251, 257 

Adaptive scaling, 71 
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Analog channels, 30, 105–6 

Gain setting, 107 
Analysis functions, 66 
Annotation, text, 56 
Append mode, 151, 392 
Application Notes, 25 
Arbitrary sample rate, 271 
Arbitrary scale (units), 324 
Arbitrary stimuli, 175 
Arc cosine, 140 
Arc sine, 140 
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Atan. See arc tangent 
Auto threshold detect, 299 
Autoplot, 213 
Autoposition Hidden Annotations, 57 
Autosave file, 151 
Autoscale after transformations, 337 
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Autoscale Horizontal, 321 
Autoscale waveform, 41 
Autoscale Waveforms, 319 
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Average (moving), 122 
Average over samples, Integrate option, 125 
Off-line Cycle/Peak Detector (MAC), 288 
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B 
Band filter, 253 
Base 10 logarithm, 141, 261 
Baseline drift, 300 
Blood pressure analysis. See rate calculations 

BPM 
BPM calculation, 301 
BPM measurement, 90 
BPM, Rate function, 129 

BSL File Import, 223 
BSL PRO, 20 

Accuracy (storage and operation), 388 
BSL vs BSL PRO, 120 

C 
Calculate (measurement), 90 
Calculation channels, 30, 116–17 
Calibration, 105–6 
Calibration Guidelines, 386 
CE Marking, 381 
center horizontal, 34 
center vertical, 34 
CH# Output Control, 163 
Channel 

Channel boxes, 84, 325 
Channel label, 84 
channel sample rate, 103 
Channel sample rate, 31 
Channel setup, 105 

Chart mode, 325 
chooser, 239 
CISPR Class 11, 381 
Clear, 243 
Clear all, 244 
Clip data, Calculation channel Function, 132 
Clipboard, 89, 245–46 
Close 

File menu command, 229 
Close prompts, 230 
Coefficients (FIR filters), 254, 389 
Color, 323 
Comb Band Stop 

Transformation, 257 
Compare Waveforms, 321 
Compliance, 381 
Compression 

down sampling, 271 
Save As option, 236 

Connect endpoints, 260 
Constant (K), Calculate measurement option, 91 
Control channel 

Calculation channel, 143 
Integrate Calculation option, 123 

Convolution, 264 
Copy, 243 

Acquisition Settings, 246 
Graph, 245 
Measurement, 245 
Wave data, 245 

Correlate (measurement), 91 
Correlation, 262, 264 
Correlation Coefficient 

Specialized Analysis, 311 
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Cosine, 140 
Count peaks, 301 
Creating new lessons, 120 
Cubic spline interpolation, 271 
Customizing menu display, 339, 393 
Cut, 242 
Cutoff frequency, 254 
Cycles/Peaks detect, 3D Output, 288 
Cycles/Peaks tab, Cycles/Peaks detect, 283 

D 
Data View, 38 
Delay 

Calculation channel option, 142 
Delta measurements, 91 
Derivative, 265 
detrending, 277, 310 
Difference 

online calculation, 128 
transformation function, 270 

Digital 
Digital channels, 30, 106–16 
Digital filters, 251–56, 390 
Digital output, 143 

Disk 
Space, sampling rate impact, 31, 154 
Space, storage mode impact, 220 
Storage option, 31, 153, 392 

Display 
Menu commands, 317 
Preferences, 392 

Draft mode, 337 
Duplicate waveform, 244 

E 
ECG Analysis 

Detect and Classify Heartbeats, 303 
Heart Rate Variability, 305 
Locate Animal ECG Complex Boundaries, 304 
Locate ECG Complex Boundaries, 303 

Edge 
Edge options (Pos/Neg), 207 

edge effects, 390 
Editing 

Cursor tool, 54 
Edit menu, 241 
Features, 66 

EGrid cursor, 55 
Electrode Checker, 158 
Ensemble Average, 313 
Epoch Analysis, 314 
Equation Generator, 134–46 
European Data Format (EDF) 

Open, 228 
Save, 235 

Event (Marker) 
Graph Selection, defining via, 205 
Graph Selection, display impact, 204 

Hotkey Setup, 193 
Location, 196 
Measurements, 202 
Overview, 191 
Palette, 195 
Preferences, 192 
Printing, 204 
Selection, 204 
Toolbar, 192 
Tooltips, 192 
Variable Sampling Rate and, 205 
Waveform editing, 205 

Event definition cursor, 55 
Event marker, 24 
Events, 46 
Events, R wave location, 307 
ex power of a data point, 140 
Excel Spreadsheet Export, 236 
Exp Exponential, 260 
Exporting data, 48, 224 
Expression, 272 
Expression evaluator, 134–46 

F 
FAQ, 387 
Fast Fourier transformations. See FFT 
FFT, 277–81, 390 
File format prompts), 237 
File menu commands, 220 
File size, 388, 392 
Filter 

Calculation, 133 
characteristics, 389 
response, 255 

Find, 296 
Find Cycle/Peak, Mac OS X, 282 

Finite impulse response filters. See FIR filter 
FIR filters, 251, 254, 389 
Font, journal, 338 
Formula 

Area, 89 
BPM, 90 
Correlation, 91 
Delta, 91 
Delta T/F/X, 92 
Freq (Frequency), 93 
Integral, 93 
Lin_reg (Linear regression), 94 
Mean, 95 
Slope, 97 
Stddev (Standard deviation), 98 
Threshold, 133 

Fourier 
FFT Fast Fourier transformation, 277 

Frequency 
frequency spectrum, 281 
Horizontal scale, 324 
measurement (Freq), 93 
rate calculation (Hz), 301 
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Frequency Bands, HRV analysis, 308 
Frequently asked questions, 387 
Friendly Grid Scaling, 77 
Function 

Calculation, 132, 135 
Equation (Expression) commands, 140 

G 
Gain setting, 107 
Gauge, 209 
Getting Started, 20 
GLP audit 

include timestamp, 336, 337 
mark selection with Events, 336, 337 

Graph template files (gtl) 
Open, 224 
Quick Start Files, 224 
Save As, 231 

graph window, 28 
Graph window, 29 
Gray non-selected waves, 337 
Grid 

Adjust spacing, 322 
GridReset, 322 

H 
Hardware. See note on page 10 
Heart Rate Variability, 305 
Help menu, 344 
High pass filter, 253 
Histogram, 276 
Hold button, SIV, 206 
Hold relative position 

Horizontal Scale, 67 
Horizontal 

Axis, 24 
scale, 39 
Scale, 40 
Scroll bar, 67 

Human Subjects, Safety, 189 
Hyperbolic 

Cosine, 140 
Sine, 141 
Tangent, 141 

I 
I-beam tool 

selection cursor, 54 
IBI Inter-beat Interval, 129, 301 
IEC60601, 381 
IFFT. See inverse FFT 
Igor Pro Experiment 

Open (import), 228 
Save As (export), 234 

IIR filters, 251, 256, 389 
INF (measurement value), 85 

Infinite impulse response filters. See IIR filters 
Initial offset, 67 
Input Values Setup (SIV), 206 
Insert 

Events, 46 
Waveform, 244 

Installation. See note on page 10 
Integral 

measurement, 93 
Transformation function, 265 

Integrate 
formulas, 267 

Integrate Calculation (online), 122 
inter sample interval, 227, 233 
Interpolate pastings, 338 
Interpolation method, resampling, 271 
Inverse mean square error, 264 

J 
Journal, 48 

Copy Measurements, 88 
Paste options, 247 
Preferences, 338 
Show Journal, 249 

Jump-to tool (correlates data views), 55 

K 
K (Constant), Calculate measurement option, 91 

L 
Lessons, creating your own, 120 
Limit data, Calculation channel Function, 132 
Limit math command, 261 
Lin_reg (linear regression measurement), 94 
line plot, 326 
Linear (FFT option), 280 
Linear interpolation, 271 
Ln natural logarithm, 261 
Log, 141, 261 
Low pass filter, 252, 265 

M 
Macintosh® system requirements, 21 
Math 

Calculation, 131–32 
Functions (Transformation), 260 
Waveform Math, 273 

MATLAB 
Open (import), 226 
Save As (export), 233 

Max measurements, 95 
Mean 

Mean square error, 264 
Measurement, 95 
Removal, 263, 279 
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Mean subtraction, Integrate option, 123 
Measurement 

Cycles/Peaks Output, 287 
Preferences, 336 
Preferences for Journal, 338 
Presets, 88 
Table of Explanations, 89 

Media menu (capture or playback), 346 
Median measurements, 95 
Medical equipment, classification, 381 
Memory 

Load all data into, 343 
Storage option, 31, 153 
Use all available memory, 339 

Menu configuration file, 339 
Menu display, customizing, 339, 393 
Min (minimum) measurement, 95 
Modeling 

Linear 
Lin_reg measurement, 94 

Moving average, 269 
MP System 

Features, 23 
MP System Requirements, 21 
MP35 

Back Panel, 383 
Front Panel, 382 
MP35 Specifications, 381 

N 
Natural logarithm, Ln, 261 
Negative edge, 207 
Network Data Transfer (NDT), 368 
New 

Data View, 220 
Noise, 388 

Calculation channel Function, 133 
Math command, 261 
Rejection (auto threshold detect, 299 

None (measurement option), 96 

O 
Off-line Averaging, Cycle/Peak Detector (MAC), 

288 
Online filtering, 133 
Open (file command), 223 
Open for Playback, 229 
Options button, Open Text file, 224 
Options, Input Values, 206 
Organize Channel Presets, 214 
Organize List, Preferences, 180 
Output Control, 161 

CH# to Output, 163 
Digital Outputs, 166 
Preferences, 162 
Pulses, 168 
Stimulator - SS58L, 168 
Stimulator—BSLSTM, 168 
Voltage, 167 

Output tab, Cycles/Peaks detect, 287 
Overlap 

Overlap Waveforms, 320 

P 
Pad with…, 278 
Padding (resampling interpolation), 271 
Paste, 243 

Acquisition settings, 247 
Measurement, 247 
Wave data, 247 

Pause mode (Append to disk), 152 
Peak 

Detect (Find Rate option), 299 
Find Cycle (Peak Detector), Mac OS X, 282 
Minimum, 301 

Peak-to-Peak (P-P measurement), 96 
Phase, 280 

Distortion, 389 
PhysioNet 

Save As (export), 232 
PICT files, 245 
Playback mode, 37 
Plot 

Plot on Screen, Setup Channels option, 156 
Plotting data, 30, 213 
Positive edge, 207 
Power Spectral Density, 277 
Power supply, 388 
P-P (peak-to-peak measurement), 96 
Preferences 

Display Preferences, 333 
Journal preferences, 338 
Menu configuration file, 339 
Output Control, 162 
Undo max, 338 

Presets, 103 
Organize Channel Presets, 214 

Print, 25, 49, 239–40 
PRO Lessons, 119 
PSD Options, HRV analysis, 308 
Pulse Sequence Output Control, 170 
Pulses Output Control, 168 

Q 
Q coefficient, filter setting, 134, 256, 389 
QRS Detector, HRV analysis, 307 
Questions, frequently asked, 387 

R 
Ramp waves, 175 
Rate 

calculation, 128–31 
Rate mean measurement, 96 
Rate median measurement, 96 
Rate standard deviation measurement, 96 
Raw data 
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Open (import), 227 
Save As (export), 233 

Record 
Start acquisition, 157 

Record/Record last, 151 
Recursive formulas, 136 
Remove 

last appended segment, 244 
mean, 263, 279 
trend, 279 
waveform, 244, 392 

Repeat mode, 155, 214 
Repositioning Events (Marker), 196 
Resample, 271 
Resampling Interpolation, 271 
Reset 

Append acquisition button, 152 
reset chart boundaries, size window, 342 
Reset Chart Display, 322 
reset thresholds, Integrate setup, 123 
reset trigger, Integrate setup, 123 

Reset Grid, 322 
Resource allocation, 339 
RS-232/RS-422 signal, 387 

S 
Safety, 381 
Safety Notice, 18 
Sample 

measurement, 96 
Rate, 153–54, 392 
Rate, Acquisition rate, 31 
Rate, Channel, 30, 31, 103 

Save, 48 
Save (File command), 230 
Save as (File command), 230, 237 
Save once (Acquisition setup), 151 

Save Settings, Preferences, 169, 180 
Scaling, 105–6 
Scaling, Friendly Grid Scaling, 77 
Scope mode, 33 
Scroll, 40, 66 

Menu option, 213 
Segment Labels, 207 
Select 

All, 244 
Area, 43, 241 
Area for measurement, 86 
Channel, 41, 83 
Cursor tool, 54 
Waveform, 41, 83 

Selection Palette, 326 
Selection tab, Cycles/Peaks detect, 286 
Set template, 262 
Set Up 

Acquisition, 31 
Channels, 101, 105 

Set up Triggering, 207 

Set wave positions, 322 
Shortcuts 

Keyboard, 61 
Toolbars, 51 

Show 
Display menu options, 325 
Input values, 101 
Input Values, 206 
Input Values Setup options, 206 
Modified input, 278 

Sine, 141, 261 
Size window, 342 
Slope (measurement), 97 
Smoothing 

online calculation, 126 
transformation function, 269 

Sound Feedback, 208 
Sound Sequence Output Control, 177 
Specifications. See MP Hardware Guide 
Spectral analysis. See FFT 
Spectrum Analyzer Palette, 329 
Square 

Square, 141 
Square Root, 141, 261 
Waves, 174 

Standard deviation measurement, 98 
Start acquisition, 31 
Starting an acquisition, 157 
Statistics (Waveform Statistics dialog), 332 
Status indicator, 31 
Status indicator, software, 157 
Stddev (standard deviation) measurement, 98 
Step plot, 327 
Stimulator 

Stimulator Reference Channel, 189 
Stimulator - BSLSTM, 168 
Stimulator – SS58L, 168 
Stimulus signal, 174 
Stopping an acquisition, 157 
Sum measurement, 98 
Symbols, MP35 unit, 381 

T 
Tab interval, Journal, 338 
Tangent, 141 
Template functions, 262 
Text Annotation, 56 
Text files, 48, 226 
Threshold 

Math command, 261 
Tile waveforms 

Tile after transformations, 337 
Tile Waveforms, 318 
Time 

Expression source, 136 
measurement, 98 
Set Horizontal Time scale, 324 
Time scale after importing, 387 
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Timestamp, journal preference, 336, 337 
Toolbars, 51 
Transform, 44 

Math commands, 260 
Menu commands, 250 

transition latency, 312 
Trigger, 207 
Troubleshooting, 387 
TTL signal, trigger, 207 

U 
Undo, 242 
User Support System, 16 

V 
Value (measurement), 98 
Values checkbox, 30, 101 

Show input values, 206 
Variable Sampling Rate, 31, 103 

data processing notes, 138 
Event plotting and, 205 

Vertical axis, 24, 106 
Vertical scale, 41, 69 
Viewing data, 39 
Virtual memory, 392 

W 
Warning 

Before overwrite data, 214 
Hardware not found, 27 

Waterfall Plot, 315 
WAV files, 228 
Waveform 

Arithmetic dialog, 90 
Color, 323 
Math transformation, 273–74 
Selection, 41, 83 
Statistics dialog, 332 

Window 
Find Rate option, 300 
Functions (filter, FFT), 390 
Menu, 344 

Windows® system requirements, 21 

X 
X/Y mode, 33, 34 

Z 
Zap, event cursor, 55 
Zoom 

Cursor tool, 43, 55 
Zoom previous, 321 
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COPYRIGHT  
Information in this document is subject to change without notice and does not represent a commitment on the part of 
BIOPAC Systems, Inc. This manual and the software described in it are copyrighted with all rights reserved. Under 
the copyright laws, this manual or the software may not be copied, in whole or part, without written consent of 
BIOPAC Systems, Inc., except in the normal use of the software or to make a backup copy. 

The same proprietary and copyright notices must be affixed to any permitted copies as were affixed to the original. 
This exception does not allow copies to be made for others, whether or not sold, but all of the material purchased 
(with all backup copies) may be sold, given, or loaned to another person. Under the law, copying includes translating 
into another language or format. This software is intended for use on only one machine at a time. 

 

Open source software for Specialized Analysis: 

 PCRE 

Regular expression support is provided by the PCRE library package, which is open source software, written by 
Philip Hazel, and copyright by the University of Cambridge, England. 
ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/ 

 The Apache Software License, Version 1.1 

Copyright (c) 1999-2001 The Apache Software Foundation. All rights reserved. 

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the 
following conditions are met: 

1. Redistributions of source code must retain the above copyright notice, this list of conditions and the 
following disclaimer. 

2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the 
following disclaimer in the documentation and/or other materials provided with the distribution. 

3. The end-user documentation included with the redistribution, if any, must include the following 
acknowledgment: "This product includes software developed by the Apache Software Foundation 
(http://www.apache.org/)." Alternately, this acknowledgment may appear in the software itself, if and 
wherever such third-party acknowledgments normally appear. 

4. The names "Xerces" and "Apache Software Foundation" must not be used to endorse or promote 
products derived from this software without prior written permission. For written permission, please 
contact apache@apache.org. 

5. Products derived from this software may not be called "Apache", nor may "Apache" appear in their 
name, without prior written permission of the Apache Software Foundation. 

THIS SOFTWARE IS PROVIDED ''AS IS'' AND ANY EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, 
BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A 
PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE APACHE SOFTWARE 
FOUNDATION OR ITS CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, 
EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF 
SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS 
INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, 
STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT 
OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. 

=================================================== 

This software consists of voluntary contributions made by many individuals on behalf of the Apache Software 
Foundation and was originally based on software copyright (c) 1999, International Business Machines, Inc., 
http://www.ibm.com. For more information on the Apache Software Foundation, please see 
<http://www.apache.org/>. 
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LIMITED WARRANTY  

BIOPAC Systems, Inc. guarantees its equipment against all defects in materials and workmanship to the original 
purchaser for a period of 12 months from the date of shipment unless otherwise stated below; effective 1-1-2015, 
BIOPAC MP36 units are guaranteed against defects in materials and workmanship to the original purchaser for a 
period of 60 months (5 years) from the date of shipment. 

If BIOPAC Systems, Inc. receives notice of such defects during the warranty period, BIOPAC Systems, Inc. will at its 
option, either repair or replace the hardware products that prove to be defective in materials or workmanship. This 
warranty applies only if your BIOPAC Systems, Inc. product fails to function properly under normal use and within the 
manufacturer’s specifications. This warranty does not apply if, in the sole opinion of BIOPAC Systems, Inc., your 
BIOPAC Systems, Inc. product has been damaged by alteration, accident, abuse, misuse, neglect, improper packing, 
shipping, modification or servicing, by any party other than BIOPAC Systems, Inc. If a problem arises, please contact 
us for authorization before returning an item. 

Any returns should be supported by a Return Mail Authorization (RMA) number issued by BIOPAC Systems, Inc. 
BIOPAC Systems, Inc. reserves the right to refuse to accept delivery of any shipment containing any shipping carton 
which does not have the RMA number(s) displayed on the outside. The Buyer will prepay transportation charges to 
the BIOPAC Systems, Inc. designated site. The warranty period for repairs and for used equipment purchased from 
BIOPAC is 90 days. 

BIOPAC Systems, Inc. makes no other warranty or representation, either expressed or implied, with respect to any 
hardware or software product, its quality, performance, merchantability, or fitness for a particular purpose.  

BIOPAC Systems, Inc. will not be liable for direct, indirect, special, incidental, or consequential damages resulting 
from any defect in a hardware or software product or its documentation, even if advised of the possibility of such 
damages, or for damage of any equipment connected to a BIOPAC Systems, Inc. product. 

TRADEMARKS  
BSL PRO is a registered trademark of BIOPAC Systems, Inc. 

Windows is a registered trademark of Microsoft Corporation in the United States and other countries. 

Mac and MacBook are trademarks of Apple Computer, Inc., registered in the U.S. and other countries. 
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