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Chapter 18 Licensed Functionality:  

BSL Curriculum Management System 
The BSL Curriculum Management System is available through optional licensing in BSL 4.1 and above only. The 

license must be authorized to use this lesson customization tool. To add a license to an existing Biopac Student Lab 

installation, please contact BIOPAC. 

Overview 

The BSL Curriculum Management System is a licensed feature that allows instructors to add customized lesson 

content and create user-defined onscreen lesson instructions for any existing BSL Lesson. It also has a built-in 

networking feature allowing instructors to easily broadcast customized content to student workstations over a local 

network. The level of control over lesson customization in the BSL Curriculum Management System goes well 

beyond the scope of standard BSL Lessons & PRO and is ideal for instructors wishing to create, edit, and modify 

content in a seamless, flexible fashion.  

This chapter is a guide to the powerful features available in the Curriculum Management System and covers:  

▪ How to associate custom recording procedures, analysis procedures, introductions and data reports with any 

existing BSL Lesson. (Any user-defined PDF can be substituted for the default BSL Lesson PDFs.) 

▪ How to edit onscreen HTML Journal content to create custom onscreen instructions. 

▪ How to configure Instructor (Host) and Student (Client) network settings for sharing lesson content. 

▪ How to share PRO Lessons and Shared Lessons over a network.  

o BSL PRO Lessons  - H01-H36 and A02-A17 

o Shared Lessons are custom lessons created by the instructor. 

Activating the BSL Curriculum Management License 

Activating the BSL Curriculum Management System license is accomplished via a BIOPAC License Key (a physical 

USB License Key containing the Curriculum Management System activation code).  

The BIOPAC License Key (USB) allows access to the BSL Curriculum Management System from any machine that 

has BSL 4.1 installed. It’s recommended to use this key on personal laptops or office computers. The key is only 

required to run the Curriculum Management portion of the BSL software. 

To Use the BIOPAC License Key (USB): 

1. Connect the Key to an available USB port. (Biopac Student Lab 4.1 must already be installed on the 

computer.) 

Register the key online at www.biopac.com/my-account/product-registration/. Registration is recommended in order 

to receive hardware support, product updates and BIOPAC License protection/replacement options.  

(If no BIOPAC account exists, a prompt will appear for creating one.) 

 

2. The USB key must remain connected in order to use the Curriculum Management System.  

Enabling the BSL Curriculum Management System on the Instructor (Host) machine 

The first step after license activation is to enable the BSL Curriculum Management System preference on the 

Instructor or “Host” machine. 

1. Launch BSL 4.1 and choose “Create/Record a new experiment” in the Startup Wizard. Click OK to create a 

new graph window. 

2. Go to Display > Preferences > Lessons and enable the BSL Curriculum Management System Host option.  

http://www.biopac.com/my-account/product-registration/
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3. Click OK and dismiss the resulting Curriculum Management System prompt. 

  

4. Close the BSL 4.1 application and relaunch it. The Curriculum Management System will now be 

present in the BSL Startup Wizard as the “Customize my lab” option. 

5. Choose “Customize my lab” for access to the Curriculum Management System customization 

options. 

 

 

 

For information on setting up the Student (Client) machines to share the Instructor machine lesson content, see page 

375. 
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Customize my lab – Accessing the BSL Curriculum Management System in the Startup Wizard 

What does the “Customize my lab” option do? The 

“Customize my lab” Startup option is a portal into 

the BSL Curriculum Management System. This 

versatile feature enables the user to substitute 

modified lesson exercise content in place of the 

default BSL Lessons materials by selecting custom 

elements from within the BSL 4.1 Startup Wizard 

options. Your customized content must be in PDF 

format for Analysis Procedures, Introductions, and 

Recording Procedures, and BIOPAC’s Journal 

(*.jcq) format for the Data Reports.  

The Curriculum Management System also includes 

the powerful BSL Visual Editor (accessed via 

“Onscreen instructions”), a flexible HTML editing 

and design tool that enables detailed modification of 

the default onscreen Journal instructions  

accompanying  each lesson recording. With the BSL 

Visual Editor, you can edit, add/format text, 

create/delete/modify tabs and details, as well as 

embed graphics and videos into every lesson segment 

ranging from setup, calibration and analysis. With 

the Curriculum Management System, implementing 

custom lesson plans becomes a simpler and more 

interactive experience. All edited content is presented 

for preview in the lower pane of the Editor and 

appears identically as in the actual lesson. 

For example, let’s say you want to modify BSL 

Lesson 1 (EMG-1) to include variations on the default exercises. Simply edit the Lesson 1 Word document source 

(Word doc sources for all lesson procedures are included on the BSL 4.1 installation DVD). Save your changes, and 

then create a PDF file of the modified lesson. (Later versions of Word or other text editors, such as OpenOffice, 

support the conversion of doc format to PDF, as will the full version of Adobe Acrobat Pro.) This modified lesson can 

then be substituted for the default lesson. The Curriculum Management System’s selectable options place the 

modified files in the Help Menu of the selected BSL Lesson where they are easily accessed by the student. 

Modified lessons can be shared from the Instructor machine (host) with any Student machines (clients) over a local 

network. Sharing lessons does not require special networking expertise. All shared content is configured in the BSL 

Curriculum Management System’s General settings via the checkbox options. 

Need to revert to the default BSL Lesson or onscreen instructions? The original Lesson procedures and instructions 

are not overwritten by creating custom lesson content. Simply uncheck the custom content boxes in the Curriculum 

Management “Lessons” settings, or click the “Change” button and navigate to a different custom lesson file.  

Custom onscreen instructions can also be reverted to the default Biopac instructions from the file menu of the BSL 

PRO application; File > Set up Curriculum Management System. On the Lessons pane of the displayed dialog, click 

the “Revert” button. 

For more details on the Curriculum Management System settings, see page 363. 

Access the BSL Curriculum Management System lesson customization options by choosing “Customize my lab” in the 

Startup Wizard.  
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Customize my Lab Radio Buttons and Controls 

Select the Lesson to customize: The first step is to select the lesson to apply your custom content to. Choose a lesson 

from the list before continuing. 

 

Select what you want to customize: Use the radio buttons to enable specific elements of your customized lesson 

content (Analysis Procedure, Data Report, Introduction, or Recording Procedure). Choose the desired option, click 

OK, and a File > Open dialog will be presented. Simply navigate to the location of your custom content and click 

“Open.” This will place your custom PDF content in the Help Menu of the lesson selected for customization and place 

your custom Data Report and Analysis Procedure into the lesson Journal. 

  

In the above example, a custom Analysis Procedure for L01 is being selected. 

Lesson customization radio button details: 

Radio Button Function 

Analysis 
Procedure 

Use the Analysis Procedure option for navigating to the directory containing the custom Analysis 
Procedure (PDF) to be used. Highlight the new file and click “Open.” This will associate the custom 
Analysis Procedure with the selected lesson and embed it as a tabbed PDF file in the lesson 
Journal. 

Data Report Use the Data Report option for navigating to the directory containing the custom Journal Data 
Report (*.jcq) file to be used. Highlight the new file and click “Open.” This will place the new Data 
Report in the Analysis Journal of the selected lesson. 

Introduction Use the Introduction option for navigating to the directory containing the custom Lesson 
Introduction (PDF) file to be used. Highlight the new file and click “Open.” This will place the new 
Lesson Introduction in the Help Menu of the selected lesson. 

Recording 
Procedure 

Use this option for navigating to the directory containing the custom Recording Procedure (PDF) 
file to be used. Highlight the new file and click “Open.” This will place the new Recording 
Procedure in the Help Menu of the selected lesson. 

On-screen 
instructions 

Opens the BSL Visual Editor, which is used to modify the default onscreen HTML Journal 
instruction content. Use this editor to edit and format text, add tabs, import pictures and videos, 
and more. See page 365 for details on using the BSL Visual Editor. 

Preview Changes 

Use the “Preview Changes” option to conduct a trial run of the modified lesson. You also have the option of changing 

other default Lesson Preferences at this time. 

More Settings 

The “More Settings” dialog presents advanced options for setting up custom lesson content. It essentially performs the 

same function as the “Customize my lab” radio buttons, but with a greater degree of control and all custom content 

options presented on a master screen. This is also where custom lesson material for broadcast from the Instructor 

(host) computer to client (student) computers is selected. (See page 375.) 
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The above Lessons settings dialog may also be accessed from the BSL PRO application via the “File > Setup BSL 

Curriculum Management System” menu option. Options and controls are as follows: 

Use custom Help menu introduction PDF: - enables option to use custom Introduction in Help menu and broadcasts 

intro to client (student) computers. 

Open – opens the selected custom introduction file for preview. 

Change… – opens a File > Open dialog for selecting a different Introduction file. 

Use custom Help menu procedure PDF: - enables options for using custom Lesson Procedure in Help menu and 

broadcasts this content to the client (student) computers. 

Open – opens the selected custom Lesson Procedure for preview. 

Change…– opens a File > Open dialog for selecting a different Lesson Procedure file. 

Use custom onscreen instructions – enables the option to show customized Journal instructional content for the 

selected lesson. If unselected, the standard default onscreen instructions are shown. 

Edit – opens BSL Visual Editor for editing the selected lesson Journal content 

Revert… – discards custom Journal instructional content in favor of the original default content. (The following 

prompt will appear when choosing this option.) 

 

Embed Data Report in data files – enables option to embed the standard or custom Data Report into the analysis 

Journal. If unselected, only the lesson segment summary will be displayed in the analysis Journal. 

Use custom Data Report Journal – the custom Data Report will be embedded in place of the standard default data 

report. If unselected, the standard default Data Report will be used. 

Open – opens the custom Data Report file for preview. 

Change… – opens a File > Open dialog for selecting a different Data Report (*.jcq) file. 

Include Analysis Procedure PDF in Data Files – when selected, the standard or custom Analysis Procedure PDF is 

embedded as a separate tab in the analysis Journal following the lesson.  

Use custom Analysis Procedure PDF: – the custom Analysis Procedure will be embedded as a Journal tab in place 

of the default Analysis Procedure. If unselected, the default Analysis Procedure will be used. 

Open – opens the selected custom Analysis Procedure for preview. 

Change…– opens a File > Open dialog for selecting a different Analysis Procedure file. 
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BSL Visual Editor 

The BSL Visual Editor is a designing and editing tool used to modify the default onscreen Journal instructions for any 

selected lesson. If a custom lesson procedure is being used, the corresponding onscreen Journal instructional content 

can be edited to match the custom procedure. 

The BSL Visual Editor is an important component in the Curriculum Management System and allows for flexible 

manipulation of onscreen Journal content of a running lesson. The Editor consists of a main toolbar area, two control 

docks, an editing window and a preview area. 

The launch BSL Visual Editor: 

• Select the “Onscreen instructions” radio button in the “Customize my lab” Startup screen. (Click OK) 

• Select “More Settings” and enable the “Use custom onscreen instructions” checkbox in the BSL Curriculum 

Management System settings window. (Click OK) 

• In the BSL PRO application, File > “Set Up BSL Curriculum Management Settings” and enable the “Use 

custom onscreen instructions” checkbox in the BSL Curriculum Management System settings window. (Click 

OK) 

The Editor can interactively modify the following areas of the lesson Journal: 

• Fast Track text, including the addition of actions, notes and other text and graphics. 

• Collapsible notes and pictures in the Details area 

• Tab name and tab title, including the addition and deletion of tabs 

• Standard text formatting tools are provided – edit font size/style/ text and background color 

• Text alignment, bulleting and numbering, increase/decrease indent 

• Create and insert tables, hyperlinks or HTML code 

• Undo, redo, cut, copy, paste, file open/save 

• Zoom forward/back text and image size 

BSL Visual Editor Window 

 
BSL Visual Editor Window 
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Main Text Editing Area 

The Main Editing Area is the workspace for modifying text and other content appearing in the Lesson Preview Area 

and appears at the center of the BSL Visual Editor screen. Simply enter standard (or HTML) text into this field, or 

modify existing text using the formatting tools (see formatting toolbar on page 367). 

 
Text Editing Area – View Source Tab  

The “View Source” tab displays the raw HTML source code for items currently selected in the Editing Area. This 

field is not editable but the content can be copied into the Editing Area and modified externally. 

 

It’s important to remember that the text in the Editing and Preview Areas mirrors the lesson text for the currently-

selected lesson Segment. Other factors affecting Editing Area content are the various elements selected in the Tab 

Constructor and Tab Interior Designer. (See explanation of these controls below.) 
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BSL Visual Editor Toolbar 

The following formatting tools are available in the Editor: 

 

Tool Description 

 

Open button. Launches a File > Open dialog for navigating to a lessons instructions file (*.xml format). 

 

Save button. Saves the current edits to the lesson instructions. 

 

Undo button. Removes the most recent editing or formatting operation. 

 

Redo button. Restores the most recent editing or formatting operation. 

 

Cut button. Cuts the selected Editor text or content. 

 

Copy button. Copies the selected Editor text or content. 

 

Paste button. Pastes the selected Editor text or content. 

 

Bold button. Toggles bold font style. 

 

Italics button. Toggles italicized font style. 

 

Underline button. Toggles underline of selected text. 

 

Strikethrough button. Toggles strikethrough of selected text. 

 

Align left paragraph button. 

 

Align center paragraph button. 

 

Align right paragraph button. 

 

Align justified paragraph button. 

 

Numbered list button. 

 

Bulleted list button. 

 

Increase indent button. 

 

Decrease indent button. 



368  BSL PRO Manual 

Visit the online support center at www.biopac.com 

 

Tool Description 

 

Insert table button. This option displays the following table formatting options: 

 

 

Insert image button. Displays File > Open dialog for navigating to an image file. 

 

Hyperlink tool. Displays dialog for entering URL information. 

 

 

HTML tool. Displays following dialog for inputting HTML code at the cursor location. 

 

Zoom Tool 

 

There are two independent Zoom tools in the BSL Visual Editor window. The Zoom tool on the top right controls the 

sizing of the Text editing Area content and the bottom right Zoom tool controls the sizing of the Preview Area 

content.  
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BSL Visual Editor Menus 

The Editor menus display an alternate method for accessing the formatting toolbar options, plus a few additional 

controls. 

   

File > Revert   

Discards global changes made to the currently open set of instructions. 

Format > Font Name, Font Size, Text Color, Background Color 

Additional formatting tools for operations not included in the formatting toolbar.  

BSL Visual Editor Tools and Controls 

BSL Visual Editor controls are described below on a sectional basis. Refer to the above image for their default Editor 

window locations. 

Segment Viewer 

 

The Segment Viewer is used to select available lesson recording 
segments for global editing and preview display. This control is dockable 
and can be positioned anywhere in the BSL Visual Editor window. 

When a Segment Viewer entry is selected, the Lesson Preview Area 
displays all required actions for that segment in the lower half of the Editor 
screen. The Lesson Preview closely resembles the instructional Journal 
presented during the running of an actual lesson. 

 (The Lesson 1 CAL Setup segment is shown in this example preview.) 

 

Segment Viewer Limitations: The Segment Viewer menu is not editable, 
and only one segment may be selected at a time. New lesson recording 
segments cannot be added, and default segments cannot be deleted. 
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Tab Constructor (for Fast Track content) 

    

 

Tab Name and Tab Title as they appear in the 
Fast Track Preview Area. 

 

The Tab Constructor is used for editing, adding and deleting 
tabs and tab text in the Fast Track Preview Area. This control is 
dockable and can be positioned anywhere in the BSL Visual 
Editor window. 

 

The “Tab Name” and “Title” fields are directly editable. To 
change existing Tab text, click into the Tab Name or Title field to 
select and enter new text. Press Enter to accept the new edits. 
Newly-added Tabs will remain “Untitled” until new text is entered 
in the active Tab Name and Title fields. 

Use the  buttons to add new Tabs or remove existing 
Tabs.  

New Tabs will appear in the Tab Name list below the currently-
selected Tab and to the right of the selected Tab in the Fast 
Track Preview. To delete a Tab, select it and click the Tab 
Delete button. (Red “X”) 

Tab Interior Designer (Fast Track) 

 

Lesson Preview of Fast Track text. 

 

Editing Area for entering/formatting Fast Track 
text. 

 

 

Use the Tab Interior Designer to select blocks of Lesson 
Preview text for editing. This control is dockable and can be 
positioned anywhere in the BSL Visual Editor window. 

Fast Track selection: 

The default formatting for BSL Lesson Fast Track text consists 
of Actions or Notes. 

Actions are are indented and bulleted by default. 

Notes appear as standard text. 

Actions or Notes can be reformatted as desired in the main Text 
Editing Area. (See page 366.) 

To enter or edit an Action or Note: 

1. Click on the desired Action or Note item in the list to 
select it. (The selected text will be outlined in red in the 
Lesson Preview.) 

2. Type the new text into the Text Editing Area in the 
center of the Editor screen.  

3. Apply the new text to the Preview by clicking the 
Refresh Preview button.  

Tab Interior Designer “Fast Track” Tools: 

Use the  button to add a new Fast Track Action. 

Use the  button to add a new Fast Track Note. 

Use the  button to add an empty space to Fast Track. 

Newly-added Actions or Notes appear below the currently-
selected Action/Note in the Fast Track list. (Items in the list 
cannot be dragged to different locations.) 
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Tab Interior Designer (Details) 

 

Text Editing Area with Main Data selected: 

 

Example of Details with collapsible sub-text: 

 

 

Enter collapsible sub-text in Text Editing Area: 

 

Collapsible sub-text as it appears in preview: 

 

Collapsible means that clicking the underlined 
Detail text in the Preview Area will show or hide 
the sub-text. 

Use the Tab Interior Designer Details option to edit the right 
pane Preview Area content. This area is where supporting 
details, illustrations, pictures and videos are typically embedded. 

The Details option consists of a Main Data entry, which displays 
the primary content in the Text Editing and Preview areas.  

To select Main Data content for editing: 

1. Click the Main Data field. 

2. Edit content by typing into the main Text Editing Area in 
the center of the screen. Import of graphics and videos 
are also supported. (See page 367 for more Text 
Editing Area tools.) 

To add optional Details text to the Main Data: 

1. Click the  button. 

2. Highlight the newly-added “Untitled” entry and enter the 
desired text. 

 

3. Press the Enter key (or click anywhere in the Editor 
window) to apply the edit. The new Details text will 
appear in the lower right Preview area. 

 

You may also:  

• Add collapsible sub-text to the selected Detail by typing 
it into the Text Editing Area. (See left example.) 

• Edit the existing Details of any selected lesson 
segment. 

• Delete Details using the  button. 
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Additional BSL Curriculum Management System Settings 

The global settings for BSL Curriculum Management are controlled and displayed in the panels within this screen. 

Access the BSL Curriculum Management Settings by: 

• Clicking the  button in the BSL Startup Wizard’s > Customize my lab option. 

• Choosing File > Set Up BSL Curriculum Management System in the BSL 4.1 PRO application. 

Status Panel  

The Status panel displays current information about the Instructor (Host) and Student (Client) machines during a 

lesson session. 

 

Control Description 

Computer name Displays the Instructor (Host) machine name. 

Host and port status Displays whether the Host machine is running or stopped. If running, the 
Host machine’s port number is displayed. 

Connected Student 
(Client) machines 

Lists all recognized Student (Client) computers on the network using the 
configuration from the Host machine. They may not be actively 
transferring data but should still be running BSL in client mode. 

General Panel 

The General panel contains basic options for configuring the Curriculum Management System that apply at the 

application level or are shared by all lessons: 
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Control Description 

Enable BSL 
Curriculum 
Management System 

Enables the BSL Curriculum Manager, allowing it to broadcast settings and content over the 
local network.  

Host port Current port number used by the Instructor (Host) machine. Default value is 15055. 

Lesson and PRO 
Lesson Startup 
Wizard visibility 

Clients restrict the available choices for the Lessons and PRO Lessons tabs on their Startup 
Wizard to match the lesson preference settings of the Host computer. 

Lesson Preferences 
and Enabled 
Segments 

Enables Student computers (Clients) to use the settings from the Host computer for individual 
lesson preferences (File > Lesson Preferences when running a lesson) as well as any 
customizations applied to the Host computer's lesson segment display. Changes to the Host 
computer’s lesson preferences must be applied by running the specific lesson and altering the 
settings in File > Lesson Preferences. 

BSL Application 
Preferences 

Enables Clients to use the Host computer's settings for all application preferences instead of 
local preferences. This sharing is unidirectional; any changes in application preferences made 
on a Client machine do not affect the Host.  To make a permanent setting change, the Host’s 
Display > Preferences settings must be modified. 

Change Password Use this option to set up or change a password to access any Curriculum Management 
Settings. When set, the password will be required when choosing “More Settings” option in the 
BSL Startup Wizard > “Customize my lab” option, or when using File > “Set Up BSL 
Curriculum Management System” in the BSL PRO application. 

Lessons Panel 

See page 364 for explanation of Lessons Settings panel. 

Shared Lessons Panel 

Shared Lessons are graph templates with instructor-provided titles made available for use on all Clients. These graph 

template files may have their own embedded Journals and PDFs to assist in distribution of Instructor materials. This 

panel configures the specific graph template files being shared. 

 

Control Description 

Share Graph 
Template... 

Displays a dialog for navigating to the location of the graph or graph template 
to be shared.  

Rename... Displays a dialog for renaming the default title of the shared lesson under the 
“Name” field. 

Unshare…  Removes the selected lesson from the shared lessons list.  
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Setting Up Curriculum Management Instructor (Host) and Student (Client) Sharing 

The BSL Curriculum Management System allows for the sharing of default and custom lessons and other instructional 

materials over a local network, and is split into “Host” software (including configuration controls and editors) and 

“Client” software. Depending on the Host machine settings, the following information may be shared: 

• Application level preferences 

• Standard and PRO Lesson visibility 

• Shared instructor-generated PRO Lessons 

• Individual lesson preferences 

• Replacement help menu introduction and procedure lesson PDFs 

• Customized lesson HTML instructions and content 

• Replacement Data Report journal 

• Replacement analysis instruction PDF for data files  

The following Host-Client controls for BSL Curriculum Manager are found in the BSL PRO application’s Display > 

Preferences > Lessons: 

 

Control Description 

BSL Curriculum Management System Host Allows this computer to “push” all customized lesson 
content to the other computers on the local network. 

Client of Curriculum Management System Allows this computer to receive the customized 
lesson content and onscreen instructions being 
“pushed” from the Curriculum Management System 
Host computer over the local network. 

Locate Host – Automatically  Searches automatically for Curriculum Management 
System Hosts on the local network. 

Locate Host – Manually  Allows the Curriculum Management System Host to 
be identified by a fixed I.P. address and port number. 
Use this option is auto-location is not supported on 
your network. 

Require Curriculum Management System host Check to prompt on application launch if no 
Curriculum Management System Host is detected. 

Allow BIOPAC standard lessons if required host is 
missing 

Allows access to the default uncustomized BSL 
Lessons if no Curriculum Management Host is 
detected. 

Local program for working with standard lessons Use the standard BSL Lesson Curriculum.This 
setting disables the Curriculum Management System. 

NOTE: Before sharing the instructional content, enable or disable the desired lessons in the Curriculum Management 

Settings and the Display > Preferences > Lessons settings. 
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To share BSL Curriculum Management materials over the network, use the following steps: 

1. Launch the BSL PRO application on the Instructor (Host) computer. 

2. Display Preferences > Lessons. Make sure that “Run BSL application as – BSL Curriculum Management 

System Host” is enabled. 

 

3. Launch the BSL PRO application on the Student (Client) computer. 

4. Display > Preferences > Lessons. Make sure that “Run BSL application as – Client of Curriculum 

Management System” is enabled. 

 

5. Check “Locate host – Automatically.” (If your network does not support auto-location, contact your network 

administrator to obtain the correct I.P. address and port information, and use the “Locate Host – Manually” 

setting.) 

6. Click OK, and click OK to the configuration change confirmation dialog. 

 

7. Close the BSL application on the Student (Client) computer. 

8. Relaunch the BSL application on the Student (Client) computer. The following dialog will appear: 

 

9. The Student (Client) computer will connect automatically to the Instructor (Host) computer over the network, 

and all configured Host preferences and shared materials will be available to the Clients. 

Note: Although detection of multiple Instructor (Host) computers is supported, only one Host computer may be used 

at a time by a Client. If multiple BSL Curriculum Management Host computers are found on the network, the 

following message will be displayed. 
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Importing and Exporting Curriculum Management Settings  

Customized content and saved Curriculum Management System preference settings can be exported into a proprietory 

custom settings archive file called *.csp format. The Import/Export functionality allows for customized content and 

preferences to be exported to a single file that can then be transferred between computers.  

This feature is useful not only for backing up custom settings, but also offers the ability to edit content on an 

office/home computer and then easily move (import) those files to a host in the lab. 

To access this feature, launch BSL and select the “Create and record a new experiment,” then choose the File menu 

and note the two Import and Export Curriculum Management Settings options: 

 

In order to use the Import option, a saved Curriculum Management Settings archive (*.csp) file must be available. A 

saved settings file must first be created by using the “Export…” option, or a saved settings file must be available 

from another machine with BSL installed. 

To Export Curriculum Management Settings 

1. Choose the “Export BSL Curriculum Management Settings” option. This launches a File > Save As dialog. 

 

2. Name the settings archive (*.csp) file and Save it to a location of your choice. 

The following confirmation dialog will appear after the archived Curriculum Management settings are exported. 

 

To Import Curriculum Management Settings 

1. Choose the “Export BSL Curriculum Management Settings” option. This launches a File > Open dialog. 

2. Navigate to the location of the saved *.csp file, select the file and click Open. 

 

The following confirmation dialog will appear after the archived Curriculum Management settings are imported. 

 

 


