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Demo Guide 
 

Thank you for downloading the 
AcqKnowledge Demo Software!  
This functional and informative Demo 
version is designed to introduce you to the 
power of AcqKnowledge data acquisition 
and analysis software, and includes a wide 
variety of prerecorded sample data files for 
simulating live recordings.  

Note that the following full-version 
AcqKnowledge features are disabled in the 
Demo version: 

• Recording of live data or external 
hardware support. 

• Saving or printing of files. 

• Compatible file types are limited to 
graphs (*.acq) or graph templates 
(*.gtl).  

However, most of the feature-rich tools 
included in the full AcqKnowledge 
software version are intact in the Demo, 
which allows you to explore these 
remarkable options using any of over 50 
available sample data files. While it’s 
difficult to cover every feature of 
AcqKnowledge software in just a few 
pages, in-depth questions can be addressed 
by combining this tutorial with our latest 
research catalog, the “AcqKnowledge 
Software Guide,” and other support PDFs 
provided in the Demo’s Help menu. 

With this guide, you’ll be able to simulate 
hands-on use of the software for your 
particular application. For more 
information about how AcqKnowledge can 
address your specific requirements, please 
contact one of our Application Specialists 
at www.biopac.com.  

For in-depth overviews of the analysis 
routines and other powerful software 
features available in AcqKnowledge, we 
encourage you to visit BIOPAC’s Video 
Tutorial page at: www.biopac.com/videos.  

 

https://www.biopac.com/
https://www.biopac.com/video/?video_category=acqknowledge-new-features&v=focus-areas-acqknowledge-tutorial
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Basic Questions 
What is the BIOPAC MP System? 
The BIOPAC MP System includes all necessary hardware and software for efficient collection of physiological data, 
with packages completely scalable to your needs. BIOPAC also manufactures industry-leading amplifiers and signal 
conditioning modules designed to measure an array of life science data including EMG, respiration, pulse, EEG, 
temperature, eye movement, skin conductance, evoked potentials, microelectrode recordings, electrical bioimpedance, 
laser Doppler flow, CO2 and O2 gas analysis, and electrogastrogram. We also offer a general-purpose amplifier that 
supports connection to other devices, including bridge transducers like pressure, force, and strain gauges. In addition, 
you can mix and match amplifiers designed to collect specific and varying physiological signal types. These modules 
snap together, allowing you to create a customized data acquisition workstation. 

This guide and the accompanying Demo software will highlight the main features of AcqKnowledge software using 
the included sample data files. You’ll examine specific sections, take readings, and perform analysis. Over 50 sample 
data files are included for ECG data, EDA data, EEG data, EMG data, respiration data, and much more. For use with 
the Specialized Analysis Package—Cardiac Output 1, EDA Events, RER, Cardiac Output 2, Noninvasive Blood 
Pressure, Impedance Cardiography, and more. Sample data files and preconfigured graph templates can be accessed 
via the AcqKnowledge Demo’s clear Startup Wizard interface. 

Hardware configurations 

   
MP160 System MP36R System 

BIOPAC’s Research Systems include: 

 Data acquisition system that allows for connection of existing equipment such as pre-amplified 
electrodes, transducers, blood flow meters, force plates, and chart recorders 

 MP160 16-channel acquisition unit with High Level Transducer (HLT100C) module  
OR 
 MP36R 4-channel data acquisition unit 
 AcqKnowledge® 5 software (Note that AcqKnowledge 5 is supported in 64-bit OS only.) 

 See the full line of research products online at www.biopac.com. 

AcqKnowledge® software can be used with multiple MP160 (or earlier-version MP150) data acquisition units to: 

 control multiple, independent experiments on one computer 

 increase the total number of channels used for a single experiment (e.g., 32-channel EEG) 

Efficient Collection 
The MP System has several advantages over other recording systems. AcqKnowledge is extremely flexible, allowing 
full control over how data is collected. Analyze data either while it is being acquired or following completion of the 
recording. AcqKnowledge will extract a range of measurements, calculations, and transformations after the data has 
been collected––most can be performed with a click or two of the mouse button. The full version of AcqKnowledge 
includes over 40 Quick Start graph templates, which include all the settings for a variety of experimental protocols 
(explained further in our RESEARCH CATALOG).  

https://www.biopac.com/
https://www.biopac.com/wp-content/uploads/research_catalog.pdf
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Easy Viewing 

 
AcqKnowledge software is designed to provide a clear interface for working with data and displaying information. 
AcqKnowledge includes... 

 Acquisition Options — variable sample rates, pause mode, multiple data views, and 
stimulation design and control 

 Display Options — advanced grid system, journal facility for note taking, embedded pdf 
documents for instruction, textual event markers, and measurement tools 

 Analysis Options — online signal averaging, ensemble averaging, epoch analysis, AR time-
frequency analysis, principal and independent component analysis, autoregressive and 
nonlinear modeling, automated analysis routines, filtering, FFT, PSD, Histogram, automatic 
data reduction, template analysis, peak detection features, find rate settings, and an equation 
generator 

 Transform Options — digital filters, Fourier linear combiners, math functions, template 
functions, integral, derivative, finite difference, integrate, smoothing, difference, resample 
waveform, resample graph, expression, delay, rescale, waveform math, slew rate limiter  

 User-Interface Options — tool tip mouse-overs (for sample rate, channel rate, measurement 
results, etc.) and real-time, custom presets, change log, searchable MP System guides (PDF 
format), as well as extensive online support and training documents 

With AcqKnowledge, you can perform complex data acquisition, triggering, and analyses using simple pull-down 
menus and dialogs—no need to learn a programming language or new protocol. 

AcqKnowledge software includes fully automated analysis routines for most physiological signals! For ECG data, 
utilize the automated HRV analysis or locate and mark ECG complex boundaries for both human and animal signals. 
Take advantage of multiple routines available for EEG, EDA, EMG, and Respiration. Look at RSA or perform a 
detailed ICG analysis with a few clicks of the mouse. Use AcqKnowledge to save time and standardize analysis 
protocols. 

 

http://www.biopac.com/


Page 4 of 19 AcqKnowledge® 5 Demo 

Let’s begin…  
The following steps will walk you through the basic features of AcqKnowledge software. This tutorial assumes the 
Demo has been downloaded and successfully installed on your computer. 

To view an example of AcqKnowledge data display in a simulated recording: 

1. Launch the Demo software by clicking the “AcqKnowledge 5.0 Demo” Desktop shortcut. 

2. The AcqKnowledge “Startup Wizard” will appear, offering various program options. The 
default option is Open a graph file. Make sure this option is selected. 

  
3. The Sample data file option in the lower portion of the screen will be selected by default.  

4. Highlight demo data.acq from the Sample data file list (you may have to scroll down). 

5.  Check Open for Graph Data Playback and click OK. The selected file will open in the AcqKnowledge 
application as a new graph window. 

 
6. Click the Replay button in the AcqKnowledge graph window to start the simulated recording.  

 

Pre-recorded data will begin scrolling across the graph window. 
This is a real-time display of a physiological recording acquired 
from an adult male subject. Note that each acquired signal appears 
in its own track, or “channel.” This default channel view is called 
“Chart Mode.”  

Data will be “collected” for 30 seconds and stop automatically, but 
the replay can be interrupted at any time by clicking the Stop 
button. (The Replay button toggles to a Stop button while replay 
is in progress.) 

After completing (or stopping) the playback, click Replay again to 
repeat the simulated recording. (Click Yes if prompted to 
overwrite the existing data.) The replay will be identical in 
appearance and length to the previous data display. 

Basic Viewing Tools: 

 Click the Grid icon  to toggle the grid display on or off. 

 Use the Zoom tool  to enlarge an area of data (see page 8). 

 Use the I-beam tool  to select an area of data (see page 8). 

 Use the Data Acquisition Setup window to modify the duration 
and recording mode of the replay (choose Playback menu > 
Set Up Data Acquisition > Length/Rate). The duration can 
be increased or decreased, and the acquisition modes changed. 
(See page 5 for further details about acquisition setup.) 
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During data playback, note that when the data plot reaches the 
right edge of the window, the waveforms begin continuously 
scrolling from right to left. For long recordings, it’s often 
desirable to view the data collected earlier in the acquisition 
while new data is coming in. 

To demonstrate this, disable the AutoPlotting and Scrolling 
options under the Playback menu (uncheck the boxes). 

 
Replay the acquisition again. Now, when the data plot reaches 
the right limit, the screen will not be redrawn. The horizontal 
scroll bar will shift position to indicate that the file length is 
longer than the visible display. 

 
At this point, you can use the horizontal scroll bar (example 
above) to look back through the data. Note the scroll bar position 
indicator changing while data collection is in progress. This 
indicates the record is getting longer as new data is being 
acquired. Reselect AutoPlotting and Scrolling to again view the 
new data as it is acquired in real time. 

During long recordings, you may wish to accomplish other tasks 
on the computer. By minimizing or resizing the application 
window, AcqKnowledge can be busy collecting data in the 
background while you're using another program. 

In addition to the ability to collect data in the background, AcqKnowledge also allows complete control over the 
channel parameters. To illustrate this, choose Set Up Data Acquisition > Channels from the Playback menu.  

 
To the left of the Channel column, the Acquire checkbox enables acquisition, and the Plot checkbox enables 
onscreen plotting. If Acquire is on but Plot is off, data from that channel will be recorded, but will not appear 
onscreen.  

The Values checkbox enables the channel’s current numeric value to be displayed in an onscreen Input Values bar 
graph (see following page). The Setup button on the upper right of the screen is used for setting up parameters in the 
selected channel, but note that in the Demo’s Playback mode, this button is disabled for Analog channels.  

Each channel label, or title can be edited as desired under the Label column. 

The Channel Sampling Rate option can be used to downsample individual channels to various sampling rates. 
Modified Channel Sampling Rate are supported in Playback mode for demonstration purposes. 

Calculation Channel Presets offer an easy way to apply filters, expressions or transformations in real time and display 
the calculated data as separate graph channels. To do this: 

Click the Calculation tab to activate the Presets  menu. Click the  (arrow icon) to generate a list of preset 
options. Use an existing preset or modify it to create a new one. Note that Calculation Presets only work in 
conjunction with Analog input presets, or with other calculation channels coupled to an Analog source channel.  

http://www.biopac.com/
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To view the input channel Value in 
numerical and/or bar chart format, choose 
the Show Input Values item in the 
Playback menu. This type of data display 
is useful for biofeedback procedures. 

Click the Options button in the Input 
Values dialog to generate controls for 
changing the size, precision, and format 
of the Input Values display. 

 
 

To further control the acquisition, select 
Set Up Data Acquisition > Length/Rate 
from the Playback menu. This is where 
all data recording parameters are set, or in 
the case of the Demo, data playback 
parameters. The basic options are Sample 
rate and Acquisition Length. 

 
• Sample rate sets the frequency at which the data is being recorded in samples per second (Hz). Normally you 

would choose a samples/second rate from the pull-down menu. However, this option is disabled in the Demo, 
which is locked to an acquisition sample rate of 1000 samples/second. 

• Acquisition Length sets the duration of the recording. Adjust the scroll bar or enter the length value directly.  

• Units can be set to samples, msec, seconds, minutes, or hours by clicking the pop-up menu to the right of the 
Acquisition Length value. 

• Repeat every is used to set up single or multiple consecutive acquisitions at a user-defined time interval. 

Restarting the acquisition with the Replay button will apply any modified settings, although as previously stated, the 
Demo is locked to an acquisition sample rate of 1000 samples/second. Parameters can also be set to store data to 
Memory, Disk, or MP160 unit. For more sophisticated acquisitions, Averaging mode can be applied. (Note that the 
Demo version does not support the use of MP160 unit or Averaging acquisition modes.) 

Using the Graph Journal 
The Journal is a text editor built into AcqKnowledge for recording notes and data and saving text and/or numeric 
values for later review. Journals can be used at the same time data is being acquired, and can be docked at the edge of 
a graph or free floating. To enable the Journal, go to “Display > Show > Journal” or use the Display toolbar button 
and select “Journal.” To paste data to the Journal, go to “Edit > Journal” and use any of the paste options. For in-depth 
details on how to use the Journal, we encourage you to watch the Tutorial Video. 

 

https://www.biopac.com/video/?video_category=acqknowledge-tutorials&v=journal-features-in-acqknowledge
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Using the Channel Buttons to Select or Hide Channels 

In the upper portion of the acquisition window, a row of small buttons indicates the acquired channels. (Channel 

buttons can be enabled via the Display toolbar button  or Display menu > Show > Channel Buttons.) 

 
The leftmost box corresponds to the waveform at the top of the screen. The box appearing outlined and shaded is the 
selected (or “active”) channel. Only one channel can be selected at a time. The color of each channel’s waveform and 
indicator box correspond to those in the graph channels and can be changed. Measurements can be taken from any 
channel, while transformations and editing operations apply to the selected channel or, in some cases, to multiple 
channels.  

To select a channel, click the waveform or channel button with the arrow  tool.  

The label of the selected channel appears to the right of the channel indicator boxes. The vertical scroll bar adjusts the 
vertical offset of the selected channel. You can use it to slide the selected waveform’s scale up or down. 

Temporarily hide channels by clicking a channel’s indicator box while holding down the Alt (PC) or Option (Mac) 
key. The hidden channel’s box will be marked with a slash, and the display redrawn minus this channel. Repeating 
this keystroke on a hidden channel restores the view. Multiple channels can be hidden at a time. 

 

Channels can also be collapsed from view by clicking the “˅” button in the upper left of the channel label  and 
restored by clicking the resulting “>” button. 

Adjusting Vertical and Horizontal Scales in a Channel 

To adjust the vertical scale of the selected channel, click the vertical scale region to the right of the channel. The Set 
Screen Vertical axis dialog box will appear. Type in a value roughly half the current value and click OK. The selected 
waveform’s screen amplitude will now be twice as large as it was before. You have independent control over each 
channel.  

  
To display the optimal vertical scale for all channels, choose Display > Autoscale waveforms. (The Autoscale option 
can also be accessed by right-clicking within a channel area on the graph.) 

You can also compress or expand the displayed waveforms along the horizontal (time) axis. Simply click anywhere in 
the horizontal scale region. The horizontal scale box will appear, allowing any entry. After clicking OK, the screen 
will be redrawn with the new time scale setting. (See “Set Screen Horizontal Axis” figure below) 

 

http://www.biopac.com/
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Using the Zoom Tool 

To enlarge an area of interest, use the zoom tool in the cursor toolbar.  

Click the zoom tool, then click and drag the mouse to form a box over the desired area. Now, release the mouse 
button and you will instantly see the enlarged area (example below).  

  
Select Zoom Back and Zoom Forward from the Display menu to move through zoom levels. (Or use the keystroke 
combination Ctrl+ or Ctrl-.) 

Selecting Data with the I-Beam Tool and Using Measurements 

To take select a section of data and take and specific 

measurements, click the I-beam selection tool . Select data 
by clicking and dragging across a waveform as shown at right. 

The sample data window shown at right has two measurement 
popup menus set to Delta T and BPM. 

In this example, the interval between two peaks is selected. 
Using the Delta T measurement, the two peaks occur 0.807 
seconds apart, which results in a BPM of 74.349 as indicated 
the BPM measurement box.  
To access any of over 30 measurement functions, click the 
popup menu next to the measured value and select the new 
measurement. To change the channel a measurement is based 
on, choose from the SC popup menu. By default, 
measurements are taken from the selected channel (as 
indicated by SC).  

The values will change while the I-Beam tool  is being dragged across the waveform. You can easily 
measure absolute functions like value, time, and sample number or use functions that operate over the 
highlighted area. These include min, max, mean, Delta T, and others. 
The measurement features can be automated so that measurements are taken and pasted into the Journal 
file when a specific event occurs or at pre-specified, user-selectable time intervals. The Find Cycle 
function (under the Analysis menu, see page 13) will identify specific events based on a variety of 
thresholds or allow you to enter a time period. In the time period mode, the software will take the selected 
measurement at the defined interval. 

The I-Beam tool  is also used to edit waveforms. The highlighted area can be cleared, cut, copied, or pasted. Data 
is edited from the selected waveform only. You can copy a section of one waveform and paste it into another by 
selecting the destination waveform before pasting it. You can also perform edits (such as pasting) between windows. 
To copy an entire waveform from one window to another, choose Edit > Select All and then choose Edit > Copy, 
and then switch to the other window and choose Edit > Insert Waveform. 

Choose Display > Preferences > Measurements or click the toolbar’s Preferences button  to modify the 
measurement display parameters. 
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Data Display Modes 

AcqKnowledge offers several display options, including X/Y plotting. You can switch display modes by using the 
toolbar icons in the upper left-hand corner of the window. 

 Scope, Chart, X/Y, and Overlap display mode icons 

By clicking these icons, your display can alternately emulate a chart recorder or oscilloscope, or you can plot data 
from one channel against data from another channel. You can also overlap appended data segments to simplify 
comparison (requires acquisition setup for append). X/Y plots are useful for respiration studies, vectorcardiograms, 
and investigations into non-linear dynamics. 

AcqKnowledge supports the display of several files onscreen at one 
time. Simply choose File > Open and make your selection. Graph 
windows can be displayed as windowed or tabbed, and moved and 
resized to ease in viewing. Clicking the window or tab brings it to 
the front. This is very useful for comparing files.  
For more detailed display options, read about modes and Data Views 
in the AcqKnowledge Software Guide available under the software 
Help menu. 
 
Event Marking System 

 
For some experiments, it’s very useful to mark when an event occurs. To do this, use the on-screen event marking 
feature. With an open graph window (in Chart or Scope mode), choose Display > Show > Events and Display > 
Show > Event Bar to activate the event marker display region near the top of the graph window. A wide range of 
event types can be added by clicking the  toolbar button, selecting an event type and clicking on the event region 
just above the graph data. To remove an event, click the “Zap” toolbar button  and click the event to be removed. 
Each event marker is represented by an icon and can be annotated with text. To add a new event marker after 
acquisition, position the cursor in the space between the bottom of the marker region and the top of the graph, and 
click the mouse. 
To add a global event during acquisition (or Playback mode,) press the Esc key 
while the recording is in progress. The figure at right depicts global event 
markers inserted into a graph while recording. 

 

Event markers can be positioned in the event marker bar, on the waveform, at the top 
of the plot, on the waveform with an indicator, or on top of the plot with an indicator. 
Click the Event Palette icon on the right edge of the Event Tools to review event 
marking options . 
Use the event marker tools to jump through the event markers or generate a popup 
menu that will allow you to search for or delete specific event markers. 
 

See the AcqKnowledge Manual under the Help menu for Event setup, control, and 
measurement options, including Hotkey setup and automated detection. You are also 
encouraged to watch the online Event Marking Tutorial Video. 

Read “User Interface & Context Menu Features” in the complete AcqKnowledge 
Manual available under the Help menu for more tips! 

 

http://www.biopac.com/
https://www.biopac.com/video/?video_category=acqknowledge-tutorials&v=event-marks
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Focus Areas 

Focus Areas allow you to define selected areas of data and permanently save them in the graph for discrete analysis. 
An unlimited number of Focus Areas can be defined, and then easily navigated with the “Focus on” toolbar buttons. 
This feature is useful for highlighting and locating noted areas in a larger data set without having to manually scroll 
through the data. 

To define and navigate to a Focus Area: 

1. Go to “Display > Show” and enable “Focus Areas 
Bar” and “Focus Area.” 

2. Using the I-Beam tool,  select an area of data. 

3. Right click inside the selected data and choose 
“Create Focus Area” 

4. Enter a name for the Focus Area in the label dialog 
and click OK. 

Unlimited Focus Areas may be created within a graph. Use 
the “Focus on” toolbar arrow tools (outlined in red in the 
figure on right) to navigate quickly through Focus Areas. 

For further details about the Focus Area tools, see the AcqKnowledge Software Guide or the online Focus Area 
Tutorial. 
We also encourage you to explore the above tutorial steps using any of the 50-plus sample data files included in the 
Demo software. These files can be opened in Playback or Analysis mode in the Startup Wizard as shown on page 3. 
 

https://www.biopac.com/video/?video_category=acqknowledge-new-features&v=focus-areas-acqknowledge-tutorial
https://www.biopac.com/video/?video_category=acqknowledge-new-features&v=focus-areas-acqknowledge-tutorial
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Powerful Analysis 
In AcqKnowledge, all acquisition settings, scalings, Journal content, preferences, 
etc., are saved with the data when File > Save is chosen. Note that modified data and 
parameters cannot be saved in the AcqKnowledge Demo version.  

The File > Save formats shown on right and explained below are supported in the 
full version of AcqKnowledge only. They are included here for illustration purposes. 

• Graph (.ACQ) saves data in a binary file format that uses minimal disk space.  
• Use the powerful Graph Template feature to save predefined experiment 

parameters. Just open a Graph Template (.GTL) and click Start to recreate 
the protocol and acquire data under the same settings. “Quick Start” Graph 
Template files are available for dozens of applications and can be used as a starting point for customized 
applications. Sample Quick Start files are installed with the Samples folder (open as Type: Graph Template). 

• Compressed will generally achieve about 60% compression. Saving small files (less than 200K) may have little 
effect. 

• Text (.TXT) is a standard ASCII format that can easily be read by other programs. 
• JPEG files can be read by most drawing and word processing programs. 
• Matlab uses the “MAT-file” binary format to save numerical and textual information as Filename.mat. 
• Excel Spreadsheet File (.XLS) option saves graph data with each channel placed into a spreadsheet column. 
• Raw (.RAW) saves data for low-level data exchange with options for data type, layout, and endian byte 

ordering. 
• With Igor Pro Experiment format (.PXP), the graph is saved to a single packed experiment file, with each 

channel saved into a separate Igor wave that preserves the channel label, waveform sampling rate, and unit 
information. 

One advantage of saving data on disk is that you can quickly and easily perform post-acquisition analyses on your 
data. AcqKnowledge is as powerful an analytical tool as it is flexible. What’s more, the software is designed to 
provide you with immediate feedback from each operation. Using AcqKnowledge, you will be able to... 

 Use digital filtering and smoothing. 
 Find patterns within data sets. 
 Automatically find cycles/peaks and calculate rate data. 
 Perform mathematical and statistical operations. 
 Log results and observations to a Journal. 
 Mark events during acquisition or analysis. 
 Transform data after it has been acquired. 

Read more about analysis, transformations and event marking in the complete 
AcqKnowledge Manual available under the Help menu. 

View video tutorials and software overviews online at www.biopac.com/videos. 

http://www.biopac.com/
https://www.biopac.com/video/?video_category=acqknowledge-new-features&v=acqknowledge-installation-example
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Transforming Data 

  

The Transform menu contains operations that modify the data in the graph after the 
recording is completed and opened for analysis. 

• Digital Filter has a sub-menu with both FIR and IIR types of filter 
operations. For most datasets, the default filter parameters may be used and 
will produce relatively robust results. 

• Math Functions has a sub-menu with several mathematical transformations; 
some transformations will produce a dialog with parameters that can be 
changed. 

• Template Functions has a sub-menu with options to examine the relationship 
between two different waveforms. 

• Integral results in a running total of all selected waveform values (using 
trapezoidal rule integration).  

• Derivative approximates an ideal differentiator. It allows you to specify a low 
pass frequency to filter the data prior to performing the derivative. 

• Difference is a running subtraction over the number of points specified. 

• Finite Difference applies an algorithm that performs numerical 
approximation of higher order derivatives. 

• Expression provides a range of 
mathematical operations—from 
addition and subtraction to arcsine 
and log transformations—to 
perform complex operations in a 
single step. For example, compute 
the mean of channels 1, 2, 3, 4 and 
5, and then arcsine transform the 
result. Save the output on a new or 
existing channel. Transform the 
entire waveform or a selected area. 
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Analysis Menu 

 

 
Use over 50 Sample Data files to 
further explore the power and 
flexibility of AcqKnowledge 
software, including the analysis 
automation tools.  

    

The Analysis menu contains many operations that derive data and 
measurements from the graph. The following brief examples are presented: 

• Histogram allows you to display data in summary format and examine 
the central tendency characteristics and variability within a waveform. 

o Enter the number of “bins” to sort the values into. For example, 
type “50” in the bins entry and click OK. To set the upper and 
lower bounds of the data to be sorted, disable Autorange. 

 
 

 

 

 

 

• Find Rate will search for cycles or peaks and calculate rate 
information. For example, it will calculate BPM for the entire ECG 
waveform. 

o Operate as a simple threshold detector or include more 
sophisticated parameters such as noise rejection and windowing. 

o Calculate the following parameters from a variety of cyclical 
data: BPM, Hz, peak max, peak min, P-P, area, and mean. 

 By default, AcqKnowledge will automatically calculate the threshold 
values and compute the rate for the entire waveform, but you can limit 
the transformation to a selected area. 

 

Watch detailed video tutorials 
online at 

www.biopac.com/videos 

As with almost every 
feature in AcqKnowledge, 
you can experiment with 
different settings to suit 
your needs. 

http://www.biopac.com/
https://www.biopac.com/video/?video_category=acqknowledge-tutorials&v=acqknowledge-find-cycle-peak-detector-part-1
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Find Cycle/Peak Analysis: 
The advanced Cycle/Peak Detector combines with the powerful new Event Marking System. Use it to perform 
amplitude, time, or event-based measurements. The following is a guided example of the Find Cycle tools. 

1. Hide all channels in the “demo data” file except CH 10 EMG. 
 

2. Zoom in on a burst in CH 10 EMG and then use the I-beam 
cursor to highlight the area around one typical EMG spike. 

3. Select Ctrl-F (or Analysis > Find Cycle) to generate the 
Cycle/Peak Detector dialog. 

4. Click the Cycles/Peaks tab and set the Threshold Level by 
clicking the Use selected maximum button under the entry 
box. 

 
5. Click the Selection tab and set Left edge to Previous peak. 

 
6. Click the Output tab. 

 Select the Measurements tab and click Paste measurements 
for each cycle to Journal. 

 Select the Events tab. 

i. Check the Output events box 

ii. Set Event 1 to Maximum on CH 10 EMG for Output type 
General > Maximum and output on CH10. 

iii. Set Event 2 to minimum on CH 10 EMG for Output type 
General > Minimum and output on CH 10. 

 
7. Click Find All Cycles. 

 Click YES if prompted to proceed with 
Measurement Scaling Enabled. If 
prompted regarding cursor position, 
click Set to Origin. Click Yes if 
prompted to create a Journal. 

8. Scroll left to the start of the data file. 

9. Use the Zoom tool to examine event 
definition and placement. 

10. Click or display Journal to review pasted 
event text. 

Click here to watch a Find Cycle demo. 

See the Find Cycle tutorial sample data files in 
the Startup Wizard “Sample Data File” menu.) 

Read more about transformations and event 
marking in the complete AcqKnowledge 
Manual available under the Help menu. 

 

http://www.biopac.com/video/?video_category=acqknowledge-tutorials&v=acqknowledge-find-cycle-peak-detector-part-1
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Exploring AcqKnowledge “View by Modules” Setup 

The default channel setup option in the AcqKnowledge Demo is . In this display, three columns of 
boxes appear next to text boxes describing the channel, label and sample rate information. All channel setups in this 
mode are performed manually. 

 

For users of MP160 hardware, AcqKnowledge features a “View by Modules” setup option. In this mode, guided 
prompts assist in adding modules/transducers and establishing necessary hardware and channel parameters. In 
addition, the Module Setup detects potential channel conflicts between the software channel assignment and the 
module’s channel switch setting, and scales the signal to the correct value and units. Module Setup mode is presented 
by default in the full version of AcqKnowledge. This can greatly assist in expediting proper setup of the connected 
BIOPAC equipment. 

To explore “View by Modules” setup in the Demo version: 

1. Open the Demo Data file while selecting “Open for Graph Data Playback.” Exit Playback Mode by choosing 
the menu “Playback > Exit Playback Mode.” The “Playback” menu item will show a simulated MP160 menu. 

2. Choose MP160 > Set Up Data Acquisition > Channels and click the  button. 

3. Click the  button and select a module from the list and click Add. (The ECG100C module 
selected below is for example purposes only. The AcqKnowledge Demo does not support the use of actual 
hardware or transducers.) 

  
4. If prompted, input the channel switch settings 

from the selected module. 
In actual practice, the “Choose Channel Switch 
Position” would match the switch number selected 
on the BIOPAC module.  
Setup detects any potential channel conflicts 
between software assignment and the module’s red 
channel switch position (see below warning 
dialog). 

 
 

For video overviews on setting up channels 
for wired, wireless, and specialty amplifiers, 

visit our Hardware Tutorial page. 

http://www.biopac.com/
https://www.biopac.com/video/?video_category=hardware-tutorials&v=setting-up-channels-in-acqknowledge
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5. Establish the configuration for gain and filters as shown on right and click OK. In 
practice it is important to set the Gain and Filter settings to match the switch 
settings on the amplifier. The software uses this information to scale the signal to 
the correct units. If the Gain is not set to match, the signal will be scaled 
incorrectly. 

6. If prompted, select a transducer and click OK. 

 
7. Perform calibration steps, if required. The software will automatically scale 

certain signals if they only require a zero setting. However, some signals require a two-point calibration. In 
this case, the software will generate additional prompts for the scale values.  
The following example shows the dialogs for setting up a TSD125 series force transducer. 

a. The software prompts the user for pretension amount; enter “0” if pretension is not required. 

 
b. Enter a low calibration value or “0” if calibrating between zero and a second weight, and then click 

“calibrate” to take a voltage reading. 

 
c. Enter a high calibration value and then click Calibrate to take a voltage reading. 

 
Note: When recording is started, the data may show an offset. This offset is the amount that was entered in 

the pretension dialog. Adjust the tension applied to the transducer to center the signal on zero. 

Using this information, the module setup automatically sets the scaling and initial visual range to match the physical 
input units from the module or transducer. 
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Scripting 
BIOPAC Basic Scripting is a scripting language development option for AcqKnowledge that allows for viewing 
of runtime variables, creating new script files and editing existing script files, triggering of individual script functions 
for testing and single step functionalities. This functionality is available via an optional license. To explore scripting, 
access the AcqKnowledge Demo’s Script menu and run some of the examples. 

 
For further information about BIOPAC Basic Scripting, you are encouraged to read the Script Menu README or the 
Biopac Basic Reference in the Help menu. 

Workflow 
AcqKnowledge Workflow is a licensed feature that allows users to create automated analysis routines or macros 
without any prior scripting knowledge. Workflow uses a simple and intuitive drag-and-drop interface to string 
together a series of Actions. This feature requires AcqKnowledge 5.0.8 or later. 

1. To create a new Workflow, choose the menu item Workflow > Workflow Editor from the menu bar in any 
graph file. Note that the Transform and Analysis tabs are greyed out and unavailable when in Workflow 
Editor. 

 
2. Three windows will be displayed on the left side of the screen. The upper 

left window lists Actions Categories under the heading Actions. Clicking 
the Actions heading will display a comprehensive list of possible Actions 
that can be performed in the window to the immediate right (beneath the 
Search window). Clicking a category filters the Actions in that category, 
and only those filtered Actions appear in the right window. Actions can 
also be located by entering key words into the Search window.  

The information window in the bottom left side of the Editor screen 
displays a description of what each Action does. If no specific Action is 
selected, it will display the “Getting started” dialog. This dialog provides 
basic instructions on how to select Actions and add them to your 
Workflow.  

3. Six control icons are located on the tool bar above the Action windows. 
The Actions these icon buttons control are (from left to right) New 
Workflow, Open Workflow, Save Workflow, Run Workflow, Run 
Workflow Step by Step, and Stop Workflow.  

http://www.biopac.com/
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Creating a New Workflow by Adding Graphs 

1. Workflows operate on graph windows selected via the 
Graph Management Actions category. Graph 
windows may be opened either through the user 
interface (e.g., via “File > Open…”) or via File 
Management Actions.  

2. Select a graph or graphs via Actions in the Graph 
Management category. If no such Actions are 
selected, the Workflow will not perform any useful 
function. Drag and drop the Action into the 
Workflow window. 

Selecting and Adding Actions to Workflow 

1. Once one or more graphs have been added to the Workflow, additional Actions can be added by simply 
dragging and dropping them into the Workflow window.  

2. Once an Action has been dropped into the Workflow window, it will be displayed as a numbered step in the 
Workflow. After an Action has been added to the Workflow, it cannot be dragged to a new position. If a user 
wishes to change the order of Actions or remove the Action from the Workflow, click the “x” in the upper 
right corner of the Action in the Workflow window to delete the Action. Actions can then be readded to the 
Workflow in the desired location or a new Action can also be added to any position in the Workflow order. 

3. Many Actions have options and variables for the user to select and/or define, which are displayed once the 
Action has been dropped into the Workflow window. These user-defined options may be shown as pull-down 
menus, check boxes or buttons, or text windows for entering numerical values. 

 
As an example, the above image shows the ECG Interval Extraction Action with options shown in both 
pulldown menus and buttons, as well as a Hemodynamics Preferences tab (closed), which when opened 
allows the user to select an additional range of options.  

4. Once Actions have been added to a Workflow and options have been 
selected for those that require them, the completed Workflow can be 
saved by clicking the Save icon and naming the Workflow file, which will be saved with the .awf file 
extension.  

Running a Workflow in AcqKnowledge 

1. Once a Workflow has been saved it can be run in conjunction with an 
AcqKnowledge .acq file. Begin by opening the associated .acq file (in 
AcqKnowledge 5.0.8 or later) with which you would like to run an existing 
Workflow.  

2. With the AcqKnowledge file open, select the Workflow tab and open the Workflow 
Editor. With Workflow Editor open, select the Open File icon from the Workflow 
toolbar and navigate to the AcqKnowledge Workflow file (.awf) you wish to open.  

3. Once the Workflow is open, the list of Actions will be displayed in the Workflow window.  

4. Make sure the Workflow contains the Actions to select the correct graph or graphs from the Graph 
Management category (see Creating a New Workflow by Adding Graphs). 
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5. To execute the Workflow, simply click the Run Workflow icon from the 
toolbar. 

6. Optionally, users can run the Workflow so that it pauses after each step. 
To do this, click the Run Workflow Step by Step icon and continue 
clicking it to progress the Workflow through each Action. Click the Stop Workflow if you need to halt the 
Workflow’s progress mid-run.  

7. The Workflow will stop automatically once all Actions have been completed. 

For additional information on Workflow, please see our short video tutorial and in-depth webinar on this feature, as 
well as the Workflow license product page. 

Please contact us to discuss how BIOPAC can provide you with solutions for life science data acquisition and 
analysis, or visit our website at www.biopac.com. Please also visit the Demo Video and Tutorial Screencast section of 
the website for comprehensive video tutorials and hardware demos. For on-demand training sessions such as 
AcqKnowledge Bootcamp see our Webinars Page. 

 
 

http://www.biopac.com/
https://www.biopac.com/video/?video_category=acqknowledge-tutorials&v=acqknowledge-workflow-automation
https://www.biopac.com/events/workflow/
https://www.biopac.com/product/workflow-licenses/
http://www.biopac.com/
http://www.biopac.com/Videos.asp?Cat=AcqKnowledge
https://www.biopac.com/events/design-acq-soft/
https://www.biopac.com/webinars/

