AcqKnowledge GLP
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Using AcqKnowledge
With the GLP System

This document describes information relevant to using AcqKnowledge with the GLP System installed and
describes other features that may be useful in a GLP compliant environment.

What Does the GLP System Do?

When you use AcqKnowledge with a GLP System installed, your systems administrator assigns you a set of
“Permissions” for the program. These Permissions indicate what operations you are allowed to perform
within AcqKnowledge and what operations are restricted. As a result of your Permissions, you may no longer
be able to perform certain operations with the software.

In addition to the Permissions, the software keeps a continuous log of all software and hardware operations
associated with a file, whether performed, canceled or failed. These GLP logs store the time, date, machine,
and MP unit for each operation. Additionally, they can contain comments giving more detail about the
reason for a change. These logs are stored along with a graph file and cannot be altered.

The software monitors only actions that you execute within AcqKnowledge and does not record personal
information from other applications on the machine.

v If you do not agree to be monitored by the GLP system, please contact your systems administrator.
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Starting the Application
1. Launch AcqKnowledge.

In order to uze the application you must provide
a valid uzername and pazsword. If pou do not have one,
contact your spstems administrator.

User Mame : IJDCernKremer
B Acoknowledg MP1S0 Update Firmware Utiity | |
axzwaord ;
53 MP Communication Type Lkiliky
Domain : I

'a"_ Acgknowledge
7} BIOPAC GLP Administrator

o]

2. With a GLP System installed, AcqKnowledge requires users to verify username and password when
the application is launched. Enter your User Name in the GLP Authorization dialog.

Cancel |

= This User Name is associated with your computer user account.
< GLP User Names should only consist of alpha-numeric and space characters.

*  Mac OS® X: If you do not know your login name, open the Terminal application, which is
located at /Applications/Utilities/Terminal. If you cannot locate the Applications folder, click on
the “Applications” button at the top of any Finder window. Once the Terminal has started, type
in whoami and press Return to display your short login name.

3. Type in your password.
= This is the same password used to log on to your computer.

4. Click on OK or Login.

a) If you see the message “Authentication failed” you may have mistyped your short login name
or your password. Login is CASE SENSITIVE. Make sure that both your login name and
password use the correct characters and case and then click on Login..

GLF Legin

In grder to use the application “AcgKnowledge
3.2.1" you must pravide a valid username and
password.  If you do not have one, contact your
syEIems administrange.

Nama: | edwarda

Password: asses

Authientication Failed_ ) ™ Canesl ) E

Mot a GLP user, l_’ancel

GLP Login

In order ta use the application “AcgKnowledge
1.8.1" vou must provide a valid wsesname and
password. Hf yow do et have one, contact your
systems administrater.

Mame:  adwardp

Pasyword: | ssssses

f Login

b) Ifyou see the message “Not a GLP user” your systems administrator has not authorized you to
use the GLP System. Contact your systems administrator to have a GLP account created for you.

¢) If you are running Windows® XP Service Pack 2, you may see the following firewall prompt.

Click “Unblock” to work with AcqKnowledge

%= windows Security alert

@ To help protect your computer, Windows Firewall has blocked

some features of this program.

Do you want to keep blocking this program?
Hame: AcqKnowledge[TM)
> Publisher. BIOPAL Systems. he.

Eeep Blocking Unblock

sk Me Later

Windows Firewal hag blocked this program fram accepling connections from the
Internet or a network. |f you recognize the program or brust the publisher. vou can
unblock it. When should | unblock a program?
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Using the Application

After logging in, AcqKnowledge will start up regularly. You may use the application normally. Based on
your permissions, you may not be able to perform certain operations with the software. In addition, certain
operations may require that you complete a GLP Log field to perform an operation.

To confirm that you are running a GLP version of AcqKnowledge, generate the About dialog and review the
software information:

Windows" XP Professional: MP150 menu > About AcqKnowledge

Mac 0S" X: AcqKnowledge application menu > About AcqKnowledge

AcqKnowledge® GLP
Version 3.8.1
Build: T

For Microsoft Windows 2P Pro
Caopyright © 1992-2004 BIOPAC Systems, Inc.
Partions Copyright © 1932-2004 Microsoft Corporation

Licensed to:

Microzoft Windows <P [NT 5.071]

Build: 2600 [Service Pack 2]
Processor. Pentium [V
Manufacturer. Geninelntel
Processor speed: 2805 MHz

Physical memory: 512 kb

Memony, 5E% Free

Line Frequency. BlHz

This section briefly describes the main GLP interactions a common user will encounter. For more details,
please see your GLP Administrator.

Log Message

Some operations may prompt you to enter a message describing the reason for executing them. This message
should be descriptive, as it will be stored along with the graph file in the GLP logs. Additionally, your
Standard Operating Procedure may govern the content of the messages you enter.

GLP Authorization

' Please describe briefly why you are performing
"Acquiring Mew Data”. This description will be placed
in the GLP logs.

Begin calibration procedure.

Empty GLP Log Message
The log message cannot be empty. Please enter a brief
description in order to perform the operation.

€ o) =

Type a short description in the editable area and then click OK or press the Enter key to accept the message.

Modification log messages must be a single line. It is not possible to enter line breaks into a modification log
message with either “Return” or “Enter” keys.

Modification log entries cannot be edited.

Based on your user permissions, you may not be required to enter a message for every operation. However,
if your permissions require a message, an empty message will not be accepted.

Note: The application does not record the parameters for transformations in its automatic log messages. If
detailed information about a transformation is required, your SOP should specify that the parameters
must be included in the GLP log message.
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Authorization

Some options in the menus and toolbars may no longer be accessible. If you do not have enough permission
to execute an operation, you may be notified with the following dialog:

GLP Authorization

You do not have sufficient privileges to perform

o the operation "Cutting from Graph". To continue,
another user with sufficient privileges must
authorize this operation.

Authorization Failure
Name: |
That user does not have permission to perform the
Password: operation.

‘ oK ‘
Cancel f Authorize —

Authorize To perform the operation, you must find another user who is allowed to perform the
operation. The authorized user must enter his/her short name login and password into this
dialog as if he/she were logging into the system. The Log will indicate who authorized you
to execute the operation. You must get authorization each time you perform an operation
outside of your permissions—there is no carryover.

After the name and password have been entered, click on “Authorize”.

If the user name and password are incorrect, you may see the login errors
Authentication failed or Not a GLP user. If the authorizing user does not
have sufficient permissions, you will see another error dialog displayed:

Cancel Ifyou do not need to perform the operation or if you cannot find an authorized user to give
you permission, click the “Cancel” button to cancel the operation.

Auto-Log off

If you are running AcqKnowledge and don’t use the keyboard or mouse for a specified period of time, the
program will automatically log you off. This is a safety precaution to prevent someone else from using your
account if you accidentally leave the machine without exiting the application and logging off.

Acquisitions and long transformations will continue to be processed if you are automatically logged off. This
makes it safe to perform long acquisitions or complex transformations without needing to physically make
sure unauthorized users do not get access to the application.

If you are logged off, you will be - GLP Auto-logout
prompted for your username and | You have been logged off for security purposae.s
password when you try to use the ' have not used the keyboard or mouse Qe ast 20 minute3)

. To continue using the program you need to Tog .
program again. Enter the same

information you used to start the program @

and you will be allowed to continue. . . .
A GLP Administrator can specify the Auto-logout period.
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Viewing GLP Logs
The GLP System maintains two separate logs:

= Modification Log — Graph-specific log for each operation performed on that graph (saved when the
graph is saved). Modification Logs are viewed and stored with the AcqKnowledge graph file.

= User Log — Per-user audit trail log for all graph files (saved when you close/exit the program).
For more log detail and for performing cross-graph log comparison, use the GLP Administrator
utility to examine the global GLP User Logs. See the “GLP Administrator” guide for usage notes.

Modification Logs

. T= é 886 Modification Log for glp test

PC Mac® 121472001 11:25:41 PST debug: Change Window Size for Graph and Journal (MP150: MP1S0 000198)
1271472001 11:25:45 PST debug: Acquiring Mew Data (MP150: MP150 0001 98] test acquisition
12/14/2001 11:25:47 PST debug: Autoscale VYertically, one Channel (FP1S0: FP1S0 0001 920
121472001 11:26:01 PST debug: Modifying the Horizental Axix - Time, Frequency, Arbitrary of Offset (MP150: MP1S0 000198): change
to frequency
125142001 11:26:11 PST debug: Saving a Graph (MP1S0: MP1S0 000122):
02/26/2002 16:15:15 PST glpadmin: Yiewing Modification Logs (MP150: MP1S0 0001 A1)

e i<[r
To view the Modification Log for a graph file, click the GLP Log icon on the toolbar, or
Windows" XP Professional: File > GLP Modification Log or Display > Show > GLP Modification Log
Mac OS® X:  Display > Show Modification Log

The Modification Log window appears similar to a journal window. You can move through the contents of
the Modification Log window by using the horizontal and vertical scrollbars. Modification Log entries
cannot be edited and are saved with the graph file. Each log entry consists of:

a) Date and time the operation was performed

b) Login name of the user who performed the operation
c) Description of the operation

d) Serial number of the MP unit the user was using

e) Any message entered by the user.

To hide the Modification Log for a graph, toggle the GLP Log icon on the toolbar or reselect the menu item
you used to view the log. Mac OS® X users can also close the log journal window or choose File > Close
Modification Log.

File Qs Display
New... #EN
Printing GLP Logs Open... %0
. : " Open File for Playback...
Choose File > Print Modification Log to print a [ File Edit Transform Close Modification Log ~ 3W
GLP log. W
. Cpen... Export Modification L
Exporting GLP Logs Clase el UL T
. . . Page Setup...
Choose File > Export Modification Log to save a Save Print Modification Log... 3P
GLP log file as a tab-delimited text (*.txt) file. Save A,
Print...
Prinkter Setup...

v GLP Modification Log
Print Maodification Log
Expark Madification Lag
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Data Integrity Validation

When the GLP System is present, AcqKnowledge performs automatic data integrity validation. Each GLP
file saved to disk is tagged with a unique stamp determined from the contents of that file. When the file is
opened, its contents are checked against this stamp. A data integrity failure will occur if the file’s contents
have been modified since a graph’s last save. This flags changes made by other programs or by disk
corruption.

This stamping is automatic—no special actions need to be taken when saving or opening files.

* Mac OS® X: To skip/stop the data integrity check when opening large files,
press Command-period during the check.

If validation is canceled or fails, a prompt will be generated to let you know that you may not be producing a
verified GLP-compliant file.

Data Integrity Validation Failure

The data in the graph file appears to have been modified
externally and may not be valid. Do you want to continue
working with the file?

an‘_’rYes\

Creating Data Snapshots

reate Data’ snapsho

Pleaze dezcribe thiz data shapshat:

(1]4 | Cancel |

Within AcqKnowledge it is possible to take a snapshot of the data within a graph and archive it in the graph
file. Later, snapshots can be displayed in new graph windows by choosing Display >Show All Data
Snaphots. These graphs may be modified, but the snapshot itself cannot be changed. Changes to the snapshot
file must be saved as new graph files.

AcqKnowledge can automatically create snapshots of the data after the completion of each acquisition. This
allows for the original data acquired from the instrument to be kept with the graph file in an immutable form.
This feature can be turned on and off by toggling the snapshot option checkbox in Display > Preferences >
General: “Create data snapshots after acquisitions.”

You can also take a snapshot of the data at other times. This can be helpful to capture intermediate results in
a complex analysis. To create your own snapshot, choose Edit > Create Data Snapshot. You will be
prompted to enter a name describing the contents of the snapshot.

File: 11.15.06
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